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Cautions

Keep safety first in your circuit designs!

1.

Renesas Technology Corporation puts the maximum effort into making semiconductor products better and more
reliable, but there is always the possibility that trouble may occur with them. Trouble with semiconductors may lead to
personal injury, fire or property damage.

Remember to give due consideration to safety when making your circuit designs, with appropriate measures such as (i)
placement of substitutive, auxiliary circuits, (ii) use of nonflammable material or (iii) prevention against any
malfunction or mishap.

Notes regarding these materials

1

These materials are intended as a reference to assist our customersin the selection of the Renesas Technology
Corporation product best suited to the customer's application; they do not convey any license under any intellectua
property rights, or any other rights, belonging to Renesas Technology Corporation or athird party.

Renesas Technology Corporation assumes no responsibility for any damage, or infringement of any third-party's rights,
originating in the use of any product data, diagrams, charts, programs, agorithms, or circuit application examples
contained in these materials.

All information contained in these materials, including product data, diagrams, charts, programs and algorithms
represents information on products at the time of publication of these materials, and are subject to change by Renesas
Technology Corporation without notice due to product improvements or other reasons. It is therefore recommended
that customers contact Renesas Technology Corporation or an authorized Renesas Technology Corporation product
distributor for the latest product information before purchasing a product listed herein.

The information described here may contain technical inaccuracies or typographical errors.

Renesas Technology Corporation assumes no responsibility for any damage, liability, or other loss rising from these
inaccuracies or errors.

Please also pay attention to information published by Renesas Technology Corporation by various means, including
the Renesas Technology Corporation Semiconductor home page (http://www.renesas.com).

When using any or al of the information contained in these materials, including product data, diagrams, charts,
programs, and agorithms, please be sure to evaluate al information as atotal system before making afinal decision on
the applicability of the information and products. Renesas Technology Corporation assumes no responsibility for any
damage, liability or other loss resulting from the information contained herein.

Renesas Technology Corporation semiconductors are not designed or manufactured for use in adevice or system that
isused under circumstancesin which human lifeis potentialy at stake. Please contact Renesas Technology
Corporation or an authorized Renesas Technology Corporation product distributor when considering the use of a
product contained herein for any specific purposes, such as apparatus or systems for transportation, vehicular, medical,
aerospace, nuclear, or undersea repeater use.

The prior written approval of Renesas Technology Corporation is necessary to reprint or reproduce in whole or in part
these materials.

If these products or technol ogies are subject to the Japanese export control restrictions, they must be exported under a
license from the Japanese government and cannot be imported into a country other than the approved destination.

Any diversion or reexport contrary to the export control laws and regulations of Japan and/or the country of destination
isprohibited.

Please contact Renesas Technology Corporation for further details on these materials or the products contained therein.
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I ntroduction

The High-performance Embedded Workshop (HEW) is a powerful development environment for embedded applications
targeted at Renesas technology microcontrollers. The main features are:

A configurable build engine that alows you to set-up compiler, assembler and linker options via an easy to use
interface.

An integrated text editor with user customizable syntax coloring to improve code readability.
A configurable environment to run your own tools.

An integrated debugger which allows you to build and debug in the same application.
Version control support.

The High-peformance Embedded Workshop has been designed with two key aims; firstly to provide you, the user, with a
set of powerful development tools and, secondly, to unify and present them in away that is easy to use.
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About This Manual

This manual describesthe HEW system. This manual is composed of two parts. HEW part describes information on the
basic “look and feel” of the HEW and customizing the HEW environment and detail the build. Simulator/Debugger part
describes Debugger functions of the High-performance Embedded Workshop.

This manual does not intend to explain how to write C/C++ or assembly language programs, how to use any particular
operating system or how best to tailor code for the individua devices. These issues are lft to the respective manuals.

Document Conventions
This manual uses the following typographic conventions:

Tablel Typographic Conventions

Convention Meaning
[Menu->Menu Option] Bold text with ->’ is used to indicate menu options
(for example, [File->Save As...]).
FILENAME.C Uppercase names are used to indicate filenames.
“enter this string” Used to indicate text that must be entered (excluding the “” quotes).
Key + Key Used to indicate required key presses. For example, CTRL+N means

press the CTRL key and then, whilst holding the CTRL key down,
press the N key.

) When this symbol is used, it is always located in the left hand margin.
It indicates that the text to its immediate right is describing “how to”

(The “how to” symbol) .
do something.
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1. Overview

This chapter describes the fundamental concepts of the High-performance Embedded Workshop. It isintended to
give users who are new to Windows® applications, filling in the details that are required by later chapters.

11 Workspaces, Projects and Files

Just as aword processor allows you to create and modify documents, the High-performance Embedded
Workshop alows you to create and modify workspaces. A workspace can be thought of as a container of
projects and, similarly, a project can be though of as a container of project files. Thus, each workspace contains
one or more projects and each project contains one or more files. Figure 1.1 illustrates this graphically.

c

PROJECT

-

WORKSPACE

PROJECT

Figure 1.1: Workspaces, Projectsand Files

Workspaces allow you to group related projects together. For example, you may have an application that needs
to be built for different processors or you may be developing an application and library at the same time. Projects
can aso be linked hierarchically within aworkspace, which means that when one project is built all of its“child”
projects are built first.

However, workspaces on their own are not very useful, we need to add a project to a workspace and then add
filesto that project before we can actually do anything.
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1.2 TheMain Window

The HEW main window appears as shown in figure 1.2.

tﬁl Demo_H852600A - High-Performance Embedded Workshop - [Demo_H852600A.c]
<+ File Edit “iew Project Optiong Build Debug Memore Tools Window Help -|ﬁl il

DeWd 8 er0rTx||or(mastne 2% o &5 ||
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e w0
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Hfonnected

4 um Debug A Find in Files Version Caritrol
Ready |Readwite  [1/93 ] [INS NUM -2

Figure 1.2: HEW Main Window

There are three main windows; the workspace window, the editor window and the output window. The
workspace window shows the projects and files which are currently in the workspace, the editor window
providesfile viewing and editing facilities and the output window shows the results of a various processes (e.g.
build, version control commands and so on).

121 TheTitleBar

Thetitle bar displays the name of the currently open workspace, project and file. It aso contains the standard
minimize, maximize and close buttons. Click the minimize button to minimize the HEW on the windows start
bar. Click the maximize button to force HEW to fill the screen. Click the close button to close the HEW (this has
the same effect as selecting [File->EXxit] or pressing AL T+F4).

122 The Menu Bar

The menu bar contains nine menus: File, Edit, View, Project, Options, Build, Tools, Window and Help. All of
the menu options are grouped logically under these headings. For instance, if you wanted to open afile then the
file menu iswhere you will find the right menu option, if you wanted to set-up atool then the tools menu isthe
correct selection. The following sectionswill cover the functions of the various menu options, as they become

4
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relevant. However, at this stage, it is worth taking a few moments to familiarize yourself with the options that
each menu provides.

123 TheToolbars

The toolbars provide a shortcut to the options, which you will use the most often. There are eight default
toolbars: Bookmarks, Debug, Debug Run, Editor, Search, Standard, Templates, Version Control, and Difference
(as shown in figure 1.3 to 1.11). Toolbars can be created, modified and removed viathe [T ools->Customize...]
menu option (see chapter 6, “ Customizing the Environment”, for further information).

Mext Bookmark  Previous Bookmark

Toegle Bookmark Glear All Bookmarks

n&a®

Figure 1.3: Bookmarks T oolbar

TCL Toolkit View Disassembly
Command Line Print the Disassembly window
Enable/Dizable Breakpoint Fadix Connect to debug platform

Toeele Breakpoint Dizconnect debue platform

lomwB|c agEne 2 B W

Figure 1.4: Debug Toolbar

Feset GPU Step QOver
Go to Cursor Step QOut
Feset Go Set PG to Gursor
Glo ‘ Stlep Hallt

i I FC
ETELE L R @!T

Figure 1.5: Debug Run Toolbar

Save File Copy  Match Braces
Open File Save all Cut Pazte Ihzert Template

MNew File Print Toeele Bookmark

|
DEEE| S $a)|Ta

Figure 1.6: Editor Toolbar

Find in Files Find Mext

Search String Find ‘ Find Previous
| | |

Cay Istring vl Tt

Figure 1.7: Search Toolbar
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Build Build & Current Congifuration current Session | —PMneh Elave Hew s Warkspace
EluildI File | ‘ Sltl:lp Launch Debugger| Wiewy Cutput
i |
T 1 T T
“EEEY =] dre s> |

Figure 1.8: Standard Toolbar

Template Selection

Define Template Ihzert Template
|

|
“r ITempIateD j T ‘

Figure 1.9: Templates Toolbar

Add File (=) Check Out Fileis)
Remove Fileis) Check In File(z)
Get Filets) Show Status

|
BE 88 a @

Figure 1.10: Version Control Toolbar

|gnore white space
Compare files

Find nest

Find previous
Find previous difference

Find next difference

oot dh oy a T &

Figure 1.11: Difference Toolbar

When the Standard toolbar or atoolbar is docked, it has a control bar as shown in figure 1.11 (i). If you want to
move the docked Standard toolbar, click and drag its control bar to the new location. Figure 1.11 (i) shows the
Standard toolbar when it is docked and figure 1.11 (ii) shows the Standard toolbar when it is floating.

i | [Debuo = |[oebuo S s | 2=

i ||Debug ﬂ ||Debug ﬂ | S i ||:E| =]

Figure 1.12: Standard Toolbar, Docked and Floating

2 Todock the menu bar or atoolbar:
1. Double-click on thetitle bar of afloating menu bar or toolbar.
or:
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2. Dragthetitle bar of afloating menu bar or toolbar and draw it toward an edge of a docked window, menu
bar, toolbar or the HEW main frame, on whose edge you would like to dock the window, until the shape
of the floating bar changes.

2 To float the menu bar or atoolbar:

1. Double-click on the control bar of a docked menu bar or toolbar.

or:

2. Drag the control bar of adocked menu bar or toolbar and draw it away from the edge of the HEW main
frame and from an edge of the other docked windows, menu bar or toolbar.

124 The Workspace Window

The “Workspace” window has three panes. The “Projects’ tab shows the current workspace, projects and files
(figure 1.13). Y ou can quickly open any project file or dependent file by double clicking on its corresponding
icon.

<& Workspace _ O] x

El@ Demo
EI@ Demo

B2 Aszembly source file

o [ lowlvl st

=5 C source file

: dbsct.c

k.
wectthl.c
-2 Dependencies

Mavigation Tab

Templates Tab

Project Tab ——

N ) Projects l ] Terplates | =] Mawigation I

Figure 1.13: Workspace Window Projects Tab

The “Navigation” tab provides jumpsto various textual constructs within your project’s files. What is actually
displayed within the navigation tab depends upon what components are currently installed. Figure 1.14 shows
ANSI C functions. See chapter 2, “Build Basics’, for more information on the “Workspace” window.
The“Templates’ tab displays template settings. See 4.12, “Templates’, for more information about a template.
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<& Workspace _ O] x

[ |
hd
@ijecis I @ Templates J (’:lhlavigaﬁon I

Figure 1.14: Workspace Window Navigation Tab

2 Toadlow the “Workspace” window or the “Output” window docking:
Click the right mouse button anywhere inside the “Workspace” window or the “ Output” window. Then a

pop-up menu will be displayed. If [Allow Docking] is checked, docking is allowed; otherwise, docking is not
allowed. Select [Allow Docking] to check or uncheck it.

When [Allow Docking] is checked, you can dock a window, atoolbar or amenu bar to the edge of the HEW
main window or to the edge of another docked window. Alsoif [Allow Docking] ischecked, you can float them
“above’ the other HEW windows or outsde the HEW main window. Figure 1.14 (i) shows a docked
“Workspace” window, and figure 1.14 (ii) shows afloating “Workspace” window.

2=l < Workspace H =] E3
E@ Demo = El@ Dema
Bt oo _ 5
Ea Aszembly source file El-4 Assembly source file
H lowbelgrs @0 oL lowhl.sic

EI 9 C source file

Intprg.c
lowsre.c
resetprg.c
s shrk.c
P vectthl.c =l 1 - vectthl.c
,,' @ijem IE Termplates I ‘] Navigation I - - (3 Dependencies
i 3 Projects IE Templates I “a_| Mavigation I

Figure 1.15: Workspace Window, Docked and Floating

When the “Workspace” window or the “Output” window is docked, it has a control bar as shown in figure 1.15.
If you want to move a docked window, click and drag its control bar to the new location.

'Close' buthon

-1 |

Figure 1.16: Control Bar of Docking Window

2 To dock the “Workspace” window or the “Output” window:
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[Allow Docking] must be checked on the pop-up menu of the window to dock the “Workspace” window or
the “QOutput” window. (The pop-up menu will be displayed when you click the right mouse button anywhere
inside the window.) Then you have two ways to dock the window.

1. Double-click on the control bar of afloating window.

or:

2. Dragthetitle bar of afloating window and draw it toward an edge of a docked window, menu bar or
toolbar, or the HEW main frame, on whose edge you would like to dock the window, until the shape of
the floating window changes.

2 Tofloat the “Workspace” window or the “Output” window:

[Allow Docking] must be checked on the pop-up menu of the window to float the “Workspace” window or

the “Output” window. (The pop-up menu will be displayed when you click the right mouse button anywhere

inside the window.) Then you have two ways to float the window.

1. Double-click on the control bar of a docking window.

or:

2. Drag the control bar of adocked window and draw it away from the edge of the HEW main frame and

from an edge of the other docked windows, menu bar or toolbar.
2 To hidethe “Workspace” window or the “ Output” window:
Click on the close button, which islocated in the top right corner of the window. Or push the right mouse
button anywhere inside a floating window and select [Hide] on the pop-up menu.
2 Todisplay the “Workspace” window or the “Output” window:
Select [View->Wor kspace] or [View->Output], respectively.

125 The Editor Window

The editor window is where you will work with the files of your project. The HEW allows you to have many
files open at one time, to switch between them, to arrange them and to edit them in whichever order you want to.
By default, the editor window is displayed in a notebook style, where each text file has a separate tab (as shown
in figure 1.16).

The editor contains a gutter on the left-hand side of the window. The gutter in HEW can be configured to
contain many columns. Each column can refer to a different component’s capability. Infigure 1.16 the editor is
displayed with the debugger address column and the standard column. The standard column allows the user to
configure the position of bookmarks and software breakpoints quickly and easily.

If you are unsure what purpose a column has or what the information it is displaying isif you place the cursor
over the column atool tip is displayed showing itsidentity.
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2 " —
SE * .7 1=
<% FILE cshrk.c *
<%  DATE ‘Mon, Jun 23, 2003 *.
<%  DESCRIFTION :Program of sbrk *.
<% CPU TYPE cH8S5~ *
e 3 * .7
<% Thiz file is generated by Renesas Project Generator (Ver.2.6). *.
e 3 * .7
- s

Finclude <no float he
#include <stdio. h:
#include "sbrk. h"

Ssoonst size t _sbrk =izes <% Specifies the minimum unit of *® —
<% the defined heap area *®

=tatic union {

long  dummy <% Dummy for 4-byte boundary *.
char heap[HEAPSIZE]: % Declaration of the area managed *®
S by sbrk =
theap area
static char #*brk={char #)iheap area; * End address of area assigned *
- -
4 I I 3

<= resetprge |0 dbscte aE shrk.c I

Figure 1.17: Editor Window

The editor window can be customized viathe “Format Views’ dialog box, which can be invoked viathe [Tools-
>Format Views...] menu option. This dialog alows you to configure fonts, colors, tabs and so on for the editor
window. It aso adlowsthe user to change the look of other views, which have been installed by HEW. If you
would prefer to use your favorite editor rather than the HEW internal editor then specify your alternative in the
“Options’ dialog box, which can be invoked via the [Tools->Option...] menu option. For further details on how
to use and configure the editor, refer to chapter 4, “Using the Editor”.

126 The Output Window

The “Output” window by default has four tabs on display. The “Build” tab shows the output from any build
process (e.g. compiler, assembler and so on). If an error is encountered in a source file then the error will be
displayed in the build tab along with the source file name and line number. To quickly locate a problem, double
click on the error to jump to the source file and line.

x|

| 4]+ Build £ Tebug }, Find in Files }, ersion Ganirol /

Figure 1.18: Output Window

The “Debug” tab shows the output from any debugger process. Any debug component that needs to display
information will send its output to this window.

10
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The“Find in Files’ tab displaysthe results of the last “Find in Files” action. To activate find in files, select the
[Edit->Find in Files...] menu option, the toolbar button. For further details on how to use find in files, refer to
chapter 4, “Using the Editor”.

The“Version Control” tab displays the results of version control actions. The tab isonly displayed if aversion
control systemisin use. For further details on version control, refer to chapter 7, “Version Control”.

127 The Status Bar

The status bar displays information as to the current state of the HEW. Figure 1.18 shows the seven sections of
the status bar.

Displ HEl stai: E
ISpiays Sl Readonly status  Line number. Calurmn number

Ingerion hoce.

|
Ready [Read-write 214 1 [ms ) | 4

I |
Caps lock. Mum lock

Figure 1.19: StatusBar

13 TheHelp System

The help menu is the rightmost menu on the HEW menu bar. It contains the menu option “Contents’ which,
when selected, takes you to the main HEW help window.

To obtain help on specific dialogs click on the context sensitive help button, which islocated in the top right-
hand corner of each dialog box (as shown in figure 1.19).

jﬂ
Context sensitive help butten

Cancel butten

Figure 1.20: Help Button

When thisis clicked, the mouse pointer will change to a pointer with a question mark above it. Whilst the mouse
pointer isin this state, click on the part of the dialog box that you require assistance on.

Alternatively, select the control that you reguire help for and then pressthe F1 key.

11
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14 Launching the HEW

To run the HEW, open the “ Start” menu of Windows®, select “Programs’, select “ Renesas High-performance
Embedded Workshop” and then select the shortcut of the HEW. By defaullt, the “Welcome!” dialog box shown
in figure 1.20 will be displayed.

Welcome!
— Optiors;
] & ‘Create a new project workspace
Cancel |
" Open a recent project workspace: Administration... |
é IE:'\Hew\demn'\demo.hws j
=

E " Browse to another project warkspace

Figure 1.21: Welcome! Dialog

To create a new workspace, select “Create a new project workspace”, and click “OK”. To open one of recent
project workspaces, select “Open arecent project workspace”, select a workspace from the drop-down list, and
click “OK”. The recent project workspace list displays the same information as that seen in the workspace most
recently used filelist. Thislist appears on the file menu. To open aworkspace by specifying aworkspace file
(\HWSfile), select “Browse to another project workspace”, and click “OK”. To register atool to or unregister a
tool from the HEW, click the “ Administration...” button (see chapter 5, “Tool Administration” for details).
Click the “Cancel” button to use the HEW without opening a workspace.

15 Exiting the HEW

The HEW can be exited by selecting [File->EXxit], pressing AL T+F4 or by selecting the close option from the
system menu. (To open the system menu, click the icon at the upper-left corner of the HEW title bar.) If a
workspace is open then the same workspace closedown procedure is followed as described in the previous
section.

16 Component System Overview

The HEW allows the user to extend the HEW functionality by adding additional components to the system. This
isachieved by registering the component in the Tools Administration dialog box. These components can add
windows, menus and toolbars to the HEW system. Examples of the components are the debugger and builder
components of HEW. The debugger component adds all of the menus and toolbars associated with the debugger
and the builder component does the same for the build functionality. The components you have registered in the
system will modify the look and feel of HEW. In some cases you may not have some of the menus which you
can seeinthismanual. For instance if the debugger component is not installed you will not have the “ Debug”
menu in the HEW main window.

12
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2. Build Basics

This chapter explains the general functions of the HEW whilst the more advanced features can be found in
chapter 3, “ Advanced Build Features’.

2.1 The Build Process

Thetypical build processisoutlined in figure 2.1. This may not be the exact build process, which your
ingtallation of HEW will use as it depends upon the tool s that were provided with your installation of HEW (e.g.
you may not have a compiler for instance). In any case, the principles are the same - each step or phase of the
build takes a set of project files and then builds them, if al succeeds then the next step or phase is executed.

& suio E
ﬂ/’ COMPILER
C
Source Files
Iil ﬂ_' ASSEMBLER
=
—‘ Assembler
/ Source Files
Project
LINKER Object
Files
Library
Files ‘
Load
Module

Figure 2.1: Typical Build Process

In the example shown in figure 2.1 the compiler is the first phase, the assembler is the second phase and the
linker isthe third and final phase. During the compiler phase, the C source files from the project are compiled in
turn, during the assembler phase, the assembler source files are assembled in turn. During the linker phase all
library files and output files from the compiler and assembler phases are linked together to produce the load
module. This module can then be downloaded and used by the debugger functionality in HEW.

The build process can be customized in several ways. For instance, you can add your own phase, disable a phase,
delete phases and so forth. These advanced build issues are left to chapter 3, “ Advanced Build Features’. In this
chapter, only the general principles and basic features will be detailed.

13
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2.2 Project Files

In order for the HEW to be able to build your application, you must first tell it, which files should be in the
project, and how each file should be built (figure 2.2).

Add Project Files
—
Remove Project Files

Project
Debug: ON . _ 7T
Optimize: OFF Set Compiler Options
List File: YES c
Source Files
Debug: OFF ] —_—
Optimize: OFF Set Assembler Options
List File: YES Assembler
Source Files
Debug: ON . . —_—
Silent: YES Set Linker options j
Map File: YES Cibrary
Files

Figure 2.2: Editing a Project

14




High-performance Embedded Workshop User’s Manual

221 Adding Filesto a Project

Before you can build your application you must first inform the High-performance Embedded Workshop, which
filesit, is composed of .

2 Toadd afilesto aproject:
1. Select [Project->Add Files...], select [Add Files...] from the “Workspace’ window’ s pop-up menu (see
figure 2.3), or press NS when the “Workspace” window is selected.

Open dbzct.c

Build dbsct.c

Build Options 4

Add Files... INS
Remove Files..

Exchude Build dbzct. o

Werzion Control r

Canfigure View. .

’7 Allow Docking
Hide

Fropertiez

Show Differences...

Figure 2.3: Project Pop-up Menu

2. The“Add” dialog will be displayed.
3. Select the file(s), that you want to add and then click “Add”.

There are anumber of other waysto add new files to the project. These are described below:

»  Clicking right button on an open file in the editor window displays a pop-up menu option (figure 2.4). If the
fileisalready in the project then the “Add File to Project” menu option isdisabled. Selecting the “Add File
to Project” then adds the file to the current project.

15
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Build File “dbsetc”

Cut Citr [+
Copy Citr [+
Paste Cirl+\

Gddl Eile o) Froject

Eind.. Cirl+F
Find In Files.. F4
Feplace Citrl+H
Goto Line Citrl+G
Match Braces Citr [+
Book marks 3
Templateg 3
Toeele Breakpoint Fa

Efiatle/Disatle Breaknaint. Gl

Figure 2.4: Editor Window Pop-up Menu

* Inthe HEW itisaso possibleto “Drag and Drop” files from Windows Explorer onto the workspace
window. These fileswill be automatically added to the project and are displayed in the folder in which they
were dragged to.

Note: If you add afileto a project when it isan unrecognized file type then it will still be added to the project.
Certain functions will be disabled with reference to thisfile. When thisfile isdouble clicked in the workspace
window instead of opening the file in the editor the open operation is passed to Windows operating system. The
default open operation isthen carried out asif the file was opened in Windows Explorer. To view the current
defined extensions use the “File Extensions” dialog (see the section on file extensions later in this chapter).

16
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222 Removing Filesfrom a Project
Files can be individualy removed from a project, selections of files can be removed or dl files can be removed.

2 Toremove files from aproject:
1. Select [Project->RemoveFiles...], or select [Remove Files...] from the “Projects’ tab’s pop-up menu in
the Workspace window (see figure 2.5). The “Remove Project Files’ dialog will be displayed (figure 2.6).

Open dbzct.c

Build dbsct.c

Build Options 4

Add Files... INS
Remove Files..

Exchude Build dbzct. o

Werzion Control r

Canfigure View. .

’7 Allow Docking
Hide

Fropertiez

Show Differences...

Figure 2.5: Projects Tab Pop-up Menu

Remove Project Files

Project files: ok

Cancel

il

(= demo]
intprg. src [ \hewtdemnoderno] Eemave
rezetprg.arc [=:Shewhdemohdemo] —
shrk.c [z:\hewhdema'.demo]
stacksct zc [=:Shewhdemohdemo] Remave Al
vectthbl zrc [z:\hewhdema'.demo]

| 2

Figure 2.6: Remove Project Files Dialog
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2. Select thefile or files which you want to remove from the “ Project files” list.
3. Click the“Remove” button to remove the selected files or click “Remove All” to remove all project files.
4. Click “OK” to remove the files from the project.
2 Toremove selected files from a project:
1. Select thefiles, which you want to remove, in the “ Projects’ tab of the “Workspace” window. Multiple
files can be selected by holding down the SHIFT or CTRL key.

2. Pressthe DEL key. Thefileswill be removed.

18
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223 Excluding a Project File from Build
A filein aproject can be individually excluded from build on a configuration by configuration basis.

2 Toexcludeafilein aproject from build:
1. Push theright mouse button on afile, which you want to be excluded from build, in the “Projects’ tab of
the “Workspace” window.
2. Select [Exclude Build file], where <file> is the selected file, from the pop-up menu (figure 2.5). Then a
red crosswill be put on the file’sicon, and the file will be excluded from build.

224 Including a Project Filein Build
An excluded file can be included in the project again.

2 Toinclude afile which has been excluded from build:
1. Push the right mouse button on afile, which has been excluded from build, on the “ Projects’ tab of the
“Workspace” window.
2. Select [Include Build file ], where <file> is the selected file, from the pop-up menu. Then ared cross will
be removed from the file'sicon, and the file will be included in build.

23 File Extensionsand File Groups

The HEW can identify files by their extension. The system defines certain extens ons depending upon the tools,
which are being used. For example, if you are using a compiler then the .c extension will bein the “C source
file” group and be used as input to the compiler phase (figure 2.1, Typica Build Process). Additionally, the
HEW allows you to define your own extensions. For example, if the project you are devel oping uses assembler
source files the default extension may be .src. If you would like to use a different extension instead of .src

(e.g. .asm) then you can define a new extension and request that the HEW treatsit in the same way asa.srcfile.

File extensions and file groups can be viewed and modified viathe “File Extensions’ dialog (figure 2.7). Thisis
invoked by selecting [Project->File Extensions...]. Thisdiaog displaysall of the extensions and file groups,
which are defined within the current workspace.

Extension | Group - Ok I

D *.abs Absalute file

*.inc Aszsembly include file Cancel |

#.lis Assembly list file i

*.zrc Azzembly source fila ==
E#*n C header file Remove |
[Epist G list file =

*c C source file Open with...

*hpp G+t header file
*lpp o list file

P it = ile

D*.cpu CPU information file

Ei*avn e e T e mal _Ij
] 3

Figure 2.7: File Extensions Dialog
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The “File Extensions’ list shown in figure 2.7 is divided into two columns. On the left are the file extensions
themselves, whilst on the right are the file groups. Many file extensions can belong to the same group. For
example, assembler source files may have severa extensionsin asingle project (e.g. .src, .asm, .mar €tc) as
shown in figure 2.8.

[ JC ] ]

.SRC .ASM -MAR LB .LPF

Assembler source files C source files Library files

Figure 2.8: File Extensionsand Groups

When creating a new extension you should consider whether the extension belongs to a group, which is aready
defined, or whether you need to create a new file group. If you are adding a completely new type of file then you
will want to create anew file group. This process is described below.

) To creste anew file extension in anew file group:

1. Select [Project->File Extensions...] from the menu bar. The “File Extensions’ dialog will be displayed
(figure 2.7).

2. Click the“Add...” button. The “Add File Extension” dialog will be displayed (figure 2.9).

3. Enter the extension, which you want to define into the “File extension” field. It is not necessary to type
the period ( . ) character. Thedrop list contains all extensions that are undefined in the current project.
Selecting one of these extensions will add the text to the file extension field automatically.

4. Select the “Extension belongsto anew group” option and enter a description, which definesthis new file
group.

5. Atthisstageit is possible to change the associated application. There are four available choicesin the

“Open” with drop list. These are listed below:

»  Editor
* None
e Other

*  Windows default

If the editor is selected, the open file function in the workspace window causes the file to be opened in the

HEW editor. If noneis selected then the open operation is disabled when the open file function is
attempted. Selecting “Other” allows you to configure an another tool for the open file operation. See“To
associate an application with a file group” for more details. If the “Windows default” option is selected
then the open file function in the workspace window passes the open file to the Windows operating
system. Thisthen selects the default behavior for thisfile extension as defined in Windows Explorer.

6. Click “OK” to add the extension to the “File Extensions’ list.

20
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—File extension:

Cancel

i

—File group:

& Extension kelongs to an existing group:

[Absolute file =l

" Extension belongs to a new group:

—Associated application:
Open " Absolute file™ with:
Windows default j

TlEalifie.

Bemuye

Il

Figure 2.9: Add File Extension Dialog (New Group)

If you want to create a new extension because your project uses a different extension from those accepted by the
HEW. For example, a phase might by default use the extension .asm but the HEW only recognizes .src. Then
you need to create a new extension and add it to an existing file group. This processis described below.

) To creste anew file extension in an existing file group:

1. Select [Project->File Extensions...] from the menu bar. The “File Extensions’ dialog will be displayed
(figure 2.7).

2. Click the“Add...” button. The “Add File Extension” dialog will be displayed (figure 2.10).

3. Enter the extension, which you want to define into the “File extension” field. It is not necessary to type
the period ( . ) character. The drop list contains all extensions that are undefined in the current project.
Selecting one of these extensions will add the text to the file extension field automatically.

4. Select the “Extension belongsto an existing group” option and select which group you would like to add
this new extension.

5. Click “OK” to add the extension to the “File Extensions’ list.
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—File extension:

®-  |asm -
Cancel

i

—File group:

& Extension kelongs to an existing group:

IAssemny source file j

" Extension belongs to a new group:

—Associated application:

DOpen " Assermbly source file™
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TlEalifie.
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Bemuye

Figure 2.10: Add File Extension Dialog (Existing Group)

In addition to opening a file with the editor, the “ File Extensions” dialog allows you to associate any application
with any file group so that when you double click on afilein the “Projects’ tab of the “Workspace” then the
appropriate application islaunched with the file. Figure 2.11 shows the association between a word processor
and the extension .DOC.

Extension | Giroup Al Ok I

* Ipp Co+ list file

Texteditor —= % cpp O+ source file Cancel |

D*.cpu CPU information file

Word processor —EF +.doc Documents il
*.exp Expanded assembly source file Remave |
Librarian -@*.Iib Library file =
EEAE Library list file Opeer with.,
*.sct Library section list file
*.rnap Lirkage map filz
*.fsy Linkage symbal file
Mo applization —— ] #.0bj Object file

S Dvoremraccad M coivna fils i
1 |

Figure 2.11: File Groupsand Applications
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2 To associate an application with afile group:
1. Select thefile group to be associated from the “File Extensions’ dialog (figure 2.11).
2. Click the“Open with...” button. The“Modify File Extension” dialog will be displayed (figure 2.12).

Group:

Linkage map file

—Associated application: Cancel |

Open " Linkage map file™ with:

Mane j

Edlitor

Other

YWindows default

Figure 2.12: Modify File Extension Dialog

3. Select “Nong’ to remove any association, select “Editor” to open thistype of filein the internal/external
editor or select “ Other” if you want to open thistype of file with a specific application. If you select
“Other” then you can select from any previoudy defined application from the drop-down list or specify a
new application.

4. Click “Add..."” to define anew application. The “Add Application” dialog will be displayed (figure 2.13).

Add Application EE3
Hame:
I Cancel |

LCormmand [excluding parameters]:

I Ll Browsze. . |

Parameters:

| il

nitial directany:

I
I Ll Browsze. . |

Figure 2.13: Add Application Dialog

5. Enter the name of the tool into the “Name” field. Enter the full path to the tool in the “Command” field
(do not include any parameters). Enter the parameters that are required to open afilein the “Parameters’
field. Be sure to use the $(FULLFILE) placeholder to specify the location file (see appendix C,
“Placeholders’, for more information on placeholders and their uses). Enter the initial directory, in which
you would like the application to run, into the “Initia directory” field. Click “OK” to create the
application.

6. Click “Madify...” to modify an application. The “Modify Application” dialog will be displayed. This
dialog isthe same asthe “ Add Application” dialog described above except that the “Name” field isread
only. Modify the settings as desired and then click “OK”.

23
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7. Click “OK” to set the application for the selected file group.
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24 Specifying How to Build a File

Once you have added the necessary files to the project the next step isto instruct the HEW on how to build each
file. To do this, you will need to select a menu option from the “ Options” menu. The contents of this menu
depend upon which tools you are using. For example, if you are using a compiler, assembler and linker then
there will be three menu options, each one referring to one of the tools.

2 To set optionsfor abuild phase:
1. Select the options menu and find the phase whose options you would like to modify. Select this option.
2. A dialog will be invoked which allows you to specify the options.
3. After making your selections, click “OK” to set them.

To obtain further information, use the context sensitive help button or select the areain which you need
assistance and then press F1.
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25 Build Configurations

The HEW allowsyou to store all of your build optionsinto a build configuration (figure 2.14). This means that
you can “freeze” all of the options and give them a name. Later on, you can select that configuration and all of
the options for all of the build phaseswill be restored. These build configurations also allow the user to specify
debugger settings for a build configuration. This means that each configuration can be targeted at a different end
platform. (See Simulator/Debugger Part in this manual, for further information).

Figure 2.14 shows three build configurations; “ Default”, “MyDebug” and “MyOptimized”. In the first
configuration, “Default”, each of the phases (compile and assemble) are set to their standard settings. In the
second configuration, “MyDebug”, each of the files are being built with debug information switched on. In the
third configuration, “MyOptimized”, each of the files are being built with optimization on full and without any
debug information. The developer of this project can select any of those configurations and build them without
having to return to the options dialogs to set them again.

"Default" "MyDebug" "MyOptimized"
Configuration Configuration Configuration
— Debug: ON Debug: ON Debug: OFF
Optimize: OFF 'Optimize: OFF Optimize: ON
List File: YES | List File: NO | | List File: NO | H
C
Source Files
— Debug: OFF Debug: ON Debug: OFF
Optimize: OFF 'Optimize: OFF Optimize: ON
List File: YES | List File: NO | | List File: NO | H
Assembler
Source Files
C:\MyProject\Default C:\MyProject\MyDebug C:\MyProject\MyOptimized

Figure 2.14: Configurations and File Options
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251 Selecting a Configuration
The current configuration can be set in two ways:
Either:

1. Select it from the drop down list box (figure 2.15) in the toolbar.

IHeIease J

Release

Figure 2.15: Toolbar Selection
or:

1. Select [Options->Build Configurations...]. Thiswill invoke the “Build Configurations’ Dialog (figure
2.16).

Build Configurations

Build configurations: 0k

Debug
Release Cancel

Add

HEmove

e

Current configuration:

Debug j

Figure 2.16: Build Configurations Dialog
2. Select the configuration that you want to use from the “ Current configuration” drop down list.
3. Click “OK” to set the configuration.
252 Adding and Deleting Configurations

Y ou can add a new configuration by copying settings from ancther configuration or delete a configuration. These
three tasks are described below.

2 Toadd anew configuration:
1. Select [Options->Build Configurations...] to display the “Build Configurations’ dialog (figure 2.16).
2. Click the“Add...” button. The “Add Configuration” dialog will be invoked (figure 2.17).

27




High-performance Embedded Workshop User’s Manual

Add Configuration

Configuration name: IMPCDHHQ
Cancel |
Bazed on configuration: IDehug j

Configuration directary: c:vhew' demaotdemai iy Caonfig

Figure 2.17: Add Configuration Dialog

3. Enter the new configuration name into the “Configuration name” field. Asyou enter the new
configuration name, the directory underneath changes to reflect the configuration directory that will be
used. Select one of existing configurations, from which you want to copy a configuration, out of the drop-
down list of the “Based on configuration” field. Click “OK” on both diaogs to create the new
configuration.

2 To remove aconfiguration:
1. Select [Options->Build Configurations...] to display the “Build Configurations’ dialog (figure 2.16).
2. Select the configuration that you want to remove and then click the “Remove” button.
3. Click “OK” to close the “Build Configurations’ dialog.
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2.6 Building a Project

The outline of the build processis shown in figure 2.1.

26.1 Building a Project

The build option only compiles or assembles those files that have changed since the last build. Additionally, it
will rebuild sourcefiles if they depend upon afile that has changed since the last build. For instance, if thefile
“test.c” #include' sthe file “header.h” and the latter has changed since the last build, the file “test.c” will be
recompiled.

2 To perform abuild:
Select [Build->Build] or click the build toolbar button () or press F7 or click the right mouse button on a
project icon in the “Projects” tab of the “Workspace” window and select [Build] from the pop-up menu.

The build al option compiles and assembles all source files, irrespective of whether they have been modified or
not, and links all of the new object files produced.

2 Toperform abuild all:
Select [Build->Build All], or click the build all toolbar button (&), or click the right mouse button on a
project icon in the “ Projects” tab of the “Workspace” window and select [Build All] from the pop-up menu.

Both the build and the build &l will terminate if any of the project files produce errors.

26.2 Building Individual Files
The High-performance Embedded Workshop |ets you build project filesindividually.

2 Tobuild anindividua file:
1. Select the file which you want to build from the project window.
2. Select [Build->Build File], click the build file toolbar button (82) or press CTRL +F7 or click theright
mouse button on afileicon in the “ Projects’ tab of the “Workspace” window and select [Build <file>]
from the pop-up menu.
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26.3 Stopping a Build
The High-performance Embedded Workshop allows you to halt the build process.

2 To stop abuild:
1. Select [Build->Stop Build] or click the stop build toolbar button (Z%). The build will be stop after the
current file has been built.
2. Wait until the message “Build Finished” appearsin the “Output” window before continuing.
2 Toforcibly terminate a current tool
1. Select [Build->Terminate Current Tool]. The HEW will attempt to stop the tool immediately.

Note: Do NOT assume that any output from the tool you terminated isvalid. It is recommended that you delete
any output files produced and ensure that the phase is executed again.

264 Building Multiple Projects
The High-performance Embedded Workshop | ets you build multiple projects and configurations at once.

2 Tobuild multiple projects:

1. Select [Build->Build Multiple]. The figuredisplayed in figure 2.18.

2. Thebuild multiple gives you the choice of which projects and configurations should be built. To select
which projects and configurations need to be built select the check box next to the project —
configuration combination you want to build. For example, in figure 2.18 if you wanted to build the
entire “hewtest2” project you would check the “hewtest2-Debug” and the “ hewtest2-Release” selections
and leave al other check boxes unchecked.

3. When you are happy with your chosen selection click the build button and the HEW will then build the
projects and configurations you have chosen.

4. If youwant to build all the projects, which you choose, you click the build all button.

5. Reaults from the build are displayed in the build window in the same way as the normal build process.

Build Multiple E3

[ Thevatest]-Debug -
[ hevatest]-Release

[ hewtest2-Debug Bwild Al

[ hevatests-Release
[ hevatest3-Debug
C | |
[ 1hevatest3-Release nee
[ 1hevatestd-Debug

[ hevatestd-Release
[ 1hevatest5-Debug

[ hevatesth-Release -
4| | 3

Figure 2.18: Build Multiple Dialog

265 The Output Window

When atool executes (i.e. compiler, assembler, linker etc.) its output is displayed in the “ Output” window. If any
of the tools produce any errors or warnings then they are displayed along with the source file name and the line
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number at which the error islocated. To quickly locate a specific bug, double click on agiven error/warning to
invoke the current editor.

26.6 Contralling the Content of the Output Window

It is often useful to display low-level information (such as the command line options that are being applied to a
file) during abuild. The HEW allows you to specify whether or not you want such options displayed in the
“Output” window during a build, build al or build file operation viathe “Tools Options’ dialog.

2 Toview or hide extrainformation during a build:
1. Select [Tools->Options...]. The“Options’ dialog will be displayed.
2. Select the“Build” tab (figure 2.19).

3. Set the three check boxesin the “ Show” group as follows. “Command line” controls whether the
command line is shown as each tool is executed. “ Environment” controls whether the environment is

shown as each tool is executed. “Initial directory” controls whether the current directory is shown as each

tool is executed.

Options EE3

Buid |Editnl | Wworkspace | Confirmation | Metwark |

— Errarg and warnings:

[ Stop build if the number of ermors exceads: I 0

[ Stop build if the number of warnings exceeds: I i]

 Show:
[ Command line
[ Enwironment

[ Initial directon

ak. I Cahicel

Figure 2.19: Options Dialog Build Tab
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2.7 File Dependencies

A typical project will contain dependencies between files, for example, one C file may “#include” one or more
header files. In complex projects, source files will include (or depend upon) others and this can quickly become
difficult to manage. However, the HEW provides a dependency scanning mechanism whereby all filesin a
project are checked for dependencies. Once complete, the project window will display an up-to-date list with all
the project file dependencies.

2 To update aproject’s dependencies:
Select [Build->Update All Dependencies] or click the right mouse button on a project icon in the “ Projects’
tab of the “Workspace” window and select [Update All Dependencies] from the pop-up menu.

Initially, the dependencies for all files are contained within the “ Dependencies’ folder (figure 2.20.i).

2.8 Configuring the Workspace Window

If you click the right mouse button anywhere inside the “ Projects’ tab of the “Workspace” window, a pop-up
menu will be invoked. Select the “ Configure View...” menu option to modify the way in which information is
displayed. The following four sections detail the effect of each option on the “Configure View” diaog.

281 Show Dependencies under Each File

If you select “ Show dependencies under each file”, the dependent files are shown under the including source file
as aflat structure, i.e. the files themselves become folders (figure 2.20.ii). If this option is not selected then a
separate folder contains all dependencies (figure 2.20.i).

¥l & Workspace 1 (=1 E3 @7l = Workspace =] EE
E--@ Demno E!@ Drema
R B
Ea Azsembly source file E\ﬁ Agzembly source file
L [H lowhsie I lawlvl.src

E| 24 € source file E| £ C source file
4] dbsctc i8] dbsctc
Demo.c
intprg.c
-- wecth

lowsre.c

Demo.c
intprg.c
lowesre.

resetprg.c
shrk.c - E] lowsich
£] vecttblc resetprg.c

I_;! 2 Dependencies

-[E] stackscth
lowsrc.h shrk.c
sbikh sbrkch
2] stackscth vechtbl.c
--[E] vecth " [B] wecth
@ijed: IE Termplates I ] Maigation I @ Projects IE Templates I “_] Mavigation I

Figure 2.20: Dependencies under Each File
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Show Standard Library Includes

By default, any dependent files found in standard include paths will not be shown (figure 2.21.i). For example, in

C code, if you write an include statement such as “#include <stdio.h>" then stdio.h will not be listed asa
dependent file. To view such system includefiles, select the “ Show standard library includes’ option (figure

2.21ii).

Il & ‘Woikspace H[=] 3

=3

@ Demo
- Agzembly source file
g c0.serc

=4 € source file
hiwickg.c

inty.c

main. c

shrk.c

=39 Dependencies

N @Pmiem IE Templates J 'i’:lNa\rigaﬁon I

Dependencies

stddef h
stdio.h

| @ijec’tx IE Templates ‘ *i’:lNavigaﬁon

Figure2.21: Standard Library Includes
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283 Show File Paths

If “Show file paths” is selected, all of the filesin the project window are shown with their full path, i.e. from a
drive letter (figure 2.22).

<& Workspace H=] B3

E@

=-[E Demo
-4 Aszembly source file
C\Hew2DemosDemohcl s
-5 T source file

3 C:Hew2\DemosDemo\hwofo.c
C:s\Hew2WDemosDemohinty.c
C:s\Hew2DemosDemohmain. c
C\Hew2DemosDemohzshbrk. o

N ) Projects l ] Terplates | =] plawigation I

Figure 2.22: File Paths Shown

2.9 Setting the Current Project

A workspace can contain more than one project but only one of the projects can be active at any time.  This
active project is the one, which build actions and debug operations can be performed on. There are three states a
project can bein. The current project, aloaded project or an unloaded project. If the project isloaded it is
possible to open the project files directory and view thefiles. It isalso possible to change the builder or
debugger options for the project. A loaded project can have tool executions performed on it from the [T ools]
menu. If the project is unloaded, itsicon appears “grayed” in the “Projects’ tab of the “Workspace” window and
no actions can be performed upon it. Y ou can set which project is active in a workspace.

2 To set aproject asthe current project:
1. Select the project from the “Projects’ tab of the “Workspace” window.
2. Click the right mouse button to display the pop-up menu and select the [Set as Current Project] option.
or:
1. Select the project, which you want to make active from the [Project->Set Current Project] sub-menu.

2 Toload aproject in the workspace:
1. Select the unloaded project from the “Projects’ tab of the “Workspace” window.
2. Click the right mouse button to display the pop-up menu and select the [Load Pr oject] option.
3. Thiswill also set the project that wasjust loaded as the current project.

2 Tounload aproject in the workspace:

1. Select the active project from the “ Projects’ tab of the “Workspace” window.
2. Click the right mouse button to display the pop-up menu and select the [Unload Project] option.
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Inserting a Project into a Workspace

When aworkspace is created, it contains only one project but, after it is created, you can insert new or existing
projects into aworkspace.

2 Toinsert anew project into aworkspace:

1

Note:

Select [Project->Insert Project...]. The“Insert Project” dialog will be displayed (figure 2.23).

2. Setthe“New Project” option.
3.
4. Enter the name of the new workspace into the “Name” field. This can be up to 32 charactersin length and

Click OK. The “Insert New Project” dialog will be invoked.

contain |etters, numbers and the underscore character. As you enter the project name the HEW will add a
subdirectory for you automatically. This can be deleted if desired.

Click the “Browse...” button to graphically select the directory in which you would like to create the
project. Alternatively, you can type the directory into the “ Directory” field manualy.

The “Project type” list displaysall of the available project types (e.g. application, library etc.). Select the
type of project that you want to create from thislist.

Click “OK” to create the project and insert it into the workspace.

When anew project is being inserted, the CPU family and tool chain cannot be specified as these

properties are aready defined by the workspace (i.e. al projects within the same workspace target the
same CPU family and toolchain).

Insert Project

Inzert

Cahicel |

" Existing project;

Browse),. |

Figure 2.23: Insert Project Dialog
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2 Toinsert an existing project into a workspace:
1. Select [Project->Insert Project...]. The“Insert Project” dialog will be displayed.
2. Setthe“Existing Project” option.
3. Enter the full path of the project database file ((HWPfile) into the edit field or click “Browse...” to
search for it graphically.
4. Click “OK” to insert the existing project into the workspace.

Note: When an existing project is being inserted into a workspace, the CPU family and tool chain upon which

that project is based must match those of the current workspace. If they do not then the project cannot be
inserted into the workspace.

211  Specifying Dependencies between Projects

The projects within aworkspace can be dependent upon one another so that when one project is built, all its
dependent projects are built first. Thisis useful if another project uses one of the othersin the workspace. For
example, imagine that a workspace contains two projects. The first project isalibrary that isincluded by an
application project. In this case the library must have been built and up to date before the second application can
build correctly. To achieve this situation we can specify the library as a dependent (i.e. child) project of the
application project. Thiswould then alow thelibrary to be built first if it is out-of-date.

When a dependent project is built the HEW attempts to match the configuration in the dependent project with
that of the current project. This meansthat if the current configuration is“Debug” then the HEW will attempt to
build the “Debug” configuration in the dependent project. If this matched configuration does not exist then the
HEW will use the configuration that was last used in the dependent project.

2 To make projects depend upon another:
1. Select [Project->Dependent Projects]. The“ Dependent Projects’ dialog will be displayed.(figure 2.24)
2. Select the project to which you would like to add dependents to. When you do this, the “ Dependent
projects” list will display al of the projects in the workspace (excluding the selected project).
3. The*Dependent projects’ list has a check box for each project listed. Set the associated check boxes to
make those projects depend upon the selected project.

4. Click “OK" to confirm the new project dependencies.

Dependent Projects EHE

Froject:

I main_project j

Cancel |

i

Figure 2.24: Dependent Projects dialog
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212  Removing a Project from a Workspace

2 To remove aproject from aworkspace:
1. Select the project from the “ Projects’ tab of the “Workspace” window and click the right mouse button to
invoke a pop-up menu.
2. Select the [Remove Project] option.
or:
1. Select the project from the “Projects’ tab of the “Workspace” window.
2. Pressthe DEL key.

3. Dialog box isdisplayed. You confirm to remove the project. In the “Options’ diaog box of the “Tools”
menu, you can select this confirmation is performed or not.

Note: You cannot remove the current project from the workspace.

213 Loading/unloading a Project into/from a Workspace

2 Toload aproject into a workspace:
1. Select the project from the “ Projects’ tab of the “Workspace” window and click the right mouse button to
invoke a pop-up menu.
2. Select the[Load Project] option.

2 Tounload aproject from aworkspace:
1. Select the project from the “Projects’ tab of the “Workspace” window and click the right mouse button to
invoke a pop-up menu.
2. Select the [Unload Project] option.

Note: You can load or unload plural projects at atime. That is more efficient to load or unload a project
individually.
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214 Relative projects pathsin the workspace

In the High-performance Embedded Workshop when you add a project to the workspace you can choose to add
the project to the workspace using arelative path. This allows you to position a project above the workspace
directory and it will still be relocated correctly if you relocate the HEW workspace. The project is aways
relative to the workspace so if the project is one directory above the workspace before it is moved the HEW will
try to find the project in the same relative location after the relocation procedure. Thisis especialy useful if you
are using a project shared between more than one workspace.

In older versions of the HEW this project would not have been relocated and would have still tried to access the
origina project path. The older version of the HEW could only relocate the projects, which werein a
subdirectory of the workspace directory. Thisis till the standard behavior for the High-performance Embedded
Workshop.

2 To change a projects rel ative path flag:
1. Select the project in the workspace window.
2. Right click and then select properties.
3. Click the “Project relative file path” checkbox to switch on or off the relative file path feature. (figure

2.25)
4. Click “OK”.

Properties
Narme: |Dema_Ha5 25008 ok,
Lacation: “HewsDemo_HBS26004\Demo_HES260045\Dema_HBS 26004 hwp

Cahicel
Last modified: 09:40:52, Monday, June 23, 2003
CPU Farnily: H85 H8/300
Tool chain: Hitachi HES H8/300 Standard Toalchain
Yersion; E.0.0.0
" Project relative file path

Figure 2.25: Properties Dialog
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User foldersin the workspace

In the High-performance Embedded Workshop it is possible to add folders to your workspace window. This
allows you to logically group your filesinto certain areas within a project. The folder can be set to any name and
thisis entered in adialog.

2 Toadd auser folder:

1
2.
3.
4.

Select the project in the workspace window.

Right click and then add folder.

Enter the name and click OK.

Y ou can now drag and drop filesinto this folder to group them logically.

2 Toremove auser folder:

1
2.

Select the project in the workspace window.

Right click and then select Remove folder. Note that the folder must be empty and that the delete key
can aso be used instead of the pop-up.

2 To modify auser folder name:

1.

2.
3.
4

Select the project in the workspace window.
Right click and then select Modify folder name.
Enter the new name in the dialog.

Click “OK”.
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3.  Advanced Build Features

This chapter explains the more advanced build concepts.

31 The Build Process Revisited

Chapter 2, “Build Basics’ began by describing the build processin terms of a compiler, an assembler and a
linker (figure 2.1). Thiswill be the case for most installations of the High-performance Embedded Workshop.
However, if you want to begin changing the build process (e.g. adding and removing phases) then it isimportant
to understand more about the way in which abuild functions.

311 What isa Build?

Building a project means applying a set of tools upon certain input filesin order to produce the desired output.
Thus, we apply a compiler upon C/C++ source filesin order to create object files, we apply an assembler upon
assembler source filesin order to create object files and so forth. At each step or “phase” of the build, we apply a
different tool upon adifferent set of input files. Figure 3.1 presents another view of the build process.

E BEGIN E
Bl N
Phase 1 Input Files ‘ Phase 1 Output Files
B N
Phase 2 Input Files ‘ Phase 2 Output Files

Phase 3 Output Files

Phase 3 Input Files

T e |

Phase X Input Files ' Phase X Output Files

Figure 3.1: Build Process

The High-performance Embedded Workshop provides the ability to change this build process viaits“Build
Phases” dialog, which can be, accessed via the [Options->Build Phases...] (figure 3.2). On theleft-hand side
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are the phases that are defined in the current project (Figure 3.2 shows a standard set of build phases). The
remainder of this chapter details the various functions that the “Build Phases’ diaog provides.

Build Phases

Build Order | Build File Order | File Mappings |

Build phaze order;

[w]HE5 HE/300 C/C++ Library Gernerator Add.
[W]HE5 HE/300 C/C++ Compiler -
[WHES H3/300 Assembler Iadity:
[w] OptLinker

(v MyPhaze HEmove

fd ene (e

Iy e

P I I _,I Impart...

L

Cancel |

Figure 3.2: Build Phases Dialog
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3.2 Creating a Custom Build Phase

If you want to execute another tool before, during or after a standard build process then this can be achieved by
creating your own (i.e. custom) build phase.

Select [Options->Build Phases...] to invoke the “Build Phases’ dialog (figure 3.2) and then click the “Add...”
button. This will invoke the new build phase wizard diaog (figure 3.3a).

Thefirst step (as shown in figure 3.3a) asks whether you want to create an entirely new phase or whether you
want to add a system phase. A system phaseisa*“ready made” phase which is aready defined within the
toolchain you are using (e.g. compiler, assembler, linker, librarian, etc.) or a utility phase (e.g. file copy,
complexity analyzer etc.).

The “Add an existing system phase” button isinactive if no more system phases are available. Select the “Create
anew custom phase” button to create your own build phase.

Mew Build Phase - Step 1 of 4 HE

wihat type of phasze would you like ta add 7

* Create a new custom phasze

€0 feddl | & existing epsten phase:

Syztem Phaze | Wergion |

< Each | Hewt » | Cancel

Figure 3.3a: New Build Phase Dialog (Step 1)
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The second step (figure 3.3b) asks what type of phase you would like to create. There are two choices: multiple
or single. When a multiple phase is executed, the command is applied to each file in the project of acertain file
group. For example, if you set the input file group to be C source files then the command will be executed once
for each C sourcefilein the project. A single phase is executed once at most during a build.

New Build Phase - Step 2 of 4
)
Wwhat tppe of phaze would vou like to create?

& Multiple phase:

The cammand is applied to each file in a file group.
An example of this type of toal iz a compiler or assembler.

Select input file group:

' Single phase:

The command iz only ever executed once per build.
An example of this type of toal iz a linker.

< Back | Heut » | Cancel

Figure 3.3b: New Build Phase Dialog (Step 2)

Theinput file group list contains the current file groups defined for the project. It is possible to define multiple
input file groups by selecting the “Multiple Groups...” entry in the input file group list. Selecting thislist entry
displaysthedidog in figure 3.3c.

Select Groups EHE
[ |Azsembly source file ;I
[ |Binary file
[ 1C header file Cancel |
[IC list file:
(w|C zource file

[ |C++ header filz
[ 1C++ list file

[ |CPU infarmation file

[ |Expanded azsembly zource file _Ij
[l | | »

Figure 3.3c: Modify multipleinput file groups

Once this choice has been made the input file group selection is displayed as “Multiple Groups...” Thisdialog
allows the user to choose multiple input file groups for the custom phase being added to the project. To select a
file group check the box next to the file groups name. One or more file groups can be selected in this dialog.
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The third step (figure 3.3d) requests the fundamental information about the new build phase. Enter the name of
the phase into the “ Phase name” field. Enter the location of the program file into the “Command” field (do not
insert any command line options as these options are specified via the [Options] menu of the HEW menu bar).
Specify the default options for the phase (i.e. what options you would like new files to take when added to the
project) into the “ Default options’ field. If you have a preferred directory in which you would like this program
to run from (i.e. where you want the current working directory to be set to before the tool is executed) then enter
itinto the “Initial directory” field.

New Build Phase - Step 3 of 4
)

Phaze name:
IM_I,JF'hase

LCaommand [excluding parameters):
Ic:'\tnnlskmytnnl.er:d [ 3 | Bromze. . |

Ciefault options:

[sFULLFILE) Ll

Initial directory:

[$(CONFIDIR) Ll Browmse... |

< Back | Heut » | Cancel |

Figure 3.3d: New Build Phase Dialog (Step 3)
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The fourth and final step (figure 3.3e) allows you to specify any environment variables, which the phase requires.

Mew Build Phase - Step 4 of 4
)

Does the command require any ervironment vaniables to be sety

If =0, enter them into the: lizk below:

ENv=1024
i |
e |
KN I

[ Eead Output On Fly

< Back | Finish | Cancel |

Figure 3.3e: New Build Phase Dialog (Step 4)

To add anew environment variable click the“Add...” button (the dialog shown in figure 3.4 will be invoked).
Enter the variable name into the “Variable” field and the variable’ s value into the “Value® field and then click
“OK” to add the new variable to the list of the fourth step. To modify an environment variables select the
variablein the list and then click the “Modify..."” button. Make the required changes to the “Variable” and
“Vaue’ fields and then click “OK” to add the modified variable to the list. To remove environment variables
select the variable that you want to remove from the list and then click the “Remove’ button.

Environment ¥arnable EHE

Wariable:

[PaTH

Walue:

Ic: wdos e mytools o windowes o temp | 3 I| Eéﬁ':ﬂ::;

Figure 3.4: Environment Variable Dialog

If the tool you are adding can display its output as the tool is running then use the ‘ Read Output On Fly’ option.
Thiswill display the tool output as each line of output happens. If this option is set to off then the HEW will
store all output, which is being displayed by the tool, and display it in the output window when the tool has
finished its operation. This can be a problem when the toal is running an operation that might take many
minutes, asit is difficult to see the progress of the current execution.

Note: Using ‘Read Output On Fly’ can cause problems when using certain tools on certain operating systems.
If you are having problems with tools locking up or freezing in HEW then uncheck the ‘ Read Output On
Fly’ option.

Click the “Finish” button to create the new phase. By default the new phase is added to the bottom of the “Build
Phase Order” list in the “Build Order” tab of the “Build Phases’ dialog (Figure 3.2).
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33 Ordering Build Phases

In astandard build (shown in figure 3.5), you could add a phase at four different positions: before the compiler,
before the assembler, before the linker or after the linker. Y ou may place your own custom phases or move
system phases to any position in the build order. It isimportant to remember that if the output of your custom
phase can be input into another phase then the phase order must be correct if the build isto behave as intended.

<

COMPILE
| «
| «

LINK

®

®

etl

Figure 3.5: Typical Build Process

The build phase dialog provides facilities for ordering build phases via the “Build Phases’ dialog. It has two tabs,
which are concerned with the ordering of phases: “Build Order” and “Build File Order”.
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331 Build Phase Order
The“Build Order” tab (figure 3.6) displays the current order in which phases will be executed when the build

currently enabled. By clicking this box, the phase can be toggled on or off.

Build Phaszes

Build Ordler | Build File Order | File Mappings |

Build phase order:

Cancel

[w]HBS5 HB/300 C/C++ Library Generator Add... |
[w|HB5 HB/300 C/C++ Campiler -
[WHES HE/300 Assembler Ll el |
[w|OptLirker |
(w|byFPhaze Efernoy
e |
[t B |
P I I _,I Import... |

Figure 3.6: Build Phases Dialog Build Order Tab
In addition the following operations can be performed:

2 Toremove aphase:
1. Select the phase that you would like to remove.
2. Click the“Remove” button.
2 Toview the properties of a system phase:
1. Select the system phase that you would like to examine.
2. Click the“Modify...” button.
2 To move aphase
1. Select the phase that you would like to move.
2. Click the“Move Up” or “Move Down” button.
2 Toimport aphase:
1. Click theimport button. A dialog isdisplayed which allows the user to browse to an existing project to
import a custom phase from.
2. Choose thelocation of the project you wish to import a custom phase from. Once selected adialogis
displayed which lists the custom phases in the imported project.

3. Selecting a phase name and then clicking properties displays the custom phase details. This allowsyou
to decide whether the phase does the functionality you require.

4. Onceyou have decided which phase to import highlight it in the list and then click OK. The phase will
then be added to the build phases dialog at the bottom of the build order.
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2 To modify acustom phase:

1. Select the custom phase that you would like to modify.
2. Click the“Modify...” button. The modify phase diaog will be invoked with the “Command” tab selected
(figure 3.7).
3. Change the contents of the fields as appropriate.
4. Setthe“Don’'t check for input file(s) existence before executing” check box if you don’t want the HEW
to abort the execution of the phaseif any of the input filesdon’t exist.
5. Select “Read Output On Fly” checkbox to display build output asit happens, rather than showing the
output at the end of each phase execution.
Modily MyPhase [ 2] x|
Carnmand | Environmentl
LCommand [excluding parameters):
IE:\tnnIs\mytnnl.eHe Ll Browsze. |
Initial directany:
[$ICONFIGDIR] | Bowse |
[~ Daon't check for input file(s] existence before executing
™ Eead Output On Fly
ak I Cancel
Figure 3.7: Modify Phase Dialog Command Tab
6. Select the“Environment” tab (figure 3.8) to edit the environment settings for the phase.
7. Usethe“Add...”, “Modify...” and “Remove’ buttons to add, modify and remove environment variables.
The operation is the same as discussed in the previous section.
8. Click “OK" when all modifications have been made.
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Modify MyPhase

Command ~ Environment |

Environment settings:

PaTH=c: \dos;c: ools
SHOWALL=FALSE

EMv=1024 e |
Eemnowe |

ok |

Cancel |
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332 Build File Phase Order

If you were to select a C source file from the “Workspace” window and then activate [Build->Build File] (or
press ) you would expect the file to be compiled. Likewise, if you were to select an assembly source file from
the workspace window and then activate [Build->Build File] you would expect the file to be assembled. The
connection between file group and which phase(s) to execute is managed by the “Build File Order” tab of the
“Build Phases’ diaog (figure 3.9).

Build Phases EE3

Build Order  Build File Qrder | File Mappingz I

File group: Phasze arder:
Aszembly source file [w] Carnpiler ®
[w|tyPhase $

C++ gource file

q | i3
ak. I Cancel |

Figure 3.9: Build Phases Dialog Build File Order Tab

Thelist displaysall of the current phases that will be executed when the build file operation is selected upon the
file group shown in the “File group” list box. In figure 3.9 the “C sourcefile” file group is selected and the
“Compiler” and “MyPhase” phases are associated with it.

Entriesin the “Phase order” ligt, of the “Build File Order” tab, are added automatically as new entries are added
to the “Build Order” tab. For example, if you were to add a phase which takes C source files asinput then this
phase will be automatically added to the list of phases to execute when a build file operation is appliedtoaC
source file. If you don't want a certain phase to execute when [Build->Build Fil€] is selected then clear the
check box to the left of the phase name in the “Phase order” list.

34 Setting Custom Build Phase Options

Once you have defined a custom phase, you will want to specify the command line options that should be used
when it is executed. Each defined phase has a menu option on the [Options] menu. To specify options for that
phase select it. The dialog that will be invoked depends upon whether the custom phase sel ected was a multiple
or single phase (according to the selection of phase typein figure 3.3b).
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Phasel... Options 2 x|
IDebug ﬂ Dptions |Dutput Files | Dependent Files
EII@ hestest = il
223 C source file Ip:\_hew-fileskDns&windows erecutablesh\CMOLINE EXE
hewtest.c
initzct o Ol
Ophions:
a FULLFILE
shrk.c s ]
: vectthl.c
[ D Default Options
[]---I@ hevatest]
[]---I@ hewtest2
EII@ evtestd

C source file Flaceholder:

hevtestd o

- File path + name - Inzert
nitzct.c —

intprg.c

e shrk.c =
1| ' | ¥

ak I Cancel |

Figure 3.10: Custom Options Dialog

Thedialog in figure 3.10 is a custom phase options dialog. The implementation of which isdightly different
depending on whether you are using amultiple or single shot phase. On the left-hand side is the project and file
list. Itispossibleto select multiple projects and filesin the same way as Windows explorer to modify the
options for more than one selection. On the right-hand side are the 3 options tabs. Thisis where you set the
options that you want to apply to the selected file(s). You can aso choose which configuration information is
being viewed from the configuration list on the upper left of the didog box. Each configuration islisted along
with aspecia entry named “Multiple configurations...”. If you select multiple configurationsthen adialog is
displayed which allows you to select more than one configuration. This method is used throughout HEW for
modifying multiple configurations at once.

341 Options Tab

The “Options’ tab (figure 3.11) alows you to define the command line options that will be passed to the phase.
The “Command” field displays the command, which was entered when you defined the phase (figure 3.3d).
Enter into the “Options” field the command line arguments that you would like to pass to the command. If you
want to insert a placeholder, select the relevant placeholder from the “Placeholder” drop-down list box and then
click the “Insert” button. For a detailed description of placeholders see appendix C, “Placeholders’.
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Option:s | Cutput FiIesI Diependent FiIesI

Cammand:
IC: YHewh ToolchaingHitachivSHYWA1 DAEIMYLbr.exe

Options:
-sub=$[COMFIGDIRMbuildlib.zub

Placeholder:

" - - | rt bt
Configuration directan j Inzert :I—— fzf.zlaceho:;er

ak. I Cahicel |

Figure 3.11: Custom Options Options Tab

342  Output FilesTab

The “Output Files’ tab (figure 3.12) is where you can specify the output file or files that will be produced by the
phase. Before each fileis passed into this phase, the HEW checks that the output files are of aless recent date
than the input file. If so, the phase will be executed for that file (i.e. input files have been modified since the
output file or files were last produced). If the files are up to date then the phase will not be executed.

Note: If no output files are specified, the phase will execute regardless.
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Options  Output Files | Dependent Files I

Add...

Modify... |
Bemove |

KN — il
ak I Cancel

Figure 3.12: Custom Options Output Files Tab

2 Toadd an output file:
1. Click “Add...”. The“Add Output File" dialog will beinvoked (figure 3.13).
2. Enter thefile path or browseto it using the “Browse...” button.
3. Click “OK” to add this output fileto the list.

Placeholder popup menu

Add Output File - 2 x|
File:
p | Browsze.. | Cance| |

Figure 3.13: Add Output File Dialog

2 To modify an output file:
1. Select the output file that you would like to modify.

2. Click “Modify...". The “Modify Output File” dialog, which isthe same as figure 3.13 except the title,
will be invoked.

3. Modify thefields as required and then click the “OK” button to add the modified entry back to the list.
2 Toremove an output file:

1. Select the output file that you would like to remove.

2. Click the“Remove” button.
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343 Dependent FilesTab

The “Dependent Files’ tab (figure 3.14) iswhere you can specify the dependent files that are needed by the
phase. Before each fileis passed into this phase, the HEW checks that the dependent files are of a more recent
date than the input file. If so, the phase will be executed for that file (i.e. dependent files have been modified
sincetheinput file or files were last modified). If not, the phase is not executed for the files.

Dptinnsl Output Files  Dependent Files |

HCUNEIGDIET
$ICOMFIGDIR]AFilet. obj

FICONFIGDIR ] File?. obj ;
${CONFIGDIR]WFilsS obi Madiy... |
oW Hewbwork zphProjecthDebughFileT. obj

c:WHewWwfork sphProject\Debug'File2. obj Remove |
oW Hewbwork zphProjecthDebughFile3.obj

c:WHewWwfork sphProject\Debug'Filed. abj

Add...

Figure 3.14: Dependent Files Tab in Custom Options
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2 To add adependent file:

1. Click “Add...”. The“Add Dependent File" dialog will be invoked (figure 3.15).

2. Enter thefile path or browseto it using the “Browse...” button.

3. Click “OK” to add this output fileto the list.

Placeholder popup menu
fidd Depandant Fils 2 x|
File:
p | Browsze.. | Cance| |
Figure 3.15: Add Dependent File Dialog

2 To modify adependent file:

1. Select the dependent file that you would like to modify.

2. Click “Madify..."”. The“Modify Dependent File” diaog, which is the same as figure 3.15 except the title,

will be invoked.

3. Modify thefields as required and then click the “OK” button to add the modified entry back to the list.

2 Toremove adependent file:
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1. Select the dependent file that you would like to remove.
2. Click the“Remove” button.
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35 File M appings

By default, the filesinput to a phase are only taken from the project, i.e. al project files of the type specified in
the “ Select input file group” drop-down list on the “New Build Phase” dialog (figure 3.3b). If you would like a
phase to take files output from a previous phase (i.e. intermediate files) then you must define thisin the “File
Mappings’ tab of the “Build Phases’ dialog (figure 3.16).

Build Phaszes 2 | x|

Build Order I Build File Order  File Mappings |

Intermmediate file mappingz for build;

Source | Destination | File Group
Agzembler Linker Object file

| fdd.. |
Campiler Linker Object file ldifi.. |
HEmove |

ak Cancel

Figure 3.16: Build Phases Dialog File Mappings Tab
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A file mapping states that you would like the HEW to pass output files of a certain type produced by one phase
(referred to as the source phase) to another phase (referred to as the destination phase). Such intermediate files
are passed in addition to the project files.

2 Toadd afile mapping:

1
2.

Click “Add..."”. The“Define File Mapping” dialog will beinvoked (figure 3.17).

Select the file group, which you want to pass between the phases from the “File group” drop-down list
box.

Select the source phase (i.e. which phase generates the files) from the “ Source phase” drop-down list box.
Select the destination phase (i.e. which phase takes these files) from the “ Destination phase’ drop-down
list box.

Click “OK” to create the new mapping.

Define File Mapping

I Object file Cancel

[ 7] %]
Eile group:

[
Source phase:
[

I.t’-‘n.ssembler

Destination phaze:

Figure 3.17: Define File Mapping Dialog

2 To modify afile mapping:

1
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Select the mapping to be modified.

2. Click “Madify...” button. The “Define File Mapping” dialog will be invoked (figure 3.17).
3.
4. Click “OK” to commit the changes.

Modify the options as necessary.
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3.6 Controlling the Build

By default, the High-performance Embedded Workshop will execute al of the phasesin abuild and only stop if
afatal error is encountered. Y ou can change this behavior by setting the controls on the “Build” tab of the
“Options’ dialog (figure 3.18).

Options EE3

Buid |Editnl | Wworkspace | Confirmation | Metwark |

— Errarg and warnings:

[ Stop build if the number of ermors exceeds: I 0

¥ Stop build if the number of warnings exceeds: I 10

 Show:

[ Command line
[ Enwironment

[ Initial directon

ak. I Cahicel

Figure 3.18: Options Dialog Build Tab

Select [Tools->Options...] to invoke the diaog. If you want to stop the build when a certain number of errors
are exceeded then set the “ Stop build if the no. of errors exceed” check box and then specify the error count limit
in the edit field to theright. If you want to stop the build when a certain number of warnings are exceeded then
set the “ Stop build if the no. of warnings exceed” check box and then specify the warning count limit in the edit
field to theright.

Note: Irrespective of what these controls are set to, the build will always halt if afata error is encountered.

In addition to specifying error and warning count limits, the “Build” tab also alows you to request that the
command line, environment and initial directory of each execution should be displayed. Check the appropriate
check boxes as necessary.
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3.7 L ogging Build Output

If you would like to write the results of each build to file then invoke the “Customize” dialog by selecting [T ools
-> Customize...] and select the “Log” tab (figure 3.19). Set the “ Generate log file” check box and then enter the
full path of the log file into the “Path” field or browse to it graphically by clicking the “Browse...” button.

Customize

Figure 3.19: Tools Customize Dialog L og Tab
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3.8 Changing Toolchain Version

If two or more versions of the same toolchain are registered in the HEW, you can choose a version of the
toolchain on the “Change Toolchain Version” dialog shown in Figure . To invoke the dialog, select [Tools-
>Change Toolchain Version...]. Choose one of the versions from the “ Available versions’ drop-down list and
click the “OK” button to enforce your choice.

Change Toolchain Yersion

[l

EE
Toolchain name: Hitachi HBS H8/300 Standard
Current version: £.0.0.0 ez |
Available versions: 5020 j |

Toalchain build phazes:

Build phase | Wersion
H&5.HE/300 Assembler 41

H&5.H8/300 C/C++ Compiler 4.0.04
H85.H8/300 C/C++ Library Generator  1.0.02

OptLinker T1.07

1] | ]

Figure 3.20: Change Toolchain Version Dialog

To show information of toolchain components select atool from the “Toolchain build phases’ list on the
“Change Toolchain Version” dialog and click the “Information” button. Then atool information dialog (figure
3.21) will show you the information of the tool. Click the “Close” button to close the dialog.

H85_H8/300 C/C++ Compiler Information

Infiormation:

High-performance Embedded Workshop
H35,H3/300 SERIES C/C++ Compiler Yer. 4.0.04
[=)1994,1996,1997 1999 Renezas Technology Corp.

=

Figure 3.21: Toolchain Information Dialog
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3.9 Using an External Debugger

The High-performance Embedded Workshop can launch an external debugger tool. If you want to use another

debugger then you must add it to the Tools menu (as described in chapter 6, “Customizing the Environment”, in
this manual).

The “Debugger” tab of the “ Customize” dialog (figure 3.22) is where the High-performance Debugging I nterface
related information is configured. 'Y ou may wish to use an older version of the debugger if certain targets are not

currently supported in the new environment. Invokeit by selecting [Tools->Customize...] and then selecting
the “Debugger” tab.

Toolbarsl Cnmmandsl GET] I Placeholders  Debugger | Log I Help I

¥ Use external debugger

HO location [W4.0 or greater):

IEZ\HEW'\HD|5'\S|M'\SH'\Hdi.EHE p | Browse. . |

Sezsion file:
|$[I:EINFIGDIFH]'\$[F'FEEIJECTNAME].hds Ll Browse. .. |

Cownload module;

I$[I:EINFIGDIFE]'\$[F'FHEIJECTNAME].abs Ll Browse... |

Figure 3.22: Customize Dialog Debugger Tab

When an externa debugger is used, check ‘Use external debugger’ and then set the following items. Firstly, the
location of the HDI executable must be specified. This must be version 4.0 or greater otherwise the behavior is
not guaranteed. The second item of dataisthe session file. Thistells HDI which session to load when it is
launched. Finally, the location of the download module is required. This alows the HEW to automatically
switch to HDI when the download modul e changes after a build.
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Click the “Launch External Debugger” toolbar button to invoke HDI with the specified session file:

2!l

After abuild, if the download module has been updated, the HEW will switch back to HDI to enable immediate
debugging. Whilst using HDI, double clicking in any source window will switch back to the HEW with the
source file open at the line which was double clicked.

3.10 Generating a M akefile

The HEW allows you to generate a makefile, which can be used to build parts of your workspace without HEW.
Thisis particularly useful of you want to send a project to a user who does not have the HEW or if you want to
version control an entire build, including the make components.

2 To generate amakefile:

1. Ensurethat the project, which you want to generate a makefile for, is the current project.

2. Ensure that the build configuration that you want to build the project with is the current configuration.

3. Select [Build>Generate M akefile].

4. Once thismenu has been selected adialog is displayed which asks the user what parts of the workspace
need to be added to the makefile. (See figure 3.23.)

5. Checking “ Scan dependencies whilst building makefile” will force a dependency scan to ensure the
make file creation is up to date.

6. Select the radio button which is relevant for your makefile and then click OK.

Generate make file EHE

& For the current configuration in the currently active project DK I
= For all configurations in the cumently active projsct Cancel |

€ For all configurations in all loaded prajects in the current warkspace

¥ Scan dependencies whilst building make file

Figure 3.23: Generate makefile Dialog

The HEW will create a subdirectory “make” within the current workspace directory and then generate the
makefileintoit. It is named after the selection, with a.mak extension for example the current project and
configuration(e.g. project_debug.mak). The executable HMAKE.EXE, located in the HEW installation directory,
isprovided for you to execute the makefiles generated by the HEW. It is not intended to execute makefiles,
which have been user modified.

2 To execute amakefile:
1. Open acommand window and change to the “make” directory where the makefile was generated.
2. Execute HMAKE. Its command lineis HMAKE.EXE <makefile>.

Note: The degree portability of agenerated makefileis entirely dependent upon how portable the project itself
is. For example, any compiler options, which include full paths to an output directory or include file
directory, will mean that, when given to another user with adifferent installation, the build will probably
fail. In general use placeholders wherever possible —using a full, specific path should be avoided when
possible.
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4. Using the Editor

This chapter describes how to use the editor that is provided with the High-performance Embedded Workshop.

41 The Editor Window

The editor window (figure 4.1) contains the file windows that are being viewed or edited. Only one window is
active at anytime. Thiswindow is called the active window (or current window) and itstitle bar will appear a
different color from that of the others (“dbsct.c” is the active window in figure 4.1). All text operations such as
typing, pasting text and so forth only affect the active window. To switch to another source file window (i.e. to
make some other window the active window) there are a number of methods:

* Clickonitifitisvisible.

*  PressCTRL+TAB to cycle through the windows one after another.

»  Select the window by name from the “Window” menu.

»  Sdlectitstab at the bottom of the editor window.

When afile has been edited, an asterisk (*) is appended to the window’ stitle bar. The asterisk remains there
until the fileis saved. The asterisk isalso removed if &l of the edited changes are undone in the current window.

e 3
i
e 3
i
e 3
i
e 3
i

FILE cdb=ct o

DATE ‘Hon, Jun 23, 2003
DESCRIPTION :Setting of B.RE Section
CPU TYFE (HBSA

Thi=z file i= generated by Reneszasz Project Generator (Ver 2 .6).

fpragna =ection SDSEC
=ztatic const struct {

char *rom_s=: <% Start addres=s of the initialized data =e
char #rom_e; <% End address of the initialized data =sect
char *ram_s=: <% Start addres=s of the initialized data =e
}IDTBL[ 1= 4 A
Ll »
% resetprgc o dbsche |2 sbrkc

Figure 4.1: Editor Window
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4.2 Working with Multiple Files

Thefile areais where you will work with the files of your project. The editor allows you to have many files open
at one time, to switch between them, to arrange them in different configurations and to edit them in whichever
order you want to. The operations that you can perform upon the windows are typical of most Windows®
applications and they can be found under the [Window] menu:

* [Window->Cascade]
Arrange all open windows so that they overlap, with the top left of each window visible.
* [Window->Tile Horizontally]
Arrange all open windows in sequence (horizontally) so that they occupy the entire editor window with no
overlapping edges.
e [Window->Tile Vertically]
Arrange all open windows in sequence (vertically) so that they occupy the entire editor window with no
overlapping edges.
* [Window->Arrange | cons]
Line up al minimized windows at the bottom of the editor window.
e [Window->Close All]
Close all open editor windows.

The files within the editor can be displayed in a“notebook” style. This means that each file has a separate tab
associated with it to aid in navigating between files.

2 To show filesin notebook:
1. Select [Tools->Options...]. The “Tools Options’ dialog box will be displayed. Select the “Editor” tab.
2. Set the “Show filesin notebook” check box as appropriate.
3. Click “OK” for the new settings to take effect.

421 The Editor Toolbars

The editor has four related toolbars: Editor, Search, Bookmarks and Templates. They provide a shortcut to the
functions of the editor, which you will use most often. The following sections describe each buttons function.

422 Editor Toolbar Buttons

O New File

The new file button creates a new source file window with a default name. When you save the file, you can
specify your own filename.

= Open File

Click this button if you want to open afile. It invokes a standard file chooser - select the file which you want to
open and then click “Open”.

=] SaveFile
Savesthe active sourcefile.
=i} Save All Files

Savesdl of thefilesin the editor.
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=] Print File

To print the contents of the current window, click this button.

3 Cut

Clicking this button will remove the current text selection and place a copy of it onto the Windows® clipboard
(it can be pasted back to afile with a paste operation).

Copy
This button allows you to copy the current text selection into the Windows® clipboard.
=) Paste

The paste button copies the contents of the clipboard into the active window at the position of the insertion
cursor.

i Find

Click this button if you want to find a certain text string in the current file. It invokes afind dialog box where
you can specify the search parameters.

iy Find in Files

To search several files for atext string then click this button. All find results are displayed in the “Find in Files”
tab of the “QOutput” window. For further information, refer to the “ Searching and Navigating Through Files’
section later in this chapter.

1} Match Braces

The match braces button highlights text between braces of type{ }, [] and (). Thisis particularly useful when
attempting to find out the structure of C/C++ code blocks which are opened with { and closed with }. To useit,
select the open brace to match from, or place the cursor beforeit, and then click this button. For further
information on brace matching, refer to the “Brace Matching” section later in this chapter.

ar Insert Template

To insert apre-defined template at the current cursor position, click thistoolbar button. The “Insert Template”
dialog box will be invoked. Select atemplate name and then click OK. For further information on templates,
refer to the “ Templates’ section later in this chapter.

) Toggle Bookmark

The High-performance Embedded Workshop editor provides standard bookmark capabilities. To set a bookmark,
select theline to mark and click this button (a green mark will then appear in the blank on the |eft side of the
editor window). To remove a bookmark, select the line to remove abookmark and click this button (the mark in
the blank on the | eft side of the editor window will disappear). For further information on bookmarks, refer to the
“Bookmarks’ section later in this chapter.
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423  Search Toolbar Buttons

Cly Find in Files

To search several files for atext string then click this button. All find results are displayed in the “Find in Files”
tab of the “Output” window. For further information, refer to the “ Searching and Navigating Through Files’
section later in this chapter.

i Find

Click this button if you want to find acertain text string in the current file. It invokes afind dialog box where
you can specify the search parameters.

#  Find Next
Finds the next occurrence of the current search string.
® Find Previous

Finds the previous occurrence of the current search string.

424 Bookmarks Toolbar Buttons

) Toggle Bookmarks

Sets abookmark at the current line or clears a bookmark at the current line.
B Next Bookmark

Jumps to the next bookmark in the current file from the current line.

ﬁh Previous Bookmark

Jumps to the previous bookmark in the current file from the current line.

|£| Clear All Bookmarks

Clears al bookmarksin the current file.

425 Templates Toolbar Buttons

*U"_" Define Template

Specify template text for subsequent insertion.

T Insert Template

Insert the template selected in the drop-down list at the current cursor position.
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4.3 Standard File Operations

431 Creating a New File

2 To create anew editing window:
Select [File->New] or click the new file toolbar button (1) or press CTRL +N.

The window will be given an arbitrary name by default. Y ou can provide a new name when you save the file.

432 Saving aFile

2 To savethe contents of an editing window:
1. Ensurethat the window, whose contents you want to save, is the active window.
2. Select [File->Save] or click the save file toolbar button (i) or press CTRL+S.
3. If thefile has not been saved before, afile save dialog box will be displayed. Enter afilename, specify a
directory and then click OK to create the file with the name given, in the directory specified.
4. If the file has been saved before, then the file will be updated (no dialog box will be displayed).
2 To savethe contents of an editing window under a new name:
1. Ensurethat the window, whose contents you want to save, is the active window.
2. Select [File->Save As..].
3. A filesavediaog box will be displayed. Enter afilename, specify adirectory and then click OK to create
the file with the name given, in the directory specified.
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433 Saving all Files

2 To save the contents of every open editor window:

1. Select [File->Save All] or click the save all files toolbar button (i)

2. If any of the files has not been saved before, afile save dialog box will be displayed. Enter a filename,
specify adirectory and then click OK to create the file with the name given, in the directory specified.

3. If any of the files have been saved before, then the file will be updated (no dialog box will be displayed).

434 Openinga File

2 Toopenafile:

1. Select [File->Open...] or click the open file toolbar button (&) or press CTRL +O.

2. Anopen filedialog box will be displayed. Use the directory browser (on the right) to navigate to the
directory in which the file you want to open islocated. Use the “Files of type” combo box to select the
type of file you want to open (or set it to “All Files (*.*)” to see every filein adirectory).

3. Onceyou have located the file select it and click “Open”.

The High-performance Embedded Workshop keeps track of the last five files that you have opened and adds
them to the file menu under the “Recent Files’ sub-menu. This gives you a shortcut to opening files which you
have used recently.

2 To open arecently used file:
Select the [File->Recent Files] menu option and from this sub-menu select the desired file.

You can also open afileviathe “Projects’ tab of the “Workspace” window. Either double click the file you want
to open or select it, click the right mouse button (to invoke a pop-up menu) and then choose the [Open <file>]
menu option (where <file> isthe name of the file sel ected).
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435 Closing Files

2 Tocloseindividual files select one of the following methods:
1. Double click on the editor window’s system menu (located at the top left of each window when not
maximized).
2. Click on the editor window’ s system menu (located at the top left of each window when not maximized)
and select the “Close” menu option.
3. Ensure that the window that you want to close is the active window and then press CTRL +F4.
4. Ensure that the window that you want to close is the active window and then select [File->Close].
5. Click on the close button (located at the top right of each window when not maximized).
2 Tocloseal windows at once:
Select [Window->Close All].
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44 Editing a File

The High-performance Embedded Workshop editor supports standard editing functionality. Thisis available
through the usual methods (i.e. the menu, toolbar and keyboard shortcuts) and is additionally supported viaa
pop-up menu (or local menu) that islocal to each editor window. To invoke it, place the pointer in an open
window and click the right mouse button. Table 4.1 outlines the basic operations that are provided by the editor.

Table4.1 Basc Editing Operations
Operation Effect Action
Cut Removes highlighted text and places it on the Click the cut toolbar button
Windows® clipboard Select [Edit->Cut]
Select [Cut] - local menu
Press CTRL+X
Copy Places a copy of the highlighted text into the  Click the copy toolbar button
Windows® clipboard Select [Edit->Copy]
Select [Copy] - local menu
Press CTRL+C
Paste Copies the contents of the Windows® Click the paste toolbar button
clipk_)pard into t_he ac_tive window at the Select [Edit->Paste]
position of the insertion cursor
Select [Paste] - local menu
Press CTRL+V
Delete Removes highlighted text (it is not copied to  Select [Edit->Clear]
the Windows® clipboard) Select [Clear] - local menu
Press Delete
Select All Selects (i.e. highlights) the entire contents of  Select [Edit->Select All]
the active window Select [Select All] - local menu
Undo Reverses the last editing operation Select [Edit->Undo]
Select [Undo] - local menu
Press CTRL+Z
Redo Repeats the last “undone” editing operation Select [Edit->Redo]

Select [Redo] - local menu
Press CTRL+Y
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Sear ching and Navigating through Files

The High-performance Embedded Workshop editor provides find, replace and file navigation functionality. The
following three sections detail how to use these festures.

451

Finding Text

2 To search for text in the current file:

1
2.

3.

Ensure that the window, whose contents you want to search, is the active window.
Position the insertion cursor at the point from which you want to start your search.

Select [Edit->Find...], press CTRL +F, select [Find...] from the editor window’ slocal menu or click the
find toolbar button (#}). The“Find” dialog box will be displayed (figure 4.2).

Find EE

Find what: Istring ﬂ Fitnd Mext |
™ Match whole word only Direction——— Cancel |

™ Match case ' Up
' Dawn

™ Fegular expression

9.

Figure 4.2: Find Dialog

Enter the text that you want to search for into the “Find what” field, or select a previous search string
from the drop-down list box. If you select text before invoking the find operation, the selected text will be
automatically placed into the “Find what” field.
If you would like to search for character string as awhole word then check the “Match whole word only”
check box. When this option is not selected, the search will be for any string that is matched by the search
string.
If you would like your search to be case sensitive (i.e. to distinguish between upper and lower case
letters) then check the “Match case” check box.
If your search string uses regular expressions then check the “Regular expressions’ check box. Refer to
Appendix B, “Regular Expressions’ for further information.
The “Direction” radio buttons allow you to select the direction of the search. Selecting “Down” means
that the search will be performed from the insertion cursor towards the bottom of the file. Selecting “Up”
means that the search will be performed from the insertion cursor towards the top of the file.
Click the“Find Next” button to begin the search. Click “Cancel” to stop the find action.

The High-performance Embedded Workshop editor also allows you to search for a string across many files.
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Finding Text in Multiple Files

2 To search for text in many files:

1.

Select [Edit->Find in Files...], select [Find in Files...] from the editor window’slocal menu or click the
find in files toolbar button (). The “Find in Files’ dialog box will be displayed (figure 4.3).

Find In Files EE3

Find: IMyStruct Find

[
Cancel
[

I filestppes: I“.c:;“.cpp;“.e:-tp;".fsy;“.h;“.hpp;“.inc;“.lis;".lp

Pl

Diirectomy Ic:'\hewkdemn'\demo J Browse. .

™ Match case ¥ Search sub directories

™ Fegular expressions
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Figure4.3: Find in Files Dialog

Enter the text that you want to search for into the “Find” field, or select a previous search string from the
drop-down list box. If you select text before invoking the find operation, the selected text will be
automatically placed into the “Find” field.
Enter the file extensions of the files you would like to search into the “In files/types’ field. If severa
extensions are specified be sure to separate them with acomma (e.g. *.c,*.h).
Enter the directory in which you would like to search filesinto the “ Directory” field. Alternatively you
may browse to the desired directory graphically if you click the “Browse...” button.
If you would like to search the directory specified and all directories below it then check the “ Search sub
directories’ check box. If you just want to search the single directory specified in the “ Directory” field
then ensure that this check box is not checked.
If you would like to search for character string as awhole word then check the “Match case” check box.
When this option is not selected, the search will be for any string that is matched by the search string.
If you would like your search to be case sensitive (i.e. to distinguish between upper and lower case
letters) then check the “Match case” check box.
Click “Find” to begin the search. Any matches found will be displayed in the “Find in Files” tab of the
“Output” window. To jump to an instance of the string, double click on the desired entry in the *“ Output”
window.

Replacing Text

Replacing text is similar to finding text, as discussed in the previous section. The difference is that when the text
isfound you have the option to replace it with other text.

2 Toreplacetextin afile:
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1
2.
3.

Ensure that the window, whose contents you want to replace, is the active window.

Position the insertion cursor at the point from which you want to start your search.

Select [Edit->Replace...], press CTRL+H or select [Replace...] from the editor window’ s local menu. A
replace dialog box will be displayed (figure 4.4).

Enter the text that you want to search for into the “Find what” field, or select a previous search string
from the drop-down list box. If you select text before invoking the replace operation, the selected text will
be automatically placed into the “Find what” field.
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5. Enter the text that you want to replace the search string with into the “ Replace with” field, or select a
previous replace string from the drop-down list box.

2%

Find what: |string LI Find Mext I
Replace: with: frumeric =l Replace |

[~ Match whole waord only Replace In—————— Replace Al |

[ Match case (" Selection

[~ Reeular expression f+ Whale file ﬂl
&l open files

Figure 4.4: Replace Dialog

6. If you would like to search for character string as awhole word then check the “Match whole word only”
check box. When this option is not selected, the search will be for any string that is matched by the search
string.

7. 1f you would like your search to be case sensitive (i.e. to distinguish between upper and lower case
letters) then check the “Match case” check box.

8. If your search string uses regular expressions then check the “Regular expressions’ check box. Refer to
appendix B, “Regular Expressions’ for further information.

9. If youclicked “Find Next”, the editor will search for the first occurrence of the search string. Click
“Replace” if you want to replace it. Click “Replace All” to replace all occurrences or click “Cancel” to
stop the replace action. If you select “Selection” in “Replace In”, selected range of the text is replaced. If
you select “wholefile”, the whole files are replaced. If you select all open files, dl filesthat are
currently open in the editor have the replace operation carried out on them.

454 Jumping to a Specified Line

2 Tojumptoalineinafile
1. Ensurethat the window, whose contents you want to replace, is the active window.
2. Select [Edit->Goto Line...], pressCTRL+G. or select [Goto Line...] from the editor window’ s local
menu. A goto line dialog box will be displayed (figure 4.5).
3. Enter into the dialog box the number of the line that you want to go to, and then click “OK”.
4. Theinsertion cursor will be placed at the start of the line number specified.

Line nurmber I'I
ak. I Cahicel |

Figure 4.5: Goto Dialog

4.6 Bookmarks

When working with many large files at atime, it can become difficult to locate specific lines or areas of interest.
Bookmarks enable you to specify lines that you want to jump back to at a subsequent time. One example of its
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useisinalarge C file where you may want to set a bookmark on each function definition. Once a bookmark has
been set, it exists until it isremoved or the fileis closed.

2

To set abookmark:
1. Placetheinsertion cursor on the line to mark.
2. Select [Edit->Bookmar ks->Toggle Bookmark], press CTRL +F2, select [Bookmarks
->T oggle Bookmark] from the local menu or click the toggle bookmark toolbar button (3 ).

3. A green mark appearsin the blank on the left side of the line to indicate the presence of an active
bookmark.

To remove a bookmark:

1. Placetheinsertion cursor on the marked line.

2. Select [Edit->Bookmar ks->Toggle Bookmark], press CTRL +F2, select [Bookmarks
->Toggle Bookmark] from the local menu or click the toggle bookmark toolbar button (2 ).

3. Themark will be removed and the line will return to normal text.

To jump to the next bookmark in afile:

1. Ensurethat the insertion cursor is somewhere within the file to be searched.

2. Select [Edit->Bookmar ks->Next Bookmark], press F2 or select [Bookmar ks->Next Bookmark] from
the local menu or click the next bookmark toolbar button ( & ).

To jump to the previous bookmark in afile:

1. Ensurethat the insertion cursor is somewhere within the file to be searched.

2. Select [Edit->Bookmar ks->Pr evious Bookmar k], press SHIFT+F2 or select [Bookmar ks->Previous
Bookmark] from the local menu or click the previous bookmark toolbar button ( 0 ).

To remove dl bookmarksin afile:

1. Ensurethat the window, whose bookmarks you want to remove is the active window.

2. Select [Edit->Bookmarks->Clear All Bookmarks] or select [Bookmar ks->Clear All Bookmarks]
from the local menu or click the clear all bookmarks toolbar button ( i ).

4.7 Printing a File

2
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Toprint afile:
1. Ensurethat the window, whose contents you want to print, is the active window.
2. Select [File->Print...], or click the print tool bar button (&) or press CTRL +P.



High-performance Embedded Workshop User’s Manual

4.8 Configuring Text Layout

The following sections detail how to set-up the layout of the text within the editor windows.

481 Page Set-up

When you print afile from the High-performance Embedded Workshop editor, the settings in the print dialog
box affect the way in which the fileis printed (e.g. double or single sided). Control over how the text is
formatted on the page can aso be controlled via the page set-up option. This allows you to specify the margins
(top, bottom, left and right) of your printouts. It is often necessary to set this because some printers cannot print
to the edges of an A4 page. Furthermore, some users have their own layout requirements (e.g. alarge left hand
margin so that code can be placed in an A4 binder).

2 To set-up the page margins:
1. Select [File->Page Setup...]. The “Page Setup” dialog will be invoked (figure 4.6).

2. Enter into the edit fields the margins required (set the “inch” or “mm” radio buttons to set the
measurements).

3. Click “OK” for the new settings to take effect.

Marging

Left: IE Right: ID—
Top: ID— Bottom: ID—

@ |nch  mm
Header:
| i
Faoater:
| i
v wiap Test

ak. I Cancel |

Figure 4.6: Page Setup Dialog

2 To set-up the page header and footers:

1. Select [File->Page Setup...]. The“Page Setup” dialog will be invoked (figure 4.6).

2. Enter into the header and footer edit fields the text required to be displayed. All norma placeholders are
available along with page numbering, text justification and date fields. These are dl expanded before
the pageisto be printed.

3. Click “OK" for the new settings to take effect.

2 To set-up print wrapping

1. Select [File->Page Setup...]. The “Page Setup” dialog will be invoked (figure 4.6).
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2. Click the wrap text check box. This switches on the wrap text facility when printing so no text is
truncated and everything isvisible.

3. Click “OK” for the new settings to take effect.

482 Changing Tabs

2 Tochangetab size:
1. Select [Tools->Options...]. The“Options’ dialog will be displayed. Select the “ Editor” tab (figure 4.7)).
2. Enter intothe“Tab size” field the number of desired tabs.
3. Click “OK” for the tab setting specified to take effect.

Options EE3
Build  Editor | Wiorkspace I Confirmation I Hetiworl, I
— Spacing:

¥ Enable auto indentation

— General:
¥ Save files before executing any toals ¥ Show files in notebook
™ Prompt befare saving files ¥ Enable spntax coloring

¥ Enable Smart-edit for C++ files

— Extemnal editor:

™ Use gxtemal editor:

| F i, |

ak. I Cahicel

Figure 4.7: Options Dialog Editor Tab

When a TAB key is pressed in the editor a tab character is usually stored in the file. However, sometimesit is
preferable to store spaces instead. The representation of tab characters can be controlled via the “ Options’ diaog.

2 To use spaces astabs:
1. Select [Tools->Options...]. The “Options’ dialog will be displayed. Select the “Editor” tab (figure 4.7).
2. Setthe“Use spaces astabs’ check box as appropriate.
3. Click “OK" for the tab setting specified to take effect.
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483 Auto Indentation

When you press return in a standard editor the insertion cursor will move to the next line down, at the first
column (i.e. against the left hand side of awindow). Auto Indentation is a feature which, when return is pressed,
places the insertion cursor on the next line (as before) but under the first non-white space character of the
previous line. This enables you to type neat C/C++ or assembler code faster as you don't have to type leading
spaces or tabs yourself.

Figure 4.8 illustrates two examples. Thefirst (i) shows the effect of pressing return when the auto indentation
feature isdisabled - the insertion cursor returns to the |eft-hand side of the window on the next line. When the
line“int z=20" istyped, it is not aligned with the previous two lines. The second example (ii) shows the effect of
pressing return when auto indentation is enabled - the insertion cursor drops underneath the “i” of the previous
line. Now, when the line “int z=20" istyped, it is automatically aligned (i.e. automatically indented).

void myfunction(void)
{
int x=5;
int y=10;
=
int z=20;

void myfunction(void)
{
int x=5;
int y=10;
=
int z=20;

i) Auto Indentation Disabled

i) Auto Indentation Enabled

Figure 4.8: Effect of Auto Indentation

2 To enable/disable Auto Indentation:
1. Select [Tools->Options...]. The“Options’ dialog will be displayed. Select the “Editor” tab (figure 4.7).
2. Set the “Enable auto indentation” check box accordingly.
3. Click “OK” for the setting of the auto indentation check box to take effect.
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4.9 Splitting a Window

The High-performance Embedded Workshop editor allows you to split atext window into two. Figure 4.9 shows
the split bar button which islocated just underneath the maximize button at the top right hand corner of any text
window.

Figure 4.9: Split Bar Button

2 To split awindow:
Double click on the split bar button to split the window in half or click on the split bar button, keep the button
pressed, move the mouse down and then rel ease the mouse button at the point you want to split the window.
2 To adjust the position of the split bar:
Click on the split bar itself, keep the button pressed then move the bar to the new position and then release
the button.
2 Toremove the split bar:
Double click on the split bar or move the split bar to the top or bottom of the window.
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410 Configuring Text

The following sections detail how to change the appearance of the text displayed in the editor windows.

410.1 Changingthe Editor Font

The High-performance Embedded Workshop allows you to specify the font to be used in itsinternal editor. All
editor windows, regardless of thefile type, use the same font.

2 To change the editor font:
1. Select [Tools->Format Views...]. The “Format Views’ dialog will be displayed. Select the Sourceicon
inthetree (figure 4.10).
2. Select the desired font from the “ Font” list.
3. Select the size of the font from the “Size” list.
4. Click “OK” to confirm the new editor settings.
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Figure 4.10: Format Views Dialog Font Tab

411  Syntax Coloring

To enhance code readability, the HEW editor can display specific strings (i.e. keywords) in different colors. For
instance, C source code comments could be shown in green and C types (e.g. int) could be shown in blue.

The coloring method used can be specified on afile group by file group basis. For example, you can define
different color schemesfor a C sourcefiles, text files, map files or even your own files.

2
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To change existing colors:

1. Select [Tools->Format Views...]. The“Format Views’ dialog will be displayed.

2. Select theitem underneath theicon in the tree you wish to modify the colour for. This should be the file
type (e.g. C sourcefile) and correct keyword group (e.g. identifier or pre-processor).

3. Select the“Colour” tab.

4. Modify the “Foreground” and “Background” color lists as desired. The color “ System” refersto the
current window foreground and background settings in control panel.
5. Click “OK” for the new colorsto take effect.

To create new keyword groups:

1. Select [Tools->Format Views...]. The “Format Views’ dialog will be displayed.

2. Select thefile type in the tree to which you wish to add the new keyword group.

3. Click “Add...” underneath the tree. The “ Add Category” dialog box will be displayed (figure 4.11). Enter
the name of the keyword group in the “ Category Title” field, then click “OK” to create the new keyword
group.

Add Category EHE
Categom Title: QK. I

|| Cancel |
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Figure 4.11: Add Category Dialog

To create new keywords:

1. Select [Tools->Format Views...]. The “Format Views’ dialog will be displayed.

2. Select the item underneath the source view icon in the tree you wish to modify the syntax highlighting
for. Thisshould be the file type (e.g. C sourcefile) and correct keyword group (e.g. identifier or pre-
processor).

3. Select the“Keywords” tab (figure 4.12).
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Figure 4.12: Format Views Dialog K eywords Tab

4. Click the“Add...

" button to add a keyword. Then the “ Add Keyword” dialog (figure 4.13) will be

launched. Specify akeyword in the “Keyword” field and click “OK” to close the dialog. To remove a
keyword, select the keyword and click the “Remove’ button.

Add Kepword HE

Keyword:

Cancel |

Figure 4.13: Add Keyword Dialog

When you create anew file, syntax coloring will not be active as anew file does not initially have an extension
(new files are named arbitrarily by the editor without an extension). In order to activate syntax coloring, you
must save the new file with a name, which has one of the above extensions.

2 To disable/enable syntax coloring:

1. Select [Tools->Options...]. The “Options’ dialog will be displayed. Select the “Editor” tab (figure 4.7).
2. Set the “Enable syntax coloring” check box as necessary and then click “OK”.
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Templates

When developing software it is often necessary to enter the same text repeatedly, for instance, when typing a
function definition, for loop or acomment block for a function. The High-performance Embedded Workshop
editor allows you to specify ablock of text (or template), which can be inserted into the currently active editor
window. Thus, once a template has been defined, it can be automatically inserted without the need to re-enter it
manually.

4121

Defining a Template

2 Todefine atemplate:
Select [Edit->Templates->Define Templates.. ], select [Templates->Define Templates...] from the
local menu, press CTRL+T or click on the define templ ate toolbar button ( “Ir ). The dialog shown in

1.

figure 4.14 will be displayed.

Click “Add”. A diaog isdisplayed that asks you to enter your chosen template name. This name must
be unique otherwise a duplicated template name message will be displayed and the template will not be

added.

If you want to modify an existing template use the “ Template name” drop down menu to select which

template you want to modify.

Enter the desired text into the “ Template text” text area. Y ou can copy text from another editor window
and then pasteit into thisdialog using CTRL +V.

There are 10 shortcut keys reserved for templates. If you want to designate one of these select thekey in
the drop list at the bottom of the edit template dialog. These range from CTRL+0 to CTRL+9.

Enter the following keywords to insert specia information when the template isinserted:

Menu Entry Placeholder Replaced With

Time $(TIME) Current time

DateasDMY $(DATE_DMY) Current date, in dd/mm/yy form

Date asMDY $(DATE_MDY) Current date, in mm/dd/yy form

Dateas YMD $(DATE_YMD) Current date, in yy/mm/dd form

Date as Text $(DATE_TEXT) Current date in text form

Line $(LINE) First line number of template insertion

User $(USER) Current windows user

File $(FULLFILE) Name of thefile

Filename $(FILE) Name and full path of thefile

Project Name $(PROINAME) Current project name

Workspace Name $(WORKSPNAME) Workspace name

Cursor position ") Insertion cursor — Positions the cursor
in this position after template has been
inserted

7. Enter the $(") character to specify where the insertion cursor is to be placed after the template has been
inserted. If thisis not specified then the insertion cursor will be placed after the last character in the
template (asin anormal paste operation).
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User Input

When defining atemplateit is possible to define auser input field. Using the following placeholder specifies
this $(USERINPUT<n>|<” sometext’ >). Thenisanumber, which identifies the user input identifier. These
placeholders can be added manually but the user input button on the define templates dialog adds these
placeholdersin an automated manner. When the template isinserted into afile adialog is displayed which
allows you to enter some custom text for each of these fields. Thistext isthen inserted instead of the
placeholder. You can define ten of these user input fields.

[fe =2l » | aK

i

;I Cancel

Add...

Hemave
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|dzer Input
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<]
Shartzuts:
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Figure 4.14: Define Template Dialog

A new addition to the HEW 3.0 isthe templatesview. Thisisshownin figure 4.15. Thisview islocated with
the workspace and navigation windows.
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A

EE Templates

@ ToolChain Templates

Project ] Templates l Mavwigation I

Figure 4.15: Templates view

Any new templates, which have been added to the HEW, are displayed under the templates folder. The
toolchain templates folder is for templates, which are read only and have been provided for use in the HEW
system by the current toolchain. Templatesin this view can be dragged for insertion into an editor file. Itisalso
possible to drag an area of text from the editor into the templates folder for quick template creation. Right
clicking on this view displays a pop-up so that you can quickly add a new template, remove the current selection
and edit the current selection.

4122 Deleting a Template

2 Todedeteatemplate:

1. Select [Edit->Templates->Define Templates...], select [Templates->Define Templates...] from the
local menu, press CTRL+T or click on the define template bookmark toolbar button ( I ). Thedialog
shown in figure 4.14 will be displayed.

2. Usethe Template name drop down list to select the name of the template you wish to remove and then
click the “Remove” button.

3. Clicking “OK" saves the template changes and dismisses the dialog.
4123 Insertinga Template

2 Toinsert atemplate:
1. Select atemplatein the toolbar, then click the insert template toolbar button (), select [Edit->
Templates->Insert Template...] or select [Templates-> Insert Template...] from the local menu. The
dialog is dismissed and the chosen template is added to the current editor window.

Note: It isalso possibleto use the defined keyboard shortcut or drag the template from the templates
view.
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4124 BraceMatching.

Complicated source code can often become unwieldy, especially when blocks of C code are deeply nested within
each other or when complex logic statements are expressed within an ‘if’ clause. To help in such situations, the
High-performance Embedded Workshop editor provides a match brace feature which highlights text between
bracesof type{ }, () and[].

2 Tofind amatching brace:
1. Either highlight the open brace to match from or place the cursor beforeit.

2. Click the match braces toolbar button ({ }), press CTRL +B, select [Edit->M atch Braces] or sdlect
[Match Braces] from the local menu.

To check the structure of an entire file, place the cursor at its start and then repeatedly invoke the match brace
operation. The editor will successively highlight each pair of bracesin turn until there are no more to match.
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413 Editor Column management

The editor in HEW has the ability to manage columns apart from the main editor column. These can be added
and used by debugger feature. Y ou can choose the column to display/undisplay.

—|o) x|
#include <no_float._h> ZI
#include {stdio.h>
#include <math.h>
#include <{stdlib.h>
void main{void);
uvoid sort{long =a};
uvoid change{long *a);
extern void srand{unsigned int};
0x00000a0c void main{void)
0x00000al6
long a[18], min, max;
long ji:
int i
0x00000218 srand{1});
0x00000a20 | printf("#i# Data Input H#n");
0x0000052c for{ i=0; i<10; i+ ){
0x00000a2e j = rand(};
000000236 if(j < B¢
000000238 j=-i;
H
0x00000a3a a[i] = j:
0x00000244 printf("a[%d]=%1d\n",i,a[i]);
¥
0x00000a62 sort(a);
0x00000a66 printf (=== Sorting results sses\n");
0x00000a72 for{ i=8; i<18; i++ )¢
0x00000a74 printf("a[%d]=%1d\n",i,a[i]);
¥ -
min _ armI.
KIN| oz

Figure 4.16: Editor columns

2 To switch off acolumnin al sourcefiles:
1. Right click on the editor window.
2. Click the“Define Column Format...” menu item.
3. The“Global Editor Column States’ dialog is displayed.
4. The"Check status’ shows whether the column is enabled or not. If it ischecked it isenabled if the
check box is gray this means that in some files the column is enabled and in other filesit isnot.
5. Click “OK” for the new column settings to take effect.

2 To switch off acolumn in one sourcefiles:
1. Right click on the editor window, which you wish to remove a column from, and the editor pop-up is
displayed.
2. Click the Columns menu item and a cascaded menu item appears. Each column is displayed in this pop-
up menu. If the columnisenabled it hasatick next to itsname. Clicking the entry will toggle whether
the column is displayed or not.
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Global Editor Column States

[w]Cowerage
[w] Editor

[w]Source Address Cancel |

Figure 4.17: Global column state Dialog
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5.  Tools Administration

Y ou control the components, which can be used by the High-performance Embedded Workshop viathe “Tools
Administration” dialog (figure 5.1), which isinvoked via [Tools->Administration...]. Modification of the
“Tools Administration” dialog box isonly possible when no workspace is open, while only reference is possible
when aworkspace is open.

Toolz: Adminigtration 2 | x|

Reqiztered components:

Component Wersion ;I

o
-9 System Toals

(] 4 I
[#] Callwalker 11 Beqgizter... |

Cancel

{" H Series Librarian Interface 1.1 .
o9 Mapview 1.0 rreqisten

----- Ea tiIity Phazes = :
=29 Debugger Components thles...l
@ Binary File Object Reader 1.0 £ |
. AP
EIfDwarf2 object reader 20
= Gener!c Cache V|ew_EE:>< 1.0 [ |
Generic Coverage Yiew ECx 1.0
Generic Event Wiew ECx 1.0
Generic Image Wiew ECx 1.0

| i 100 b fiman O = | LI_‘ Uninstaller... |

Tool information...

[™ Show all components

Current HEW toolz database location:
IC:\Hew Modify...

Figure5.1: Tools Administration Dialog (Example)
There arefive standard types of component:

» Toolchain - aset of build phases (e.g. compiler, assembler, and linker). These components provide the build
capability.

» System Tool - an application (.EXE), which can be launched from the “Tools” menu. They are often
provided as extra applications, which support the toolchain (e.g. an external debugger like the Hitachi
Debugging Interface (HDI) or an interactive graphical librarian).

» Utility Phase - a“ready made” build phase which supports some specific build functionality (e.g. analyze
complexity of source code, count lines of source code, etc.). These components provide added functionality
to the build that is not toolchain specific.

» Debugger Component —acomponent that supports some specific debugger functionality (e.g. Target
platform, Object reader, etc).

» Extension Component —a component that provides key functionality in a certain area of the HEW system.
These components cannot be unregistered when installed (e.g. The HEW builder, debugger and flash
support).
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51 Tool Locations

The HEW maintains the locations of HEW compatible components automatically as each new tool isinstalled.
After installation, the HEW stores information about the component (including its location) — thisisreferred to
asregigration. Although initia registration is automatic, during the course of development or if you want to
manage the tools being used in your projects more effectively, you may need to register components yourself.
The remainder of this chapter discusses registration and how it affects you.

52 HEW Registration Files (*.HRF)

When a HEW compatible component (i.e. toolchain, system tool or utility phase) isinstalled, part of its
ingtallation will include afile with the extension .HRF (figure 5.2.i). Thisfile, named a“HEW Registration File”,
describes the component to the HEW. The process of registration refers to loading a component’s .HRF file into
the tools administration dialog (figure 5.2.ii).

i. INSTALL ii. REGISTER

? C\ [oh)
MyTool MyTool

D MYTOOL.HRF _D MYTOOL.HRF (.|
H =

etc @v etc

help @ help

. HEW
bin

Figure5.2: HRF File Location and Registration

In order to use a component with HEW it must first be registered. The “Tools Administration” dialog (figure 5.1)
shows all currently registered components. To accessit, ensure no workspaces are open and then select [Tools
->Administration...]. If you attempt to access tools administration when there is a workspace open the tools
administration dialog is opened but cannot be modified. When HEW isinstalled by default any new tools are
automatically registered.

HEW storestool information in atool database file. By default thisis created in the HEW application directory,
however if you are working in a network environment this directory may be set to another location. Itispossible
to change the tool directory location.

2 To change the toolslocation:

1. Select [Tools->Administration...].

2. Click the“Modify” button for the “ Current HEW tools database location” field.
3. Select the directory under which the new tool islocated, then click “OK”.
4

Thiswill switch the directory and change the tool location to the new directory. It will be necessary to
scan for any new toolsthat may be in thislocation thisis achieved by using the scan disk or register tool
functionality.
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53 Registering Components

The HEW will automatically attempt to register any new components installed since the last time it was invoked.
However, in some circumstances you may need to register components yourself.

531 Searching Drivesfor Components

In some casesit is useful to search adrive for HEW compatible components. Thisis especialy useful if the
HEW install ation was deleted or corrupted asit can recreate your tool information instantly.

2 To search for components:
1. Click the“Search Disk...” button on the “Tools Administration” dialog (figure 5.1). The “ Search Disk for
Components” diaog will be displayed (figure 5.3).

Search Dizk for Components

. . . . Cloze
Select the directony in which to begin the search:; —

Il::'\Hew Browsze.

¥ Include subfolders Start

.

Located components:

Component | Wersion | HRF Locatim:l Register |
Generic Watch Wiew ECx 1.0 C:A\HewhToo

Generic Waveform View ECx 1.0 C:A\HewhToo Register Al |
Binamy File Object Reader 1.0 CAHewhToo

ElfDvaarf2 object reader 20 I::'\HBWRTDD_I

Intel Hex Record Object Reader 1.0 CAHewhToo

SRecord object reader 1.0 CAHewhToo

H&5 HE/300 Seres Simulator Target Platform 3.0 I::'\Hew'xTiDILI

1| | 3

Search Status: B0 file(z] found

Figure5.3: Search Disk for Components Dialog

2. Enter the directory in which you would like to search into the top field or browse to it graphically by
clicking the “Browse...” button.

3. Check the “Include subfolders’ check box if you would like to search the directory specified and all
directories below it.

4. Click the“Start” button to begin the search. During the search, the “ Start” button will change to a“ Stop”
button. Click the “ Stop” button to halt the search at any time.

5. Theresults of the search are shown in the “ Located components” list. Select a component and click
“Register” to register an individual component or click “Register All” to register all located components.

6. Click “Close” to exit the dialog.
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53.2 Registering a Single Component

The HEW allows you to navigate directly to a single component in order to register it. The HEW Registration
File (*.HRF) islocated in the root directory of acomponent’sinstallation.

2 To register acomponent:
1. Click the“Regigter...” button on the “Tools Administration” dialog. A standard file open dialog will be
launched with its file filter set to “HEW Registration Files (*.hrf)".
2. Navigate to the .HRF file of the component you would like to register, select it and then click “ Select”.
3. A dialog will be invoked which displaysinformation regarding the selected tool. Click “Register” to
confirm that you want to register the tool or click “Closeg’ to abort the operation.

54 Unregistering Components

The components, which are registered with the HEW, affect the way in which it behaves. For example, every
compatible system tool, which isregistered, will be added to the tools menu when anew project is created.
Sometimes this may not be desirable. If so, open the “Tools Administration” dialog, select the component from
the “Registered components’ list and then click the “Unregister” button. A dialog will be invoked which asks
you to confirm this action. Click “Yes’ to confirm the action.

Note:  Unregistering a component does not remove itsingtallation from hard disk. It smply removes the
information, which the HEW was storing about that component (i.e. it “disconnects’ it from the HEW).
The action can be easily reversed at anytime by registering the tool (see above). If you want to remove a
component from the hard disk (i.e. uninstall a component) then refer to the section “Uninstalling
Components” later in this chapter.
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5,5  Viewing and Editing Component Properties

To view information regarding a component, select it from the “Registered components” list and then click the
“Properties’ button. The properties dialog will be displayed with the “General” tab selected (figure 5.4). Thistab
displays the name, version and location of the selected component. None of the information on thistab is
editable.

H85 HE/300 S5tandard Toclchain 5.0.2.0 Properties EHE

General | Infarmation | Environment |
Mame : H35 H8/300 Standard T oolchain
Yersion : 5.0.20
Location : c:hhewitools\hitachithBha_0_2

Cancel |

Figure 5.4: Properties Dialog General Tab

Select the “Information” tab to view any information about the component (figure 5.5). This may include
copyright information, enhancements, bug fixes, user notes and so on.

H85_HB/300 Standard Toolchain 5.0.2.0 Properties

General  Infarmation | Environment

Infarmation:
High-performance Embedded wWork zhop j

H&5 HE8/300 Standard Toolchain [Wer, 5.0.2.0)

H&5 HE&/300 CAC++ Library Generator [Ver, 1.0.02)
H85 HB8/300 CAC++ Carnpiler [Ver. 4.0.04) LI

Cahicel |

Figure 5.5: Properties Dialog I nformation Tab
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Select the “Environment” tab, if it exists, to view and edit a component’ s environment settings (figure 5.6). This
dialog is most commonly used to modify the environment of atoolchain.

H85 HE/300 S5tandard Toclchain 5.0.2.0 Properties

Generall Information  Enviranment |

Ervironment wariables:
CH38=C:\Hew T ools'HitachitHEVE_ 0 2hinclude dd
CH3BTMP=CATEMP
P& TH=C:"Hew\T ools\HitachitHEYE_0_24bin L=l

ik |

Hemnmve

KN I i
ak. I Cancel |

Figure5.6: Properties Dialog Environment Tab

To add anew environment variable, click the“Add...” button (the dialog shown in figure 5.7 will be invoked).
Enter the variable name into the “Variable” field, the variable' svalue into the “Value” field and then click “OK”
to add the new variable to the “ Environment” tab. Placeholder pop-up menus are included to ensure that the
environment can be specified as flexibly as possible. For a detailed description of placeholders see appendix C,
“Placeholders’.

To modify an environment variable, select the variable that you want to modify from the “ Environment” tab and
then click the“Modify...” button. Make the required changesto the “Variable” and “Value” fields, and then
click “OK” to add the modified variable to the “ Environment” tab. To remove an environment variable, select it
and then click the “Remove” button.

Environment ¥arnable EHE
Wariable:
= ak.
T ok |
Cancel |

> | Placeholder
21 PopUP FREnU

Walue:

Ic: wdos e mytools o windowes o temp

Figure5.7: Environment Variable Dialog
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Uninstalling Components

The HEW provides abuilt in uninstaller method, which can remove unregistered components.

2 Touninstall acomponent:

1. Select[Tools->Administration...].
2. Click onthe uninstaller button. The“Uninstall HEW Tool” dialog isinvoked (figure 5.8).
Uninstall HEW Tool 7l x|
Cl
Select the directary in which ta begin the zearch for tools: &l
v Include subfolders
Located Toolz which can be uninstalled:
Component | Yerzion | Installation Directony Wrimetall |
1| | i
Search Statuz:  1dle
Figure 5.8: Uninstall HEW Tool
3. Enter thedirectory in which you would like to search into the top field or browse to it graphically by
clicking the “Browse...” button.
4. Check the “Include subfolders’ check box if you would like to search the directory specified and all
directories below it.
5. Click the“Start” button to begin the search. During the search, the “ Start” button will change to a“ Stop”
button. Click the “ Stop” button to halt the search at any time.
6. Theresults of the search are shown in the “Located Tools which can be uninstalled” list. Select a
component and click “Uninstall” to uninstall a component.
7. Click “Exit” to exit the dialog.

A component may only be uninstalled if it is not currently registered with the HEW. If you attempt to uninstall a
tool, which is registered, then the dialog shown in figure 5.9 will be displayed. In such a case, you must return to
the “Tools Administration” dialog via[Tools->Administration...], unregister the tool and then invoke the tool
uninstaller again.

97




High-performance Embedded Workshop User’s Manual

High-performance Embedded Workshop
& Hitachi H85,HE/300 Standard Toolchain 5.0.2.0 is currently registered; you mayp not uninstall a tool that iz registered with HEW,

Please uze the administration dialog to unregister the Tool.

Figure5.9: Unableto Uninstall Tool

If atoal is not registered with the HEW then the dialog shown in figure 5.10 will be displayed when the
“Unregister” button isclicked. This confirmation dialog displays all of the files and folders that will be deleted.
If you are certain that these files and folders can be deleted then click the“Yes’ button. To abort the uninstall
click the“No” or “Cancel” buttons.

Confirmation EE3

The following files and folders will be deleted:

C:\HewhTools\HitachitHENE_O_24hE_5020 huf
C:\HewhT ools\HitachitHEVG_0_24hB_5020. huf
C:\HewhTools\HitachitHEVE_O_2WHEW
C:\HewhToolz\HitachitHE8Y5_0_2include

C:AHewhT oolzbHitachi HEWE_0_2\bin' 2600a_00. pak
C:AHewhToolz\HitachitHE8Y5_0_2\bint2600a_01.pak
C:AHewhT oolzbHitachi HEWE_0_2\bin 2600a_10.pak
C:AHewhToolz\HitachitHE8 5_0_2\bin%2600a_11.pak
C:AHewhT oolzbHitachi HEWE_0_2\bin' 2600n_00. pak
C:AHewhToolz\HitachitHE8Y5_0_2\bint2600n_01.pak
C:AHewhT oolzbHitachi HEWE_0_25bin 2600n_10.pak
C:\HewhToolz\HitachitHE8Y5_0_2\Bint2600n_11.pak
C:\HewhTools\HitachitHEVE_0_24bin'300_000.pak.
C:A\HewhTools\HitachitHEWE_024bin300_0071 . pak
C:A\HewhTools\HitachitHEWE_0_24bin'300_010.pak LI

C:AHewhToolz\HitachitHE5_0_2\bin j

Are pou sure pou want to delete the above filer and folders?

HNo Cancel |

Figure 5.10: Confirmation Dialog
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57 Technical Support Issues

The “Tools Administration” dialog is also capable of displaying information regarding “hidden” system
components. These are part of the HEW itself that cannot be unregistered/registered manually. If you check the
“Show all components’ check box on the tools administration dialog, extra component folders are displayed (see
figure 5.11).

Toolz: Adminigtration 2 | x|
Reqistered components: ’—IDK
Cormpangnt I YYersion = Cancel
-] Spstem Tools |
----- [C3 Utility Phases :
-[_] Debugger Components Reaqizter... |
F-[C] Extension Components -
----- L7 Communication Toaks Wrregrster |
[#-[Z0 System Extension Camponents = :
-9 Project Generators Froperties... |
- Hitachi Hf 0
Eppart..
------ 5H Project Generator 21 e |
----- [_ Project Generators - Custom S earch disk
- [_ Wersion Contral System 4|—
& @0 Toolchain Support Tool information...l
- _0 Definition Parser I —
| | ,l Urimztaller... |
¥ Show all components
Current HEW toolz database location:
IC:\Hew Modify... |

Figure 5.11: All Components Shown

When seeking technical support, you may be asked to give details about some or al of these components. To do
S0, open the respective folder, select acomponent and click the “Properties’ button. The properties dialog that
will be invoked behaves in the same way as discussed previoudy in this chapter, with the exception that thereis
no “Environment” tab.

The HEW also has a feature, which outputs tool information regarding the registered componentsto afile. This
allows you to retrieve information on the entire HEW system. Thisinformation can then be sent to your
technical support contact if you are experiencing problems with the HEW.

2 To output tool information:
1. Click the[Tools->Administration] menu item.
2. Click the“Tool information...” button. A standard windows file save dialog is displayed.
3. Choosethefilelocation and click OK.
4. A fileiscreated in the chosen location with the current registered tool setup of the HEW 2.

If any of the components have problems these can be seen in the tools administration dialog. If theicon hasan
additional icon this explains the problem. There are two additional icons that can be displayed. |f acomponent
isfound but cannot be used dueto it being an old version or another dependent component is not available then
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theicon in figure 5.12 is used to show this. If the component is not located where the registration file saysitis
then theicon in figure 5.13 is used to show this.

Reqgistered components:

Component

..... Hitz~li SiimarH PICSTT ckmika Shzead

Figure 5.12: Incompatible component found icon

----- Ha5 HE/300 Senez Simulator T arget Platform 4.0
----- Ht o Embedded Monitar Platform 1.0
- Intel Hex Record Obiect Reader 1.0

Figure5.13: Component not found icon
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58 On-Demand components

The HEW version 3.0 onwards has the concept of on-demand components. These components are not
automatically loaded by the application or the debugger component. These components can be loaded by the
user or as part of the project generation process.

2 Toload or unload an on-demand component manually:
1. Click the[Project->Components...] menu item.
2. The component gallery dialog isdisplayed. Thisisdisplayed in figure5.14.

3. Select the component you wish to load. Click the load button. The componentsimage should change to
the loaded state.

4. If you wish to unload a component. Select the component. Click the unload button. The components
image should change to the unloaded state.

5. Click OK to verify the changes.

x|
=5 Application E xtenzions 0k,
Lnaded companent E ITROM component
@ O5SEE. component Cahicel |
Unloaded component @ Cugtom memorng view component
Intermediate state component 72! Pin wiew component

Lmad

Unload

il

Figure 5.14: Component Gallery

Note: Each project in your wor kspace can have different componentsloaded and unloaded. If you have
multiple projectsyou can use the“Multiple projects...” and “ All projects’ itemsto change a components
load status over morethan oneproject. If you select a combination which meansthe component isloaded
in one project and not anther then the intermediate stateicon isdisplayed.
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59  Custom Project Types

The [Project->Create Project Type...] menuitem in HEW allows you to create a template for your project.
This menu item takes the settings of the current project and then creates a project type for you. The user can
specify the name of the new type and style of the project generation wizard. Once created these project types
appear in the “Tools Administration” dialog and are initially hidden in the system components part of the tools
administration tree. To export one of the custom project generators select the “Export” button on the “Tools
Administration” dialog. The execution environments of the custom project generators are packaged on the
execution file that can beinstalled. When thisfileis executed on the target user’s machine, the custom project
generator isinstalled.
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6. Customizing the Environment

Customizing the Toolbar

The High-performance Embedded Workshop provides 2 standard toolbars as detailed in chapter 1, “Overview”.

In addition to these, you may also construct your own toolbars viathe “ Customize” dialog (figure 6.1).

Customize EE3

Toolbars | Cnmmandsl GET] I F'Iacehnldersl Debuggerl Log I Help I

Toolbars:

V¥ Show Toolips Mew...

Rezet |

Tioslbar name;:
Editor

Figure 6.1: Customize Dialog Toolbars Tab

2 To create anew toolbar:

1.

Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.

2. Click the“New...” button. The dialog shown in figure 6.2 will be displayed.
3.
4. Click “OK" to create the new toolbar.

Enter the name of the new toolbar into the “Toolbar name” field.

Mew Toolbar EE3

Taolbar narne:
IM T oolbad
Cahicel |

Figure 6.2: New Toolbar Dialog
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When anew toolbar is created it will appear undocked (i.e. “floating”) and empty.

2 To add buttonsto atoolbar:
1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the “Commands’
tab (see figure 6.3).
2. Browse the available buttons by selecting the button categories from the “ Categories’ list. Select a button
from the “Buttons’ areato display information on its operation.
3. Click and drag a button from the dialog onto the toolbar.

Customize EE3

Toolbars  Commands | GET] I F'Iacehnldersl Debuggerl Log I Help I

Categories: — Buttonz

HE & &+ =@
{} T @

Bookmark z
Templates
Werzion Contral

Select a cateqary, then click a button to see itz description. Drag the buttan
to any toolbar

— Dezcription
Open an exizting document

Figure 6.3: Customize Dialog Commands Tab
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To remove buttons from atoolbar:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the “ Commands’
tab (see figure 6.3).

2. Click and drag a button from the toolbar onto the “Buttons’ area.
To remove a user defined toolbar:
1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.

2. Select the user-defined toolbar from the “ Toolbars” list, and the “Reset” button in figure 6.1 changes to
the “Delete” button. Then click the “Delete” button.

To reset a standard toolbar back to itsoriginal state:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.

2. Select the standard toolbar from the “Toolbars” list and then click the “Reset” button.

To show or hide toolbar tooltips:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.

2. Set the“Show Tooltips” check box as desired.

To modify the toolbar name of atoolbar created by a user:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.

2. Inthe“Toolbars’ list, select atoolbar, which has been created by a user and whose name you, want to
modify.

3. Modify the name of the toolbar in the “ Toolbar name” filed.
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Customizing the Tools Menu

The“Tools" menu can be customized to include your own menu options.

2 To add anew menu option:

1

Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the “Menu” tab
(see figure 6.4). Thefirst thing for you to decide is whether you are adding a global application wide
tool (“Application wide tools.”), which will be available to all of your workspaces. Or whether you wish
to add a workspace wide tool (“Workspace wide tool:”), which isonly valid for the current workspace.
Once you have made the choice choose the relevant section of the dialog.

Customize EE3

Toolbarsl Commands Menu |F'Iacehnlders| Debuggerl Log I Help I

Application wide tools:

M arme | Wersion |

Workspace wide tools:

M arme | Wersion |

Hitachi Mapwiew 1.0

Hitachi Call ‘W alker 1.1 Ffin..
Hitachi H Series Librarian Interface 1.1 —

EEmove

OK

LLLE L

N o gk w
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Figure 6.4: Customize Dialog Menu Tab

Click the*“Add...” button (the dialog shown in figure 6.5 will be invoked). If you would like to add an
existing system tool to the menu then select the “ Select from existing system tools” radio button, choose
the tool from the drop-down list and then click “OK”. Alternatively, if you would like to add atool of
your own then follow the remaining steps.

Enter the name of the tool into the “Name” field.

Enter the command, excluding arguments, into the “Command” field.

Enter any arguments that you would like to pass to the command into the “ Arguments’ field.

Enter an initia directory in which you would like the tool to run, into the “Initial directory” field.

Click “OK” to add the menu option to the “Tools” menu.
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Add Tool
% Define new user bool ok |
— Tool details: ez |
Hame :
IEr:pInler
Carrnand :

|$MINDIF|]\E:<p|0rer.e:<e

Arguments

Ll Browsze. . |

Initial directary :

i

|$[TEMPDIF|]

|LI Browse. .. |

" Select from existing system tools:

IHitachi Mapwiew [verzion 1.0]

]

Figure 6.5: Add Tool Dialog

New menu options are added to the bottom of thelist (i.e. bottom of the tools menu) by default. The order of

menu optionsin the “Tools” menu can also be modified.

2 To modify amenu option:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the “Menu” tab

(seefigure 6.4).

2. Select the menu option that you would like to modify and then click the “Modify...” button.
3. Make the desired changes on the “Modify Tool” dialog (figure 6.6) and then click “OK”.

ModifyT ool HE

Mame :

Command ;

|$[WINDIF|]\E:4|:IDrer.e:<e

Argunents

Initial directary :

|$[TEMF'DIF|]

Cancel |
Ll Erowse...l

2|
| mowe |

Figure 6.6: Modify Tool Dialog

2 To remove amenu option:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the “Menu” tab

(seefigure 6.4).

2. Select the menu option that you would like to remove and then click the “Remove” button.
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6.3 Configuring the Help System

The High-performance Embedded Workshop provides context sensitive help within the editor window. In other
words, if you select some text in the editor window and then press F1, the High-performance Embedded
Workshop will attempt to locate help on that selected item. The help files, which will be searched, are listed in
the “Help” tab of the “Customize” dialog.

2 Toaddanew helpfile:
1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the “Help” tab
(seefigure 6.7).

Customize EE3

Toolbarsl Cnmmandsl Menu I F'Iacehnldersl Debuggerl Log Help |

Help files:

Drescription | File Name Add...
C/C++ Standard Library Help  e\hew2stoolzhhitachibe. .

HEemave

Kl |2
Ciefault help file;
| C/C++ Standard Library Help =~

Figure 6.7: Customize Dialog Help Tab

2. Click the“Add...” button. The “Add Help File” diaog will be displayed (figure 6.8).

3. Enter adescription of the help fileinto the “Title” field.

4. Enter the full path of the help file into the “ Path” field (or browse to it graphically by clicking on the
“Browse..."” button).

5. Click “OK” to define the new help file.

Add Help File EHE
Title:
= Ok,
IF'rogramming inAMSIC 4'
Cancel |
Path:
Ic:'\fileskhelp'\ansi.hlp Browsze. I

Figure 6.8: Add Help File Dialog
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To make ahelp file the default choice, select it from the “ Default help file” drop-down list or set it to “(None)” if
you would like to be prompted for ahelp file when F1 is pressed.

6.4 Specifying Wor kspace Options

The High-performance Embedded Workshop allows you to control several aspects of a workspace viathe
“Options’ dialog (figure 6.9). To invoke it select [Tools->Options...], and select the “Workspace” tab.

Options
Bwild I Editor  “orkspace ] Cnnfirmation] Netwnlk]

[ Open last workspace at start-up

¥ Bestore files on opening workspace

[ Display workspace information dialog on opening workspace
[~ Save workspace before executing any toals

[ Prompt befare saving workspace

¥ Prompt before saving session

Default directony for new work spaces:

C:Hew Browsze. .

ak. | Cahicel

Figure 6.9: Options Dialog Workspace Tab

The following sections explain the options available on this tab.

6.4.1 Open last workspace at start-up

Set this check box if you would like the High-performance Embedded Workshop to automatically open the last
workspace you opened when it is launched.

6.4.2 Restore the files on opening wor kspace

When you close aworkspace, the HEW stores, which files were open. When you open a workspace, the HEW
can restore (i.e. open) the same files so that you can continue your session in exactly the same state as when you
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left it. If you would like the files associated with a workspace to be opened when you open a workspace then set
this check box.

6.4.3 Display wor kspace information dialog on opening wor kspace

When many workspaces are being used, it is sometimes difficult to remember exactly what was contained within
each workspace. To help resolve this, the High-performance Embedded Workshop alows you to enter a textual
description of each workspace.

2 To enter aworkspace description:

1. Select the workspace icon from the “ Projects’ tab of the ”Workspace” window.

2. Click the right mouse button to invoke the pop-up menu and then select the “ Properties’ option. The
dialog shown in figure 6.10 will be displayed.

3. Enter the description into the “Information” field.

4. Check the “ Show workspace information on workspace open” check box if you want aworkspace
properties dial og to be launched on opening a workspace. This check box has the same role as the
“Display workspace information dialog on opening workspace” on the “Workspace” tab of the “Options’

dialog.
5. Click “OK” to save the description on the “ Information” diaog. Click the “Cancel” button not to save the
description.

Workspace Properties EHE
Hame: |Dema_Ha5 25008 ; ,
Location; CAHewhDemo HA5 2600450 emo_HES 26004, e c I
Lastmodiied:  10:28:30, Monday, Jure 23, 2003 4”“3
CPLI Farnily: HB85,H8/300
Tool chain: Hitachi HES H&/300 Standard
Information:;

Mo workspace information available ;I

¥ Show warkspace information on work space open

Figure 6.10: Workspace Properties Dialog

When aworkspace is opened, the High-performance Embedded Workshop can display thisinformation so that it
is possible to determine whether the workspace is the desired workspace. To display thisinformation on opening
aworkspace, set the “ Display workspace information dialog on opening workspace” check box.

6.4.4 Save wor kspace befor e executing any tools

To force the High-performance Embedded Workshop into saving the current workspace before executing any
build phases (i.e. build, build al or build file operations) or version control commands set the “ Save workspace
before executing any phases’ check box.
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6.4.5 Prompt befor e saving wor kspace

In addition to the above check box, set thisto prompt before saving.

6.4.6 Default directory for new wor kspaces

When anew workspace is created the High-performance Embedded Workshop invokes the “ New Workspace”
dialog. One of the fields on this didog is the directory in which the new workspace will be created. By defaullt,
thisistheroot directory. However, if you would like to set this default directory to another location (e.g.
“C:\Workspaces’) then enter the desired directory into the field or browse to it graphically viathe “Browse...”
button.

6.4.7 Prompt before saving sesson

Checking this option will force the High-performance Embedded Workshop into displaying a prompt before the
session is saved to disk.
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6.5 Using an External Editor

The High-performance Embedded Workshop allows you to use an external editor. Once an externa editor has
been specified, it will be launched when the following actions are performed:

» Double clicking on afilein the “Projects’ tab of the “Workspace” window.

» Double clicking on an entry in the “Navigation” tab of the “Workspace” window.
» Double clicking on an error/warning in the “Build” tab of the “ Output” window.

» Double clicking on an entry in the“Find in Files’ tab of the “ Output” window.

» Selecting the [Open <file>] option from the “Workspace” windows pop-up menu.
» Clicking the “Launch Editor” toolbar button.

2 To specify an externa editor:
1. Select [Tools->Options...]. The “Options’ dialog will be displayed. Select the “Editor” tab (figure 6.11).

Build  Editor |Workspace| Confirmationl Netwnrkl

T ab size: I 4

— Spacing;

¥ Enable auta indentation

— General:
W Save files before executing any tools ¥ Show files in noteboak:
™ Prompt before saving files ¥ Enable spntax colaring

¥ Enable Smart-edit for C++ files

— External editar:

[ Usze extemal editar:

| Fl it |

ak. I Cancel

Figure 6.11: Options Dialog Editor Tab
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2. Check the “Use external editor” check box.
The “External Editor” dialog will be displayed (figure 6.12).

External Editor

LCommand:
IE:\WINDDWS\Notepad.EHe Browsze... | Ok |

Arguments to open file: Cancel |

[FULLFILE) 9

Arguments to open file at Jine:

|$[FULLFILE] |L|

Figure 6.12: External Editor Dialog

3. Enter the path of the executable (without any arguments) into the “Command” field.

4. Enter the arguments required to open afileinto the “ Argumentsto open file’ field. Use the $(FULLFILE)
placeholder to represent the path of the file to be opened.

5. Enter the arguments required to open afile at a specific line into the “ Arguments to open file at line” field.
Use the $(FULLFILE) placeholder to represent the path of the file to be opened and the $(LINE)
placeholder to represent the line number at which the cursor should be initially positioned.

6. Click “OK” to define the editor.
Note:  When using an externa editor be aware of the following issues:

» Each time you invoke the external editor, in whichever way, a separate instance of the editor will be launched.
* You must save your own files before you perform abuild file, build or build al operation.

6.6 Customizing File Save

The High-performance Embedded Workshop allows you to customize file save on the “Editor” tab of the
“Options’ dialog (figure 6.11). To open the tab, select [T ools->Options...] and click the “Editor” tab.

The following sections explain the options related to file save.

6.6.1 Save files befor e executing any tools

To force the High-performance Embedded Workshop into saving edited files before executing any build phases
(i.e. build, build al or build file operations) or version control commands, set the “ Save files before executing
any tools’ check box.

6.6.2 Prompt before saving files

In addition to the above check box, set thisto prompt before saving.
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6.7 Using an External Debugger

The High-performance Embedded Workshop can launch an external debugger tool. If you want to use another
debugger then you must add it to the “Tools” menu.

The “Debugger” tab of the “ Customize” dialog (figure 6.13) is where the Hitachi Debugging Interface related
information is configured. Y ou may wish to use an older version of the debugger if certain targets are not
currently supported in the new environment. Invoke it by selecting [T ools->Customize...] and then selecting
the “Debugger” tab.

Toolbarsl Cnmmandsl Menu I Placeholders  Debugger | Log I Help I

¥ Uze external debugger

HOI location [4.0 ar greater]:

IC:\Hew'\HDIE'\SIM'\SH'\Hdi.exe Ll Browse... |

Sesgion file:
|$[EDNFIGDIH]\$[PHDJEETNAME].hds Ll Browse. . |

Download module:

I$[EDNFIGDIFE]'\$[F'F|DJECTNAME].abs Ll Browse. . |

Figure 6.13: Customize Dialog Debugger Tab

To use an external debugger, check the “Use external debugger” checkbox and specify the items described below.
There are three items of information, which need to be specified. Firstly, the location of the HDI executable must
be specified. This must be version 4.0 or greater otherwise the behavior is not guaranteed. The second item of
dataisthe session file. Thistells HDI which session to load when it is launched. Finally, the location of the
download moduleis required. This allows the HEW to automatically switch to HDI when the download module

changes after abuild. Click the “Launch External Debugger” toolbar button to invoke HDI with the specified
session file.

After abuild, if the download module has been updated, the HEW will switch back to HDI to enable immediate
debugging. Whilst using HDI, double clicking in any source window will switch back to the HEW with the
source file open at the line which was double clicked.
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6.8 Using Custom Placeholders

Throughout the High-performance Embedded Workshop the user can use a number of pre-defined placehol ders
for directory definitions. For example the user can use the “$(PROJDIR)” variable to signify the current HEW
project directory. Thismakesit much easier to relocate projects and keep al of the paths correct.

The High-performance Embedded Workshop also has the ability to define custom placeholders. This meansyou
can enter your own custom placeholder definition and decide upon its directory value. Once defined this
placeholder becomes available throughout the rest of the HEW system.

The placeholders can be defined on an application wide level so the placeholders are available to all workspaces
and projects that use the HEW. The other method of defining the placeholdersis using the workspace wide
custom placeholders this means the placeholders can only be used in the current workspace. Thislistisonly
available when you have a workspace open.

Toolbarsl Commandsl Menu  Placeholders I Debuggerl Log I Help |

Applicatioh wide custom placeholders:

Placehalder | Diirectary |

Todify

[ iy
[ e
Add. |
[ e
[ s
o |

Hemoye

Wwiorkzpace wide custom placeholders:
Placehalder I Diirectary I d

..

Femoye

(18

Figure 6.14: Customize Dialog Placeholder Tab

2 To add acustom placeholder:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the
“Placeholders’ tab (figure 6.14).

2. Choose whether you need to use an “ Application wide custom placeholder” or “Workspace wide custom
placeholder”. Click “Add” on the adjacent button to the list you require.

3. Thedidog, add “New Custom Placeholder” dialog is displayed. (figure 6.15)

4. Inthefields provided choose a suitable name for the placeholder and a description of what the
placeholder means.

5. Then choose a directory, which relates to this placeholder. It is possible to use placeholders that are
aready defined in this field such as $(PROJDIR).
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Mew Custom Placeholder [ %]

Placeholder: “
I Cancel |

Description:

Diirectory:

I Browse... |

Figure 6.15: New Custom Placeholder Dialog

6.9 Using the wor kspace and project log facilities

The HEW 3.0 has workspace and project logging facilities integrated into the application. These facilities can be
switched on via the log tab on the Tools customize dialog. Thisoption is especially useful when the network
databaseisin operation. Thisisbecause user names and changes are logged to thisfile. Thisdialog isshownin
figure 6.16.

When the workspace log is clicked any workspace changes will be logged to afile with the same name as the
workspace with a*“.log” extension. Thisfile will be located in the same directory as the workspace file.

When the generate log for projectslog is clicked any projectsin the current workspace that have changes made
to them will be logged to afile with the same name as the project with a“.log” extension. Thisfile will be
located in the same directory as the project file.

Thelog file is updated when the workspace is saved.

Customize 7|

T-:c-lbarsl Commandsl L | Debugger Log |Help |

[ Generate buid log:

Bt

I LI Browse.,. |

[T Generate workspace log

[T Generate log for projects

]9 I Cancel

Figure 6.16: Tools customizelog tab
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7. Version Control

The High-performance Embedded Workshop provides facilities for connecting to a version control tool. Some of
the reasons why version control tools are used with a project are:

» To maintain theintegrity of aproject.
» To store each stage of a project.
» Toenabledifferent usersto co-develop a project by controlling revisionsto its source files.

Figure 7.1 illustrates a typical project where aversion control system isin use. This shows three users who al
use the same-shared network drive to exchange source code. The version control system provides access and
updates to the source files.

NETWORK

Figure7.1: Version Control
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7.1 Selecting a Version Control System

Initialy, the version control sub-menu will appear as shown in figure 7.2. At thistime only the [Version
Control -> Select...] option is available because a version control system is not yet active for the current
workspace.

Adminiztration... ﬂﬂl (T

[Ehatae iaE chaT Ve,

FE—

o Cantrol Select. .
Customize... [EOmfiEuTE..
Options... [ EadFTES]

Yol [ il
)1 CanmotExterma Mebuggen.. [% _emolve fiels]
S NER ]

o Check Db el
= ChecklhFile(s)
(&) Stafus of Filels]

Format Wiews. ..

Figure 7.2: Version Control Sub-Menu
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2 To select aversion control system:
1. Select [Version Control->Select...]. The diaog shown in figure 7.3 will be displayed. Thisdialog lists
all of the supported version control systems.
2. Select the desired version control system from the “Version control systems’ list and click the “ Select”
button. The “Current version control system” is changed to reflect the new selection.
3. Click the “OK” button to confirm the selection.

Select Yersion Control System

Werzion control systems; ak

Customn YES

Cancel

Select

adil

Current verzion control system:

Mone

Figure 7.3: Select Version Control System Dialog

Note: Only those version control systems, which have been installed with the HEW, will appear in the “ Select
Version Control System” dialog (figure 7.3).

Once aversion control tool is selected you will notice that the [Version Control->Configure...] option has now
become available.

The next chapter discusses the usage of the custom version control system.
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8.  Using the Custom Version Control System

The custom version control system is a configurable addition to the High-performance Embedded Workshop,
which allows you to connect to aversion control system aready installed on your machine. To clarify further,
the High-performance Embedded Workshop does not provide a version control tool itself, only a means by
which you can integrate the version control system, which you use into your workspaces and projects.

8.1 Defining Version Control Menu Options

The custom version control system allows you to invoke a version control command either by selecting an
option from the [Tools-> Version Control] sub-menu or by clicking aversion control toolbar button. When
either of these actions are performed, the associated commands are executed and the output is displayed in the
“Version Control” tab of the “Output” window.

2 To execute aversion control menu option or toolbar button:

1. Select whichever items you would like to apply the version control command to from the “ Workspace”
window. This may include aworkspace, project(s), folder(s) and file(s). When the command is selected,
all of the files will be extracted from the selected items and passed, in turn, to the version control
command. For example, if you select the workspace icon then all of thefilesin all of the projects will be
passed, in turn, to the version control command. Thiswill include any system files. For exampleif you
select the project item then

2. Select the required menu option from the [Tools->Version Control] sub-menu or click the desired
version control toolbar button.

The custom version control support allows you the most flexibility in specifying how aversion control systemis
to be used. To configureit, select [Version Control->Configure...]. The “Version Control Setup” dialog will be
displayed (figure 8.1).
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Yersion Control Setup EHE

Commatds l F'miecls] General]

System menu options and toolbar buttons
Rt ——
Check In File(s
Check Out File(s)
Get File(s)
Fermowve Filefz)
Status of File(s)

Madify, ..

User menu options

1L

0K, I Cancel ‘ Expott... | Impeort... | .

Figure 8.1: Version Control Setup Dialog Commands Tab
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The “Commands’ tab contains two lists of menu options. The first list, “ System menu options and toolbar
buttons’, represents those menu options which always appear on the version control sub-menu. These menu
options also have an associated toolbar button on the version control toolbar. The second list, “User menu
options’, represents those additional user defined options which are added to the bottom of the version control
sub-menu. Figure 8.2 shows the structure of the version control sub-menu.

Syaterm
Defired
Cipticn

= .

@ st N
. . User
Histary of Filels) Diefined
Undo Check out of Filels) Opticn

Figure 8.2: Version Control Sub-Menu

811 System menu options and toolbar buttons

In order to invoke commands from the toolbar or the system defined options of the [T ools->Version Control]
sub-menu, you must first define the associated commands that should be executed when they are activated. The
names of the options and their intended action arelisted in table 8.1.

Table8.1: System Menu Option

Option Description

Add File(s) Add selected file(s) to version control system.

Remove File(s) Remove selected file(s) from version control system.

Get File(s) Get a read only local copy of the selected file(s) from version control system.

Check In File(s) Put back, i.e. update, the selected file(s) in version control system with the
local copy.

Check Out File(s)  Get a writable local copy of the selected file(s) from version control system.
Status of File(s) View the status of the selected file(s).

2 To modify asystem menu / toolbar option:
1. Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed.
2. Select the option to be modified from the “ System menu options and toolbar buttons” list and then click
the “Modify...” button. The dialog shown in figure 8.3 will be displayed. This figure shows a dialog
when “Add File(s)” has been selected for example.

3. Commands are added viathe “Add...” button. See the section, “ Defining Version Control Commands”’,
later in this chapter for further information.

4. Closethe “Define Command for “<command>"" diaog by clicking “OK".
5. Closethe“Version Control Setup” dialog by clicking “OK”.
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Define Commands for “Add File[s]"

Commands

dd
Tt
HEemayve

I e

LLLERE

Fal w2 e

Figure 8.3: Modify System Menu Option (Example)
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812 User menu options

Y ou can create as many user defined menu options as you like, name them how you want and define their order
in the menu. User defined menu options do not appear on the version control toolbar.

2 To create anew version control menu option:
1. Select [Version Control->Configure...]. The diaog shown in figure 8.1 will be displayed.
2. Click the“Add..” button. The dialog shown in figure 8.4 will be displayed.
3. Enter the name of the menu option into the “ Option” field.
4

. Commands are added to the menu option viathe “ Add...” button. See the section, “Defining Version
Control Commands”, later in this chapter for further information.

5. Closethe “Add Menu Option” dialog by clicking “OK”.
6. Closethe “Version Control Setup” dialog by clicking “OK”.

Add Menu Option

Diption ;
IMprlion

Cancel
LCorrmands:

Tt
HEemayve
I e

Fal w2 e

L LLAE]

Figure 8.4: Add Menu Option Dialog
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2 Toremove an existing version control menu option:

1.
2.

3.

Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed.

Select the menu option to be removed from the “User menu options” list and then click the “ Remove’
button.

Close the “Version Control Setup” dialog by clicking “OK”.

2 To modify an existing version control menu option:

1
2.

3.
4.

Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed.

Select the menu option to be modified from the “User menu options” list and then click the “Modify...”
button beside the list. The dialog shown in figure 8.4 will be displayed. (Thetitle of the dialog is“Modify
Menu Option™.)

Modify the commands as necessary and then click “OK”.

Close the “Version Control Setup” dialog by clicking “OK”.

2 To change the ordering of version control menu options:

126

1.
2.

Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed.
Select the menu option to be moved and then click the “Move up” and “Move down” buttons as
necessary.

Close the “Version Control Setup” dialog by clicking “OK”.
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8.2 Defining Version Control Commands

Commands are defined when the “Add...” or “Modify..." buttons are clicked on the dialogs shown in figure 8.3
and figure 7.4. In either case, the dialog shown in figure 8.5 isinvoked.

Add Command EE3

— Command ;

- |
Wergion control executable ;
IVI'\VSS'\W|N32\SS.BHE Browse... |
— Cancel |

Arguments
IHistory $[YCOIR)HFILENAME] Y $USERNAME), $(PASS ﬂ

Initial directony ;

[$FILEDIF] P Bowse. |

— Executable return code

&' Return code of executable is not meaningful

" Command has failed if the retun code is 1ot Equal To ﬂ ID

Figure 8.5: Add/Modify Command Dialog

2 To define acommand:

1. Enter the full path of the command into the “Version control executable” field or browse to it graphically
by clicking the “Browse...” button.

2. Enter the arguments for the command into the “ Arguments’ field.

3. Enter theinitial directory in which you would like to run the executable from into the “Initial directory”
field or browse to it graphically by clicking the “Browse...” button. In most cases this should be set to the
“$(FILEDIR)" placeholder, i.e. execute the command from the same directory asthefile.

4. Set the “Executable return code” options as described in the following section.
5. Click “OK” to define the new command.

821 Executablereturn code

If the return code of the command(s) can be used to indicate a failure then you should select the “Command has
failed if the return code is’ option and set the two fields to the right as required.

If the“Command has failed if the return code is’ option is selected then the HEW will check the return code of
each command to determine whether a failure occurred. If so, no further commands will be executed and any
other processes which would follow the commands (e.g. build) will not be executed.

If the “Return code of tool is not meaningful” option is selected then the HEW will not check the return code of
each. Consequently, all commands will execute regardless.
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8.3 Specifying Arguments

It is obvious that arguments must be specified correctly, otherwise the version control tool executed will not
function asintended. However, it is also important, when using custom version control support, to specify the
argumentsin aflexible way as asingle version control command can be applied to more than onefile. To
facilitate this, the “ Arguments’ field has a placeholder button (refer to appendix C, “Placeholders’, for anin
depth discussion of placeholders) which, when clicked on, invokes a pop-up menu of available placeholders
(figure 8.6). An explanation of each placeholder and how their values are derived can be found in table 8.2,
Arguments Field Placeholders.

l User login name
User login password
“ersion control directory
Camment
File path + name
Filename
File leaf
File extension
File directory
Configuration directory
Project directory
Workspace directory
Temp directory
Command directory
Windows directory
Windows system directory
Workspace name
Project name

Configuration name

Figure 8.6: Arguments Field Placeholder Pop-up Menu
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Table 8.2: Arguments Field Placeholders

Placeholder Value and How its Determined

User login name Current user login (“General” tab)

User login password Current user password (“General” tab)

Version control directory “Virtual” version control mapping (“Projects” tab)
Comment Comment specified before command execution
File path + name Full path and name of file involved in operation
Filename Filename (including extension) of file involved
File leaf Filename (excluding extension) of file involved
File extension Extension of file involved in operation

File directory Directory of file involved in operation
Configuration directory Current configuration directory

Project directory Current project directory

Workspace directory Current workspace directory

Temp directory Temporary directory

Command directory Version control executable directory

Windows directory Directory where Windows® is installed
Windows system directory Directory where Windows® system files exist
Workspace name Current workspace name

Project name Current project name

Configuration name Current configuration name

831 Specifying File L ocations

When referring to afile’ slocation, be sure to use a placeholder, otherwise the command will only relate to a
hardwired file. For example, let’simagine that a version control executable has been selected which usesa—GET
command to obtain aread only copy of afile. The “Arguments’ field could be specified as:

-CET “c:\vc\files\project\min.c”

However, when executed, this command can only ever get the file MAIN.C. To resolve this problem, HEW uses
a system of placeholders and directory mappings. The latter tell the HEW which “working” directories (i.e.
where source files are being worked on) map to which “controlled” directories (i.e. where the source files are
stored in the version control system). Mappings between these two directory systems can be specified via the
“Projects’ tab of the”Version Control Setup” dialog (figure 8.7).
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Yerzion Control Setup

Commands  Frojects |Genera||

Shove details Far project : I Frojecti j

— Details ;

Yergion control directorny mappings ©

Source Directory | Werzion Control Directany Add...
c:wwark happlicationhprojectl = wchawhapphproject]
o mark happlicationhsrc whvwchawhapphan b iy, |
o hwork hahared whwch ot zhared —
HEemayve |
N I -1
Enwironment :
Add..
el it

EEmmvE

f

ok I Cancel Ewpont... Import. ..

Figure 8.7: Version Control Setup Dialog Projects Tab

2 To define anew mapping:

1. Select [Version Control->Configure...]. The diadog shown in figure 8.1 will be displayed. Select the
“Projects’ tab, and the dialog shown in figure 8.7 will be displayed.

2. Click the“Add..."” button that is next to the “Version control directory mappings’ list. The dialog shown
in figure 8.8 will be displayed.

3. Enter the source (i.e. “working”) directory into the “ Source directory” field or browse to it graphically by
clicking the “Browse...” button.

4. Enter the version control directory (i.e. “controlled”) directory into the “Version control directory”.

Yerzion Control Directory Mapping 2 | x|

Source directary : ak.
Ic:'\work'\shared ﬂ Browse... I Cancel

Yerzion control directon ©

il

I:-:Z wechawhshared

Figure 8.8: Version Control Directory Mapping Dialog
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2 To modify an existing mapping:
1. Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed. Select the
“Projects’ tab, the dialog shown in figure 8.7 will be displayed.
2. Select the mapping to be modified from the “Version control directory mappings’ list and then click the
“Modify...” button. The dialog shown in figure 8.8 will be displayed.
3. Make the necessary changes to the two directories and then click “OK” to confirm the edits.
2 To remove an existing mapping:
1. Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed. Select the
“Projects’ tab, the dialog shown in figure 8.7 will be displayed.
2. Select the mapping to be removed from the “Version control directory mappings’ list and then click the
“Remove’ button.

Once the mappings have been defined you can use the “Version control directory” placeholder, $(VCDIR), to
represent the directory in which the project fileis stored. Consider the scenario shown in figure 8.9. Here are
three directories, which are mapped from a shared version control drive (X:\) to alocal drive where the
development is being done (C:\).

LOCAL - C:\ Mapped To NETWORK - X:\

- =

C:\work\application\projectl X:\vc\sw\app\project1

=

X:\ve\sw\app\src

-
-

Bl

C:\work\application\src

Eﬁ

C:\work\shared

X:\vc\sw\shared

Figure 8.9: Example Mappings

Now let’simagine that aversion control executable has been selected which uses a—GET command to obtain a
read only copy of afile. In order to get al of the filesin a project we need to use the following command:

- GET “$(VCDI R)\ $( FI LENANE) *

When the HEW executes the command for a given project file, it will replace $(VCDIR) for the equivalent
version control directory in the file mapping.

For example, suppose FILEL.C islocated at:
c:\work\application\projectl\filel.c
If the get command is applied to FILEL.C then:

(1) x:\ve\sw\app\projectl is substituted for $(VCDIR) asthisisthe version control directory mapping for
c:\work\application\projectl.

(2) FILEL.C is substituted for $(FILENAME).
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Project File: C:\work\application\projectl \ filel.c
Arguments: $(VCDIR) \ $(FI LENAVE)

(€] @
Command: X:\vc\swapp\projectl \ filel.c

Figure 8.10: Example of Substitution

8.3.2 Specifying Environment
Select the “ Projects’ tab of the “Version Control Setup” dialog to view the current settings (figure 8.7).

To add anew environment variable click the“Add...” button beside the “ Environment” list (the dialog shown in
Figure will be invoked). Enter the variable nameinto the “Variable” field, the variable’ svalue into the “Vaue’
field and then click “OK” to add the new variable to the “ Environment” list.

Environment ¥ariable
Wariable :
f

Walle

> | Placeholder
I | POpUR MEny

0

IH
x

Cahicel

Figure 8.11: Environment Variable Dialog

To modify an environment variable, select the variable that you want to modify from the “ Environment” list and
then click the“Modify...” button beside it. Make the required changesto the “Variable’ and “Vaue” fields and
then click “OK” to add the modified variable back to thelist. To remove an environment variable, select the
variable that you want to remove from the “ Environment” list and then click the “Remove” button besideit.

132




High-performance Embedded Workshop User’s Manual

8.3.3 Specifying Comments

If a command contains the placeholder “$(COMMENT)” then the HEW will request that you enter the comment
when the command is executed (viathe dialog as shown in figure 8.12).

Please Enter Comment EE3

File: c:\hewtdemohdemohsbrlk. c

Cancel |
Comment

[ Apply comment to al files

Figure 8.12: Please Enter Comment Dialog

Y ou may specify acomment for each file or, if you would like to specify the same comment for al files, check
the “Apply comment to al files’ check box before clicking “OK”.
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8.34 Specifying a User Name and Passwor d

Most version control toolswill require you to pass a user name and password on the command linein order to
keep files secure and to keep a record of which files were changed by which users. The custom version control
support provides two placeholders “User login name”, $(USERNAME), and “ User login password”,
$(PASSWORD). When the command is executed, these placeholders will be replaced with the current settingsin
the “General” tab of the “Version Control Setup” dialog (figure 8.13).

Yerzion Control Setup

Eommandsl Projects General |

— Execution :

¥ Prompt before executing command
[ Bunin DOS ‘Window

[ Use forward slash ' as version control directory delimiter

— Usger details :

Uzer: JHAREK,

s

Password ;

— Configuration file:
Current verzion contral configuration file:

C:AHew Project1WCustomy 25 hve

ok Cancel Ewpont... Import. ..

Figure 8.13: Version Control Setup Dialog General Tab
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In order to give the 3(USERNAME) and $(PASSWORD) fields a value you will first need to login. If you have
not logged in before acommand is executed which uses either of these placeholders then you will be prompted
to do so before the command can be executed.

2 Tologin (i.e. specify auser name and password):

1

a s w D

Click the“Log in...” button. The dialog shown in figure 8.14 will be displayed.

Enter your user name into the “User name” field.

Enter your password into the “ Password” field.

Re-type your password again into the “ Confirm password by retyping it below” field.

Click “OK” to set the new user name and password. If there is any inconsistency between the two

versions of the password which you entered then you will be requested to type your password again.

Uzer name : ok I
JHARE,
I Cancel |

Pazsword

Ixmmmm

Confirm password by retyping it belov

Figure8.14: Login Dialog
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84 Controlling Execution

The “Genera” tab of the“Version Control Setup” dialog (figure 8.13) allows you to control the way in which
the version control tool is executed. It also shows the full path to the current version control configuration file.

84.1 Prompt before executing command

If this check box is set then, before any version control commands are executed, adialog is displayed (figure
8.15) which listsal of the filesinvolved in the operation. Files may be deselected by clearing the associated
check box. Clicking “OK” will apply the command to each of the selected files. Clicking “Cancel” will abort the
operation.

History [ 7] x|

Filez

widemo.c  [c:hhewidemohdemao)

(wzbrk.c [z:\hewhdema'.demo] Cancel |

(v vectthl zrc [o:hhewdemohdemao)

KN — Il

Figure 8.15: Command Prompt Dialog (Example)

8.4.2 Run in DOS Window

By default, the output of the version control commandsiis redirected to the “Version Control” tab of the “ Output”
window. If you would rather run each command in a separate DOS window then set this check box.

8.4.3 Useforward slash ‘/* asversion control directory delimiter

By default, when the HEW substitutes the placeholder $(V CDIR) it uses the backward slash character ‘\" to
divide directories. However, if the version control system you are using uses a forward slash character (e.g.
Visua SourceSafe) to divide directories then set the “Use forward slash */* as version control directory
delimiter”.

8.5 Importing and exporting a Set-up

Each workspace can have a different version control set-up. The HEW allows you to store the version control
settings independently so that you can import them into other workspaces. This greatly reduces the amount of
timeit takes to configure the same version control settings across several workspaces.

2 To export aversion control set-up:
1. Select [Version Control->Configure...]. The diaog shown in figure 8.1 will be displayed.

2. Click the“Export..." button. A standard file save dialog will be displayed. Browse to the directory in
which you would like to save the configuration.

3. Enter the name of the file and then click “OK”.
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2 Toimport aversion control set-up:
1. Select [Version Control->Configure...]. The diaog shown in figure 8.1 will be displayed.

2. Click the“Import..."” button. A standard file open dialog will be displayed. Browse to the * .HVC file
which you would like to import.

3. Sdlect thefile and then click “OK”.
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9. Using Visua SourceSafe

The High-performance Embedded Workshop provides specific support for the Visua SourceSafe version control
system. At the time of writing, the HEW can only attach to versions 5 and 6 of Visua SourceSafe.

The Visua SourceSafe version control system associates a project in your workspace with aproject inside a
Visual SourceSafe database. It alows you to quickly invoke the standard commands either by selecting an option
from the [T ools->Version Control] sub-menu or by clicking aversion control toolbar button.

9.1 Attaching Visual SourceSafeto a Workspace

The following sections describe how you can associate Visual SourceSafe with your current workspace.

9.11 Selecting Visual SourceSafe
First, you need to select Visual SourceSafe as the version control system.

2 TouseVisua SourceSafe 5.0 or 6.0:

1. Select [Tools->Version Control->Select...]. The“Select Version Control System” dialog will be
displayed (figure 7.3) which lists al of the supported version control systems.

2. Select the“Visua SourceSafe 5.0/6.0" entry from the Version Control Systemslist and click the “ Select”
button.

3. Click “OK" to confirm the selection. The SourceSafe Login diaog is displayed (figure 9.1).

4. Enter your Visua SourceSafe login into “Username” and password into “ Password”.

5. Enter into Database path the full path to the Visual SourceSafe database (i.e. SRCSAFE.INI) into which
you would like to add this project.

6. Click “OK”. The “Create SourceSafe Project” diaog isinvoked (figure 9.2).

7. The“Project name” field displays the name of the project (i.e. folder) to be created in the database. If
necessary you can change this name to another.

8. Thetree underneath the “ Project name” field shows the structure of the database specified in step 6.
Select the folder into which you would like to create the folder specified in the “ Project name” field.

9. Click “OK".

10. HEW will require you to repeat steps 7-9 for as many projects as are present in the current workspace.

SourceSafe Login EHE

Uzernarne: I
Password: I ﬂl

Latabaze path: I Browsze. . |

Figure 9.1: SourceSafe L ogin Dialog
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Create SourceSafe Project

PBroject name:

Iprniect

$/project

Ea [§;| agip i’

||

Figure 9.2: Create SourceSafe Project

The HEW has now created the necessary projects within Visual SourceSafe and sets-up the version control
toolbar and menu for immediate access. However, athough the Visual SourceSafe projects themselves have
been created, no files have been added to them.

9.1.2 Adding filesto Visual SourceSafe

The previous section has only established the mappings between the project directory on your hard disk (i.e. the
working directory) and the project directory in Visual SourceSafe (i.e. the controlled directory). Although the
project directory (and any subdirectories) on your hard disk may contain many source files whereas the directly
itsmapped to in Visual SourceSafe will beinitially empty.

Firstly, you must select Visual SourceSafe as the version control system.

2 Toaddafileor filesto Visual SourceSafe:

1. Select thefile(s), which you would like to add to Visua SourceSafe. You may also select afile folder,
project folder, aworkspace folder or combination thereof. When selecting the project or workspace
folder then the system files will be added to the selected file list. For example, selecting the project folder
will also add the project file to thefilelist. If the project file isthen checked out and the version is newer
than when it was last |oaded you will be asked whether you want to reload the project.

2. Click the Add Files toolbar button ( @?) or select the [Tools->Version Control->Add Files] menu

option.

When you add filesto Visual SourceSafe thelocal versionsin your working directory will become read only. To
check that the add files operation was carried out as you expected, or to quickly review the status of all of the
filesin aproject:

1. Select the project folder whose files you want to check.

2. Click the Status of Filestoolbar button ( @ ) or select the [Tools->Version Control->Status of Files]
menu option.

3. Thestatus of each file will be displayed in the “Version Control” tab of the “ Output” window. The
information shown includes whether the file is added to the project, if the file is checked out and, if it is
checked out, who did so.
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9.2 Visual Sour ceSafe commands
The following 8 operations are available:

* Add afileto version control

* Remove afile from version control

» Get aread only copy of afileor files

» Check out aread/write copy of afileor files (i.e. for editing)

» Check inapreviously checked out file or files (i.e. update Visual SourceSafe with the edits made)
» Undo apreviously check out operation on afile or files (i.e. cancel any edits made)*

* View thestatus of afile

* View the history of afile*

*These commands can only be accessed viathe [T ools->Version Control] sub-menu whereas all of the other
commands can be accessed from both the toolbar and menu.

921 Removing a File from Version Control

Although files appear in your HEW project (in the “Projects’ tab of the “Workspace” window, Visua
SourceSafe is not necessarily controlling them.

2 Toremovealfileor filesfrom Visua SourceSafe:
1. Select thefile(s), which you would like to remove from Visual SourceSafe. Y ou may also select afile
folder, project folder, a workspace folder or combination thereof.
2. Click the Remove Filestoolbar button ( @- ) or select the [Tools->Version Control->Remove Files]
menu option.

922 Getting a Read Only Copy of a Filefrom Version Control

Visual SourceSafe protects your source files and ensures that only one user can have a writable copy of a
controlled file at any one time. However, it is possible for any user to obtain aread only copy of any file.

2 Toget aread only copy of afileor files from Visual SourceSafe:
1. Select thefile(s), which you would like to get from Visua SourceSafe. Y ou may also select afile folder,
project folder, a workspace folder or combination thereof.
2. Click the Get Filestoolbar button ( % ) or select the [Tools->Version Control->Get Files] menu
option.

923 Checking Out a Writable Copy of a File from Version Control

Visual SourceSafe protects your source files and ensures that only one user can have a writable copy of a
controlled file at any one time. The check out operation takes awritable copy of thefile from Visua SourceSafe
and placesit on your local drive. Thiscan only be done if another user does not already check out the file or files
in question.

2 To check out awritable copy of afileor files from Visual SourceSafe:
1. Select thefile(s), which you would like to check out from Visua SourceSafe. You may also select afile
folder, project folder, a workspace folder or combination thereof.
2. Click the Check Out Filestoolbar button ( 5 ) or select the [Tools->Version Control->Check Out
Files] menu option.
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3. When the operation is finished the file has ared tick next to itsname. This meansyou as the current
user of HEW has checked it out.

9.24 Checking In a Writable Copy of a Fileinto Version Control

Visual SourceSafe protects your source files and ensures that only one user can have a writable copy of a
controlled file at any one time. The check out operation takes awritable copy of thefile from Visua SourceSafe
and placesit on your local drive. Once afileis checked out it is edited and then checked back in so that the edits
can be made available to other users.

2 Tocheck in edits made to afile or filesin Visual SourceSafe:
1. Select thefile(s) upon which you would like to check back into Visual SourceSafe. You may also select a
file folder, project folder, a workspace folder or combination thereof.

2. Click the Check In Filestoolbar button ( 2 ) or select the [T ools->Version Control->Check In] menu
option.

9.25 Undoing a Check Out Operation

Visual SourceSafe protects your source files and ensures that only one user can have a writable copy of a
controlled file at any one time. The check out operation takes awritable copy of thefile from Visua SourceSafe
and placesit on your local drive. Once afileis checked out it is edited and then checked back in so that the edits
can be made available to other users. However, if the check out operation was carried out by mistake, or perhaps
isno longer required, then the operation can be undone.

2 Toundo acheck out of afile or filesfrom Visua SourceSafe:

1. Select the file(s) upon which you would like to undo a previous check out operation. Y ou may also select
afile folder, project folder, a workspace folder or combination thereof.

2. Select the [Tools->Verson Control->Undo Check Out] menu option.

9.2.6 Viewing the Status of a File

Although files appear in your HEW project (in the Projects tab of the Workspace window), Visua SourceSafeis
not necessarily controlling them. Of those files, which are being controlled by Visua SourceSafe, some will be
checked in and others will be checked out (i.e. being edited by a user). The status command displays the current
status of afile or file(s).

2 Toview the status of afileor filesin Visua SourceSafe:

1. Select the file(s) whose status you would like to view. You may also select afile folder, project folder, a
workspace folder or combination thereof.

2. Click the Status of Filestoolbar button ( @. ) or select the [Tools->Version Control->Status of Files]
menu option.

3. If afilehasabluetick next to it auser different to you has checked it out.
9.2.7 Viewing the History of a File

Visual SourceSafe controlsthe edits to the filesin its projects and allows you to view the complete history of
these edits right back to the time that the file was first added to the project.

2 Toview the history of afileor filesin Visual SourceSafe:
1. Select the file(s) whose history you would like to view. Y ou may also select afile folder, project folder, a
workspace folder or combination thereof.
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2. Select the [T ools->Version Control->Show History] menu option.
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9.3 Visual SourceSafe Integration Options

Y ou can control the way in which the history and status commands are displayed by selecting [Tools->Version
Control->Configure...].

To display the results of a history command in adialog box then check the “Display dialog box for history”
check box or clear it if you would rather display the output in the “Version Control” tab of the “Output” window.
To display the results of a status command in adialog box then check the “Display dialog box for file status’
check box or clear it if you would rather display the output in the “Version Control” tab of the “Output” window.
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10. Network Facilities

10.1 Overview

The High-performance Embedded Workshop version 3 is capable of sharing workspaces and projects across a
network. Thisalows usersto concurrently work on shared projects and see each other’ s changes as they happen.
This system can be used in conjunction with version control. The major difference with using this system is that
each user can modify and update the workspace and project without making al of the other users reload their
project and potentially lose all their changes.

This system isimplemented by making one of the machines attached to the network the server machine. All
other client machines then use the service this machineis providing. So if one of the client machines adds a new
file, the server machineisnotified. The server then notifiesall other clients the action hastaken place. This
structure is shown below in figure 10.1.

Metwarked workspace and praject.

=

Metwork

-2 Metworked_Data_Example
B3 Networked_Data_Example
-3 Dehug

B+ SimDebug 5H-2

Server

Metwork access

Al files sre under the netwiork
zervice's control. These include
the workspace, project, session
and source files.

|
| ‘ ‘ | | ‘ Clients do not access data directly
with the workspace and project
files on the netwark. The clients cannot
directly communicate with each ather
gither. Al communication iz directed
Clients through the server machine.

Figure 10. 1: Network database access structure

The network system allows users to be given access rightsto files. This alows the project administrator to make
sure the only people who can modify the project and source files are allowed to do so. This might allow the
administrator to limit each user to only have write capabilities for their own area of the project, other areas
would beread only. This could limit any potentia conflict or damage one user could do to other areas of the
project. These limitations can be set to a number of different levels. Thisisoutlined later in this section.

Note:  Certain operationsarelocked when other clients are carrying them out. Thismeansthat if one
machineis currently changing the toolchain options all of the other machines can only seeread only
versions of this data.

Note:  The performance of HEW does suffer when using the network facilities. 1f workingin a small
team it might be more suitable to use the single user mode and version control.
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Enabling network access

2 To use network access:

1
2.
3.

10.1.2

Select [Tools->Options]. The HEW tools options dialog is displayed.

Select the network tab. Thisisdisplayed in figure 10.2.

Click the enable network access checkbox. This should add an administrator to the system without a
password. The administrator isthe only user that can add additional usersto the system and change user
accessrights. The administrator has the highest level of access.

Before leaving the network dialog the administrator must set their password. It isnot possible to leave
thisdialog until thisis completed. Thisis described below.

Setting the administrator user’s password

2 To set the password:

1

© N o Ok
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Continue from the previous sections steps.

Click the password button. This should have been enabled when the network data access was enabled.
The password dialog isdisplayed. Thisisshownin figure 10.3.

The user nameisread only inthetopfield. In thiscaseit should be Admin.

Type the new password into both of the fields and click OK.

This should set the user and password on the [ Tools->Options] network tab.

It isnow possible to leave the [Tools->Options] dialog.

When the dialog is closed you are asked if you want to save the workspace and then re-openit. Thisis
because the workspace must be re-opened in the shared access mode. If the changes are not saved then
they will belost.

When the workspace is re-opened adialog is displayed which asks you to log back into the system.
Once you havelogged in adiaog is displayed which shows your current accessrights. For exampleif
you are the admin user the level will be administrator. When thisdialog is closed the HEW server
window is opened and the network facilities are enabled.
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e —— 2 x|

Build I E ditar I Workspacel Confirmation  Metwork |

Metwaork databaze access

Lagirn... |
Uszer:
Password... |
Passwiord:

Aocesz rights. .

oK I Cancel

Figure 10. 2: Initial setup of network tab

x
Iﬁdmin
Cahicel |

Pazsword:
f

LConfirm pazzword by retyping below:

Figure 10. 3: Password dialog
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Adding new usersto the system

Theinitial setting of the network database adds an administrator user and a guest user to the system. The
following levels of access are possible in the HEW system:

* Administrator:

Full access to every aspect of HEW. The user can add and remove users from the projects and
change accessrights. The administration user can change the workspace and project files and also
the source files.

*  Full read/write access:

The workspace and project files can be modified, as can the source files. But it isnot possible to
change user access rights from this access level.

* Read/writefile access:
Only the source files can be modified. All project settings can only be viewed not modified.
* Readonly:

All source files and project files can only be viewed as read only. Nothing can be modified.

When any user opens a network-enabled project they must type in their user name and password. Until thisis
done no access can be granted. Once entered the user is given one of the levels of access as seen above.

2 Toadd anew user to the system:

1

o~ wDN

Log in with a user who has administrator access rights. The process for doing thisis described above.
Select [Tools->Options]. The HEW tools options dialog is displayed.

Select the network tab. Thisisdisplayed in Figure 10.2.

Click the access rights button. The dialog displayed in Figure 10.4 is displayed.

Click the add button. Thelogindialogisdisplayed. Thisallowsyou asthe administration user to add
anew log in name and password. Normally the password should be set to some default text or left
blank. Then click OK.

Once OK isclicked the user is added with read only rights. To change the access level select the user
you wish to modify and then click the required radio button. Then click OK to save the accessrights
changes.

2 Toremove an existing user to the system:
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Log in with auser who has administrator access rights. The process for doing thisis described above.
Select [Tools->Options]. The HEW tools options dialog is displayed.

Select the network tab. Thisis displayed in Figure 10.2.

Click the access rights button. The dialog displayed in Figure 10.4 is displayed.

Select the user you wish to removein the userslist.

Press the remove button.

Then click OK to save the access rights changes.
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E@@ User access rights |

Access level

Add
Eemowve |

Aooess
% Administrator

€ Full read/vwrite access
" Read/write file access only

" Read only access

ak I Cancel

Figure 10. 4: Accessrightsdialog

10.1.4 Changing your password

To change your password:
1. Logintothe HEW network database you are changing your password for. Select [T ools->Optiong].
The HEW tools options didog is displayed.
Select the network tab. Thisis displayed in Figure 10.2.
Click the password button.
Enter your new password and confirm it in the second edit box.
Click OK.
Then click OK to save the password change.

o o~ wDN

10.1.5 Usingthenetwork HEW service

When you connect to a networked project for the first time the HEW automatically connects you to the correct
network HEW service. Thisisdefined using machine name. If the service cannot be found using the machine
name in the workspace then the dialog displayed in figure 10.5 is shown. Simply type or browse to the machine
where the serviceislocated and click OK. If you want to be the server machine then leave the radio button on
its default selection, use local machine.
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Select Server Location

f+ ze local machine

= Usge network machine Cancel

Access
Computer name;

[ i

|| Browse...

Figure 10. 5: Select machine name

If you have previoudy been the server of aworkspace then the following message will be displayed when you
attempt connection to another machine. Thisdialog isdisplayed in figure 10.6. Clicking OK then connects your
machine to the new location.

High-Performance Embedded Workshop [ %]

& Wiortkspace is registered to be shared on computer 'PADOSSZ, you are registered to in server locally, do pou want ko change your server registration.

Cancel |

Figure 10. 6: Select machine name

Note:  If the network isrunning multiple HEW wor kspaces with the network service enabled then a user
can only access one of them at onetime. The only instance when thisisnot the caseisif the same machine
isserving all of the network wor kspaces.
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11. Difference View

The High-performance Embedded Workshop now has an integrated difference view. Thisview allows detailed
difference comparisons to be made with local files on the drive and aso with filesin the version control system.
In the HEW version 3 onwards the Visual SourceSafe component has this facility.

The difference window can beinvoked two ways. The first is from the show differences menu item on the tools
menu. The second is via the workspace window pop-up with the same name. When using the pop-up menu the
current file selection is automatically added to the edit box. Clicking the show differences menu item displays
the dialog shown below in figure 11.1.

Lo
chewhprojects\myprojectimpprojectidbect o File ity version cortral
1 14 -]
1 g 13
15 16
1? #pragma section SDSEC 1 fpragma section SDEEC
18 static const struct { 18 gtatic const struct |
13 char *rom s; /* 8tart address of tb 1 char *rom s; /* gtart address of the :
2 char *rom_e; /* Bnd address of the e char *rom_e; /* End address of the in:
th char *ram_s; /* 8tart address of tF 2 <har *ram_s; /* Start address of the :
= | DTEL[1= (b =
JDTBEL[]= {
Lk} {_ _sectop("D"), _ secend("D"), _ sectop(’ = {__sectop("D"), _ secend("D"), _ sectop("R"]
L {__sectop("$ABSEBD"), _ secend{"SABS8D") = // {__sectop("$ABE8D"), _ secend("§AESED"™), _
EEN {_ sectop("$AB31ED") , _ secend("$AB3l¢ = // {_ sectop("SAB3L1ED") , _ secend ("SAB31&D"
% e 25
i
7 #ipragma section $BIEC 2 ffpragma section $ESEC
2 statice const struct | 2 gtatic const struct |
21 char *h_s; /* Start address of nc char *h_s; /* gtart address of non—:
Bl char *b_e; /* End address of non- ¥ char *b_e; /* End address of non-in:
sULETEL [1= $}BTEL[]= | b
22 nge rR =2
LLI £ sectan (TR™Y =ecend (TR Y - _}ILI_I j;l

Figure 11. 1: Difference view

2 To perform adifference comparison with two files on your loca drive:

1.

Select [T ools->Show Differences...]. The difference compare filesdialog is displayed. Thisisshown
infigure 11.2.

Ensure the compare with file on drive radio button is enabled.

Enter the first and second file to compare. Y ou can either select a previous difference comparison or
browseto anew file.

Clicking the advanced button displaysthe dialog in 11.3. Thisallows you to perform the difference
comparison without taking white space into account. Click OK when you are finished with this options
dialog.

Click compare.

The difference view isdisplayed. The two files being compared are |oaded into each side of the split
view. Their names are at the top of each window.

2 To perform adifference comparison with alocal file and afilein SourceSafe:
1. Ensure the SourceSafe component is enabled. Also note that the file must be have been added into the
version control system.
2. Select [Tools->Show Differences...]. The difference compare filesdiaog is displayed. Thisis shown
infigure 11.2.
3. Ensure the compare with version control radio button is enabled.
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4. Enter thefirst fileto compare. You can either select a previous difference comparison or browse to a
new file.

5. Clicking the advanced button displaysthe dialog in 11.3. Thisallowsyou to perform the difference
comparison without taking white space into account. Click OK when you are finished with this options
diaog.

6. Click compare.

7. Thedifference view isdisplayed as shown in figure 11.1.

Compare files

Reference file:

IK:'\HEW2D\HEW 3.D'\E><E'\Win'\Fie|easej Browse. . |

" Compare with file on drive

Compare

Cancel

il

Advanced...
Target file:

j Browse. . |

' ‘Compare with version contof

Figure 11. 2: Difference comparefiles dialog

Compare Files - Advanced Options |

Cancel |

Figure 11. 3: Difference advanced options dialog

The difference view functionality can be accessed in two different ways. The difference view hasits own
toolbar thisis shown in figure 11.4. Thisfunctionality can also be accessed via the difference window right
mouse button pop-up. Thisisshownin figure 11.5.

lgnore white space
Compare files

Find mext

Find presious
Find previous difference

Find next difference

Mwdh g o T 4

Figure 11. 4: Differencetoolbar
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P Compars...

Export rezults ta file. .

L4 |gnore whitespace

i Find
% Find previous
ﬁ' Find rest

+ Previous difference
& Meut difference
Refresh comparizon

Figure 11. 5: Difference popup menu
The functionality for each menu item isdescribed below:

¢ Compare: This opens anew compare window so that some new files can be comapred and the
differences displayed.

« Export resultsto file: This opens a dialog which allows you to choose afile to export the current
difference results to atextual format.

« Ignore white space: Theignore white space option which is on the advanced options dialog can be
toggled viathis menu item.

¢ Find: Displaysastandard find dialog. Thisusesthe same find dialog asthe HEW editor.
e Find next: Findsthe next string that meets the find requirements.

« Find previous: Finds the next previous string that meets the find requirements.

* Previous Difference: Automatically jumps the view to the next previous difference.

* Next Difference: Automatically jumps the view to the next difference.

e Refresh comparison: Refreshs the view to manually run the difference comparison again. This can be
used if either file has been modified since the last comparison.

The difference window also alows the colours in the view to be customised. This procedureis outlined below:

2 To change the colors viewed in the difference window:
1. Select [Tools->Format Views...]. The format views dialog is displayed.
2. Expand the difference view. Thediaog isshown and looks the same as figure 11.6.
3. Select the category you want to change. The color display tab is displayed and allows modification.
The categories available are Left hand side moved lines, Left hand side different lines, Right hand side
moved lines and Right hand side different lines,

4. Click OK to keep the changes.
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Source Font |

Dizazzembly

Difference

[ LHS Different Lines

M LHS Moved Lines

[ RHS Different Lines

[ RHS Maoved Lines Font

B [Covierhiew |
=) Output

Fairt Size
HEW Zample Text

Add Iodify Eemowve 0k I Cancel
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12. Technical Support

The High-performance Embedded Workshop has a number of integrated technical support features.

2 To check for HEW product updates or service packs:
1. Select [Help->Technical support->Check website for updates].
2. Your default web browser isinvoked and defaults to the HEW download page for your region.
3. Browsethisareafor HEW updates to fix bugs or add new features.

Occasionaly you may experience some unforeseen problems with the HEW application. If a problem does
occur that results in a application crash the HEW bug tracking program will be invoked automatically. This
allows you to compile a bug report and this can then be sent to your technical support contact in avariety of
ways. Itisalso possibleto invoke this tracker program manually. Thisis described below:

2 To create and send a HEW bug report:

1. Select [Help->Technical support->Create Bug Report].

2. Detailed information is generated from your HEW system. This may take sometime. The bug report
dialog isthen displayed. Thisisshownin figure12.1.

3. Itispossibleto then add additional information concerning the exact issue you have found in the large
edit box.

4. Onceyou are happy with your report, you can choose the method of sending the report in the submit
drop list. Thishas e-mail entries and an entry for printing the report.

5. Then click submit. Thiswill send the report.

Submit a Bug Report

“You may submit a Bug Report through e-mail, or by conventional means.

The box below containz information gathered from vour machine, and any additional information
about the state of the software if a crash occuned.

‘Y'ou may check and edit the acquired data, and should add any additional information at the

end of the text.

Ré&M Informatiorn : ;I
Load : 0%

Total RAM - 267,837 440 bytes

Free Rak : 65,019,904 bytes

Page File : 384.319.488 bytes

Page File Free 189,648 896 bytes

Total Yirtual : 2,147 352 576 bytes

irtual Free : 231.693.824 bytes

Project Details :

Mo project information available

Please type a description of the problem vou wizh to report:

— How wauld you like ta subniit the repart? Submit
Pt ﬂ

Figure 12. 1: Submit bug report dialog
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13. Navigation facilities

The High-performance Embedded Workshop 3.0 has a number of new integrated navigation facilities. The
navigation window islocated alongside the project and templates window. Thisview isshown below in Figure
13.1.

£

Mavigation entries

E'Cl M avigation categary
EI@ demo Project
Bl aw CShark
----- &) CSharkl)
----- & ~CShark()
----- &) GetClazzM ame(woid]

----- &) m_nSharpTesth —
Bl g% CCrocodile

----- &) CCrocodilel)

----- &) ~CCrocodile()

----- &) GetClazzM ame(woid]

----- &gl m_nLiveiriy ater

----- &) m_nSharpTesth

B g% CFish Clazs name
----- & CFishl)
----- &3 ~CFishl)
----- &7 GetClazsMame(void) Class members

----- &) m_nLiveiniater

B o CGreatwhite

----- &) Chreatwhitel]

----- &) ~Chreatwhite()

----- &) FeedTheShark|CCrocodile™ myGoat)

----- &) FeedTheShark[CFish® myFizhwFood)

----- &) FeedTheShark[char® pze0therType)

----- &) FeedTheShark[CHoreze™ mpHorzeyFood)

----- &) FeedTheShark[CPerzon” myPerzonFood) =]

Project | Templates JNa\rigaﬁunI

Figure 13.1: Navigation view

The navigation view contains categories for al supported navigation types. In HEW 3.0 the following
navigation components are supported as standard:

e C++ Classes: All classes, functions and members are displayed for C++ source files.
e CDefines: All #defines for C and C++ source files are displayed.
e CFunctions: All ANSI C standard functions are for C source files displayed.

Each category is displayed in the top level of the view. Underneath each category each project in the workspace
isdisplayed. Then the items belonging to that particular project are displayed below the project icon.

157




High-performance Embedded Workshop User’s Manual

It is possible to disable scanning for certain navigation categoriesif you do not require the information.

2 To switch off anavigation category:
1. Right click on the navigation window. The pop-up menu displayed in figure 13.2 is shown.
Select the “ Select Categories’ menu item.
Thedialog in figure 13.3 is displayed.
Uncheck any categories you are not interested in seeing definitions for.
Click OK.

o s~ wDN

130 ko Declaration

Go ko Definition

Configure Yiew, .,
Select Categories. ..

IT Allow Docking
Hide

Figure 13. 2: C++ Navigation pop-up menu

Select Categories

Pleaze zelect the cateqories to scan for:

[w] Defines
[W]C Functions Caticel |
[w] C++ Clagzes

Figure 13. 3: C++ Navigation select categories dialog

Note: The navigation itemsare displayed gradually asthefilesare scanned. This meansit may take some
timeif thereare many filesto fully complete the navigation view update.

Filesarerescanned when they are saved. Thismeansthat navigation infor mation will not be available for
new classes and functions until thefile or filesare saved.
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131 C++ Navigation component

The C++ navigation component is the most complicated of the three supported navigation components. It
supports the following structuresin the view for C++ source files. The basic structure of the information is
shown below in figure 13.2.

£

EI -[1C++ Classes C++ navigation categary title
=5 @ demo Project name

- o CPerson

i‘i CCracodile

CCrocodileShark,

CFish Class name

CHorze

CMammaI

!I!--H--H--H--H--H--H--H

be

----- &) CGreatwhitel]

----- &) ~Chreatwhite()

----- &) FeedTheShark|CCrocodile” myGoat
----- &) FeedTheShark|CFish* myFishyFood '
----- &) FeedTheSharkichar® psz0therType Class Member functions
----- &) FeedTheShark[CHorse® myHorseyF
----- &) FeedTheShark[CPerson™ myPersonl
----- &) FeedTheShark[void]
----- &) GetClazzM ame(woid]
..... g m_nDangerous Protected member wariable
..... apl m_nlaws Frivate member variable

----- &) m_zhiMame )
E-[@] Globals Global varables and
E functions folder

----- &) kheap_area

----- &7 INT “ectors(] b
1| | 3
Project J Templates Navigation |

Figure 13. 4: C++ Navigation information

The C++ navigation view uses a number of icons to describe the type of function or variable the icon belongs too.
These are listed in the table below:
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Description

Public member function

Private mermber function

Protected member fiunction

Private metmber variahle

Protected member wvanahble

clefelele]e]

Public member rarable

Figure 13. 5 C++ Navigation | cons

The navigator view allows you to move around your source code quickly and efficiently. Double clicking on a
navigation item by default jumps you to the associated navigation items definition. Normally the definitionis
found in the source file and the declaration is found in the header file.

This default behavior can be modified for this action. This can be achieved via the configure view dialog. The
configure view dialog modifies the way datain the navigation view is displayed.

2 To configure the C++ navigation views data:
1. Right click on a C++ navigation item in the navigation window. The pop-up menu displayed in figure
13.2 is shown.

2. Select the“Configure view” menu item.
Thedidog in figure 13.5 isdisplayed.
4. Decide what items you wish to modify and click OK to accept the changes.

w

Configure Yiew |

Figure 13. 6 C++ Configure view dialog
Thefollowing items are available on the configure view dialog.
»  Group by access: This option groups the display of public, protected and private member variables and
functions together in the navigation view.
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Jump to definition on double click: By default this option is checked. If this option is switched off then
adidog is displayed which asks you where you wish to jump. You rather than HEW resolve the
ambiguity. Thisdialog isshown in figure 13.6.

Select Query Location x|

Select the query to jump to;

Go to Declaration ["animal.h", line 12)
Ga to Definition [animal.h'', line 12]

Cancel |

Figure 13. 7 C++ Configure view dialog

Another useful facility isthe capability of viewing the base or derived classes for a certain selection.

2 Toview the Base or derived classes

1
2.
3.

13.2

Select the class that interests you in the navigation view.

Right click and view the pop-up menu.

To see the derived classes for the selection click the “ Show Derived Classes’ menu item. To seethe
base classes for the selection click the “ Show Base Classes’ menu item.

Depending on the selection adialog is displayed which shows the class structure selected in an
expanded tree format.

Click OK to close this dialog once you have the information you reguire.

C Function and #defines navigation components

These components simply add the function and #define definitions to the navigation view. It isthen possible to
jump to these definitions by double clicking on the label you wish to view.
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14. Smart Editor

Another feature of the High-Performance Embedded Workshop isits smart edit facility. Thisisenabled by
default for al C++ sourcefiles. Thisfeature allows the HEW editor to access C++ navigation information and
provide auto-completion help when using C++ classes and member functions.

2 Toview the Smart edit status:

1

2.
3.
4

Click on the [T ools->Options] menu item.

Select the “Editor” tab of the tools options dialog.

Thedialogin figure 14.1 isdisplayed. The“Enable Smart-edit for C++ files” should be checked.
Click OK.

e — 21X

Build  Editor |\N’n|kspace| Ennfirmatinnl Netwnrkl

— Spacing:
I L= spaces as tabs Tabsize: | 4

[V Enable auta indentation

- General
[V Save files before executing any tools ¥ Show files in notebook.
[~ Prompt before saving files ¥ Enable syntax coloring

W Enable Smart-edit for C+ files

r~ Extemal editor:

[~ Use external editar:

| Hadif.. |

Cancel |

Figure 14.1: Navigation view

With this option switched on if you are working on a C++ file the smart-edit capability should be enabled.

Note: If the C++ Class navigation category has been switched off the Smart-edit capability of HEW will
not be active.

During normal usage the following editor operations will make the smart edit facilities visible.

2

If you are using an object and are trying to access the members using the*." or ‘->'. If you do thisa

pop-up will be displayed which may help you select the correct member more efficiently than typing.
Whilst typing the pop-up will keep track of the keys you have pressed to help your selection. If you press
return then the currently selected member will be added. This pop-up is also used when using the *::’
method and it isdisplayed in figure 14.2.
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2 If you aretrying to use a C++ function then the dialog in Figure 14.3 is displayed when the first open
bracket is entered. Thisdiaog allowsyou to see what functions are available for the current object.
Selecting the function automatically enters the remaining parameters for you.
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#include "greatwhite.h"
wold main(void):

wold main{void)

CGreatWhite cJaws:
cJaws.n_n

3 DT -
agim_nDangerous
Egim_nFins
agim_nlaws
a)m_nlLeqgs

A m_nLiveiniater
Egim_nlives
“m_n3ea

P - - 1

Figure 14.2: Smart-edit member selection

#include "greatwhite.h"

volid main{void):

wold main(wvoid)
ClhreatWhite myfish:

nyfish . FeedTheSharlk(

int FeedThesShark({CFish™® myFishyFood) :l
T int FeedTheShark{CHorse™ myHorseyFood)
int FeedThes rson’® rsonFood) J

int FeedThesShark{char* pszOtherType) LI

Figure 14.3: Smart -edit function selection

Note: Smart-edit auto completion may not pop-up for a variety of reasons. HEW can only provide help
when the file has been scanned by the navigation component. For thisto work the file must have been
saved.

Another issueisthat #definesare not considered so this means that redundant areas of code may still be
visble.
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Another important consideration isif the syntax of your codeisincorrect the smart editor may not be able

to parseyour code correctly and the smart edit functionality will fail. In this case no pop-up will be
displayed.

Please note that Smart-edit does not support macro usage.
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Simulator/Debugger Part
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Section1l Overview

This section describes the fundamenta concepts of the High-performance Embedded Workshop (HEW)
necessary to use the simulator/debugger. 1t isintended to give users who are unfamiliar with the Windows®
operation, the details that are required by subsequent sections.

11 Workspaces, Projects, and Files

Just as aword processor alows you to create and modify documents, the HEW alows you to create and modify
workspaces.

A workspace can be thought of as a container of projects. Similarly, a project can be thought of as a container of
project files. Thus, each workspace contains one or more projects and each project contains one or more files.

Figure 1.1 shows this configuration.

PROJECT

C

PROJECT

C

PROJECT

WORKSPACE

Figurel.1 Workspaces, Projects, and Files

Workspaces allow you to group related projects together. Thisisuseful when you have an application that needs
to be built for different processors, when you are developing an application and library at the sametime, or in
other cases. Projects can aso be linked hierarchically within aworkspace, which means that when one project is
built al of its child projects are built first.

However, workspaces on their own are not very useful, first you need to add a project to a workspace and then
add files to that project before you can actually do anything.

12 Launching the HEW
To initiate the HEW, open the [Start] menu of Windows®, select [Programs], select [Renesas High-performance

Embedded Workshop], and then select the shortcut of the HEW. The [Welcome!] dialog box shown in figure
1.2 will be displayed by default.
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Welcome!
— Optiors;
] & ‘Create a new project workspace
Cancel |
" Open a recent project workspace: Administration... |
é IE:'\Hew\demn'\demo.hws j
=

g " Browse to another project warkspace

Figure1.2 Welcome! Dialog Box

To create a new workspace, select the [Create a new project workspace] button, and click the [OK] button. To
open one of the recent project workspaces, select the [Open a recent project workspace] button, select a
workspace from the drop-down list, and click the [OK] button. The [Recent project workspace] list displaysthe
same content as that seen in the workspace most recently used filelist. Thislist also appears on the file menu.
To open aworkspace by specifying aworkspace file (HWSfile), select the [Browse to another project
workspace] button, and click the [OK] button. To register or unregister atool from the HEW, click the
[Administration] button. Click the [Cancel] button to use the HEW without opening a workspace.
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Creating a New Workspace

S To create anew workspace

1

Select the [Create a new project workspace] option from the [Welcome!] dialog box (figure 1.2) and click
the [OK] button or select [File -> New Workspace...]. The [New Project Workspace] dialog box will be
displayed (figure 1.3).

Mew Project Workspace

Frojects |

[ & pplication
@ Azzembly Application I
Demonstration

@ Ermpty Application
Y5 Impart Makefile I

ﬂ Library Directony:

IC:\HEW Browsze. |

LCPU Farnily:
Hes5 Ha/300 =l

Wiorkspace Mame:

Broject Name:

Toal chain:
| Hitachi HB5 HB/300 Standard =l

Froperties. .. |

Ok I Cancel

2.

5.

Note:

Figure1.3 New Project Workspace Dialog Box

Enter the name of the new workspace into the [Workspace Name] field. This can be up to 32 characters
in length and contain | etters, numbers, and the underscore character. Asyou enter the workspace name,
the HEW will add a subdirectory and project name for you automatically. To select the directory in
which you would like to create the workspace, use the [Browse...] button or type the directory into the
[Directory] field manually. This allows the workspace and project name to be different.

Select the CPU family and tool chain upon which you would like to base the workspace. Note that these
cannot be changed once the workspace has been created.

When anew workspace is created, the HEW will also automatically create a project with the name
specified in the project name field and place it inside the new workspace. The [Project types] list displays
all of the available project types (application, library, etc.). Select the project type you want to create
from thislist. The project types displayed will be all valid types for the current pair of CPU family and
toolchain. The project types are classified in three classes: toolchain-only, debugger-only, and full
project generator that configures both the debugger and tool chain aspect of the HEW.

Click the [OK] button to create the new workspace and project.

It isnot possible to create a workspace if one already existsin the samedirectory.
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14 Opening a Workspace

S To open aworkspace

1. Select [Browse to another project workspace] option from the [Welcome!] dialog box (figure 1.2) and
click the [OK] button or select [File -> Open Workspace...]. The [Open Project Workspace] dialog box
will be displayed.

2. Select the workspace file that you want to open ((HWS files only).

3. Click the [Open] button to open the workspace. If the HEW is set up to display information when a
workspace is opened, the [Workspace Properties] dialog box will be displayed (figure 1.4). Otherwise,
the workspace will be opened.

Note that whether the [Workspace Properties] dialog box is shown depends on the setting of either the
[Show workspace information on workspace open] check box in the [Workspace Properties] dialog box
or the [Display workspace information dialog on opening workspace] check box on the [Workspace]
sheet of the [Tools Options] dialog box. Click the [OK] button in the [Workspace Properties] dialog box
to open the workspace. Click the [Cancel] button to stop opening the workspace.

Workspace Properties EE3

MHanne: Demo_HAES 26004
Location: C:%HewhDemao_HAES 2600440 ema_HBS 26004 hws = |
Lastmodiied:  13:32:12, Friday, May 23, 2003 _ Cancel |
CPU family: H&5 Ha/300
Tool chain: Hitachi HES HE/300 Standard

Information:

Mo workspace information available ;I

¥ Show workspace information on workspace open

Figure1.4 Workspace PropertiesDialog Box

The HEW keeps track of the last five workspaces that you have opened and adds them to the [File] menu under
the [Recent Workspaces] submenu. This gives you a shortcut to opening workspaces, which you have used
recently.

2 To open arecently used workspace

Select [Open a recent project workspace] in the [Welcome!] dialog box, select the name of the workspace
from the drop-down list, and then click the [OK] button.

Another way isto select [File -> Recent Workspaces], and then from this submenu select the name of the
workspace.

Note: TheHEW only permits one workspaceto be open at atime. Consequently, if you attempt to open
a second workspace, the first will be closed before the new oneis opened.

15 Saving a Workspace

Selecting [File -> Save Workspace] saves aHEW workspace.
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16 Closing a Wor kspace

Selecting [File -> Close Workspace] closes aHEW workspace. |If there are any changes to the workspace or any
of its projects, you will be requested whether or not you wish to save them.

Selecting [File -> Save Workspace] can save a HEW workspace.

1.7 Using Old Workspaces

The HEW can open any workspace that was created on a previous version of the HEW. This should not cause
any problems, and any differences in the workspace file details should be upgraded when the workspaceis
opened. A back-up version of theinitial workspace or project file must be saved in the current directory of the
file that has been upgraded. The session files used in the Hitachi Debugging Interface will not be upgraded.

18 Exitingthe HEW

The HEW can be exited by selecting [File -> Exit], pressing the ALT + F4 accelerator, or selecting the [Close]
option from the system menu. (To open the system menu, click the icon at the upper-left corner of the HEW title
bar.) If aworkspaceis currently open, the same workspace closing procedure is followed as described in section
1.6, Closing a Workspace.

19 Debugger Sessions

The HEW stores all of your builder optionsinto aconfiguration. In asimilar way, the HEW stores your
debugger optionsin asession. The debugging platforms, the programs to be downloaded, and each debugging
platform’s options can be stored in a session.

Sessions are not directly related to aconfiguration. This means that multiple sessions can share the same
download module and avoid unnecessary code rebuilds.

Each session’s data should be stored in a separate file in the HEW project. For details, refer to section 3.4,
Debugger Sessions.
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Section 2 Simulator/Debugger Functions
This section describes the functions of the H8S, H8/300 series simulator/debugger.

21 Features

» Since the simulator/debugger runs on a host computer, software debugging can start without using an actual
user system, thus reducing overall system development time.

» The simulator/debugger performs a smulation to cal culate the number of instruction execution cyclesfor a
program, thus enabling performance evaluation without using an actual user system.

» Thesimulator/debugger provides pseudo-interrupt and I/O-simulation functions for smple system-level
simulation.

» Thesimulator/debugger offers the following functions that enable efficient program testing and debugging.
The ability to handle al of the H8S, H8/300 series CPUs

Functions to stop or continue execution when an error occurs during user program execution

Profile data acquisition and function-unit performance measurement

A comprehensive set of break functions

Functions to set or edit memory maps

Functions to display function call history

Coverage information is displayed in the C/C++ or assembly-source level

Visual debugging functions provided through the display of images or waveforms

. The breakpoints, memory map, performance, and trace can be set through the dial og boxes under Windows®.
Environments corresponding to each memory map of the H8S, H8/300 series microcomputers can be set
through the dialog box.

1. Intuitive user interface
2. Onlinehelp
3. Common display and operationality

© N O A®N R

22 Target User Program

Load modules in the Elf/Dwarf2 format can be symbolically debugged with the simulator/debugger. Load
modulesin other formats can be downloaded, and their instructions can be executed, however, they cannot be
symbolically debugged. For details, refer to section 4.10, Elf/Dwarf2 Support.

23 Simulation Range

The simulator/debugger provides simulation functions for the H8/300, H8/300L, H8/300H, H8S/2600, and
H8S/2000 series microcomputers.

The simulator/debugger supports the following H8S, H8/300 series microcomputer functions:

* All CPU ingtructions

» Exception processing

* Regigters

* All address areas

* CPU modes shownintable 2.1
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Table2.1 Platformsand CPU Modes

Names of Debugging Platforms CPU Modes
H8/300 Simulator H8/300

H8/300L Simulator H8/300L

H8/300HA Simulator H8/300H: advanced mode
H8/300HN Simulator H8/300H: normal mode
H8S/2600A Simulator H8S/2600: advanced mode
H8S/2600N Simulator H8S/2600: normal mode
H8S/2000A Simulator H8S/2000: advanced mode
H8S/2000N Simulator H8S/2000: normal mode

The simulator/debugger does not support the following H8S, H8/300 series MCU functions. Programs that use
these functions must be debugged with the H8S, H8/300 series emulator.

e Dual-port RAM

o Timer

*  Pulse-width modular

»  Serial communication interface (SCI)
» A/D converter

* 1/O ports

* Interrupt controller

24 Memory M anagement

Memory Map Specification: A memory map is used to cal culate the number of memory access cycles during
simulation. The following items can be specified:

*  Memory type

o Start and end addresses of the memory area
*  Number of memory access cycles

* Memory data buswidth

For details, refer to section 4.21.2, Modifying the Memory Map and Memory Resource Settings. The user
program can be executed in all areas except for theinternd 1/O area.

Memory Resour ce Specification: A memory resource must be specified to load and execute a user program.
The following items can be specified:

o Start address
* End address
e Accesstype

The access type is readable/writable, read-only, or write-only.

Since an error occurs if the user program attempts an illegal access (for example, trying to write to read-only
memory), such an illegal accessin the user program can be easily detected.

Unlike the other memory, EEPROM is writable by the EEPMOV instruction even if its access type s read-only.
Other instructions than EEPMOV are not available.

For details on memory resource setting, refer to section 3.3.2, Memory Resource.
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25 Instruction-Execution Reset Processing

The simulator/debugger resets the instruction execution counts and the number of instruction execution cycles
when:

» Theprogram counter (PC) is modified after the instruction simulation stops and before it restarts.
* The Run command to which the execution start address has been specified is executed.
» Initialization is performed.
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Exception Processing

The simulator/debugger detects the generation of TRAPA instructions (H8/300H, H8S series only) and trace
exceptions (H8S series only) and simulates exception processing. Accordingly, simulation can be performed
even when an exception occurs.

The simulator/debugger simulates exception processing with the following procedures.

1
2.

178

Detects an exception during instruction execution.

Saves the PC and SR in the stack area. EXR is aso saved when the enabled bit of EXR ison. If an error
occurs when saving, the simulator/debugger suspends exception processing, displays the generation of the
exception processing error, and returns to the command-wait state.

Setsthe | bitsin CCR to 1.

Reads the start address from the vector address corresponding to the vector number. If an error occurs
when reading, the simulator/debugger suspends exception processing, displays the generation of the
exception processing error, and returns to the command-wait state.

Starts instruction execution from the start address. If the start addressis 0, the simulator/debugger stops
exception processing, displays that an exception processing error has occurred, and enters the command
input wait state.
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2.7 H8S/2600 CPU Specific Functions

MAC Instruction: The multiplication/accumulation operation (MAC instruction) can be performed on the
H8S/2600 CPU. In thisinstruction, a saturation and non-saturation operations are selectable. The
simulator/debugger determines the operation with avalue of bit 7 (hereafter called asthe MACS hit) in the
SY SCR register of interna 1/0.

MACS bit 0: Non-saturation operation
MACS bit 1: Saturation operation

EXR Register: The EXR register can be used on the H8S/2600 CPU. It is aso possible to set the enable or
disable of this register. The simulator/debugger determines the operation with avalue of bit 5 (hereafter called as
the EXR bit) in the SY SCR register of internal 1/0O.

EXR bit 0: EXR disabled
EXR bit 1: EXR enabled

The SYSCR addressis set in [SY SCR Address] in the [Simulator System] dialog box.

Note: Set the SYSCR addressin the internal 1/O. Note that the simulator/debugger determines the MACS bit as
0 (non-saturation) and the EXR bit as 0 (EXR disabled) when the SY SCR address is set other than the
internal 1/0.

For details, refer to section 4.21.1, Simulator System Dialog Box.

2.8 Control Registers

The H8S/2600 series support the SY SCR (system control register) as the control register mapped to the memory.
It enables multiplication/accumul ation operation, user program simulation for EXR accessing, and debugging.

The SYSCR addressis set in [SY SCR Address] in the [Simulator System] dialog box. For modifying or
displaying the control register, use the [10] window.

For details, refer to section 4.22.1, Modifying the Simulator System Settings, or section 4.5, Viewing the /0
Memory.
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29 Trace

The simulator/debugger writes the execution results of each instruction into the trace buffer. The conditions for
trace information acquisition can be specified in the [Trace Acquisition] diaog box. Right-clicking on the
[Trace] window displays the pop-up menu. Choose [Acquisition...] from the pop-up menu to display the [Trace
Acquisition] dialog box. The acquired trace information is displayed in the [Trace] window.

The trace information can be searched. The search conditions can be specified in the [ Trace Search] dialog box.
Right-clicking on the [Trace] window displays the pop-up menu. Choose [Find...] from the pop-up menu to
display the [Trace Search] dialog box.

For details, refer to section 4.14, Viewing the Trace Information.
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Standard I/O and File |/O Processing

The simulator/debugger enables the standard 1/0O and file 1/O processing listed in table 2.2 to be executed by the
user program. When the 1/0 processing is executed, the [1/O Simulation] window must be open.

Table 2.2 shows the supported 1/0 functions. The function codes have 16-bit address, 24-bit address, and 32-bit
address versions. Select the version according to the CPU to be used.

Table2.2 1/0O Functions
No. Function Code Function Name Description
1 H'01 (16-bit address) GETC Inputs one byte from the standard input
H'11 (24-bit address) device
H'21 (32-bit address)
2 H'02 (16-bit address) PUTC Outputs one byte to the standard output
H'12 (24-bit address) device
H'22 (32-bit address)
3 H'03 (16-bit address) GETS Inputs one line from the standard input device
H'13 (24-bit address)
H'23 (32-bit address)
4 H'04 (16-bit address) PUTS Outputs one line to the standard output device
H'14 (24-bit address)
H'24 (32-bit address)
5 H'05 (16-bit address) FOPEN Opens a file
H'15 (24-bit address)
H'25 (32-bit address)
6 H'06 FCLOSE Closes a file
7 H'07(16-bit address) FGETC Inputs one byte from a file
H'17 (24-bit address)
H'27 (32-bit address)
8 H'08 (16-bit address) FPUTC Outputs one byte to a file
H'18 (24-bit address)
H'28 (32-bit address)
9 H'09 (16-bit address) FGETS Inputs one line from a file
H'19 (24-bit address)
H'29 (32-bit address)
10 H'0A (16-bit address) FPUTS Outputs one line to a file
H'1A (24-bit address)
H'2A (32-bit address)
11 H'0OB FEOF Checks for end of the file
12 H'0C FSEEK Moves the file pointer
13 H'0D FTELL Returns the current position of the file pointer

For details on I/O functions, refer to section 4.22, Standard 1/0O and File I/O Processing.

181



High-performance Embedded Workshop User’s Manual

211  Calculation of the Number of Instruction Execution Cycles

The simulator/debugger cal culates the number of instruction execution cycles by using the expression, the data-
bus width of the memory map, and the number of access cycles, which is described in the H8S, H8/300 Series
Programming Manual. However, note that the number of instruction execution cycles may differ when the
number of instruction execution cycles that is calculated on the smulator/debugger and the one that the program
is executed on the system.

MOVFPE and MOV TPE Instructions: The number of cycles for transferring data of the E-clock
synchronization instruction is the value between 9 to 16. The simulator/debugger calculates as’11 + number of
operand access cycles' . The number of operand access cycles can be calculated from the data bus width of the
memory and the number of access cycles.

EEPMOQV Instruction: The number of cycles for the EEPROM -write instruction is the sum of the number of
cyclesfor reading instructions and cycles for transferring data.

SLEEP Instruction: The simulator/debugger does not add the number of cycles considering the case when the
SLEEP instruction is used for halting program.

Standard 1/0 and file I/O processing: The standard 1/0 and file 1/0 processing are specific functions for the
simulator/debugger, and they are not added to the number of cycles. Note that the standard I/O and file 1/0O
processing are the period while the branch to the position specified with the system-call address of the BSR and
JSR ingtructions is completed to return to the called source after the 1/0 processing.
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2.12 Break Conditions

The simulator/debugger provides the following conditions for interrupting the smulation of a user program
during execution.

» Break due to the satisfaction of a break command condition

» Break due to the detection of an error during execution of the user program
» Break dueto atrace buffer overflow

» Break dueto execution of the SLEEP instruction

» Break dueto the [STOP] button

Break Dueto Satisfaction of a Break Command Condition: There are five break commands as follows:

* BREAKPOINT: Bresk based on the address of the instruction executed
« BREAK_ACCESS: Break based on access to amemory range
« BREAK_DATA: Break based on the value of data written to memory

* BREAK_REGISTER: Break based on the value of data written to aregister
* BREAK_SEQUENCE: Break based on a specified execution sequence

If [Stop] is specified as the action for when a break condition is satisfied, user program execution stops when the
break condition is satisfied. For details, refer to section 4.15, Using the Simulator/Debugger Breakpoints.

When a break condition is satisfied and user program execution stops, the instruction at the breakpoint may or
may not be executed before a break depending on the type of break, aslisted in table 2.3.

Table2.3 Processng When a Break Condition is Satisfied

Command Instruction When a Break Condition is Satisfied
BREAKPOINT Not executed

BREAK_ACCESS Executed

BREAK_CYCLE Executed

BREAK_DATA Executed

BREAK_REGISTER Executed

BREAK_SEQUENCE Not executed

For BREAKPOINT and BREAK_SEQUENCE, if abreakpoint is specified at an address other than the
beginning of the instruction, the break will not be detected.

When a break condition is satisfied during user program execution, abreak condition satisfaction messageis
displayed on the status bar and execution stops.

Break Dueto Error Detection during User Program Execution: The simulator/debugger detects simulation
errors, that is, program errors that cannot be detected by the CPU exception generation functions. The [Simulator
System)] dialog box specifies whether to stop or continue the simulation when such an error occurs. Table 2.4
lists the error messages, error causes, and the action of the simulator/debugger in the continuation mode.
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Table2.4 Simulation Errors

Error Message

Error Cause

Processing in Continuation
Mode

Address Error

Odd PC value

Instruction was fetched from the internal
1/O area

Access in words from odd-number
addresses

Access in longwords from odd-number
addresses

Operates in the same way as the
actual device operation.

Memory Access Error

Access to a memory area that has not
been allocated

Write to a memory area having the write
protect attribute

Read from a memory area having the
read disable attribute

Access to an area where memory does
not exist

Write to the EEPROM by instructions
other than EEPMOV

On memory write, nothing is
written; on memory read, all bits
are read as 1.

lllegal Instruction

Execution of a code that is not an
instruction

Execution of MOV.B Rn, @-SP or
MOV.B @SP +Rn

lllegal Operation

Incorrect relation between the values in
the C flag or H flag of the CCR in the
DAA or DAS instruction and the values
before adjustment

Zero division executed by the DIVXU or
DIVXS instruction, or overflow

Always stops

Continues simulation but the
result is not guaranteed

Continues simulation but the
result is not guaranteed

When a simulation error occurs in the stop mode, the simulator/debugger returns to the command input wait state
after stopping instruction execution and displaying the error message. Table 2.5 lists the states of the program
counter (PC) at smulation error stop. The condition code register (CCR) value does not change at simulation

error stop.
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Table25 Register Statesat Smulation Error Stop

Error Message PC Value
Address Error, ¢ When an instruction is read:
Memory Access Error The start address of the instruction that caused the error.

¢ When an instruction is executed:

The instruction address following the instruction that caused the
error.

lllegal Instruction The start address of the instruction that caused the error.

lllegal Operation The instruction address following the instruction that caused the error.

Use the following procedure when debugging programs that include instructions that generate simulation errors.

1. First execute the program in the stop mode and confirm that there are no errors except those in the intended
locations.
2. After confirming the above, execute the program in the continuation mode.

Note: If an error occursin the stop mode and simulation is continued after changing the smulator mode
to the continuation mode, simulation may not be performed correctly. When restarting a
simulation, alwaysrestore theregister contentsand the memory contentsto the state prior to the
occurrence of theerror.

Break Dueto a Trace Buffer Overflow: After the [Break] mode is specified with [Trace Buffer Full Handling]
in the [Trace Acquisition] dialog box, the simulator/debugger stops execution when the trace buffer becomes full.
The following message is displayed in the [Output] window when execution is stopped.

Trace Buffer Full

Break Dueto Execution of the SLEEP Instruction: When the SLEEP instruction is executed during
instruction execution, the simulator/debugger stops execution. The following message is displayed in the
[Output] window when execution is stopped.

Sl eep

Note: When restarting execution, change the PC value to theinstruction address at therestart location.

Break Dueto the [Halt] Button: Users can forcibly terminate execution by clicking the [HALT] button during
instruction execution. The following message is displayed on the status bar when execution is stopped.

St op

Execution can be resumed with the GO or STEP command.

213 Floating-Point Data

Floating-point numbers can be used for the following rea-number data, which makes floating-point data
processing easier. The following data can be specified for floating-point data:

» Datainthe [Set Break] dialog box when the break typeis set to [Break Data] or [Break Register]
» Datain the [Memory] window

» Datainthe[Fill Memory] dialog box

» Datain the [Search Memory] dialog box

* Input datain the [Register] dialog box

185



High-performance Embedded Workshop User’s Manual

The floating-point data format conforms to the ANSI C standard.

In the simulator/debugger, the rounding mode for floating-point decimal-to-binary conversion can be selected in
the [Simulator System] dialog box. One of the following two modes can be selected:

* Round-to-nearest (RN)
* Round-to-zero (RZ)

If a denormalized number is specified for binary-to-decimal or decimal-to-binary conversion, it is converted to
zero in RZ mode, and left as a denormalized number in RN mode. If an overflow occurs during decimal-to-
binary conversion, the maximum floating-point value isreturned in RZ mode, and the infinity is returned in RN
mode.

2.14  Display of Function Call History

The simulator/debugger displays the function call history in the [Stack Trace] window when simulation stops,
which enables program execution flow to be checked easily. Selecting a function name in the [Stack Trace]
window displays the corresponding source program in the [Editor] window. This alows the function that has
called the current function to also be checked.

The displayed function call history isupdated in the following cases:

*  When smulation stops due to the break conditions described in section 2.16, Break Conditions.
*  When register values are modified while simulation stops due to the above break conditions.
* While single-step execution is performed.

For details, refer to section 4.13, Viewing the Function Call History.

2.15 Performance Measurement

The simulator/debugger has the profiler function and performance analysis function for performance
measurement of the user program.

2151 Profiler

The profiler function displays the memory address and size alocated to functions and global variables, the
number of function calls, and the profile data for the entire user program. The profile data displayed differs
according to the CPU.

Profile information is displayed in list, tree, and chart formats.

Profile information is useful in optimizing user programs by reducing the size and putting the most frequently
caled functionsin-line.

When using the profile information saved in afile, it is possible to optimize user programs based on dynamic
information using the optimizing linkage editor.

For details, refer to section 4.12, Viewing the Profile Information, and section 4.2.3, Optimize Option Profilein
the Optimizing Linkage Editor User's Manual.
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2152 Performance Analysis

The performance analysis function displays the number of execution cycles and function calls for the specified
function in the user program. Since performance data for only the specified function is acquired, smulation can
be done faster. For details, refer to section 4.16, Analyzing Performance.

216  Pseudo-Interrupts
The simulator/debugger can generate pseudo-interrupts during simulation in the following two ways:

1. Pseudo-interrupts generated by break conditions
A pseudo-interrupt can be generated using a break command to specify [Interrupt] as the action when a break
condition is satisfied. For details, refer to “ Specifying the Action at Break” in section 4.15.2, Setting a
Breakpoint.

2. Pseudo-interrupts generated from the [ Trigger] window
A pseudo-interrupt can be generated by clicking a button in the [Trigger] window. For details, refer to section
4.20, Generating a Pseudo-Interrupt Manually.

If another pseudo-interrupt occurs between a pseudo-interrupt occurrence and its acceptance, only the interrupt
that has a higher priority can be accepted.

Note: Inthe pseudo-interrupts, whether an interrupt isaccepted is deter mined by interrupt infor mation
[Priority], not the vector number. Note that when H'8 is specified asthe priority level of an
interrupt, that interrupt isalways accepted. The smulator/debugger does not simulate the
operation of theinterrupt controller.

217 Coverage

The simulator/debugger acquires instruction coverage information during instruction execution within the
measurement range specified by the user.

In the measurement range, addresses are directly specified, and al functionsin afile whose name has been
specified are set.

The status of each instruction execution can be monitored through the instruction coverage information. In
addition, thisinformation can be used to determine which part of a program has not been executed.

The [Coverage] window displays the acquired instruction coverage information:

The instruction coverage information can be displayed in the [Editor] window by highlighting the column
corresponding to the source line of the executed instruction.

For the address range or function to be measured, the coverage statistical information is displayed in a
percentage format, which is helpful to know the amount of program that has been executed.

The instruction coverage information can be saved in or loaded from afile. Only afilein the .COV format can
be loaded.

For details, refer to section 4.17, Acquiring Code Coverage.
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Section 3 Preparations for Debugging

This section describes the preparations for debugging your program. Y ou will learn how to select and configure
a debugging platform with which to debug, how to load the user program, and what the debugger sessions are.

3.1  Building before Debugging

To debug your program in the C/C++ source level, your C/C++ program must be compiled and linked with the
[Debug] option enabled. When this option is enabled, the compiler putsal the information necessary for
debugging your C/C++ code into the absol ute file or management information file. If either of these filesis used
for this purpose, it isusualy called adebug object file. When you create your project, the initial setup will
normally be configured for debugging.

Note: Make sureyou have the [Debug] option enabled in your compiler and linker, when you generate
an object filefor debugging.
Even if your debug object file doesnot contain any debugging information (for example, the S-
record format), you can still load it into the debugging platform, but you will only be able to debug
it in the assembly-language level.

32 Selecting a Debugging Platform

Selecting the debugging platform is very dependent on the installation method of the HEW. If the HEW hasa
toolchain installed, the application project generator will be able to set up both the toolchain and the debugger
targets simultaneously. This allows the options for the targets and tool chain to be matched closely so no
inconsistencies occur. If thereisno toolchain installed, you will only be able to select debug-only project types.
By default, the HEW will display the debug-only project generation type for each CPU family in the [New
Project Workspace] dia og box.
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Mew Project Workspace

Frojects |

' Application

Demonstration
@ Ermpty Applicati
Y5 Impart Makefile

ﬂ Library

@ Azzembly Application I

Wiorkspace Mame:

Broject Name:

Cirectony:

IC:\HEW Browsze. |

LCPU Farnily:
Hes5 Ha/300 =l

Ly}

Toal chain:
| Hitachi HB5 HB/300 Standard =l

Froperties. .. |

Ok I Cancel

The dialog box shown in fig

[Application]

[Assembly Application]

[Demonstration]
[Empty Application]
[Import Makefile]
[Library]

Note: Select [Empty Appl
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Figure3.1 New Project Workspace Dialog Box
ure 3.1 allows you to select a project generation type that matches your target CPU.

Project for generating an execution program that includes theinitial routine file
written in the C/C++ language.

Project for generating an execution program that includes theinitial routinefile
written in the assembly language.

Project for generating a demonstration program written in the C language.
Project for only setting the toolchain environment (no generation file).

A project to create an executable program by importing an existing makefile.
Project for generating alibrary file (no generation file).

lication] to generate a debug-only project.
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New Project -Step 1

Toalchain wersion ©

[5.0.0.0 =l

Which CPU do you want to uze for this
project’?

CPU Sefies
S -
2000
300H
300 =
CPU Type:
2621 g
2622
2623
G Jid

If there iz ho CPU type to be zelected,
zelect the "CPU Type' that a similar to
hardware specification or zelect "'Other'’.

< Back | et = I Finish | Cancel

Figure3.2 CPU Selection Display (Step 1)

1. Select the CPU and Toolchain version in Step 1. The CPU types ([CPU Type]) are classified according to the

CPU series ([CPU Series]). Select the CPU corresponding to the program to be developed because the

generation file differs according to the [CPU Type] and [CPU Series] settings. If thereis no corresponding
CPU, select a CPU with similar hardware specifications or [Other].

The following buttons at the bottom of the dialog box are the same as those in the [New Project] wizard

dialog box.
[Next>]
[<Back]
[Finish]
[Cancel]

Moves to the next display.
Returns to the previous display.

Opens the [Summary] dialog box (selections followed by this button are default).
Returns to the [New Project Workspace] dialog box.
To moveto Step 2, click the [Next>] button in Step 1.
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New Project -Step 2

Specify global options.

Operating Mode; Im
Address Space: Im
2 I
Merit of Librany: Im
Stack caloulation: Im

Speain SERE addiess
IDefauIt j IH'U

[ |Change nunmber of parameter registj

[ 1Treat double as float
[ |Pass struct parameter via register
[1Faszs 4-byte parameterreturn value

11z tru. throw &nd jalch of E++_ILI
4 3

Mewt> 1 Finish | Cancel |

Figure 3.3 Option Setting Display (Step 2)

2. Specify the options common to all project filesin Step 2. The specifiable items depend on the CPU selected
inStep 1.
List Box Settings:

[Operating Mode] Specifies the operating mode of the object to be created.
[Normal] Normal mode.
[Advanced] = Advanced mode.

[Address Space] Specifies the address space of the object to be created.

[1M byte] Specifies 1-Mbyte address space.
[16M byte] Specifies 16-Mbyte address space.
[256M byte]  Specifies 256-Mbyte address space.
[4G byte] Specifies 4-Gbyte address space.

[Merit of Library] Specifies whether the priority of the standard library is speed
or code size.
[Code Size] Reducessize.
[Speed] Execution speed.
[Stack calculation] Specifies the range of the stack address.
[Small] 1-byte calculation of the stack address.
[Medium] 2-byte calculation of the stack address.
[Large] 4-byte calculation of the stack address.

Check Box Settings:
[Change number of parameter registersfrom  Three registers for storing parameters.
2(default) to 3] There are two registers by default.
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[Treat double as float]

[Pass struct parameter viaregister]

[Pass 4-byte parameter/return value via]

register]

[Use try, throw and catch of C++]

[Enable/disable runtime type information)

Generates an object making the value of the double-precision
floating-point type as the single-precision floating-point type.
Specifies whether or not the parameter of the structureis
allocated to the register. When checked, the parameter is
passed with the register. When not checked, the parameter is
passed with the memory, not with the register.

Specifies whether or not the 4-byte parameter

or thereturn value is alocated to the register. When checked,
the parameter is passed with the register. When not checked,
the parameter is passed with the memory, not with the
register.

Checking enables the C++ exception processing functions
(try, catch, and throw).

Enables or disables the type information at execution.

When checked, dynamic_cast and typeid are available.
When not checked, dynamic_cast and typeid are unavailable.
For details, refer to the compiler manual.

To moveto Step 3, click the [Next>] button in Step 2.

21x
WWhat kind of initialization routine
would vou like to create?
¥ Use I/O Library
Mumber of [A0 Streams:
g |
¥ Use Heap Memory
Heap Size: IH'42D
Generate maint Function
IO zource file :I
[ 1/0 Register Definition Files
Generate Hardware Setup
Function
INone :I
< Back Finish |  Gancel

Figure3.4 Generation File Setting Display (Step 3)

3. Specify the generation filein Step 3.

[Use /O Library] Checking enables use of standard 1/O libraries.
[Number of I/O Specifies the number of 1/0 streams that
streams] can be used simultaneously.

[Use Heap Memory] Checking enables use of the heap area management function sbrk( ).
[Heap Size] Specifies the unit of the size of the heap areato be

managed.
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[Generate main( ) Function]  Selects generation of a model main function.
Generates amain function file [(Project name).c(cpp)]-.

[I/O Register Definition Files] Checking generates an /O register definition file (iodefine.h) written in the C

language.
[Generate Hardware  Selects generation of amodel 1/0
Setup Function] register initial setting program.

Generates a hardware setting file
(hwsetup.c(cpp) or hwsetup.src).

Note: Toincludeamain function that has already been made, select [None] in [Generate main()
Function] and after making the project, add the file containing the main function to the
project. Note that if the name of the function to beincluded is different, the function calling
section in resetprg.c must be modified. Be sureto refer to the hardware manual of the CPU for
actual values of the sample file contents, such asthe vector table definition and 1/0 register
definition, which are generated by the project generator.

To moveto Step 4, click the [Next>] button in Step 3.

2|

— Library :

[runtime @ runtime routines 1=
Wlnew : Perfarms memory allocation and
[ ctypeh : Handles and checks characte
[Imathh : Performs numerical calculatio
[Imathfh : Performs numerical calculatic
[ |stdargh : Supports access to variahble
Wstdioh : Performs input/output handlin
(wztdlibh : Performz O program standarc
(wlztringh : Performs string comparizaon, «
[Jins{EC++) : Perfarms input/output proc
[ Jcomplex{ECH) : Performs complex nu -
K I _>I_I

Enable all | Disable all |

Firizh | Cancel |

Figure3.5 Standard Library Setting Display (Step 4)

4. Specify the configuration of the standard libraries used by the C/C++ compiler in Step 4.
The functions defined in the checked items and the runtime function are included.
[Enable all] Selects all standard library functions.

[Disableal] Does not select al standard library functions.
Note that only the minimum required functions, runtime and new, are selected.

To moveto Step 5, click the [Next>] button in Step 4.
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2%

Wihat are the stack zettings?

Stack Pointer Address:
over—on reset

[HFFEFCT

Stack Size:
IH'2DD

< Back TR ST Finish | Cancel

Figure3.6 Stack Area Setting Display (Step 5)

5. Specify the stack areain Step 5. Thisis done by setting the initial value of the stack pointer and the stack size.
Theinitial value of the stack areas depends on the CPU selected in Step 1.
Note: The stack areaisdefined by stacksct.h which isgenerated by the HEW. If stacksct.h has been
modified by an editor, it cannot be modified from [Project -> Edit Project Configuration] in
the HEW.

To moveto Step 6, click the [Next>] button in Step 5.
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21x
What zuppaorting files would vou like
to create’
[v Wector Definition Files
Wector Handlers:
Handler | vectar
PowerOM_Rezet 0 Power On Rese
Manual_Reset 1 Marual Rezet
K I i
<Back [THER Finish |  Gancel

Figure3.7 Vector Setting Display (Step 6)

6. Specify the vector in Step 6.

[Vector Definition Files]  Checking generates a vector definition file and a vector table setting function
definition file.

[Vector Handlers] [Handler]

[Vector]

Displays the handler program name of the reset
vector.

To modify the handler program, after selecting the
handler program name by clicking on it, enter the
new handler program name. Note that if the handler
program is modified, areset program (resetprg.c)
isnot generated.

Displays a description of the vector.

Note:  Sincethe generated reset program and interrupt functions are samples, be sureto refer to the

CPU hardware manual.

To moveto Step 7, click the [Next>] button in Step 6.
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2%

— Targets :

[(HIS/26008 Simulator
[(HES 2600 Simulator

Tareet tvpe : IZBDD =l

<Back [ Mext> |  Finsh |  Gancel |

Figure 3.8 Debugger Target Setting Display (Step 7)

7. Specify the debugger targetsin Step 7.
[Targets] Sets the debugger targets. Select (by checking) the debugger targets. No selection or a
selection of more than one target is possible.
[Target Type] Specifies the type of the targets displayed in [Targets].
To moveto Step 8, click the [Next>] button in Step 7.
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2%

Target natme :
|HE5/26004 Simulator

Configuration name :
|SimDebuE_HES—2SDDF\

— Detail optiong :

Item | Setting
Simulator IO enable
Simulator 10 addr.  0x0
Bus mode a

ol i |

<Back [ Mext> |  Finsh |  Gancel |

Figure3.9 Debugger Option Setting Display (Step 8)

8. Set the options for the debugger targets selected in Step 8.

[Configuration name] By default, the HEW generates two configurations: [Release] and [Debug]. If a
debugger target is selected, a configuration for the selected target is also generated
(an abbreviation including the target name). This configuration name can be
changed in [Configuration name].

[Detail options] Sets the debugger target options. To modify an option, select [Item] and click
[Modify]. If the selected item cannot be modified, [Modify] remains gray even
when [Item] is selected.

[Simulator /O] System call for standard 1/0 or file I/O
from the user program is enabled ([Enable])
or disabled ([Disable]).

[Simulator /O addr.]  Address for above system call.

[Bus mode] Currently cannot be used by the

simulator/debugger.
To moveto Step 9, click the [Next>] button in Step 8.
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2%

The followine source files will be

generated:

File Ma.. | Ext.. | Description

dbzct [= Setting of B.R Section

ol zrc Program of Low level

lowsrc C Proeram of L0 Stream

zhrk. = Program of =hrk

indefine h Definition of [0 Register

intpre c Interrupt Program

resetpre Reset Program

detmio = Main Program

lowsrc h Header file of I/0 Stream f

zhrk. h Header file of shrk file

stackgct  h Setting of Stack area

<] | 2l
<Back | tei> | Finsh | Gancel |

Figure3.10 Generation File Name M odification Display (Step 9)

9. Thefilesto be generated by the HEW based on the settings made so far isdisplayed asalist in Step 9.

[File Name]

[Extension]
[Description]

File name

To change afile name, after selecting the file name by clicking on it, enter the new file

name.
File extension
Description of thefile

Clicking the [Finish] button in Step 9 displays the [Summary] dialog box.
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Praject Surnmary:

-------- FROJECT GENERATOR -
PROJECT NAME : Demo_HB526004

PROJECT DIRECTORY :  C\Hew\Dema_H&526004\Deme
CPU SERIES : 2600

CPU TYPE : 2612

TOOLCHAIN MNAME - Hitachi HE5 HE/300 Standard Te

TOOLCHAIMN VERSION : E.0.0.0
GEMERATIOM FILES :
CAHewhDemo_HE5 2600840 emo_HA5 26004 dbsct o
Setting of B Section
CAHewhDemo_HE5260084Demo_HE5 26008\ o, zrc
Proaram aof Low level
CAHewhDemo_HE5260084Demo_HA5 26004 owsre. o
Proaran of 1/0 Stream
CAHewhDemo_HE5 260084 emo_HA5 260048 bk, o
Proaram aof sbrk
CAHewhDemo_HE5260084Demo_HA5 26004 odefine. h
Definition of [/0 Reqgizter -

4| | 3

Click OF to generate the project aor Cancel to abort.

[¥ Generate Readme.txt as a summary filg in the project directony

Cancel |

Figure3.11 Summary Dialog Box

10. The project generator displays information on the project to be generated in the [Summary] dialog box. After
confirming the display contents, click [OK].
Checking [Generate Readme.txt as a summary filein the project directory] will save the project information
displayed in the [Summary] dialog box as atext file named Readme.txt in the project directory.

33 Configuring the Debugging Platform

Before loading a program into your debugging platform, the platform must be set up to match your application
system. The items that must be set are typically the device type, operating mode, clock speed, and memory map.
It is particularly important to set the memory map. Inthe HEW, the project generation process will have
completed much of thiswork. However if you are using a board with a configuration different from the standard
types, then some customization will be required.

331 Memory Map

The debugging platform needs to know which areas in the device's address space are RAM, ROM, on-chip
registers, or areas where memory is not allocated. Therefore, the memory map must be set up.

When you select the device type and mode in the project generator, the HEW will automatically set up the map
for that device and the mode in which the processor is operating. For example, in a device with internal ROM
and RAM, the areas where these are located in the device's memory map will be set by default.

When external memory is used, the debugging platform requires to be informed.
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When using the simulator, the memory map settings can be modified in the [Memory] tab of the [Simulator
System] diaog box. For details, refer to section 4.21.2, Modifying the Memory Map and Memory Resource

Settings.

In this case, the settings can be referred to in the [Simulator] sheet of the [Standard Toolchain] dialog box.
Clicking the [View] button of the [Standard Toolchain] dialog box (figure 3.12) displays the [CPU hardware
map] dialog box (figure 3.13).

H8S _HE/300 Standard Toolchain

Canfiguratian :

| SimDebug_Ha5-26004 =l

1]

EI--J@ All Loaded Projects

E@ Demo_ ,
- C source file
[Z3 G+ source file
23 Assembly source file
123 Linkage syrmbl file

Standard Library | CPU

HMemony resounce

Simulator | Toolchain Dptionl LI_’I

Start | End B
0:00000000 | Ox0000FFFF | RAw
0«00FFEOD0 | DxDOFFEFBF | RAw
0«00FFFB00 | D«DOFFFF3F | RAw
O«D0FFFFED | DxOOFFFFFF | RAw

Figure3.12 Standard Toolchain Dialog Box

201




High-performance Embedded Workshop User’s Manual

CPU hardware map

Operation

El
- 4F [00000000 - 0001FFFF] On-Chip

i &k 00000400 PResstPRG.Pin
‘&, 00000800 P.CCSDSEC.CH

- 4 [DOFFEODD - OOFFEFEF] On-Chip

i~ &t OOFFEOOD: BR
& DOFFEDCOD 5
A [00FFF200 - DOFFFF3F) 140
A [00FFFFEQ - DOFFFFEF] 14D
A [00FFFFCO - ODFFFFFF] OnChip

B[] Mapfile

@ $VECTO[D00D0000 - 00000003}
& $VECTH[D00D0014 - DOODOOTF]
@ $VECTY [0000001c - DOODOOTE]
& $VECTS [00000020 - DO0D00Z3]
& $VECTI[00000024 - DOODODZ7]
@ $VECT10 [00000028 - 0000002
& $VECT11 [0000002c - O0DDOO2E
& $VECT1E [00000040 - 0000004
& $VECT17 [00000044 - 0000004
& $VECT13 [00000048 - 0000004
& $VECT13 [0000004c - 0000004
& $VECT20 [00000050 - 0000005
& $VECTZT [00000054 - 00D0005;
& $VECT24 [000000E0 - O0DO0OE?
= $VECT 25 (00000064 - 0000006, T
3

[ Estemnal
@

B Feserve

[ Allacated Area

HE
Meman view
Physical Memany Seclion
MEMOTY Mmap Iesource
00000000
00200000 R PResetPRGE
FIntPRG
00000300
00400000 £
C3DSEC
00600000 C$BSEC
D
00800000
00400000
00C00000
00E0O0OD
QOFFFFFF
[ On-Chip ROM Or
W On-Chip FiAM B R
O Monuse

Clase

Thefollowing information is displayed:

[Operation]

[Memory View]

3.3.2

To use the simulator, the memory resource of the address range being used must be saved.

Figure3.13 CPU hardware map Dialog Box

Displays the address range in the upper step.

Displays the linkage map in the lower step.

Displays memory map and memory resource information.
A memory resource aready alocated (Allocated Area) is displayed in yellow.

Memory Resource

In this case, the settings can be referred to in the [Simulator] sheet of the [Standard Toolchain] dialog box (figure

3.12). The [Simulator] sheet contains the following buttons:

[View]
[Add]
[Modify]

[Remove]

Adds a memory resource.

Displays the memory map information.

Modifies the selected memory resource.

Removes the sel ected memory resource.

Clicking the [Add] button displays the [Add memory resource] dialog box (figure 3.14).
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Add memary

—fddress :
Start

End: | 010000001 =

Aittribute IF{ vl
814 I Cancel |

Figure3.14 Add memory resource Dialog Box

Specify the following itemsin the [Add memory resource] dialog box:

[Start] Start address
[End] End address
[Attribute] Attribute (R: Read-only, R/W: Readable/Writable)

The memory resource settings can be changed in the [Memory] tab of the [Simulator System] dialog box. For
details, refer to section 4.212, Modifying the Memory Map and Memory Resource Settings.

Modification of the memory resource information in the [Memory] tab of the [Simulator System] diaog box will
be reflected in the contents of the [Standard Toolchain] dialog box, and modification in the [ Standard Toolchain]
dialog box will be reflected in the [Memory] tab of the [Simulator System] dialog box as well.

333 Downloading a Program

If there is sufficient memory in the system in which to download your program, you can then proceed to
download a program to debug. By default, the program output from the linker of the current project is
automatically downloaded.

It is also possible to manually choose the download modules after the project creation. Thisisachieved viathe
[Debug Settings] dialog box shown in figure 3.16. Thisdialog box alows you to control the debug settings
throughout your workspace. The tree on theleft of the dialog box contains all of the current projects. Selecting
aproject in thistree will then show you the settings for that project, and the session selection in the session drop-
down list. Multiple sessionsor all sessionsin thislist box can be selected. If you select multiple sessions, you
can choose to modify the settings for one or more sessions at once. The [Debug Settings] dialog box displays the
following debug options:

» Current debug target for the current project and session selection
» Download modules for the current project and session selection

The download module list displays the order in which the fileswill be downloaded to the target. It ispossible to
add, remove, modify, move up, and move down modulesin thislist.

< Toadd anew download module:
1. Select [Options -> Debug Settings...]. The dialog box shown in figure 3.16 will be displayed.
2. Select the project and configurations you are interested in adding a download module to in [tree control].
3. Click the [Add] button. The dialog box displayed in figure 3.15 is displayed.
4. The[Format] list box containsalist of supported object format readers. This allows you to choose the
correct reader for the download module you wish to add to the project.
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o

The [Filename] field allows you to browse to the download module on your disk, or simply typeit into
[edit control] if you have not yet built the module.

6. Enter an offset addressto the [Offset] field (suitable only for some object formats).

7. Specify the memory accesssizeas 1, 2, 4, or 8.

8. Todownload only the debugging information, check the [Download debug information only] check box.
9. To verify memory during downloading, check the [Perform memory verify during download] check box.

10. When the user clicks the [OK] button, the debug download module is added to the bottom of thelist. If
you wish to position the module in a different position in relation to the other modules, select the module
and then use the [Up] and [Down] buttons to position the module correctly.

Download Module ﬂﬂ

IH'DDDDDDDD
Cahicel |
Format:
[Elf/Dwart2 |
Filenarne:
I$[EDNFIGDIH]\$[PHDJECTNAME].abs [ 2 | Browse. .. |
ACCess size
-

™ Download debug jnformation only

[~ Perfarm memory verify during download
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IDebug

=

@ abedef

21

Target | DOptions |

Target:

| 5H2 Moritor =

Default Debug Format:

IS_I,Jerf j
Download Modules:

File Name | Difset Address | Fe Add |

DAHEW 2OMExehwinD... H'OD 5

Bemaove |
1 | i
oK

Any changes made in the [Debug Settings] dialog box do not take effect until you click the [OK] button.

The default debug format is set to the first download module in the list by default. Only one default debug
object format can be specified for each session. All currently installed debugger formats are listed here.

Figure3.16 Debug Settings Dialog Box ([Target] Sheet)

Debug Settings

I ReleazeSession

[

@ tutarial

Target Options

Cormand batch file load timing:

Command Line Batch Processing:

[~ Connect up to target on debug go

o]

Cancel

Figure3.17 Debug Settings Dialog Box ([Options] Sheet)
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The [Options] sheet (figure 3.17) of the [Debug Settings] dialog box contains the option that determines when a
target is connected. |If the option is checked, the target is not connected until you select [Build -> Debug -> Go].
If the option is unchecked, the target is connected whenever a configuration is opened. This happens when a
new workspace or project is opened or also when you switch configuration using the toolbar or [Build
Configurations] dialog box.

The [Command Line Batch Processing] list in the sheet containsalist of command line batch commands. These
batch commands can perform debug operations via the command line. When these commands are executed can
be selected in the [Command batch file load timing] drop-down list. Add the batch file to be executed after
selecting an item in the [Command batch file load timing] drop-down list. The order in the list isthe order in
which the command line batch fileswill be executed when the timing event occurs.
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334 Manual Download of Modules

Once you have decided which modules are to be downloaded to the target, it is possible to manually update the
modules of the connected target by selecting [Debug -> Download Modules]. Thisalows asingle module or al
of the modulesto be downloaded. This can aso be achieved by right-clicking on modules under the [Download
Modules] folder in the [Workspace] window.

335 Automatic Download of Modules

When you select [Debug -> Run...], the HEW calculates whether any of the files or debugger settings that affect
the modules have changed since the last download. If the HEW detects a change, then it asks the user whether a
download needs to take place for each module. If the user selects[Y es], then the module is downloaded to the
target.

If you have banked multiple modules at the same start address, only the first module at that addressis
downloaded by default. It isthen possible to manually load or unload the other modulesin the list whenever you
want from the [Debug -> Download M odules] and the [Debug -> Unload Modules] menu items.

336 Unloading of Modules

It is possible to manualy unload downloaded modulesin the list whenever you want from the [Debug -> Unload
Modules] menu item. This can also be done from the [Download Modul€] pop-up menu in the [Workspace]
window.

When amodule is unloaded, its symbols are erased from the HEW debugging system, but the memory contents
of the target remains unmodified. After a module has been unloaded, it cannot be debugged unlessit is reloaded.

34 Debugger Sessions

The HEW stores al of your builder optionsinto aconfiguration. In asimilar way, the HEW stores your
debugger optionsin asession. The debugging platforms, the programs to be downloaded, and each debugging
platform’s options can be stored in a session.

Sessions are not directly related to aconfiguration. This means that multiple sessions can share the same
download module and avoid unnecessary program rebuilds.

Each session’s data should be stored in a separate file in the HEW project. Debugger sessions are described in
detail below.

341 Selecting a Sesson
The current session can be selected in the following two ways:

» From the toolbar
Select a session from the drop-down list box (figure 3.18) in the tool bar.

|| $ R ||Debug j ||Fie|easeSession j | )1 {'or'} | @ E

Figure3.18 Toolbar Selection

* From the dialog box
1. Select [Options -> Debug Sessions...]. Thiswill open the [Debug Sessions] dialog box (figure 3.19).
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Debug Sessions

Sessions | Synchronized Debugl

Debug zessions:

Defaultsession

SimS ezsionH A5 - 26000,

Current segzion;

SimS ezsionH A5 - 26000,

=

HEmove

SavE &g,

L |

Eraperties

o |

Cahicel

Figure3.19 Debug Sessions Dialog Box

2. Select the session you want to use from the [Current session] drop-down list.
3. Click the [OK] button to set the session.
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Adding and Deleting Sessions

A new session can be added by copying settings from another session or deleting a session.

¢ Toadd anew empty session

I e A o

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 3.19).

Click the[Add...] button to display the [Add new session] dialog box (figure 3.20).

Check the [Add new session] radio button.

Enter a name for the session.

Click the [OK] button to close the [Debug Sessions] dialog box.

This creates a file with the same name as the entered session name. If the file name already exigts, an
error is displayed.

Add new zession

Mame:
Cancel

21x
' Add new session oK I

* Use an existing session file

M ame:

Itutnlial

Session file path:

I Browze |

v DOpen and mairtain link to session fils

[~ Make session file link read only

Figure3.20 Add new session Dialog Box
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» Toimport an existing session into anew session file

1

S A

6.

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 3.19).

Click the[Add...] button to display the [Add new session] dialog box (figure 3.20).

Check the [Use an existing session file] radio button.

Enter a name for the session.

Browse to the existing session file location that you would like to import into the current project.

If the [Open and maintain link to session file] check box is not checked, the imported new session fileis
generated in the project directory.

If the [Open and maintain link to session file] check box is checked, anew session fileis not generated in
the project directory but islinked to the current session file.

If the [Make session file link read only] check box is checked, the linked session fileis used as read-only.
Click the [OK] button to close the [Debug Sessions] dialog box.

¢ Toremoveasesson

1
2.
3.

4.

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 3.19).
Select the session you would like to remove.

Click the [Remove] button.

Note that the current session cannot be removed.

Click the [OK] button to close the [Debug Sessions] dialog box.

» Toview the session properties

1
2.
3.

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 3.19).
Select the session you would like to view the properties for.
Click the [Properties] button to display the [Session Properties] dialog box (figure 3.21).

Session Properties

Mame: SimSeszionHB5-2600M

Lozation: C:usersAeleasehutanalsutanialzsims eszionkBs-2600n. = |
Lastmodified:  15:4%04, Wednesday, March 13, 2002 _ Cancel |

[~ Eead only
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¢ To make asession read-only

1.

5.

g > w DN

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 3.19).

2. Select the session you would like to make read-only.
3.
4. Check the [Read only] check box to make the link read-only. Thisisuseful if you are sharing debugger-

Click the [Properties] button to display the [Session Properties] dialog box (figure 3.21).

setting files and you do not want data to be modified accidentally.
Click the [OK] button.

To save a session with a different name
1.

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 3.19).

Select the session you would like to save.

Click the [Save as] button to display the [Save Session] dialog box (figure 3.22).

Browse to the new file location.

If you want to export the session file to another location, leave the [Maintain link] check box unchecked.

If you would like the HEW to use thislocation instead of the current session location, check the
[Maintain link] check box.

Click the [OK] button.

Save Session 2] %]
Save jn:l@ tutarial j - £k B~

Diebug

SimD ebug_HB5-2600M
ReleazeSession hsf
SimSessionHB5-2600M. haf

File name: || Save I
Save as lype: IF'rniec:ts [*.haf] j Cancel |

[~ Maintain link

A

Figure3.22 Save Session Dialog Box
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343 Saving Session Information

* Tosaveasession
Select [File -> Save Session]. A standard file save dialog is displayed.

Note: You can display the dialog box that asks you whether or not the session is saved.. Clicking [No] loses
the changes you made in the session. Thisdialog box is displayed by checking [Confirm before saving a
session] on the [Workspace] tab in the [Option] dialog box selected from the [Tools->Options] menu.

344 Reloading Session I nformation

e Toreload asession

Select [File -> Reload Session]. Clicking thiswill lose any changes to your session currently and the reload
the current session into HEW. A confirmation will be displayed before the reload happens.

345 Debugging Multiple Targets

For the method to debug multiple targets in synchronization, refer to section 4.23, Synchronizing Multiple
Debugging Platforms.
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Section 4 Debugging

This section describes the debugging operations and their related windows and dialog boxes.

41 Viewing a Program

How to look at your program as source code and assembly language mnemonics is explained here. The HEW has
various facilities for dealing with code and symbol information which are explained in this section and you will
be shown how to look at text files viathe user interface.

Note: After abreak occurs, the HEW displaysthelocation of the program counter (PC) on the editor. In
most cases, for exampleif an Elf/Dwarf2 based project ismoved from itsoriginal path, the source
filemay not be automatically found. In thiscase, the HEW will open a sour ce file browser dialog
box to allow you to manually locate thefile. This path will then be used to update any other source
filesin this debug project.

411 Viewing the Source Code

Select your source file and click the [Open] button to make the HEW open the file in the integrated editor. Itis
also possible to display your source files by double-clicking on them in the [Workspace] window.

wold maindwvoid) j
{ s
Source code long a[l0]. min, max;
Iong 3
int 1

Bookmark ) printf("### Data Input ###n")

Fi Break matrk

e for{ i=0; i<10: i++ ){
PC address arrow o, jif?j%‘?ngg-%:
= -3

af1] = 3.
printf{"al[*d]=%1ld~n".1i.a[1]}):

=zortia);

printf("*%% Sorting results *exsp”)

for{ i=0; 1<10; i++ ){
printf{"al[xd]=X1d~n".1i.a[1]}):

i of

Figure4.1 Editor Window

The editor isdivided into two areas: the gutter area (containing markers for breakpoints, PC location, etc.) and
the text area (containing color syntax highlighted code). Thisis shown abovein figure4.1.

4.1.2 Source Address Column

After your program has been downloaded, the [Editor] window displays the addresses for the current source file
(figure 4.2). The addresses are shown on the left-hand side of the [Editor] window. Thisisuseful for deciding
where to set the PC or hardware breakpoints.
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«# tutorial.c -0l x|
#include <no_float.h> ﬂ‘
#include <stdio._h>

#include <math.h>

#include <stdlib.h>

void main{void);

void sort(long =a);

void change(long =a);

extern void srand{unsigned int);

0x00000&0c void main{uoid)
0x00000a16
long a[18], nin, max;
long j;
int i;
0x00000a12 srand(1);

0=00000220( ||  printf{"### Data Input HHN");

000000420 For( i=8; i<18; i++ )¢
0=00000a2s j = rand();
0=00000436 if(j < o)
0=00000a38 i=-is
H

0200000235 a[i] = j;
0x00000244 printf(“a[%d]=%1d\n",i,a[i]);

H
0=00000&62 sort(a);
0x00000a66 printf (" #«x Sorting results #=x\n");
0x00000a72 for{ i=8; i<18; i++ ){
0=00000274 printf{"a[%d]=%1d\n",i,a[i]);

3 =
5 mio _ arar. o

Figure4.2 Editor Window and Address Column

< To switch off acolumn in al source files

Right-click on the [Editor] window or select the [Edit] menu.

Click the [Define Column Format...] menu item.

The [Global Editor Column States] dialog box is displayed.

The check box indicates whether the column is enabled or not. If it is checked, the columnis enabled. If
the check box is gray, the column is enabled in somefiles and disabled in others.

5. Click the [OK] button for the new column settings to take effect.

A w DN A

Global Editor Column States

[w|Coverage
[w]E ditar
[w]Source Address

Figure4.3 Global Editor Column States Dialog Box

< To switch off acolumn in one source file
1. Right-click on the [Editor] window which contains the column you wish to remove to display the pop-up
menu.
2. Click the [Columns] menu item to display a cascaded menu item. Each column isdisplayed in this pop-
up menu. If the column isenabled, it hasatick mark next to itsname. Clicking the entry will toggle
whether the column is displayed or not.
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413 Debugger Columns

The debugging platform can add columns to the [Editor] window, which is called as the debugger column.
These added columns are referred to as debugger columns.

The columns that can be added to the [Source] window differ according to the debugging platform. The
[Coverage] column that graphically displays code coverage during debugger execution is an example of the
columns that can be added.

Right-clicking on the column displays the respective pop-up menu for that column. Double-clicking on the
column has a different effect depending on the column. For example, in the [Editor] column, this setsa PC
breakpoint.

If you are unsure what purpose a column has or what the information it is displaying, place the cursor over the

column, and atool tip is displayed.

414 Viewing the Assembly-L anguage Code

If you have a source file open, right-click to open the pop-up menu and select [Go to Disassembly] to open the

[Disassembly] window at the same address as the current [Editor] window.

If you do not have a source file, but wish to view code in the assembly-language level, either choose [View ->

Disassembly...], use the Ctrl + D accelerator, or click on the [Disassembly] window’ s toolbar button [.

The [Disassembly] window opens at the current PC location and shows [Address] and [Code] (optional) which

show the disassembled mnemonics (with labels when available).

«# Dizazsembly 10| =|
_main 6DF3 MOV . W R3.@-ER7 ;I
DOODDADE 01206DF4 STH.L {ER4-ERE ) . @-SF
00000A12 79370028 SUB.W #H'0028 R7
0000DAlE 0OD74 MOV. W R7.R4
0DO00ODALE 79000001 MOV . W #H'0001.RO
00000A1C SEODOCBG JSR @ =srand:24

o 00000420 79001F42 MOV. W #H'1F42.R0
00000424 &DFOD MOV . W RO, @-ER7
0000DA26 SEODOEE4 JSR @ printf_lite:24
00000AZ2A OBB? ADDS . L ¥2.ER7
DO00DA2C 1955 SUB.W R5.RS
D0000AZE SEODODCEO JSR @ rand:24
DO00DA32 17FD EXTS.L ERDO
00000A34 OFB6E MOV . L ER0 . ERG
DO00DA3E 4C0D2 BGE @H'0A34:8
D0000DA3E 17B6 HEG.L ER6&

ODO00DA3A ODE3 MOV . W R5.R3

0DO000A3C 1053 SHLL. W ¥2.R3

DODDDA3E 0943 ADD.W R4 .R3

00000440 010069B6 MOV . L ERG . @ER3

00000DA44 OFED MOV . L ER&.ERD

00000A46 D1006DFD MOV . L ERO, @-ER7

D000DA4A4 6DFS MOV. W RE . @-ER7

00000A4C 79001F56 MOV . W #H'1F56 . RO

DO00DDASD &DFOD MOV. W R0 .@-ER7

00000AS2 SEDDDBEA4 JSE @ orintf lite:2%_IZJ
b 4 i

Figure4.4 Disassembly Window
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415 Modifying the Assembly-L anguage Code

Y ou can modify the assembly-language code by double-clicking on the instruction that you wish to change. The
[Assembler] dialog box will open.

Aszzembler E

Addiezs  Code MrEmonic
00001012 O100BDFE MOV.L ERBE-ERT

QK. | Cancel |

Figure4.5 Assembler Dialog Box

The address, machine code, and disassembled instruction are displayed. Enter the new instruction or edit the old
instruction in the [Mnemonics| field. Pressing the Enter key will assemble the instruction into memory and move
on to the next instruction. Clicking the [OK] button will assemble the instruction into memory and close the
dialog box. Clicking the [Cancel] button or pressing the Esc key will close the dialog box.

Note: Theassembly-language display is disassembled from the actual machine code in the debugging
platform's memory. If the memory contents are changed the dialog box (and [Disassembly]
window) will show the new assembly-language code, but the sour ce file displayed in the [Editor]
window will be unchanged. Thisisthe same even if the sour cefile contains an assembler.

416 Viewing a Specific Address

When you are viewing your program in the [Disassembly] window, you may wish to look at another area of your
program'’s code. Rather than scrolling through alot of code in the program, you can go directly to a specific
address. Select [Set Address] from the pop-up menu, and the dialog box shown in figure 4.6 is displayed.

Set Address 2 | x|

Address oK,

Imain
Cancel |

Figure4.6 Set AddressDialog Box

Enter the address or label name in the edit box and either click on the [OK] button or press the Enter key. The
[Disassembly] window will be updated to show the code at the new address. When an overloaded function or a
class nameis entered, the [Select Function] dialog box opens for you to select afunction. For details, refer to
section 4.10, Elf/Dwarf2 Support.

417 Viewing the Current Program Counter Address

Wherever you can enter an address or value into the HEW, you can also enter an expression. If you enter a
register name prefixed by the hash character, the contents of that register will be used asthe valuein the
expression. Therefore, if you open the [Set Address] dialog box and enter the expression #pc, the [Source] or
[Disassembly] window will display the current PC address. It also allows the offset of the current PC to be
displayed by entering an expression with the PC register plus an offset, e.g., #PC+0x100.
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4.2 Operating Memory

This section describes how to look at memory areasin the CPU's address space. How to look at a memory area
in different formats, how to fill and move a memory block, and how to load and verify a memory areawith a
disk file are described.

421 Viewinga Memory Area

Tolook at a memory area, choose [View -> CPU ->Memory...] with the Ctrl + M accelerator or click the[View
Memory] toolbar button [|&]] to open the [Memory] window. Thiswill open the [Format] dialog box shown in
figure 4.7.

Format

Beain: Ok
IH'DDDDDDDD

LCancel |

End:
|H'DDDDDDFF

Format:
[Byte 1) =l

Dizplay Walue As:
I.&NSI character j

Bytez Count For One Line:

|16 Byte =l

Figure4.7 Format Dialog Box

Enter the range you wish to display as an address vaue or an equivalent symbol in the [Begin] and [End] fields.
Select the data size and format for the display from the [Display Value As] and [Format] drop-down lists,
respectively. Select the number of bytes displayed in one line from the [Bytes Count For One Ling] drop-down
list. Click the [OK] button or press the Enter key, and the dialog box closes and the [Memory] window opens.
The display can be scrolled within the range of the entered display start and end addresses.

- Memory =] E3
Address | +0 | +1 | +2 | +3 | +4 | +5 | +6 | +7 | Talue | -~
0x00000000 52 65 6E &8 73 6l 73 00 Renesas.

Ox0000000s 00 oo oo oo oo oo oo L
Ox00000010 00 oo oo oo oo oo oo L
Ox0000001s 00 oo oo oo oo oo oo L
Ox000000z0 00 oo oo oo oo oo oo L
Ox000000zs 00 oo oo oo oo oo oo L
Ox00000030 00 oo oo oo oo oo oo L
Ox00000038 00 oo oo oo oo oo oo L LI

Figure4.8 Memory Window
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There are three display columns:

[Address] First address of the memory data displayed on this row

[+n] Memory data read from [Address] and ‘n” means the offset value from the first address of the
row. Datais read from the debugging platform’s physical memory in the access width, and then
converted to the display width.

[Value] Datadisplayed in an alternative format

422 Displaying Data in Different Formats

If you want to change the display format of the [Memory] window, select [Format] from the pop-up menu. The
dialog box shown in figure 4.9 isdisplayed.

Format

Beain: oK
IH'DDDDDDDD

LCancel |

End:
|H'DDDDDDFF

Format:
[Byte 1) =]

Dizplay Walue As:
I.&NSI character j

Bytez Count For One Line:
|16 Byte =l

Figure4.9 Format Memory Display Dialog Box

To display and edit memory in different widths, use the [Format] drop-down list. For example, choose the [Byte]
option and the display will be updated to show the memory areaasindividua bytes.

The data can be converted into different formats, as shown in the third column [Value]. The list of formats
depends on the data selection.

To change the number of bytes displayed on one line, use the [Bytes Count For One Line] drop-down list. For
example, choose the [8 Byte] option and the display will be updated to show the 8-byte data on oneline.

423 Splitting Up the Window Display

To vertically divide the [Memory] window display into two, select [Split] from the pop-up menu and move the
split-up bar. Moving the split-up bar to the top end or bottom end of the window cancels the split-up display.

424 Viewing a Different Memory Area

To change the memory area displayed in the [Memory] window, use the scroll bars. To quickly look at a new
address, use the [Format] dialog box. This can be opened by choosing [Format] from the pop-up menu.
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Enter the new address value, and click the [OK] button or pressthe Enter key. The dialog box closes and the
[Memory] window display is updated with the data at the new address. When an overloaded function or a class
name is entered, the [Select Function] dialog box opens for you to select afunction.

425 M odifying the Memory Contents

The memory contents can be modified via the [Edit Memory] dialog box. Move the cursor on the memory unit
(according to the [Memory] window display choice) that you wish to change. Either double-click on the memory
unit or press the Enter key. The dialog box shown in figure 4.10 is displayed.

Edit Memory E2

Current W alue:
I Cancel |

Mew ' alue:
I.b.

Figure4.10 Edit Memory Dialog Box

A number or C/C++ expression can be entered in the [New Value] field. After you have entered the new number
or expression, click the [OK] button or press the Enter key. Then the dialog box closes and the new value is
written into memory.

The memory contents can also be modified by moving the cursor on the memory unit and entering the new value
in hexadecimal through the keyboard.

426 Selecting a Memory Range

If the memory address range isin the [Memory] window, you can select the range by clicking on the first
memory unit (according to the [Memory] window display choice) and dragging the mouse to the last unit. The
selected range is highlighted.

If the memory address range is larger than or outside the [Memory] window, you can enter the start address and
byte count in the respective fields of the [Format] dialog box.
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4.2.7 Finding a Valuein Memory

To find avaue in memory, open the [Memory] window and select [Search] from the pop-up menu. Otherwise,
when the [Memory] window has already been opened, simply pressthe [F3] key.

The [Search Memory] dialog box shown in figure 4.11 is displayed.

Data:

Search Data fs:
IElyte 1) LI

[¥ Search Equal Data [~ Search Backward

Figure4.11 Search Memory Dialog Box

Enter the start and end addresses of the range in which to search (the start and end address of the [Memory] will
be automatically filled in) and the data value to search for, and select the search format. If pattern search is
selected as the search format, a byte string of up to 256 bytes can be searched for. The end address can also be
prefixed by aplus (+); the end address will become the (start address) + (entered value).

Search conditions other than pattern search are data match/mismatch and search direction. Note that only data
match and forward direction can be selected with pattern search.

Click the [OK] button or press the Enter key. The dialog box closes and the HEW searches the range for the
specified data. If the datais found, the address at which the data has been found is displayed in the [Memory]
window.

If the data could not be found, the [Memory] window display remains unchanged and a message box informing
that the data could not be found is displayed.

If [Search Next] is selected from the pop-up menu in the state where data has been found, the search will
continue from the next address.

428 Fillinga Memory Areawith a Value
A value can be set as the contents of a memory address range using the memory fill function.

To fill the same value in amemory range, choose [Fill] from the pop-up menu of the [Memory] window or
choose [Fill] from the [Memory] drop-down menu. The [Fill Memory] dialog box is shown in figure 4.12.
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21X
I Cancel |

Data:

Format:

| =

Figure4.12 Fill Memory Dialog Box

If an address range has been selected in the [Memory] window, the specified start and end addresses will be
displayed. Select aformat from the [Format] drop-down list and enter the data value in the [Datd] field. Itisalso
possible to fill the memory by checking the [Verify] check box and comparing the data value to be filled and the
filled memory data. On clicking the [OK] button or pressing the Enter key, the dialog box closes and the new
value is written into the memory range.

429 Copying aMemory Area

Y ou can copy a memory area using the memory copy function. Select a memory range and then choose
[Copy...] from the pop-up menu. The [Copy Memory] dialog box opens (figure 4.13).

|
Cancel |
End:
|
Deztination:
|
Format:
IElyte 1) j
[~ Merify

Figure4.13 Copy Memory Dialog Box

The source start address and end address selected in the [Memory] window will be displayed in the [Begin] and
[End] fields. Checking the [Verify] check box enables copying while comparing the copy source and copy
destination. The copy unit can be selected in the [Format] list box. Enter the destination start addressin the
[Destination] field and click the [OK] button or press the Enter key. Thiswill close the dialog box and copy the
memory block to the new address.
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4210 Savingand VerifyingaMemory Area

A memory areain the address space can be saved into adisk file using the memory save function. Open the
[Save Memory As] dialog box by choosing [File -> Save memory...].

21x
IElinary LI
Cahcel |

File name:

|manual.bin LI _I

Start addreszs:
|D

End Address:
IH'FFFFI

Figure4.14 Save Memory As Dialog Box

Enter the start and end addresses of the memory block that you wish to save, and a name and format for the file.
The [File name] drop-down list contains the previous four file names used for saving memory.

Clicking the [Browse...] button can open the standard [File Save As] diaog box. On clicking the [OK] button or
pressing the Enter key, the dialog box closes and the memory block will be saved into the disk as afile of the
specified format type. When file saving has compl eted, a confirmation message box may be displayed.

A memory areain the address space can be verified using the memory verify function. Open the [Verify
Memory] dialog box by choosing [File -> Verify Memory...].

Yerify Memory : 2=l

=
Cancel |

File name:
| =1

Offzet address:

Figure4.15 Verify Memory Dialog Box

4211 Disabling Update of the Window Contents

Automatic update of the [Memory] window contents, which is performed when user program execution stops
and in other cases, can be disabled. Thisis done by checking [Lock Refresh] in the pop-up menu.

4212 Updating the Window Contents

The [Memory] window contents can be forcibly updated. Thisis done by checking [Refresh] in the pop-up menu.
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Comparing the Memory Contents

The contents of two memory blocks can be compared. Open the [Compare Memory] dialog box by selecting
[Memory -> Compare...] from the main menu or by selecting [Compare...] from the pop-up menu of the
[Memory] window.

Ciompare Memary

Start Compare:

Format:

I Buwte 13 LI

Figure4.16 Compare Memory Dialog Box

Enter the comparison format ([Format]), the start address ([Begin]) and end address ([End]) of the source
memory area, and the start address ([Start Compare]) of the destination memory area. If the memory block is
already highlighted in the [Memory] window, the start and end addresses will be automatically filled in when the
[Compare Memory] dialog box is opened.

If there is amismatch, the address where it was found is displayed in a message box.

4214

Loading a Memory Area from aFile

A file can be loaded to the debugging platform’s memory. Select [Load...] from the pop-up menu of the
[Memory] window to open the [Load Program] dialog box.

Load Program 2 x|
Format: Open
IElinary LI
File name:

| ==
Offget address:

Figure4.17 Load Program Dialog Box

Enter the file format ([Format]) and the file name ([File name]). If the load address value is to be changed, enter
the offset value in the offset field ([Offset address]), otherwise enter zero.
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4.3 Displaying Memory Contentsas an | mage

The memory contents can be displayed as an image in the [Image View] window.

431 Opening the Image View Window

Choose [View -> Graphic -> Image...] or click the [Image] toolbar button [![] to open the [Image Properties]
dialog box shown in figure 4.18.

Image Properties EH

r— Color Information:

Et/Ee IEbit”hdeH Calar, 'I
Samplit: I"'H:4 ]'
Earmat: I chunky s I

— Bufer Infomatiot:

Data Address: IH'UUUUUUUU j
Palette fddiess: IH'DUDUUUUU j
*width/Height Size(Pixel):

_ I—D Buffer Size:
which: | HOOOOO0O00. Byte
Height: I il

—View Information:
—Yiew Mode: = Position;

@ Full Size o Eositir I 0
' Part Size r Pasitir; I 0

— Start Position: = it erght SieelErel:

& Top G ling | 0
" Bottom Height: I 0

ok I Lancel |

Figure4.18 Image Properties Dialog Box
The [Image Properties] dialog box is used to specify the display method of the [Image View] window.

The following items are to be specified:

[Color Information] Specifies the color information of the image to be displayed.
[Mode] Specifies the format.
[MONOCHROME] Displaysin black and white.
[RGB] Displayed in R (red), G (green), and B
(blue)
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Displayed in B (blue), G (green), and R
(red)

Displayed by Y (brightness), Cb (color
differencein blue), and Cr (color difference
in red)

Specifies Bit/Pixel according to the selected [Mode]. (Valid when

Specifies the format of sampling. (Valid when Y CbCr is selected)

[BGR]
[YCbCr]
[Bit/Pixel]
RGB or BGR is selected)
[Sampling]
[Format]

[Buffer Information]

[Data Address|

Specifies Chunky/planar. (Valid when Y CbCr is selected)
Specifies the area to store data, size, and the address of the palette.

Specifies the start address of the memory where image dataisto

be displayed. (Displayed in hexadecimal)

[Palette Address)

Specifies the start address of the memory of color palette data.

(Displayed in hexadecimal) (Valid when 8Bit is selected for RGB or BGR)

[Width/Height Size] Specifies the width and height of the image.

[Width (Pixel)]

[Height (Pixel)]

[Buffer Size]

[View Information]

Specifies the width of the image.

(When aprefix is omitted, the values are
input and displayed in decimal.)
Specifies the height of the image.

(When aprefix is omitted, the values are
input and displayed in decimal.)
Displays the buffer size of theimage
from the width and height

(Displayed in hexadecimal)

Specifies the location, size, and data start location of the part to be

displayed among the entire image.

Specifies the entire/part to be displayed in the image.

Displays the entire image.
Displays part of theimage.

Displays data from the upper |eft.
Displays data from the lower |eft.

Specifies the start position of theimage where part of theimageis

to be displayed. (Valid when [Part Size] is selected)

[View Mode]
[Full Size]
[Part Size]
[Start Position]
[Top]
[Bottom]
[Position]
[X Position]
[Y Position]

Specifies the X axis of the start location.
(When aprefix is omitted, the values are
input and displayed in decimal.)
Specifiesthe Y axis of the start location.
(When aprefix is omitted, the values are
input and displayed in decimal.)

[Width/Height Size] Specifies the height and width of the image to be displayed partly.

[Width (Pixel)]

Displays the width of display.
(When aprefix is omitted, the values are
input and displayed in decimal.)
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[Height (Pixel)] Displays the height of display.
(When aprefix is omitted, the values are
input and displayed in decimal.)

After the settings have been made in the [Image Properties] dialog box, clicking the [OK] button opens the
[Image View] window.

Even after the [Image View] window is displayed, the display contents can be modified by opening this dialog
box by choosing [Properties...] from the pop-up menu.

Figure4.19 Image View Window

Displays the memory contents as an image.

432 Automatically Updating the Window Contents
Checking [Auto Refresh -> Not Refresh] in the pop-up menu will not refresh the window.

Checking [Auto Refresh -> Stop] in the pop-up menu will alow the window contents to be automatically
updated when user program execution stops.

Checking [Auto Refresh -> Realtime] in the pop-up menu will alow the window contents to be automatically
updated in an instruction interval specified with the [Response] command.

433 Updating the Window Contents

Selecting [Refresh Now] from the pop-up menu immediately updates the window contents.

434 Displaying the Pixel Information

Double-clicking within the window displays information on the pixel on which the mouse pointer islocated in
the [Pixel Information] dialog box.
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2%

Pixel Infarmation
Color mads: | RGE 24bit
Pizel | R:101,G:134,B:58
Pozition ¥ 325 AE 261
Butfer Size Width: 840 Height: 4s0
Image Size  Width: 84 Height: 256

Figure4.20 Pixel Information Dialog Box

Thisdialog box displays pixel information on the cursor location.

[Color Mode]

[Pixel]

[Position]

[Buffer Size]

[Image Size]

Displays the format of the image.

Displays color information of the cursor location. (Displayed in decimal)

Displays the cursor locationin X and Y axis. (Displayed in decimal)
[X] Displaysthe X axis of the cursor location.
[Y] Displaysthe Y axis of the cursor location.

Displays the buffer size. (Displayed in decimal)
[Width] Displays the buffer width.
[Height] Displays the buffer height.

Displays the width and height of the display. (Displayed in decimal)
[Width] Displays the width.
[Height] Displays the height.

4.4 Displaying Memory Contents as Waveforms

Memory contents can be displayed aswaveformsin the [Waveform View] window.

44.1 Opening the Waveform View Window

Choose [View -> Graphic -> Waveform...] or click the [Waveform] toolbar button [E[] to open the [Waveform
Properties] dialog box shown in figure 4.21.
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Data Addreszs: IH'DDDDDDDD j

Data Size: |'| fBit =l
Channel:

’7 = Maonn % Steren

Buffer Size: IH'DDDD'I aoo j

] 4 I Cancel |

Figure4.21 Waveform Properties Dialog Box
Specifies the waveform format. The following items can be specified.
[Data Address]  Specifies the start address of data in memory. (Displayed in hexadecimal)
[Data Size] Selects 8Bit or 16Bit.
[Channel] Specifies Mono or Stereo.
[Buffer Size] Specifies the buffer size of data. (Displayed in hexadecimal)

After the settings have been made in the [Waveform Properties] dialog box, clicking the [OK] button opensthe
[Waveform View] window.

Even after the [Waveform View] window is displayed, the display contents can be modified by opening this
dialog box by choosing [Properties...] from the pop-up menu.

=10l x|

|»

[ 32768
L 16304

F-16384

-32768
32768

]
AR VVYWWLUJWJWWJM

i i i -3ETRG T

0 128 6 204 512 B40 768 £g6 024 -
4] |

Figure4.22 Waveform View Window

Displays the memory contents as waveforms. The X axis shows the number of sampling dataand the Y axis
shows the sampling value.
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442 Automatically Updating the Window Contents
Checking [Auto Refresh -> Not Refresh] in the pop-up menu will not refresh the window.

Checking [Auto Refresh -> Stop] in the pop-up menu will alow the window contents to be automatically
updated when user program execution stops.

Checking [Auto Refresh -> Realtime] in the pop-up menu will allow the window contents to be automatically
updated in an instruction interval specified with the [Response] command.

443 Updating the Window Contents

Selecting [Refresh Now] from the pop-up menu immediately updates the window contents.

444 Zoom-In Display

Selecting [Zoom In] from the pop-up menu displays the waveforms with the horizontal axis enlarged.

445 Zoom-Out Display

Selecting [Zoom Out] from the pop-up menu displays the waveforms with the horizontal axis reduced.

446 Resetting the Zoom Display

Selecting [Reset Zoom] from the pop-up menu displays the waveformsin its original size.

447 Setting the Zoom M agnification

In the [Zoom Magnification] submenu of the pop-up menu, the zoom magnification can be selected from 2, 4, or
8.

448 Setting the Horizontal Scale

In the [X Scal€] submenu of the pop-up menu, the size of the X axis can be selected from 128, 256, or 512 pixels.

449 Non-Display of Cur sor

Selecting [Clear Cursor] from the pop-up menu hides the cursor display.

4410 Displaying the Sampling Information

Selecting [Sample Information...] from the pop-up menu displays the [Sample Information] dia og box.
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SampleInformation

Data Size: | 1 8hit
Charingl: I Steren
b | H'00000041
Walue
v | HFFFFasas
| HFFFF2289

Figure4.23 Sample I nformation Dialog Box

Displays the sampling information of the cursor location in the [Waveform View] window. The following
information is displayed.

[Data Size] Displays 8bit or 16bit.
[Channdl] Displays the data channel.

[Valug] [X] Displaysthe X axis of cursor location.

[Y] Displaysthe Y axis of cursor location (displays Y axes for both the upper and
lower plots when Stereo is selected).

45 Viewing the I/O Register

Aswell asaCPU and ROM/RAM, amicrocomputer also contains on-chip peripheral modules. The exact
number and type of peripheral modules differ between devices but the typical modules are aDMA controller,
seria communications interface, A/D converter, integrated timer unit, bus state controller, and watchdog timer.
Registers that are mapped to the microcomputer’ s address space control s the on-chip peripheral modules.

The [Memory] window enables you to look at datain continuous memory addresses as byte, word, longword,
single-precision floating-point, double-precision floating-point, or ASCII values. However, registers of different
sizes are allocated to non-continuous memory addresses in the 1/0O register. To handle this register, the HEW has
the [10] window to facilitate checking and setting up of these kinds of registers.

451 Opening the 10 Window

To open the [I0] window, select [View -> CPU -> 10] or click the [View Q] toolbar button [. Modules that
match the on-chip peripheral modules organize the /O register information. When the [10] window isfirst
opened, only alist of module namesis displayed.
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OOFEEE29

Figure4.24 10 Window

452 Expanding the 1/O Register Display

To display the names, addresses, and values of the 1/0 registers, double-click on the module name or select the
module name by clicking on it or using the cursor keys and press the Enter key. The module display will expand
to show the individual registers of that peripheral module and their names, addresses, and values. Double-
clicking (or pressing the Enter key) again on the module name will close the 1/O register display.

For adisplay in the bit level, expand the I/O register in asimilar way to the [Registers] window.

453 Manually loading an 10 file

To manually load an 10 fileright click on the IO window and select the “Load 1O file...” menu item on the 10
window pop-up. A standard file browser isinvoked. Simply select the file you require to load and click OK.
The 1O file will beloaded into the window.

454 Modifying the I/O Register Contents

To edit thevaluein an I/O register, type hexadecimal values directly into the window. To enter more complex
expressions, double-click or press the Enter key on the register to open a dialog box to modify the register
contents. When you have entered the new number or expression, click the [OK] button or press the Enter key;
the dialog box closes and the new value is written into the register.

4.6 Looking at Labels

Symboal information isincluded in the debugging information, which is used when the HEW links the user
program source code to the actual code in the memory. Symbol information is also included in the debug object
file. Thisinformation is alist of names that indicate addresses in the program. These names are called labelsin
the HEW. The [Disassembly] window shows the first eight characters of each label instead of the corresponding
address or as a part of an instruction operand .

Note: When alabel value matches an operand, the corresponding instruction operand isreplaced by the
label. If two or morelabels have the same value, the one that comesfirst in alphabetical order is
displayed.

Hint:  When [edit control] accepts an address or avalue, alabel can be input instead.
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46.1 Listing Labels

Choose [View -> Symbol -> Labels] or click the [View Labels] toolbar button tolist dl labels defined in the
current debugger session.

BEF | Addres= | Hame A|
H'00401214 _ D ROM J
H'00401220 _ B BGHN
H'00401224 B_END

H'00401218 _ D BGH
H'0040121C _ D END
H'00400400 _INT ReservedlO6
H'00400400 _INT Reservedld?
H'00400400 _INT ReservedlSl
H'00400400 _INT Reservedlcl
H'00400400 _INT Reserved205
H'00400400 _INT ReservedZld
H'00400400 _INT Reserved223
H'00400400 _INT Reserved23?
H'00400400 _INT ReservedZdl
H'00400400 _INT Reserved250
H'00400400 _INT ReservedlO?
H'00400400 _INT ReservedlZ2S
H'00400400 _INT Reservedld3
H'00400400 _INT Reservedlcl
H'00400400 _INT Reservedl?0

T AnAnngnn THT  Dmmmnree. Aane
{I I L

Figure4.25 Label Window

Y ou can view symbols sorted either alphabetically (by ASCII code) or by address value by clicking on the
respective column heading.

Double-clicking in the [BP] column can set or clear a software breakpoints at the start of the function.
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46.2 Adding a L abel

Choose [Add..] from the pop-up menu and open the [Add Label] dialog box to add alabel:

Add Label [ 7] x|

Mame: || LI 0K I
Address: [Ho00a00a0 =l Gancel |

Figure4.26 Add Label Dialog Box

Enter the new label name into the [Name] field and the corresponding value into the [Address] field and press
[OK]. The [Add Label] dialog box closes and the label list is updated to show the new label. When an
overloaded function or a class nameis entered in the [Address] field, the [Select Function] dialog box opens for
you to select afunction. For details, refer to section 4.10.3, Supporting Duplicate Labels.

46.3 Editing a L abel

Choose [Edit...] from the pop-up menu and open the [Edit Label] dialog box to edit alabel:

Edit Label _main

Mame: |_main ;I CK I

Address: [HoooaotoTZ] | Cancel |

Figure4.27 Edit Label Dialog Box

Edit the label name and value as required and then press [OK] to save the modified version in the label list. The
list display is updated to show the new label details. When an overloaded function or a class nameis entered in
the [Address] field, the [Select Function] dialog box opens for you to select a function. For details, refer to
section 4.10.3, Supporting Duplicate Labels.

233




High-performance Embedded Workshop User’s Manual

46.4 Deleting a L abel

To deletealabel, select the label and choose [Delete] from the pop-up menu. A confirmation message box
appears:

Confirmation Reguest

Delete Label BTEL

I~ Don't ask this question again

oK I Cancel i

Figure4.28 Message Box for Confirming L abel Deletion

If you click [OK], the label isremoved from the list and the window display is updated. If the message box is not
reguired then do not select the [Delete Label] option of the [Confirmation] sheet in the HEW [Options] dialog
box.

465 Deleting All Labds

To delete al the labels from the list, choose [Delete All] from the pop-up menu. A confirmation message box
appears:

Gonfirmation Request

Delete Al Labels

I Dan't ask this question azain

o (o] S Cancel i

Figure4.29 Message Box for Confirming All Label Deletion

If you click [OK], al thelabels are removed from the HEW system’s symbol table and the list display will be
cleared. If the message box is not required, do not select the [Delete All Labels] option of the [Confirmation]
sheet in the HEW [Options] dialog box.

4.6.6 Loading Labelsfrom aFile

A symbol file can be loaded and merged into the HEW's current symbol table. Choose [Load...] from the pop-up
menu to open the [Load Symbols] dialog box:
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Load Symbols EE3

Lock jn: |¢3H83tut j gl Ig
i

ttorial. spm

File narme: Im_l,l_cnde. aum Open I
Files of lwpe: IS_I,Ime| Files [*.spm)] j Cancel |

Figure4.30 Load Symbols Dialog Box

The dialog box operates like a standard Windows® [open file] dialog box; select the file and click [Open] to start
loading. The standard file extension for symbol filesis“.sym”. When the symbol loading is complete a
confirmation message box may be displayed showing how many symbols have been loaded (this can be switched
off in the [Confirmation] sheet on the HEW [Options] dialog box).

46.7 Saving Labelsinto a File

Choose [Save As...] from the pop-up menu to open the [Save Symbols] dialog box. The [Save Symbols] dialog
box operates like a standard Windows® [Save File As] dialog box. Enter the name for the file in the [File name]
field and click [Save] to save the HEW's current [abel list to asymbol file. The standard file extension for
symbol filesis“.sym”.

See appendix B, Symbol File Format, for symbol file format.

Once afileis specified by the [Save As...] menu, the current symbol table can be saved in the same symbol file
just by choosing [Save] from the pop-up menu.

46.8 Sear ching for a Label

Choose [Find...] from the pop-up menu to open the [Find Label] dialog box:

Find Label EHE

Hame: I ﬂ ] I
gddress:l j Cancel |

[ Match caze

Figure4.31 Find Label Dialog Box

Enter al or part of the label name that you wish to find into the edit box and click [OK] or press the Enter key.
The HEW searchesthe label list for alabel name containing the text that you entered.
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Note: Only thelabel is stored by 1024 char acters of the start, ther efor e the label name must not overlap
mutually in 1024 charactersor less. Labelsare case sensitive.

46.9 Sear ching for the Next Label

Choose [Find Next] from the pop-up menu to find the next occurrence of the label containing the text that you
entered.

4.6.10 Viewing the Source Corresponding to a L abel

Select alabel and choose [View Source] from the pop-up menu to open the [Source] or [Disassembly] window
containing the address corresponding to the label.
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4.7 Looking at Registers

If you are debugging at assembly-language level, then you will probably find it useful to see the contents of the
CPU's general registers. Y ou can do this using the [Register] window.

4.7.1 Opening the Register Window

To open the [Register] window choose [View->CPU->Registers] or click the [Register] toolbar button . The
[Register] window opens showing all of the CPU's general registers and the values, displayed in hexadecimal.

; =100 x|
Register Mame | Register W alue -
RO H'00000000
R1 H00ao0oao
R2 H'00000000
R3 H00ao0oao
R4 H'00000000
R5 H00ao0oao
RE H'00000000
R7 H00ao0oao
RS H'00000000
Ra H00ao0oao
R10 H'00000000
R11 H00ao0oao
R12 H'00000000
R13 H00ao0oao
R14 H'00000000
R15 H'0FFFFFFQ
PC H'00000800
GER H'00000000
YBR H00ao0oao |
MACH H'00000000
MALCL H00ao0oao -
N I o .z

Figure4.32 Register Window
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4.7.2 Expanding a Bit Register

If aregister isused as a set of flags at the bit level for the control of state, its one-character symbol rather than its
state indicate each bit. Double-click on the register’s name to display the [Edit Register] dialog box and switch
each bit on or off. Checking the check box for any bit specifiesit as holding a 1, while removing the check
specifiesitasaO.

21x]
Walue:
D i’
WIRE Cancel |
[w|EL LI

Figure4.33 Expanding a Bit Register

4.7.3 Choosing a Register to be Displayed

To choose aregister to be displayed in the [Register] window, choose [Settings...] from the pop-up menu. This
dialog box is shown in figure 4.34.

Settings HE
Begisters:

WIERD
[WwER1
WIERZ LCancel |
WwER3

WwIER4

[WIERS

w|ERE

WIER7

[w|PC

[w|CCR

[w|ExR

[w| kA CH

[w] kA& CL

Figure4.34 Set Dialog Box
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4.7.4 Splitting Up the Window Display

To vertically divide the [Register] window display into two, select [Split] from the pop-up menu and move the
split-up bar. Moving the split-up bar to the top end or bottom end of the window cancels the split-up display.

475 Modifying Register Contents
To change aregister's contents, open the [Edit Register] dialog box in one of the following methods:

» Enter avaluedirectly in the window.
» Double-click the register you want to change.
» Select the register you want to change, and choose [Edit...] from the pop-up menu.

Set A
Cancel |
wihole Fegizter j

Figure4.35 Edit Register Dialog Box

Y ou can enter anumber or C/C++ expression in the [Vaug] field. Y ou can choose whether to modify the whole
register contents, a masked area, floating or flag bits by selecting an option from the drop-down list (the contents
of thislist depend on the CPU model and selected register).

When you have entered the new number or expression, click the [OK] button or press the Enter key; the dialog
box closes and the new value is written into the register.

4.7.6 Using Register Contents

Use the value contained in a CPU register by specifying the register name prefixed by the “#” character, e.g.:
#R1, #PC, #R6L, or #ER3 when you are entering a value el sewhere in the HEW, for example when displaying a
specified addressin the [ Disassembly] or [Memory] windows.

48 Executing Your Program

This section describes how you can execute your program's code. Y ou will learn how to do this by either running
your program continuoudly or stepping single or multiple instructions at atime.

481 Running from Reset

To reset your user system and run your program from the reset vector address, choose [ Debug->Reset Go], or
click the [Go Reset] toolbar button .

The program will run until it hits a breakpoint or abreak condition is met. Y ou can stop the program manually
by choosing [Debug->Halt], or by clicking the [Halt] toolbar button [,

Note: The program will start running from whatever addressis stored in the Reset Vector location.
Thereforeit isimportant to make sure that thislocation contains the address of your startup code.
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482 Continuing Run

When your program is stopped, the HEW will display an yellow arrow mark in the gutter of the line in the editor
and [Disassembly] windows that correspond to the CPU's current program counter (PC) address value. Thiswill
be the next instruction to be executed if you perform a step or continue running.

To continue running from the current PC address, click the [Go] toolbar button , or choose [ Debug->Go].

To continue running from a specified address which is not the stop address, change the PC value in one of the
following ways, and click the [Go] toolbar button or choose [Debug->Go].

» Change the PC value in the [Register] window. Refer to section 4.7.5, Modifying Register Contents.

» Place the text cursor (not the mouse cursor) to atarget linein the [Source] or [Disassembly] window, and
choose [Set PC Here] from the pop-up menu.

483 Running to the Cur sor

Sometimes as you are going through your application you may want to run only a small section of code, that
would require many single steps to execute. Y ou can do this using the Go To Cursor feature.

2 How to use the Go To Cursor

1. Makesurethat a[Source] or [Disassembly] window is open showing the address at which you wish to stop.

2. Position the text cursor on the address at which you wish to stop by either clicking in the [Address] field or
using the cursor keys.

3. Choose [Go To Cursor] from the pop-up menu.

The debugging platform will run your code from the current PC value until it reaches the address indicated by
the cursor's position.

Notes: 1. If your program never executesthe code at thisaddress, the program will not stop. If this
happens, code execution can be stopped by pressing the Esc key, choosing [Debug->Halt], or
clicking on the [Halt] toolbar button .
2. TheGo To Cursor featurerequiresa PC breakpoint - if you have already used all those
available, then the feature will not work.

484 Running from a Specified Address

The [Run Program] dialog box allows the user to run the program from any address. Choose [Debug -> Run...]
to open the [Run Program] dialog box.

Run Program ﬂﬂ

PBrogram Gounter:

|H'DDDDDDDD|
Beset Go
Temporary PG Breakpoints:

Cancel

i

Figure4.36 Run Program Dialog Box
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The following execution conditions can be specified in this dialog box:

[Program Counter] Instruction address to start execution. Theinitial valueis
the current PC vaue.

[Temporary PC Breakpoints] A temporary PC breakpoint. When execution started
by this dialog box stops, this breakpoint is cleared.

Note: The[Temporary PC Breakpoints] feature requiresa PC breakpoint - if you have alr eady used all
those available then the featur e will not work.

Clicking the [Go] button starts execution according to the settings. Clicking the [Reset Go] button starts
execution from the reset vector. Clicking the [Cancel] button closes this dialog box without executing
instructions.

485 Single Step

To debug your codeit isvery useful to be able to step asingle line or instruction at a time and examine the effect
of that instruction on the system. In the [Editor] window, then a step operation will step asingle sourceline. In
the [Disassembly] window, a step operation will step a single assembly-language instruction. If the instruction
calls another function or subroutine, you have the option to either step into or step over the function. If the
instruction does not perform a call, then either option will cause the debugger to execute the instruction and stop
at the next instruction.

486 Stepping Into a Function

If you choose to step into the function the debugger will execute the call and stop at the first line or instruction of
the function. To step into the function either click the [Step In] toolbar button , or choose [ Debug->Step In].

4.8.7 Stepping Over a Function Call

If you choose to step over the function the debugger will execute the call and al of the code in the function (and
any function callsthat that function may make) and stop at the next line or instruction of the calling function. To
step over the function either click the [Step Over] toolbar button , or choose [Debug->Step Over].

488 Stepping Out of a Function

There are occasions when you may have entered a function, finished stepping through the instructions that you
want to examine and would like to return to the calling function without tediously stepping through dl the
remaining code in the function. Or alternatively you may have stepped into a function by accident, when you
meant to step over it and so want to return to the calling function without stepping al the way through the
current function. Y ou can do this with the Step Out feature.

To step out of the current function either click the [Step Out] toolbar button , or choose [Debug->Step Out].

489 Multiple Steps

You can step severd instructions at atime by using the [ Step Program] dialog box. The dialog box & so provides
an automated step with a selectable delay between steps. Open it by choosing [Debug-> Step...].
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The [Step Program] diaog box is displayed:

Step Program d |

Steps:

Delay fzeconds)

|1 - 25 seconds :I
[~ Step Over Calls

[~ Source Level Step

0] % I Cancel

Figure4.37 Step Program Dialog Box

[Steps] Number of stepsto be executed.

[Delay (seconds)] Delay between steps when the program is automatically stepped.
Value 0 to 6 can be specified where value 0 indicates the longest delay.

[Step Over Calls] Selecting this box steps over function calls.

[Source Level Step] Selecting this box steps the program at the source level.

Clicking the [OK] button or pressing the Enter key starts step execution.

4.8.10 Executing Multiple Targets

Multiple targets can be debugged in synchronous execution. For details, refer to section 4.23, Synchronizing
Multiple Debugging Platforms.

49 Stopping Your Program

This section describes how you can halt execution of your application's code. This section describes how to do
thisdirectly by using the [Halt] button and by setting breakpoints at specific locations in your code.

491 Halting Execution

When your program is running, the [Halt] toolbar button is enabled [ (ared STOP sign), and when the
program has stopped it is disabled [ (the STOP signisgrayed out). Click on the [Halt] toolbar button, or
choose [Debug->Halt Program].

When the program has been stopped by [Halt], "Stop" isdisplayed in the [Debug] sheet of the [Output] window.

492 Standard Breakpoints (PC Breakpoints)

When you are trying to debug your program you will want to be able to stop the program running when it
reaches a specific point or pointsin your code. You can do this by setting a PC breakpoint on the line or
instruction at which to want the execution to stop. The following instructions will show you how to quickly set
and clear smple PC breakpoints. If more complex breakpoint operation is required, use the [Event] window,
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which can be opened by clicking the i@ putton or choosi ng [View -> Code -> Event]. For details, refer to
section 4.15, Using the Simulator/Debugger Breakpoints.

» To set aPC breskpoint in the [Editor] window

1

Make sure that the [Disassembl €] or an [Editor] window is open at the place you want to set a PC
breskpoint.

Choose [ Toggle Breakpoint] from the pop-up menu, or press F9, at the line showing the address at which
you want the program to stop.

You will seeared circle appear in the gutter to indicate that a PC breakpoint has been set.

The current breakpoint set can be enabled or disabled by using [Enable/Disable Breakpoint] in the pop-up
menu.

Now when you run your program and it reaches the address at which you set the PC breakpoint, execution halts
with the message "Break = PC Breakpoint" displayed in the [Debug] sheet of the [Output] window, and the
[Source] or [Disassembly] window is updated with the PC breakpoint line marked with an arrow in the gutter.

Note: When a break occurs, the program stopsjust beforeit isabout to execute the line or instruction at

which you set a program PC breakpoint. If you choose Go or Step after stopping at the PC
breakpoint, then the line marked with an arrow will bethe next instruction to be executed. When
multiple targets are debugged, it ispossible to specify either or both of them is stopped. For details,
refer to section 4.23, Synchronizing Multiple Debugging Platfor ms.

» Toset aPC breakpoint by using the [Breakpoints] dialog box
The [Breakpoints] dialog box is shown in figure 4.38. It allows the user to view the current breakpoints set.
Clicking the [Edit Code] button displays the source where each breakpoint is set. The [Remove] or [Remove
All] button deletes one or all breakpoints, respectively. The check box of each breakpoint enables or disables
the breakpoint.

2]
Cancel |
Edit Gode |
Bemove |
Femove gl |

Figure 4.38 Breakpoints Dialog Box

» Toggling PC breakpoints
It is possible to toggle the [PC Breakpoints] setting by either double-clicking in the [BP] column of theline
where the PC breakpoint is set or placing the cursor on the line and pressing the F9 key. The setting to be
toggled depends on the debugging platform.
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410 Elf/Dwarf2 Support

The HEW supports the Elf/Dwarf2 object file format for debugging applications written in C/C++ and assembly
language for Renesas microcompuiters. It provides a powerful way of accessing, observing and modifying the
symbolic level debugging information about the user application that is running.

Key Features

» Source level debugging

» C/C++ operators

» C/C++ expression (casting, pointers, references, etc.)
*  Ambiguous function names

* Overlay memory loading

» Watch - locals, and user defined

o Stack Trace

410.1 C/C++ Operators
The C/C++ language operators are available:
55L& N L2, <<%, (), <, >, <5, 05, =5, 15, &&, |

Buf fer_start + 0x1000

#R1 | B 10001101

((pointer + (2 * increnent_size)) & H FFFFO000) >> D 15
I(flag » #ER4)

4.10.2 C/C++ Expressions

Expression Examples

oj ect . val ue //Specifies direct reference of amember (C/C++)
p_Qbj ect - >val ue //Specifiesindirect reference of amember (C/C++)
Cl ass: :val ue //Specifies reference of a member with class (C++)
*val ue //Specifies apointer (C/C++)

&val ue /ISpecifies areference (C/C++)

array| 0] //Specifies an array (C/C++)

oj ect . *val ue //Specifies reference of a member with pointer (C++)
::g_val ue //Specifies reference of aglobal variable (C/C++)

Cl ass::function(short) //Specifiesamember function (C++)

(struct STR) *val ue //Specifies cast operation (C/C++)
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4.10.3 Supporting Duplicate Labels

In some languages, for example C++ overloaded functions, alabel may represent more than one address. When
such alabel nameisentered in adiaog box, the HEW will display the [Select Function] dialog box to display
overloaded functions and member functions.

Select Function
Select Function Mame Set Function Mame
Sample: Func({long, char) R | Sanple: Func(short ., char)
Sample: :Func(long.char. int)

Differ:  Funci{short.char)

Differ: Func{long, char) 5 |
< |
<4 |

r— Counter

All Function Select Function Set Function

I 5 Funcions I 1 Functions I L Functions ok I Cancel

Figure4.39 Select Function Dialog Box

Select overloaded functions or member functionsin the [Select Function] dialog box. Generally, one function
can be selected at one time; only for setting breakpoints, multiple functions can be selected. This dialog box has
three areas.

[Select Function Name]  Displays the same-name functions or member functions and
their detailed information.

[Set Function Name] Displays the function to be set and their detailed information.

[Counter] [AIl Function] Displays the number of same-name functions
or member functions.
[Select Function] Displays the number of functions displayed
in the [Select Function Name] list box.
[Set Function] Displays the number of functions displayed
in the [Set Function Name] list box.

Selecting a Function

Click the function you wish to select in the [Select Function Name] list box, and click the [>] button. Y ou will
see the selected function in the [Set Function Name] list box. To select dl functionsin the [Select Function
Name] list box, click the [>>] button.

Deselecting a Function

Click the function you wish to deselect from the [Set Function Name] list box, and click the [<] button. To
deselect all functions, click the [<<] button. The deselected function will be moved from [Set Function Name]
list box back to the [Select Function Name] list box.

Setting a Function

Click the [OK] button to set the functions displayed in the [Set Function Name] list box. The functions are set
and the [Select Function] dialog box closes.
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Clicking the [Cancel] button closes the dialog box without setting the functions.

4104 Debugging an Overlay Program
This section explains the settings for using the overlay functions.
Displaying Section Group

When the overlay modeis used, that is, when several section groups are assigned to the same address range, the
address ranges and section groups are displayed in the [Overlay] dialog box.

Open the [Overlay] dialog box by choosing [Memory->Configure Overlay].

Addrezs: Section Mame:
O01000-001023 s | [
00zZ000-00Z008

Cahce

i

[-| 11} _>ILI

Figure4.40 Overlay Dialog Box (at Opening)
This dialog box has two areas. the [Address] list box and the [Section Name] list box.

The [Address] list box displays the address ranges used in the overlay mode. Click to select one of the address
rangesin the[Address] list box.

Section Mame:
Pzectll, Faectll d i
PzectlZ,FPsectll
Pzectl3,FPsectll

s o

oz 000-00200E
Cahce

i

Figure4.41 Overlay Dialog Box (Address Range Selected)
The [Section Name] list box displays the section groups assigned to the selected address range.
< Setting Section Group

When using the overlay function, the highest-priority section group must be selected in the [Overlay] dialog box;
otherwise the HEW will operate incorrectly.

First click one of the address ranges displayed in the [Address] list box. The section groups assigned to the
selected address range will then be displayed in the [Section Name] list box.
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Click to select the section group with the highest-priority among the displayed section groups.

Overlay E

Address: Section Mame:
PsectOl, Psectll
Psectl?

Psectl3, Psectls

001000-001023

00z000-002008

Cancel |

Figure4.42 Overlay Dialog Box (Highest-Priority Section Group Selected)

After selecting a section group, clicking the [OK] button stores the priority setting and closes the dialog box.
Clicking the [Cancel] button closes the dialog box without storing the priority setting.

Note: Within the addressrange used by the overlay function, the debugging infor mation for the section
specified in the [Overlay] dialog box isreferred to. Therefore, the same section of the currently
loaded program must be selected in the [Overlay] dialog box.

411 Lookingat Variables

This section describes how you can look at variables in the source program.

4111 Tooltip Watch
The quickest way to look at avariablein your program isto use the Tooltip Watch feature.
2 To use Tooltip Watch:

Display the source file containing the variable that you want to examine on the [Editor] window.
Rest the mouse cursor over the variable name that you want to examine - atooltip will appear near the variable
showing avalue of that variable.

¢ MEM 221  woid COPY MEM(wvoid)

ZZE !
223 unsigned short wu;
224 for({ uw=0; u < sizeof (NAME); ut++ )

223 *(TempZ Name+ \ = * (NAME+u) ;
226
227 } u=H7EZ

Figure4.43 Tooltip Watch

4112 Instant Watch

Display the source file containing the variable that you want to examine on the [Editor] window.
Rest the mouse cursor over the variable name that you want to examine and choose [Instant Watch...] from the
pop-up menu; the [Instant Watch] dialog box will appear and display the variable at the cursor location.
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Instant Watch

st {0x7c000088 | istruct strB)

Figure4.44 Instant Watch Dialog Box

“+" shown to the | eft of the variable name indicates that the information may be expanded by clicking on the
variable name, and “-" indicates that the information may be collapsed. Clicking [Add] registersthe variable in
the [Watch] window. Clicking [Close] closes the window without registering the variable in the [Watch] window.

4113 Watch Window
You can view any value in the [Watch] window.

Opening a [Watch] Window

To open a[Watch] window, choose [View->Symbol->Watch] or click on the [Watch ] toolbar button ifitis
vishle. A [Watch] window opens. Initialy the contents of the window will be blank.

- Watch ;IQI ll
Mame I Walue I Twpe
=R a { 0=7c000024 | tint[10]}

..... R [ HDA0000a0 { D:x7c000024 } (nt)

..... R[] HDA0000A0 { D:x7c000028 } (it}

..... R [ HDA0000A0 { Dx7c00002e } (it}

..... R [A] HDA0000A0 { Dx7c000030 } (it}

..... R [4] HDA0000A0 { D:x7c000034 } (it}

..... R [E] HDA0000A0 { Dx7c000038 } (it}

..... R [5] HDA0000A0 { Dx7c00003: } (it}

..... R [7] HDA0000A0 { D:x7c000040 } (it}

..... R [E] HDA0000A0 { D:x7c000044 } (it}

..... R [ HDA0000A0 { D:x7c000048 } (it}
...... B max HDA0000A0 { Dx7c00004e } (it}

Figure4.45 Watch Window

Thiswindow allows the user to view and modify C/C++-source level variables. The contents of this window are
displayed only when the debugging information available in the absol ute file (*.abs) includes the information on
the C/C++ source program. The variable information is not displayed if the source program information is

excluded from the debugging information during optimization by the compiler. In addition, the variables that are

declared as macro cannot be displayed.
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Thefollowing items are displayed.
[Name] Name of the variable

[Value] Value and assigned location.
The assigned location isenclosed by { }.

[Typel Type of the variable

The [R] mark shows that the value of the variable can be updated during user program execution. When the color
of the[R] mark is black, avaueisupdated in an instruction interval specified with the [Response] command

Adding a Watch Item
Use the [Add Watch] dialog box in the [Watch] window to add Watch items to the [Watch] window.
< To use Add Watch from a [Watch] window:

Open the [Watch] window.
Choose [Add Watch] from the pop-up menu.
The [Add Watch] dialog box opens:

Add Watch E3

) Addiess I j ok I
{® 1/ Ariatile on expression
Cancel |

shr

Figure4.46 Add Watch Dialog Box

Enter the name of the variable that you wish to watch and click [OK]. The variable is added to the [Watch]
window. A variable can be dragged from the [Editor] window and dropped into the [Watch] window.

Note: If the variablethat you have added isa local variable that isnot currently in scope, the HEW will
add it to the [Watch] window but its value will be ‘Not available now’.

Expanding a Watch Item

If awatch item isapointer, array, or structure, then you will see aplus sign (+) expansion indicator to left of its
name, this means that you can expand the watch item. To expand a watch item, click on it. The item expands to
show the elements (in the case of structures and arrays) or data value (in the case of pointers) indented by one tab
stop, and the plus sign changesto aminus sign (-). If the elements of the watch item also contain pointers,
structures, or arrays then they will also have expansion indicators next to them.
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« ¢ Watch Window = =] B3
B Name Value
i - gler ="yas"
[o] -boTl
[1] -p's
Expansion [21 -pTi=
inci
inglicatar L +Temp Name =" Renesas Technology
P +TempZ Name =" Renesas Technology
w@g; x Dx0000105e
[« | i

Figure4.47 Expanding a Watch Item

To collapse an expanded watch item, click on theitem again. The item's elements will collapse back to the single
item and the minus sign changes back to a plus sign.

Editing a Watch Item's Value

Y ou may wish to change the value of awatch variable, e.g. for testing purposes or if the value isincorrect due to
abug in your program. To change a watch item's value use the Edit VValue function.

< Editing awatch item's value:
Enter avalue directly in the window.

In another way, select theitem to edit by clicking on it, you will see a flashing cursor on the item.
Choose [Edit Value] from the pop-up menu.
The [Edit Value] diaog box opens:

Edit Value e |

Expression: Immc

Current Value:  HO000794b { 0x00ffibbd }

ok |
Mew Valus: IH"I 0oan Sancel |

Figure4.48 Edit Value Dialog Box

Enter the new vaue or expression in the [New Value] field and click [OK]. The [Watch] window is updated to
show the new value.

Deleting a Watch Item

To delete awatch item, select it and choose [Delete] from the pop-up menu. The item is deleted and the [Watch]
window is updated.

To delete all watch items, choose [Delete All] from the pop-up menu. All items are deleted and the [Watch]
window is updated.
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Specifying Realtime Update

The R mark shown to the left of each variable indicates whether the variable is updated in real time. When an R
mark is black, the value of the corresponding variable will be automatically updated in an instruction interval
specified with the [Response] command during user program execution.

A pop-up menu containing the following optionsis available in the [Watch] window:

* Auto Update
Marks the selected variable with abold R and updates the variable in real time.
* Auto Update All
Marks al variables with bold Rs and updates all variablesin real time.
» Delete Auto Update
Marks the selected variable with an outlined R and cancels realtime update.
» Delete Auto Update All
Marks al variables with outlined Rs and cancels realtime update.

M odifying the Radix
The radix for the selected variable display can be modified by choosing [Radix] from the pop-up menu.
Saving the Watch Window Contentsin a File

To save the contents of the [Watch] window, choose [Save As...] from the pop-up menu; the Save As dialog box
opens. It allows the user to specify the name of afile and to save the contents of the [Watch] window in thefile.
If the [Append] check box is selected, the window contents are appended to the existing file, and if it is not
selected, the exigting file is overwritten.

Opening a Memory Window

The contents of the memory area to which the selected variable is assigned can be displayed in the [Memory]
window. Choose [Go To Memory...] from the pop-up menu; the [Set Address] dialog box opens, showing the
information (start address, end address, and size) of the selected variable as default. Clicking [OK] opens the
[Memory] window.

4114 Locals Window
Thelocal variables and their values can be displayed in the [Locals| window.
Opening the L ocals Window

To open the [Locals] window, choose [View->Symbol->Local] or click the [Locals] toolbar button =,

.- Locals =

Value
x 0x00ffec00
+str =Myit

Figure4.49 Locals Window
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Asyou debug your program, the [Locals] window will be updated. If alocal variable is not initialized when
defined, then the value in the [Locals] window will be undefined until avalue is assigned to the locd variable.

Thelocal variable values and the radix for local variable display can be modified in the same manner asin the
[Watch] window.

412  Viewing the Profile Information

The profile function enabl es function-by-function measurement of the performance of the application program in
execution. This makesit possible to identify parts of an application program that degrade its performance and the
reasons for such degradation.

The HEW displays the results of measurement in three windows, according to the method and purpose of
viewing the profile data.

4121  Stack Information Files

The profile function allows the HEW to read the stack information files (extension: “.SNI") which are output by
the Optimizing Linker (ver. 7.0 or later). Each of these files contains information related to the calling of static
functionsin the corresponding source file. Reading the stack information file makes it possible for the HEW to
display thisinformation to do with the calling of functions without executing the user application (i.e. before
measuring the profile data). However, this feature is not available when [Setting->Only Executed Functions] is
checked in the pop-up menu of the [Profile] window.

When the HEW does not read any stack information files, the data about the functions executed during
measurement will be displayed by the profile function.

To make the linker create a stack information file, choose [Options -> H8,H8/300 siries Standard Toolchain...],
and select [Other] from the [Category] list box and check the [Stack information output] box in the
[Link/Library] sheet of the [Standard Toolchain] dialog box.

HB85_ H8/300 Standard Toolchain EHE
Corfiguration : C/C++ | Assembly  Link/Library | Standard Libray | CPU 4| »

|simDebug_Has 26004 =l Categony: Iﬁ
=3 All Loaded Projects

Mizscellaneous options :
R Cem =

Lt ecord at the end
infarm. autput
[1Compress debug information
[CILow memany uze during linkage

User defined options : Abszolute/Relocatable/Library j

=

=

Options Link/Library :

noprelink rom D= nomessage list 3
"$[COMFIGDIR)$PROJECTMAME ). map" nooptimize start
PF|esetPHGJD4UU,P,E,C$DSEC,C$BSEC,D!USDD,B,H.-"DFLI

ok I Cancel |

Figure4.50 Standard Toolchain Dialog Box (1)
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4.12.2  Profile Information Files

To creste a profile information file, choose the [Output Profile Information Files...] menu option from the pop-
up menu of the [Profile] window and specify the file name, after measuring a profile data of the application
program.

Thisfile contains information on the number of times functions are called and global variables are accessed. The
Optimizing Linker (ver. 7.0 or later) is capable of reading the profile information file and optimizing the
allocation of functions and variables in correspondence with the status of the actual operation of the program.

To input the profiler information file to the linker, choose [Optimize] from the [Category] list box and check the

[Include Profile] box in the [Link/Library] sheet of the [Standard Toolchain] dialog box, and specify the name of
the profile information file.

HB85_ H8/300 Standard Toolchain EHE
Corfiguration : C/C++ | Assembly  Link/Library | Standard Libray | CPU 4| »
|simDebug_Has 26004 =l Categony: Im

E'@ All Loaded Pro Show entries for :

R Cem

I Optimize iterns j

Dptimize : ISpeed Vl Eliminated size :I 0=001E 3:
V] Liniify strings ™ Include profile :

[VIE minate dead code I—
[v]Llze short addressing

[v]Fieallocate registers e Eifis |

[CJElminate same code [EEGHE SEe s

[(JUse indirect callfjump Size: I UxDDDBE

Optimize branches

[W]Llze shart dispdimm LLities I 0x0020 3:

Options Link/Library :

noprelink rom D= nomessage list -
"$[COMNFIGDIR)$(PROJECTMAME).map" optimize speed
start hd|

Cancel |

Figure4.51 Standard Toolchain Dialog Box (2)

To enable the settings in the [Include Profile] box, specify the [Optimize] list box as some setting other than
[None].

4123 Loading Stack Information Files

Y ou can select whether or not to read the stack information file in amessage box for confirmation that is
displayed when aload module is|oaded. Clicking the [OK] button of the message box loads the stack
information file. The message box for confirmation will be displayed when:

* There are stack information files (extension: “*.SNI").

» The[Load Stack Information Files (SNI files)] check box is checked in the [Confirmation] sheet of the
[Options] dialog box (figure 4.52) that can be opened by choosing [ Tools->Options] from the main menu.
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Options EE3
Build I E ditar I WWorkspace  Confirmation | Netwnlkl

— Display confirmation dialogs for:

[w]Drelete Template ;I Set Al |
[ 1Logze segzion changes on refrezh —

[w]Load memony Clear Al |
W] erify memony —

[w] 5 ave memony

] Fill mermion

[w] T et memory

[w]Drelete Al Labels

[w]Drelete Label

[ 1Loading Labels

[w] 5 aving Labels

[w] Clear Coverage Data

[w] Clear Coverage Data at Closing

[w] 5 ave Coverage at Session Saving

[w]Drelete P B ange b
[w]Drelete All P4 Ranges

[w]Drelete Al P4 Ranges at Loading

[w]Load Stack Information Files [SMI files) LI

ak. I Cahicel

Figure4.52 Options Dialog Box

4124  Enabling the Profile
Choose [View->Performance->Profile] to open the [Profile] window.

Choose [Enable Profiler] from the pop-up menu of the [Profile] window. The item on the menu will be checked.

4125 Specifying Measuring Mode

Y ou can specify whether to trace functions calls while profile data is acquired. When function calls are traced,
the relations of function calls during user program execution are displayed as a tree diagram. When not traced,
the relations of function calls cannot be displayed, but the time for acquiring profile data can be reduced.

To stop tracing function calls, choose [Disable Tree (Not traces function call)] from the pop-up menu in the
[Profile] window (a check mark is shown to the left of the menu item).

When acquiring profile data of the program in which functions are called in a specia way, such astask switching
in the OS, stop tracing function calls.
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4126 Executing the Program and Checking the Results

After the user program has been executed and execution has been halted, the results of measurement are
displayed in the [Profile] window.

The [Profile] window has two sheets; a[List] sheet and a[Tree] sheet.

4.12.7 List Sheet

This sheet lists functions and globa variables and displays the profile data for each function and variable.

Pr S |

Function\ariable I F I Address I Size I Times I Cvele I Ext mem I 10 area | Int mem | |

_$BTBL W HOOODSG6C — HOODDOODS O 0 0 0 0
Zshrk siee ¥ HODOODSGSE  HOODDOOD4 O 0 0 0 0
Tjconexp}2g ¥ HODOODSG48  HOODDOOZO0 O 0 0 0 0
Zfconmnts$29 ¥ HODOODSBCE  HOODDOOSD O 0 0 0 0
w12 ¥ HOOODSAES  HOODDOOEQ O 0 0 0 0
“ftable$2s ¥ HODOOD5A60  HOODDOOSS O 0 0 0 0
“ctype ¥ HODOODS960  HOODDOTOD O 0 0 0 0

y 0 0 0 0 0

_nfiles HO0005944  HOO00000

_rsft F HOOOOBE4C HOOOODOO3E O i} i} i} i}
_powl0 F HOOODS7B4  HOODODO9S O 0 0 0 0
_mult F HOOOOS6BC — HOODDDOFE O 0 0 0 0
_add F HO0005674 HOODOOD48 0 0 0 0 0
_%_morecor F HO0005618 HO000D0GS 0 0 0 0 0
_malloc F HO000S57C  HOODODOOO 0 0 0 0 0
_setshit F HOOODS4EC  HOODODOSO 0 0 0 0 0
_rnd F HO000S3E4 HOODOMOE 0 0 0 0 0
_power F HOOOOB268  HOODOO17C O 0 0 0 0
_multtid F H'00005200 HOODOO0GS 0 0 0 0 0 ;I
4' :I\ List f; Tree f

Figure4.53 List Sheet

Clicking the column header sorts the items in an alphabetical or ascending order. Double-clicking the

[Function/Variable] or [Address| column displays the source program corresponding to the addressin the line.

Right-clicking on the mouse within the window displays a pop-up menu. For details on this pop-up menu, refer

to section 4.12.8, Tree Sheet.
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4128 Tree Sheet

This sheet displays the relation of function calls along with the profile data that are values when the function is
called. This sheet is available when [Disable Tree (Not traces function call)] is not selected from the pop-up
menu in the [Profile] window.

Profile i |
Function Address Size Stack Size | Times | Cwcle | Ext mem | 10 area | Int mem |

). _PowerOM_Reset PG HO0000800 HOO0OOO2C  HOOOODOOOD
). _INIT IOLIE HO00O01170 HOODOOOBZ2  HO000000C
E " main QOO0TZC0" HO00000S i i 13
HOOOOT340°  HOO000088  HO000001S
HOOOD1614  HOODOD02C  HOOOOOO04
HO00OM50E  HOOD0003C  HO000000S
HO00OM3CGE  HOO000040  HO0000028
HO00O1222  HOODOOO74  HOOOOOO18
HOOOO3EBOD HOO0OO0SO  HOOOOO00OC
HO0002DAC HOODOOODC  HOO0000OC
HO00O116C  HOO000004  HO0000000
HOOOD10GA  HO0DOD0SA  HOODDOOM G
Cummy HO0000248  HOO0O0OO4  HO00O0000
INT Illegal_code HO0000244  HOODO0OO4  HO0OOO0000
------- _Manual_Reset_PC HO000082C  HOO000O18  HO0000000

= = o
= = o

oo
= = o
= = o

cooooooooo o of
cooooooooo o of
e I e e I e e e e e
o e e e o e o e e e e
o e e e o e o e e e e

A0 I List A Tree

Figure4.54 Tree Sheet

Double-clicking a function in the [Function] column expands or reduces the tree structure display. The
expansion or reduction is aso provided by the“+” or “-* key. Double-clicking the [Address] column displays the
source program corresponding to the specific address.

Right-clicking on the mouse within the window displays a pop-up menu. Supported menu options are described
in the following:

* View Source
Displays the source program or disassembled memory contents for the address in the selected line.
* View Profile-Chart
Displays the [Profile-Chart] window focused on the function in the specified line.
» Enable Profiler
Toggles acquisition profile data. When profile data acquisition is active, a check mark is shown to the left of
the menu text.
* Not trace the function call

Stops tracing function calls while profile data is acquired. This menu is used when acquiring profile data of
the program in which functions are called in a special way, such astask switching in the OS.

To display the relation of function callsin the [Tree ]sheet of the [Profile] window, acquire profile data
without selecting this menu. In addition, do not select this menu when optimizing the program by the
optimizing linkage editor using the acquired profile information file.

* Find...

Displaysthe [Find Text] dialog box to find a character string in the [Function] column. Search is started by
inputting a character string to be found in the edit box and clicking [Find Next] or pressing the Enter key.

* Find Data...
Displaysthe [Find Data] dialog box.
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Find Data E3

Find Data Find Next |
& Plaximum: Cancel |

= Minimum

Figure4.55 Find Data Dialog Box

By selecting the column to be searched in the [Column] combo box and the search type in the [Find Data)
group and entering [Find Next] button or Enter key, search is started. If the [Find Next] button or the Enter
key isinput repeatedly, the second larger data (the second smaller data when the Minimum is specified) is
searched for.

» Clear Data
Clears the number of times functions are called and profile data. Data in the [List] sheet of the [Profile]
window and the data in the [Profile-Chart] window are also cleared.

* Output Profile Information Files...
Displays the [Save Profile Information Files] diaog box. Profiling results are saved in a profile information
file (.pro extension). The optimizing linkage editor optimizes user programs according to the profile
information in thisfile. For details of the optimization using the profile information, refer to the manual of
the optimizing linkage editor.

Note:

If profileinformation has been acquired by choosing the [Not trace the function call] menu, the
program cannot be optimized by the optimizing linkage editor.

e Output Text File...
Displaysthe [Save Text of Profile Data] dialog box. Displayed contents are saved in atext file.
* Setting
This menu has the following submenus (the menus available only in the [List] sheet are aso included).

1.

Show Functions/Variables

Displays both functions and global variables in the [Function/Variable] column.
Show Functions

Displays only functionsin the [Function/Variable] column.

Show Variables

Displays only global variablesin the [Function/Variable] column.

4. Only Executed Functions
Only displays the executed functions. If a stack information file (.sni extension) output from the
optimizing linkage editor does not exist in the directory where the load module islocated, only the
executed functions are displayed even if this check box is not checked.
5. Include Dataof Child Functions
Sets whether or not to display information for a child function called in the function as profile data.
* Properties...

This menu cannot be used in this simulator/debugger.

4.12.9

Profile-Chart Window

The [Profile-Chart] window displays the relation of calls for a specific function. This window displays the
specified function in the middle, with the callers of the function on the left and the callees of the function on the

257




High-performance Embedded Workshop User’s Manual

right. The numbers of times the function callsthe called functions or is called by the calling functions are also
displayed in this window.

Profile-Chart - _main = B K|

_PovaerOM_Reset_| 0 _mair

Figure4.56 Profile-Chart Window

4.12.10 Typesand Purposes of Displayed Data
The profile function is able to acquire the following information:

Address Y ou can see the locations in memory to which the functions are allocated.
Sorting the list of functions and global variablesin order of their addresses
allows the user to view the way the items are allocated in the memory space.

Size Sorting in order of size makesit easy to find small functionsthat are frequently
called. Setting such functions asinline may reduce the overhead of function
cals.

Stack Size When there is deep nesting of function calls, pursue the route of the function

calls and obtain the total stack size for all of the functions on that route to
estimate the amount of stack being used.

Times Sorting by the number of calls or accesses makes it easy to identify the
frequently called functions and frequently accessed global variables.

Profile Data

* [Times] (the number of function callsor global variable accesses)
* [Cycle] (the number of execution cycles)

* [Ext_mem] (the number of external memory accesses)

* [I/O_ared] (the number of internal 1/O area accesses)

e [Int_mem] (the number of internal memory accesses)

The number of execution cyclesis calculated by subtracting the total execution cycles at a specific function call
instruction execution from the total execution cycles at areturn instruction execution of a specific function.

4.12.11 Creating Profile Information Files

To creste aprofile information file, choose the [Output Profile Information Files...] menu option from the pop-
up menu. The [Save Profile Information Files] dialog box is displayed. Pressing the [Save] button after selecting
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afile name will write the profile information to the selected file. Pressing the [Save All] button will write the
profileinformation to all of the profile information files.

2 Profile Information Fileg 2 x|
Profile Information files Gloze |
Program Files | Profile nformation files
Sarmple C¥Hew¥Sample¥sSamplepro

Save All |
Bramee,. |

1| | i

Figure4.57 Save Profile Information Files Dialog Box

412.12 Notes

1

The number of executed cycles for an application program as measured by the profile function includes a
margin of error. The profile function only alows the measurement of the proportions of execution time that
the functions occupy in the overall execution of the application program. Use the Performance Analysis
function to precisely measure the numbers of executed cycles.

The names of the corresponding functions may not be displayed when the profile information on aload
module with no debug information is measured.

The stack information file (extension: “.SNI") must be in the same directory as the load modulefile
(extension: “.ABS’).

It is not possible to store the results of measurement.
It is not possible to store the results of measurement.
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413  Viewing the Function Call History

The [Stack Trace] window shows the function call history.

4131 Openingthe Stack Trace Window

To open the [Stack Trace] window, choose [View -> Code -> Stack Trace] or click the [Stack Trace] toolbar

button T/

Eind| Hame Value

F func3 (short *) { 000000094 }

=] param 3 O0x00003ffa { 0x00003fd8 } (short*)
L lozal 3 D3 { 0x00003fd4 } {unsigned long)
F funcZ (short *) { OxD0O000072 }

=] param Z 000003 ffa { O0x00003fed } (short+*)
L local Z D'Z { 0x00003fe0 } {unsigned long)
F funcl (short *) { 0x0000003e }

=] param_ 1 0x00003ffa { O0x00003f£f0 } (short*)
L lozal 1 D1 { 0x00003fec } {unsigned long)
F maini) { O0x0000001Z }

L start D"103 { 0x00003ffa } ({zshort)

Figure4.58 Stack Trace Window

Thefollowing items are displayed.

[Kind] Indicates the type of the symbol.
F: Function
P: Function parameter
L: Local variable
[Name] Indicates the symbol name.
[Value] Indicates the value, address, and type of the symbol.

4.13.2 Viewing the Source Program

Select afunction and choose [Go to Source] from the pop-up menu to display, then the source program
corresponding to the function, which has been selected by opening the [Editor] window, is displayed.

4133  Specifying the View

Choose [View Setting...] from the pop-up menu to open the [Stack Trace Setting] dialog box, which alowsthe
user to specify the [Stack Trace] window settings.
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Mest level (-64) |i|§] =

— Display =vmbol
[~ Parameter
[~ Local Variable

— Diaplay Radix
* Hexadecimal
" Decimal
 Qotal
" Binary

Cancel |

Figure4.59 Stack Trace Setting Dialog Box
[Nest level] Specifies the level of function call nesting to be displayed in the [Stack Trace] window.
[Display symbol]  Specifies the symbol typesto be displayed in addition to functions.

[Display Radix] Specifies the radix for displaysin the [Stack Trace] window.
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4.14  Viewingthe Trace Information

The simulator/debugger acquires the results of each instruction execution as trace information and displaysit in
the [Trace] window. The conditions for the trace information acquisition can be specified in the [Trace
Acquigition] dialog box.

4141 Opening the Trace Window

To open the [Trace] window, choose [View -> Code -> Trace] or click the [Trace] toolbar button J

4142  Specifying Trace Acquisition Conditions

After the [Trace] window opens, the trace acquisition conditions must be specified in the [Trace Acquisition]
dialog box. To open this dialog box, choose [Acquisition...] from the pop-up menu.

Trace Acquisition

—Trace Start/Stop———————————————
" Dizable

Cancel |

—Inztruction Tvpe
£ Inztruction
= Subroutine

— Trace Buffer Full Handline
+ Continue
= Break

— Trace Capacity
f+ 1024 records
€ 4096 recaords
£~ 15384 records
32768 records

Figure4.60 Trace Acquisition Dialog Box

Thisdialog box specifies the conditions for trace information acquisition.

[Trace Start/Stop]
[Disable] Disables trace information acquisition.
[Enable] Enables trace information acquisition.

[Instruction Type]
[Instruction]  Acquirestrace information for all instructions.
[Subroutine]  Acquires trace information for the subroutine instructions only.

[Trace Buffer Full Handling]
[Continue] Continues acquiring trace information even if the trace information acquisition buffer
becomes full.
[Break] Stops execution when the trace information acquisition buffer becomesfull.

The trace buffer capacity can be selected from 1024 records, 4096 records, 16384 records, and 32768 recordsin
the [Trace Capacity].
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Clicking the [OK] button stores the settings. Clicking the [Cancel] button closes this dial og box without
modifying the settings.

4.14.3

Acquiring Trace Information

After trace acquisition is enabled, trace information is acquired during instruction execution. The acquired

information will be displayed in the [Trace] window.

< Trace M=l 3
PTE. I Cycle |Address I CCR | Mult | Instruction |Access Data | Source I Labe;l
-05343 0000029266 000300 = MOV. L OOFFFBES<... woid main(woid) _mai:
-05342 0000029281 000304 === STH.L O0FFFEDC. ..

-05341 0000029289 000308 e SUE.W R7<-FEE4

-05340 0000029293 00080C === MOV. L ER4<-00FF. .. {

-05339 0000029301 OO0B0E or MOV W RO<L-0001 srandil):

-05338 0000029312 000812 = J5R PC<-00000DE4

-05337 0000029316 O0O00DE4 === EXTU.L ERO<-0000. .. _sra—'
-05336 0000029334 000DB& e MOV. L O0FFFOEA<. ..

-05335 0000029345 0O00DEE === RT3 PC<-00000G16

-05334 00000Z9357 000816 or MOV.L ERO<-0000. .. printf("...

-05333 0000029368 00031C = MOV. L O0FFFEEOL. . .

-05332 00000Z9379 000320 === T3R PC<-00000CT4

-05331 0000029390 000C74 e MOV. L O0FFFBAS<. .. _pr
-05330 0000029394  000CTE === MOV. L ERg<-00FF. .. =
-NC220 nnnnn?>aan? nnneaa —_ AT TT e —FRREN

i | 4

Thiswindow displays the following trace information items:

[PTR]
[Cycle]
[Addresg]
[CCR]
Mult]
[Instruction]

[Access Data]

[Source]

4.14.4

Pointer in the trace buffer (O for the last executed instruction)

Figure4.61 Trace Window

Total number of instruction execution cycles (cleared by instruction-execution reset)

Instruction address

Displays the contents of the condition code register (CCR) as a mnemonic.

Displays the flag in the multiplier as a mnemonic (H8S/2600 series only).

Instruction mnemonic

Data access information (display format: destination <- accessed data)

C/C++ or assembly-language source programs

Sear ching for a Trace Record

Use the [Trace Search] dialog box to search for atrace record. To open thisdialog box, choose [Find...] from the

pOop-up menu.
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Figure4.62 Trace Search Dialog Box

This dialog box specifies the conditions for searching trace information. Specify a search itemin [Item] and
search for the specified contentsin [Value].

[PTR] Pointer in the trace buffer (O for the last executed instruction, specify in the form of -nnn)
[Cycl€e] Total number of instruction execution cycles

[Address] Instruction address

[Instruction] Instruction mnemonic

Clicking the [OK] button stores the settings and starts searching. Clicking the [Cancel] button closes this dialog
box without searching.

When atrace record that matches the search conditionsis found, the line for the trace record will be highlighted.
When no matching trace record is found, a message dialog box will appear.

If afind operation is successful, choosing [Find Next] from the pop-up menu will move to the next found item.

4145 Clearing the Trace Information

Choose [Clear] form the pop-up menu to empty the trace buffer that stores the trace information. If more than
one [Trace] window is open, al [Trace] windows will be cleared asthey all access the same buffer.

4146 Savingthe Trace Informationin aFile

Choose [Save...] from the pop-up menu to open the [Save Asg] file dialog box, which allows the user to save the
contents of the trace buffer as atext file. A range can be specified based on the [PTR] number (saving the
complete buffer may take severa minutes). Note that this file cannot be reloaded into the trace buffer.

4.14.7 Viewing the Source File
The [Editor] window corresponding to the selected trace record can be displayed in the following two ways:

» Select atrace record and choose [View Source] from the pop-up menu.
» Double-click atrace record

The [Editor] or [Disassembly] window opens and the selected line is marked with a cursor.
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4148 Trimming the Source
Choose [Trim Source] from he pop-up menu to remove the white space from the | ft side of the source.

When the white space is removed, a check mark is shown to the left of the [Trim Source] menu. To restore the
white space, choose [Trim Source] while the check mark is shown.

4149 Analyzing Statistical Information

Choose [Statistic] from the pop-up menu to open the [Trace Statistic] dialog box and analyze stetistical
information under the specified conditions.

Statistic |
— Statiztic Analysiz
= Default T Range

Set
Itemm Icode'l j 4|
Mew
Start IW
Erd : |
Clear |
Result :
Condition | Amount | FTR
codel =0 2 0001 5,-00014
ADDRESS=0000000C 3 000712 -00011,-00010
codel=E320 3 00007 00006, -00005
code2="2322 & codel=E3200 3 00007 00006, -00005

KN I

Cloze

L

Figure4.63 Trace Statistic Dialog Box

Thisdialog box alows the user to analyze statistical information concerning the trace information. The target of
analysisis specified in [Item] and the input value or character string is specified by [Start] and [End].

When [Default] is selected, the input value or character string cannot be specified as arange. To specify arange,
select [Range].

[Set] Adds anew condition to the current one

[New] Creates anew condition

[Result] Obtains the result of statistical information analysis

[Clear] Clears all condition and results of stetistical information analysis

Clicking the [Close] button closes this dialog box.
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415 Using the Simulator/Debugger Breakpoints

Sophisticated breakpoint functions are available in the simulator/debugger in addition to the HEW standard PC
breakpoints. The user can specify break conditions and actions after a break condition is satisfied, and can
display the breakpoints set.

4151 Listing the Breakpoints

Choose [View -> Code -> Eventpoints] or click the [Eventpoints] toolbar button @ to open the [Event]
window, which lists the breakpoints set.

Type State Condition Action
P Enable PC=H'O000100D Stop

Softuare Break /i Scfivare Event

Figure4.64 Event Window
Thefollowing items are displayed:

[Enable] Displays whether the breakpoint is enabled or disabled.
[Enable]: Valid
[Disable]: Invalid

[Type] Displays break types
[BP]: PC break
[BA]: Break access
[BD]: Bresk data
[BRY]: Break register (Register name)
[BS]: Bresk sequence
[BCY]: Break cycle

[Condition] Displays the conditions that satisfies abreak condition. The contents displayed differ from the type
of the break. When the type of the break is BR, the register name is displayed, and when the type of
the break is BCY, the number of cyclesis displayed.

BP: PC = Program counter (Corresponding file name, line, and symbol name)
BA: Address = Address (Symbol name)

BD: Address = Address (Symbol name)

BR: Register = Register name

BS: PC = Program counter (Corresponding file name, line, and symbol name)
BCY: Cycle = Number of cycles (displayed in hexadecimal)

[Action] Displays the operation of the s mulator/debugger when a break condition is satisfied.
[Stop]: Execution halts
[File Input] (file name) [File state]: Memory datais read from file]
[File Output] (file name) [File state]: Memory datais written to file]
[Interrupt] (Interrupt type/priority): Interrupt processing

For [Action], the condition specifying [Stop] is displayed on the [Software Break] tab and the condition
specifying othersis on the [Software Event] tab.
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4.15.2  Setting a Breakpoint

Choose [Add...] from the pop-up menu in the [Event] window to open the [Set Break] dialog box, which allows
the user to set abreak condition.

The [Set Break] dialog box has two pages: [Condition] page for specifying break conditions and [Action] page
for specifying the action when abreak condition is satisfied. In the [Action] page, the pop-up menu is selected on
the [Software Break] and [Software Event] tabs for specifying [Stop] and others, respectively.

Specifying Break Conditions:

Specify break conditionsin the [Condition] page in the [Set Break] dialog box (figure 4.65).

Condition | Action |

Break twpe - IPO Breakpoint LI
Address : IH"I noo
Caunt : |1

ok | #mebn |

Figure4.65 Set Break Dialog Box (Condition Page)
Thisdialog box specifies break conditions.
Set abreak typein the [Break type] box. The following shows the conditions that can be specified in each type.

[PC Breakpoint] Up to 1024 breakpoints can be specified

[Address] Address where a break occurs

[Count] Number of times that a specified instruction isfetched (when the prefix is
omitted, values must be input and are displayed in decimal) (1 to 16383,
default: 1)

[Break Access] Up to 1024 addresses can be specified
[Start address]  Start address of memory where a break occursif the memory is accessed
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[End address]  End address of memory where a break occursif the memory is accessed (If
no dataisinput, only the start addressiis break range)
[Accesstype]  Read, Write, or Read/Write

Up to 1024 values of data can be specified
[Start address]  Address of memory where a break occurs

[Data Data value that causes a break
[Size] Datasize
[Option] Data match/mismatch

Up to 1024 register names can be specified

[Register] Register name where break conditions are specified

[Size] Datasize

[Data] Data value that causes a break (If no dataisinput, abreak occurs whenever
datais written to the register)

[Option] Data match/mismatch

[Break Sequence] Only one address can be specified

[Break Cycle]

[Addressl] to  Passaddressesthat are the conditionsto generate a break.
[Address3] (All eight breakpoints do not have to be set.)

Up to 1024 cycles can be specified
[Cycle] Number of cyclesto determine abreak (H'1 to H' FFFFFFFF).
A condition will be satisfied by a number of cycles of [Cycle] x n. However,
the specified number of cycles and the number of cycles that satisfied the
condition may be different.
[Count] Number of times breaks will occur
[ALL] A break will occur whenever a condition is satisfied.
[Times] (when the prefix is omitted, values must be input and are displayed
in hexadecimal) (1 to 65535)
A break will occur only when the number of times
the conditionsis satisfied is equal to or below the
value specified for [Times).

When [PC Breskpoint] and [Break Sequence] is selected, if an overloaded function or class nameincluding a
member function is specified in address, the [Select Function] dialog box opens. In the dialog box, select a
function. For details, refer to section 4.10.3, Supporting Duplicate L abels.

Clicking the [OK] button sets the break conditions. Clicking the [Cancel] button closes this dialog box without
setting the break conditions.
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Specifying the Action at Break:

Specify the action when abreak condition is satisfied in the [Action] page in the [Set Break] dialog box (figure
4.66).

Condition  Action

Action tyvpe :

ok | #eut |

Figure4.66 Set Break Dialog Box (Action Page)

This dialog box specifies the action when a break condition is satisfied. Set the action in [Action type]. The
following show the itemsthat can be set in each action.

[Stop] Stops the operation of user program when a condition is satisfied. Thereis no item to be set.
[File Input] The data of a specified fileisreferred to and its contents are written to the specified memory
when acondition has been satisfied
[Input file] Datafile to refer to.
When the simulator/debugger has reached referring to the end of afile, it
will repeat referring to the beginning of the samefile.

[Address] Memory address where data should be written to.
[Datasize] Data size to be written to (1/2/4/8).
[Count] Number of data to be written to (when the prefix is omitted, values must be

input and are displayed in decimal) (H'1 to H’' FFFFFFFF).
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[File Output] The contents of a specified memory is written to the specified file when a condition has been

satisfied.

[Output file] Datafile to be written to.

[Append] When aexisting file is specified for the [Output Fil€],

[Address]| Memory address to read data to.

[Datasize] Size of one data to refer to (1/2/4/8).

[Count] Number of datato refer to (when the prefix is omitted, values must be input
and are displayed in decimal) (H’'1 to H' FFFFFFFF).

[Option] Data match/mismatch

[Interrupt] Interrupts the program when a condition has been satisfied. For details, refer to section 2.16,

Pseudo-Interrupts.

[Interrupt typel] Specifies the interrupt vector number (when the prefix is omitted, values
must be input and are displayed in hexadecimal) (0 to H' FF)

[Priority] Interrupt priority (when the prefix is omitted, values must be
input and are displayed in hexadecimal) (H'0 to H'11)
Whether or not the interrupt is accepted is determined by the CPU’s
specification of the selected debugging platform. However, when H’8 or
larger is specified for the priority, interrupts are always accepted.

Note: When the samefileis specified for multiple [File Input], the simulator/debugger will read data
from thefilein the order conditions are satisfied. When the same file is specified for multiple [File
Output], the smulator/debugger will write datato thefilein the order conditions are satisfied.
However, when [File Input] and [File Output] specify the samefile, only the operation for the first
condition satisfied isvalid.

4153 Modifying Breakpoints
Select a breakpoint to be modified, and choose [Edit...] from the pop-up menu to open the [Set Break] dialog box,

which alows the user to modify the break conditions. The [Edit...] menu is only available when one breakpoint
is selected.

4154 Enabling a Breakpoint

Select abreakpoint and choose [Enable] from the pop-up menu to enabl e the selected breakpoint.

4155 Disabling a Breakpoint
Select abreakpoint and choose [Disabl €] from the pop-up menu to disable the selected breakpoint. When a

breakpoint is disabled, the breakpoint will remain in the list, but a break will not occur when the specified
conditions have been satisfied.

4156 Deleting a Breakpoint
Select abreakpoint and choose [Delete] from the pop-up menu to remove the selected breakpoint. To retain the

breakpoint but not have it cause a break when its conditions are met, use the [ Disable] option (see section 4.15.5,
Disabling a Breakpoint).

4157 Deleting All Breakpoints

Choose [Delete All] from the pop-up menu to remove all breakpoints.
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4.15.8 Viewingthe SourceLinefor a Breakpoint

Select abreakpoint and choose [Go to Source] from the pop-up menu to open the [Source] or [Disassembly]
window at address of breakpoint. The [Go to Source] menu is only available when one breakpoint is sel ected.

4159 Closing Input or Output File

Select abreakpoint and choose [Close File] from the pop-up menu to close the selected [File Input] or [File
Output] data file and to reset the address to read the file.

4.15.10 Closing All Input and Output Files

Choose [Close All Files] from the pop-up menu to close all [File Input] and [File Output] datafiles and to reset
the address to read thefile.

416  Analyzing Performance

Use the [Performance Anaysis] window to select afunction name and anayze the performance.

4.16.1 Opening the Performance Analysis Window

Choose [View -> Performance -> Performance Analysis] or click the [PA] toolbar button @ to open the
[Performance analysis] window.

« Performance fine =] 3 !
Ihdesx | Function I Cycle l Crount l 5 ! Histogram !

1] _main 1304 1 0%

1 printf 1100 22 0%

b rand 440 il %

Figure4.67 Performance Analysis Window
Thiswindow displays the number of execution cycles required for each specified function.
The number of execution cycles are calculated as follows:

Execution cycles = total number of execution cycles when execution returns from the function
— total number of execution cycles when the target function is called

Thefollowing items are displayed:

[Index] Index number of the set condition

[Function]  Name of the function to be measured (or the start address of the function)

[Cycle] Total number of instruction execution cycles
[Count] Total number of calls for the function
[%] Ratio of execution cycle count required for the function to the execution cycle count required for

the whole program
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[Histogram] Histogram display of the above ratio

4.16.2 Specifying a Target Function

After the [Performance Analysis] window is open, choose [Add Range...] from the pop-up menu or press the
Insert key to open the [Performance Option] dialog box, which alows the user to specify afunction to be
analyzed.

Performance Option

Function Mame

|| Cancel |

Figure4.68 Performance Option Dialog Box

This dialog box specifies afunction (including alabel) to be evaluated. Up to 255 functions can be specified in
total. When an overloaded function or a class name including a member function is specified, the [Select
Function] dialog box opens. In the dialog box, select a function. For details, refer to section 4.10.3, Supporting
Duplicate Labels.

Clicking the [OK] button stores the setting. Clicking the [Cancel] button closes this dialog box without setting
the function to be evauated.

Select afunction that has been set and choose [Edit Range] from the pop-up menu or press the Enter key to open
the [Performance Option] dialog box and to change the function to be evaluated.

4.16.3 Starting Performance Data Acquisition

Choose [Enable Analysis] from the pop-up menu (a check mark is shown to the left of [Enable analysis]) to start
acquiring performance analysis data.

4164 Resetting Data
Choose [Reset Counts/Times] from the pop-up menu to clear the current performance analysis data.

4165 Deleting a Target Function

Select afunction and choose [Delete Range] from the pop-up menu to delete the selected target function and to
recalculate the data for the other ranges. The selected function can also be deleted by the Delete key.

4.16.6 Deleting All Target Functions

Choose [Delete All Ranges] from the pop-up menu to delete all the current target functions and to clear the
performance analysis data.

4.17  Acquiring Code Coverage

The [Coverage] window acquires code coverage information (CO coverage and C1 coverage) in the range
specified by the user, and displays the information.
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4.17.1 Opening the Coverage Window

Choose [View -> Code -> Coverage...] or click the [Coverage] toolbar button @ to open the [Open Coverage]
dialog box.

r— Options

& New Windaw oK |

" Start address; I

End address: I— Cancel |
® Fie [iesetpra.c [ 1Bz, |

Configuration directary
' Open a recent coverage file Project direckory
‘Warkspace directory
HEW installation directory
‘Warkspace name

= Browse to another coverage file Project name
Configuration name

Figure4.69 Open Coverage Dialog Box

This dialog box specifies the coverage acquiring range. To set coverage for anew range, the following two ways
are available:

*  Specifying the start and end addresses on the new window

[Start Address] Start address of coverage information display
(When aprefix is omitted, the valuesis input in hexadecimal.)

[End Address]  End address of coverage information display
(When aprefix is omitted, the value is input in hexadecimal.)

»  Specifying the file on the new window

[File] Source file whose type number is .C or .CPPin the current project.
Functionsin the specified file can be set as the coverage range.
If the type number of the file is omitted, .C is complemented. The file that has other type
numbers than .C or .CPP cannot be specified.
A placeholder or the [Browse...] button isavailable.

To use the settings saved in a coverage information file, choose the file from [Open a recent coverage file], or
open afile open dialog box by [Browse to another coverage file] and select the file. When [Open arecent
coverage file] is selected, up to four recent files that have been saved are displayed.

Clicking [OK] opens the [Coverage] window.
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*  Coverage window (specifying address)

=
Rarnge I Statistic I Status Timesl Pass I Addrezs I Aszembler -
H'O0OO00S00- H'O0000S50  35% Enable 1 S oooooso0 MOV.L [HiH'00:
1 S aoooosn:s  ADD #H'FO |
1 S aooposod LD Rz, VER
S aoooosose MOV.L [HiH'00:
Enable & - 00000808 ISR ARZ
Clear Al - 00000804 NOF
1 S aoooosaoc Mov #H'FO,E
1 S QoO00sS0E EXTU.E R3,R4d
1 = aoogoslo  LDc Rd, SR
1 S aoooosls NOp
1 S aoooosld MOV.L HiH'00]
1 S aooonsle JER REZ
1 S aoooosls NOp
1 S Qooo0sla  SLEETD -
l | KN | H

Figure4.70 Coverage Window (Specifying Address)
Thiswindow is divided into two by a splitter.
* Leftsde

Thiswindow displays the coverage range and statistical information. The following item is displayed:

[Range] Address range

[Statistic] Percentage of the instructions executed within the range
[Status] Enable or Disable status of the coverage range

* Rightsde

Thiswindow displays the coverage information of the function in C/C++ and assembly-language level. You can
select afunction by clicking the function name in left side of the window.

The following items are displayed:
[Times] Number of times instruction was executed

[Pass] Execution status of conditional branch instructions
T: A branch occurred because the condition was satisfied
F: No branch has occurred because the condition was not satisfied

[Address] Instruction Address
[Assembler] Disassembled display
[Source] C/C++ or assembly-language source

When the [Coverage] window is closed, the acquired coverage information and the conditions to acquire
information will be cleared.

»  Coverage window (specifying source file)
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Figure4.71 Coverage Window (Specifying Sour ce File)
Thiswindow is divided into two by a splitter.
o Leftsde

Thiswindow displays the coverage range and statistical information. The following item is displayed:

[Function] List of functions
[Statistic] Percentage of the instruction executed within the function
[Status] Enable or Disable status of the respective function

Note: 1. The functions can be sorted by their names, percentage, status, either in ascending or descending order,
by
clicking the Column tab (“Functions’ or “ Statistic” or “Status”).
2. By sdlecting the popup menu item (“Enable All"), all the functions can be set “enable” or “disable’.
3. By selecting the popup menu item (“Clear All"), the coverage data of all the functions can be cleared.

* Rightsde

Thiswindow displays the coverage information of the function in C/C++ and assembly-language level. You can
select afunction by clicking the function name in left side of the window.

Thefollowing items are displayed:
[Times] Number of times instruction was executed

[Pass] Execution status of conditional branch instructions
T: A branch occurred because the condition was satisfied
F. No branch has occurred because the condition was not satisfied

[Address]| Instruction Address

[Assembler] Disassembled display
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[Source] C/C++ or assembly-language source

When the [Coverage] window is closed, the acquired coverage information and the conditions to acquire
information will be cleared.

4.17.2  Acquiring Coverage Information

Select [Enable Coverage] from the pop-up menu and execute the user program to acquire coverage information.

4.17.3  Viewing the Source Window

Choose [View Source] from the pop-up menu to open the [Editor] window and to display the [Editor] window
corresponding to the cursor location in the [Coverage] window.

4174 Changing the Display Address

Choose [Go to Address...] to open the [Go To Address] dialog box.

Go To Addre

Bdress
Cance| |

Figure4.72 Go To Address Dialog Box

This dialog box changes the address displayed in the [Coverage] window.

4175 Changing the Coverage Range
»  Specifying the coverage range with an address

Choose [Set Range...] from the pop-up menu to open the [Coverage Range] dialog box.

% Start address: Iﬁ j oK I
End address: IBEEI =] Cancel |

€ Fle | -ﬂ E!r-:uwse...l

Figure4.73 Coverage Range Dialog Box (Specifying Address)

Thisdialog box specifies the condition to acquire instruction execution information. The following items can be
specified.

[Start Address]  Start address (When a prefix is omitted, the value isinput in hexadecimal.)

[End Address]  End address (When a prefix is omitted, the valueisinput in hexadecimal.)
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Clicking [OK] changes the coverage range.
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»  Specifying the coverage range with a source file

Choose [Set Range...] from the pop-up menu to open the [Coverage Range] dialog box.

€ Start address: I j 0k I
Erd address: I j Cancel |

& Fie Iresetplg.c _}J Browse...l

Figure4.74 Coverage Range Dialog Box (Specifying Sour ce File)

This dialog box specifies the condition to acquire instruction execution information. The following items can be
specified.

[File] Source file whose type number is .C or .CPP in the current project.
Functions in the specified file can be set as the coverage range.
If the type number of the file is omitted, .C is complemented. The file that has other type
numbers than .C or .CPP cannot be specified.
A placeholder or the [Browse...] button isavailable.

Clicking [OK] changes the coverage range.

4.17.6  Clearing Coverage Information

Choose [Clear Data] from the pop-up menu to clear the acquired coverage information.

4.17.7 Saving Coverage Informationin aFile

Choose [Save Data...] from the pop-up menu to open the [ Save Data] dialog box, which allows the user to save
the coverage information in afile.

LI Browse,. |
Cancel I

Figure4.75 Save Data Dialog Box

Thisdialog box specifies the location and name of a coverage information file to be saved. The placeholder or
the [Browse...] button can be used.

If afile name extension is omitted, .COV is automatically added. If afile name extension other than .COV
or .TXT is specified, an error message will be displayed.
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4.17.8 Loading Coverage Information from a File

Choose [Load Data...] from the pop-up menu to open the [Load Data] dialog box, which allows the user to load
the coverage information from afile.

Load Data

File name:
Filel
| ile [ 3 I Bromsze, | Gancel |

Figure4.76 Load Data Dialog Box

Thisdialog box specifies the location and name of a coverage information file to be loaded. The placeholder or
the [Browse...] button can be used.

Only .COV files can be loaded. If afile name extension other than .COV is specified, an error message will be
displayed.

Note: If the coverage range is specified by a source file, the saved .COV file cannot be loaded.

4.17.9 Updating the Information

Choose [Refresh] from the pop-up menu to update the [Coverage] window to the latest information.

4.17.10 Stopping Update

Choose [Lock Refresh] from the pop-up menu to only update [Times] and [Pass] when program execution stops.
Memory accesses to update instruction codes in the [Coverage] window are stopped.

4.17.11 Confirmation Request Dialog Box

A confirmation request dialog box will appear when [Clear Data] or [Set Range...] isclicked or an attempt is
made to close the [Coverage] window.

irmation Regquest

Coverage data will be cleared.

¥ Save Coverage data

— T Gancel

Figure4.77 Confirmation Request Dialog Box

Clicking [OK] clears the coverage data. Choosing [Save Coverage data] opens the [Save Coverage Data] dialog
box (figure 4.78) to save the coverage datain afile beforeit is cleared.
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4.17.12 Save Coverage Data Dialog Box

When [File -> Save Session] menu option is clicked, the [Save Coverage Data] dialog box will appear, which
allows the user to save the [Coverage] window datain separate filesor asingle file.

Mo To 4l ez To All.

Figure4.78 Save Coverage Data Dialog Box

When multiple [Coverage] windows are open, a [Save Coverage Data] dialog box will appear for each open
coverage window.

Clicking the [No To All] button closes the dialog box without saving any coverage data.
Clicking the [Y es To All] button saves the data of all [Coverage] windowsin asinglefile.

Note: If thefileis specified for the coverage range, not all [Coverage] windows can be saved in asinglefile.

4.17.13 Displaying the Coverage I nformation in the Editor Window

The coverage information is reflected to the [Editor] window by highlighting the debugger columns
corresponding to the source lines of executed instructions. When the coverage settings are modified in the
[Coverage] window, the debugger column display will be updated.

a = ] 3]
0x0000138¢ \{xoid main(void) ZI
long al10], min. max
long j;
int i;
000001392 printf (4t Data Irput #HHY¥R7); J
0:000013%9¢ for( i=0; i<10; i+ J{
100001324 i = rand();
0:000013ac ifti < 0{
000001360 IR
000001362 alil = i:
0:000013c0 , primtf ("alZdl=%ld¥n", i,alil);
00000136 sortlal; hd
Kl ' 4

Figure4.79 Debugger Column (Coverage)
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418 Viewingthe Current Status

Choose [View -> CPU -> Status] or click the [View Status] toolbar button E to open the [Status] window and

see the current status of the debugging platform.

Iten Status

Memory Mode None

Target Device Configquration O00000000-07FFFFFF
Z0000000-Z7FFFFFF
40000000-47FFFFFF
COo000000-CO000FFF
FFFFEOOO-FFFFEFFF
FFFFFEOO-FFFFFFFF

System Memory Besources oooo0000-00007FFF
0&6000000-0&8000FFF
O7FFFOOO-07FFFFFF
FFFFFEOO-FFFFFFFF

Program MName Memory Loaded hrea
- -ug SH-ZWdemo_shZ. abs H'O00oo0ooo - H'0o0ooool?
H'O0000Z%00 - H'0000084F
H'O000l000 - H'OOOOSEBES

EXT
EXT
EXT
EXT
PAM
Is0
Pead/Mrite
Pead/Mrite
Pead/Mrite
Pead/Mrite

EIB\ Memory,ﬂ Platform )\Everﬂs ,"

Figure4.80 Status Window

The [Status] window is split into three sheets:

* [Memory] sheet

Contains information about the current memory status including the memory mapping resources and the

areas used by the currently loaded object file.
o [Platform] sheet

Contains information about the current status of the debugging platform, typically including CPU type and

mode; and run status.
» [Events] sheet

Contains information about the current event (breakpoint) status, including resource information.

419  Debugging with the Command Line Interface

Use the [Command Line] window to enter text-based commands instead of window menus and commands.

4191 Opening the Command Line Window

Choose [View -> Command Line] or click the [Command Line] toolbar button to open the [Command Line]

window.
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«* Command Line:no batch file:no log file:  [E[=]

Figure4.81 Command Line Window

Thiswindow allows the user to control the debugging platform by sending text-based commands. A series of
predefined command lines can be called from afile and the output can be recorded in afile. The command can
be executed by pressing the Enter key after the command isinput at the prompt (>) on the last line. For
information about the available commands, refer to section 5, Command Lines, and the on-line help.

If available, the window title displays the current batch and log file names separated by colons.
Pressing the Ctrl + 1 or Ctrl + | keyson thelast line displays the previously executed command line.

The HEW command and TCL (ver. 8.4.1) commands can be input in this window.

4.19.2  Specifying a Command File

It isuseful to use acommand file when a series of predefined command lines need to be executed. Create a
command file by atext editor and write necessary command lines. The default extension of acommand file
is.hdc.

Choose [Set Batch File...] from the pop-up menu to open the [Set Batch File] dialog box, in which the name of a
command file (*.hdc) can be specified. Clicking the [OK] button displays the specified command file name as
the window title. Clicking the [Cancel] button closes the dialog box without modifying the setting.

Set Batch File EHE3

Bath Pl
|| [ 3 | Browse,. | ok

Figure4.82 Set Batch File Dialog Box

4.19.3 Executinga Command File
Click the [Play] button in the [Set Batch File] dialog box or choose [Play] from the pop-up menu to execute the

command file. The [Play] menu is displayed in gray while the fileis running and can be used when the command
file execution stops and control returns to the user.
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4194  Stopping Command Execution

Choose [Stop] from the pop-up menu to stop command execution. The [Stop] menu becomes valid during
command execution.

4195 SpecifyingalogFile

Choose [Set Log File...] from the pop-up menu to open the [Open Log File] dialog box, in which alog file to
store the command execution results can be specified.

Open Log File EHE

Lo File: : BE

I LI Browse,. | - Cance

Figure4.83 Open Log File Dialog Box

Enter the name of alog file (*.log). The logging option is automatically set and the name of the fileis shown on
the window title bar.

Opening a previous log file will ask the user if they wish to append or overwrite the current log.

4.19.6 Starting or Stopping L ogging

Choose [Logging] from the pop-up menu to toggle logging to file on and off. When logging is active, the button
becomes effective. Note that the contents of the log file cannot be viewed until logging is completed, or
temporarily disabled by clearing the check box. Re-enabling logging will append to thelog file.

4.19.7 Entering a Full Path totheFile

It is recommended that the full path to afileis specified as afile namein the [Command line] window because
the current directory can be moved. However, care must be taken to enter the correct full path to afilewhenitis
entered from the keyboard. To save this trouble, a full path can be easily specified by browsing through files.

Choose [Browse...] from the pop-up menu to open the [Browse] dialog box. Select afile and click [Open] to
paste the full path to the selected file to the cursor location. This option can only be used when the cursor is
located on the last line.

4.19.8 Pasting a Placeholder

Select a placeholder from the [Placeholder] submenu in the pop-up menu to paste the selected placeholder to the
cursor location. This function is only available when the cursor islocated on the last line.
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420 Generating a Pseudo-Interrupt Manually

Choose [View -> CPU -> Trigger] or click the [Trigger] toolbar button @ to open the [Trigger] window, which
allows the user to generate a pseudo-interrupt manually by pressing a button on the window.

=101 x|
1 2 3 4
a i 7 i
g 10 11 12
13 14 13 18

Figure4.84 Trigger Window

Thiswindow displays trigger buttons that generate pseudo-interrupts manually. The details of the interrupt to be
generated by pressing each trigger button can be specified in the [Trigger Setting] dialog box.

Up to 256 trigger buttons can be used.

For details on the interrupt processing in the simulator/debugger, refer to section 2.16, Pseudo-Interrupts.
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4.20.1 SettingaTrigger Button

Choose [Setting...] from the pop-up menu to open the [Trigger Setting] dialog box and to specify the details of

the pseudo-interrupt to be generated by pressing each trigger button.

2%

Trigeer Mo |1 hd I QK
Gance| |

[+ Enable

MHarme: |1—
Interrupt Twpel: IW
Interrupt Tvpel: IW
Briority: m

Figure4.85 Trigger Setting Dialog Box

This dialog box alows the user to specify the details of the pseudo-interrupt to be generated by pressing each
trigger button.

[Trigger No.] Selects atrigger button to specify details

[Name] Specifies the name of the selected trigger button, which will be displayed in the [Trigger]
window

[Enable] Enables the trigger button when this box is checked.

[Interrupt Typel] Specifies the Interrupt vector number. (0 to H'FF)

[Priority] Interrupt priority. (0 to H'11)
Whether or not the interrupt is accepted is determined by the CPU’ s specification of the
selected debugging platform. However, when H’'8 or larger is specified for the priority,
interrupts are always accepted.

Clicking the [OK] button stores the setting. Clicking the [Cancel] button closes this dialog box without setting

the details of the interrupt.

Note: If the [Cancel] button isclicked after multipletrigger button settings are modified, the
modifications of all those buttons are canceled.

4.20.2 Changing the Number of Trigger Buttons

Specify the number of trigger buttons displayed in the [Trigger] window in the [Number of Buttons] submenu in

the pop-up menu. [4], [16], [64], or [256] can be selected.
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4.20.3 Changingthe Size of Trigger Buttons

Specify the size of trigger buttons displayed in the [Trigger] window in the [Size] submenu in the pop-up menu.
[Large], [Normal], or [Small] can be selected.

421  Modifying the Simulator/Debugger Settings

This section describes how to modify the smulator system, memory map, and memory resource settings after the
simulator/debugger is started.

4211 Modifying the Smulator System

The [System] tab in the [Simulator System] dialog box modifies the system call start location, execution mode,
and floating-point rounding mode.

Choose [Options -> Simulator -> System...] or click the [Simulator System] toolbar button ﬂ to open the
[System] tab in this dialog box.

Simulator System EHE
System | Memoryl
CPU:
|Has /28004, =l
Drata Area Bit Size; Sustemn Call &ddresss [ Enable
|D'24 |H'nnnnnnnn
Program Area Bit Size: Execution tode
E fStop [~
Responge: Bound Mode
ID'4DDDD IHDund To Nearest j
SYvSCR Address
[HooFFFFas
Cancel | el

Figure4.86 Simulator System Dialog Box (System Tab)

The following items can be specified in this dialog box:

[CPU] Displays the current CPU. (The CPU must be specified in the [Debug Settings] dialog box.

[Data Area Bit size] Specifies the number of bitsin the data space. The following values can be set in
each CPU:
H8/300, H8/300L, H8/300HN, and H8S/2600N: 16
H8S/2000N:

H8/300HA: 17 to 24
H8S/2600A and H8S/2000A: 17 to 32
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Specifies the number of bitsin the program area. The following values can be set
in each CPU:

H8/300, H8/300L, H8/300HN, and H8S/2600N: 16

H8S/2000N:

H8/300HA: Same as the number of address space bits

H8S/2600A and H8S/2000A: 17 to 32

Specifies the SY SCR address.

Specifies the start address of a system call that performs standard input/output or
file input/output processing from the user program. [Enable] When checked, a
system call is enabled.

Specifies the window refresh timing, that is, how many instructions should be
executed between refresh actions (1 to D'65535).

[Execution Mode]  Specifies whether the simulator/debugger stops or continues operating when a simulation
€rror occurs.

[Stop]

Stops the simulation.

[Continue]  Continues the simulation.

[Round Mode] Specifies the rounding mode for floating-point decimal-to-binary conversion.
[Round to nearest] Rounds to the nearest value.

The denormalized number is not converted to 0.

[Round to zero] Rounds toward zero.

The denormalized number is converted to 0.

Clicking the [OK] or [Apply] button stores the modified settings. Clicking the [Cancel] button closes this dialog
box without modifying the settings.

4.21.2 Modifying the Memory Map and Memory Resour ce Settings

The [Memory] tab in the [Simulator System] dialog box sets and modifies the memory map and memory

resource.
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Simulator System EE3
System  Memory |
Memaory g e‘-’gl =15 egEl Memary Resource: “‘:"glbg Kil
Begin | End | Tupe | 5. | Begin | End | Abtribute
Q0000000 OO001FFFF ROM 16 | 00000000 00007FFF Read Wi
OOFFEDOD OOFFEFBF Rakd 16 | OOFFEOOO OOFFEFBF Read Wi
OOFFFa00 OOFFFF3F 1/0 3 || DOFFFa00 O0FFFF3F Read Wi
OOFFFFED OOFFFFEF 1/0 3 || DOFFFFED O0FFFFFF Read Wi
DOFFFFCO | DOFFFFFF | RAM 16
1] | A | B
Ok I Cancel | i |

Figure4.87 Simulator System Dialog Box (Memory Tab)
The following items can be specified in this dialog box:
[Memory Map] Displays the memory type, start and end addresses, data bus width, and access cycles.
[Memory Resource] Displays the access type and start and end addresses of the current memory resource.

[Memory Resource] can be added, modified, or deleted using the following buttons:

o
_E'l Adds [Memory Resource] items. Clicking this button opens the [Set Memory Resource] diaog box,
and memory map items can be specified.

ﬁl Modifies [Memory Resource] items. Select an item to be modified in the list box and click this
button. The [Set Memory Resource] dialog box opens and memory map items can be modified.

i
_E'l Deletes [Memory Resource] items. Select an item to be deleted in the list box and click this button.

[Memory Resource] isthe same setting information as that of [Memory Resource] of the [Simulator] sheet in the
[H8S, H8/300 Standard Toolchain] dialog box. Modifications are reflected on both items. For the [H8S, H8/300
Standard Toolchain] dialog box, refer to section 3.3.1, Memory Map.

[Memory Map] can be added, modified, or deleted using the following buttons:

L]
_':'l Adds [Memory Map] items. Clicking this button opens the [ Set Memory Map] dialog box (figure
4.88), and memory map items can be specified.

ﬁl Modifies[Memory Map] items. Select an item to be modified in the list box and click this button.
The [Set Memory Map] dialog box (figure 4.88) opens and memory map items can be modified.

i
_E'l Deletes [Memory Map] items. Select an item to be deleted in the list box and click this button.
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[Memory Map] and [Memory Resource] can be reset to the default value by the ﬂ] button. Clicking the [OK] or
[Apply] button stores the modified settings. Clicking the [Cancel] button closes this dialog box without
modifying the settings.

4213 Set Memory Map Dialog Box

The [Set Memory Map] dialog box specifies the memory map of the target CPU.

The contents displayed in this dialog box depend on the target CPU. The simulator/debugger uses the specified
datato calculate the number of cyclesfor memory accesses.

Set Memory Map EE3
Temary type: oK I
[ROM =]

Cahicel |

Begin
|H'00000000

End
|H'O0FFFFFF

Diata bus

[z =]
State count;

2

Figure4.88 Set Memory Map Dialog Box
The following items are specified:

[Memory type] Memory type
[ROM] Internad ROM
[RAM] Internal RAM
[EXT] Externa memory
[10] Interna 1/0

[EEPROM] EEPROM
[Begin] Start address of the memory corresponding to a memory type
[End] End address of the memory corresponding to a memory type
[Data bus] Memory data bus width

[State count] Number of memory access cycles

Clicking the [OK] button stores the settings. Clicking the [Cancel] button closes this dial og box without
modifying the settings.

Note: Thememory map setting for the area allocated to a system memory resour ce cannot be deleted or
modified. First delete the system memory resource allocation with the [Simulator Memory
Resour ce] dialog box, then delete or modify the memory map setting.

289




High-performance Embedded Workshop User’s Manual
4214  Set Memory Resour ce Dialog Box

The [Set Memory Resource] dialog box sets and modifies memory resources.

Set Memory Resource EHE

Begin
|H'00000000

ok |
Cancel |
End
|H00003FFF

Attribute;
IFiead.n"\A-"lite j

Figure4.89 Set Memory Resource Dialog Box

The following items are specified:

[Begin] Start address of the memory areato be allocated
[End] End address of the memory areato be allocated
[Attribute] Accesstype

[Read] Read only

[Write] Write only

[Read/Write] Read and write

Click the [OK] button after specifying the [Begin], [End], and [Attribute]. Clicking the [Cancel] button closes
this dialog box without modifying the setting.

422  Standard /O and File 1/O Processing

Use the [Simulated 1/0O] window to enable the standard 1/0O and file I/O system calls from the user program.

4221 Opening the Simulated I/0O Window

Choose [View -> CPU -> Simulated 1/0] or click the [Simulated 1/0] toolbar button g to open the [Simulated
1/0] window.

[ Simulated 1/0 Window [_ (3] =]
Simulated I/0

Figure4.90 Simulated 1/0 Window

The standard output from the user program is displayed in this window. The key input from this window is
handled as the standard input to the user program.
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4.22.2 1/0 Functions
Table 4.1 lists the supported 1/0 functions.

Table4.1 1/O Functions

No. Function Code Function Name Description
1 H'01 (16-bit address) GETC Inputs one byte from the standard input
H'11 (24-bit address) device
H'21 (32-bit address)
2 H'02 (16-bit address) PUTC Outputs one byte to the standard output
H'12 (24-bit address) device
H'22 (32-bit address)
3 H'03 (16-bit address) GETS Inputs one line from the standard input device

H'13 (24-bit address)
H'23 (32-bit address)

4 H'04 (16-bit address) PUTS Outputs one line to the standard output device
H'14 (24-bit address)
H'24 (32-bit address)

5 H'05 (16-bit address) FOPEN Opens a file
H'15 (24-bit address)
H'25 (32-bit address)

6 H'06 FCLOSE Closes a file

7 H'07(16-bit address) FGETC Inputs one byte from a file
H'17 (24-bit address)
H'27 (32-bit address)

8 H'08 (16-bit address) FPUTC Outputs one byte to a file
H'18 (24-bit address)
H'28 (32-bit address)

9 H'09 (16-bit address) FGETS Inputs one line from a file
H'19 (24-bit address)
H'29 (32-bit address)

10 H'0A (16-bit address) FPUTS Outputs one line to a file
H'1A (24-bit address)
H'2A (32-bit address)

11 H'0B FEOF Checks for end of the file
12 H'0C FSEEK Moves the file pointer
13 H'0OD FTELL Returns the current position of the file pointer

To perform 1/O processing, use the [System Call Address] in the [Simulator System] dialog box (section 4.21.1)
in the following procedure.

1. Setthe address specialized for I/O processing in the [System Call Address], select [Enable] and execute the
program.

2. When detecting a subroutine call instruction (BSR, JSR, or BSRF), that is, asystem call to the specidized
address during user program execution, the smulator/debugger performs 1/0 processing by using the RO and
R1 values (H8/300, H8/300L series) or the ER1 value (H8/300H, H8S series) as the parameters.

Therefore, before issuing a system cdl, set as followsin the user program:

»  Set the function code (table 4.1) to the RO register
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MSB 1byte 1byte LSB
, Function
| H'01  |code | - | — |

»  Set the parameter block address to the R1 register (for the parameter block, refer to each function
description)

MSB LSB

Parameter block address

* Reserve the parameter block and input/output buffer areas
Each parameter of the parameter block must be accessed in the parameter size.

After the 1/O processing, the simulator/debugger resumes simulation from the instruction that follows the system
call instruction.

Each 1/0 function is described in the following format:

)] @ 4)
(©)

Parameter Block

®)

Parameters

(6)

(1) Number corresponding to table 4.1
(2) Function name

(3) Function code

(4) 1/0 overview

(5) 1/0 parameter block

(6) 1/0 parameters

1 GETC Inputs one byte from the standard input device
H'01, H'11, H'21

Parameter Block

One byte One byte

+0 Input buffer start address

« Function code: H'11 (24-bit address), H'21 (32-bit address)

One byte One byte

+0

, [T Input buffer start address - - - - - -
+

Parameters

* Input buffer start address (input)
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Start address of the buffer to which the input datais written to.

2 PUTC Outputs one byte to the standard output device
H'02, H'12, H' 22

Parameter Block

« Function code: H'02 (16-bit address)
One byte One byte

+0 Output buffer start address

« Function code: H'12 (24-bit address), H'22 (32-bit address)

One byte One byte

+0

, [ Output buffer start address - - - - - -
+

Parameters

* Output buffer start address (input)
Start address of the buffer in which the output data is stored.

3 GETS Inputs one line from the standard input device
H'03, H'13, H' 23

Parameter Block

« Function code: H'03 (16-bit address)
One byte One byte

+0 Input buffer start address

« Function code: H'13 (24-bit address), H'23 (32-bit address)
One byte One byte

+0

, [T Input buffer start address - - - - - -
+

Parameters

* Input buffer start address (input)
Start address of the buffer to which the input data is written to.

4 PUTS Outputs one line to the standard output device
H'04, H'14, H' 24

Parameter Block

 Function code: H'04 (16-bit address)
One byte One byte

+0 Output buffer start address

« Function code: H'14 (24-bit address), H'24 (32-bit address)

One byte One byte

+0
+2

ffffff Output buffer start address - - - - - -

Parameters
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*  Output buffer start address (input)
Start address of the buffer in which the output data is stored.

5 FOPEN Opensafile
H'05, H' 15, H' 25

The [FOPEN] opens afile and returns the file number. After this processing, the returned file number must be
used to input, output, or close files. A maximum of 256 files can be open at the sametime.

Parameter Block

« Function code: H'05 (16-bit address)

One byte One byte
+0 Return value File number
+2 Open mode Unused
+4 Start address of file neme

« Function code: H'15 (24-bit address), H'25 (32-bit address)

One byte One byte
+0 Return value File number
+2 Open mode Unused
+4
w | Start address of file neme - - - - - - -

Parameters

* Return value (output)
0: Normal completion
—1: Error
»  File number (output)
The number to be used in all file accesses after opening.
*  Open mode (input)
H'00: "r"
H'01: "w"
H'02: "a"
H'03: "r+"
H'04: "w+"
H'05: "at"
H'10: "rb"
H'11: "wb"
H'12: "ab"
H'13: "r+b"
H'14: "w+b"
H'15: "atb"
These modes are interpreted as follows.
"r": Open for reading.
"w": Open an empty file for writing.
"a": Open for appending (write starting at the end of thefile).
"r+": Open for reading and writing.
"w+": Open an empty file for reading and writing.
"a+" : Open for reading and appending.
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"b" : Openin binary mode.
o Start address of file name (input)
The start address of the area for storing the file name.

6 FCLOSE Closes afile
H'06

Parameter Block

One byte One byte
+0 Return value File number

Parameters

* Return value (output)
0: Normal completion
—1: Error
* File number (input)
The number returned when the file was opened.
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7 FGETC Inputs one byte from afile
H'07, H' 17, H' 27

Parameter Block

« Function code: H'07 (16-bit address)

One byte One byte
+0 Return value File number
+2 Input buffer start address

« Function code: H'17 (24-bit address), H'27 (32-bit address)

One byte One byte
+0 Return value File number
+2
—————— Input buffer start address - - - - - - -
+4

Parameters

* Return value (output)
0: Normal completion
—1: EOF detected
* File number (input)
The number returned when the file was opened.
e Start address of input buffer (input)
The start address of the buffer for storing input data.
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8 FPUTC Outputs one byte to afile
H'08, H'18, H'28

Parameter Block

« Function code: H'08 (16-bit address)

One byte One byte
+0 Return value File number
+2 Output buffer start address

« Function code: H'18 (24-bit address), H'28 (32-bit address)

One byte One byte
+0 Return value File number
+2
—————— Output buffer start address - - - - - - -
+4

Parameters

* Return value (output)
0: Normal completion
—1: Error
* File number (input)
The number returned when the file was opened.
e Start address of output buffer (input)
The start address of the buffer used for storing the output data.
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9 FGETS Reads character string data from afile
H'09, H'19, H'29

Reads character string data from afile. Datais read until either anew line code or aNULL code isread, or until
the buffer isfull.

Parameter Block

« Function code: H'09 (16-bit address)

One byte One byte
+0 Return value File number
+2 Buffer size
+4 Input buffer start address

« Function code: H'19 (24-bit address), H'29 (32-bit address)

One byte One byte
+0 Return value File number
+2 Buffer size
+4
w | Input buffer start address - - - - - - -]

Parameters

* Return value (output)
0: Normal completion
—1: EOF detected
* File number (input)
The number returned when the file was opened.
» Buffer size (input)
The size of the area for storing the read data. A maximum of 256 bytes can be stored.
o Start address of input buffer (input)
The start address of the buffer for storing input data.
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10

FPUTS

Writes character string datato afile

H'OA, H'1A, H'2A

Writes character string data to afile. The NULL code that terminates the character string is not written to the file.

Parameter Block

Parameters

Return value (output)
0: Normal completion
—1: Error

File number (input)

« Function code: H'0A (16-bit address)

One byte One byte
+0 Return value File number
+2 Output buffer start address

« Function code: H'1A (24-bit address), H'2A (32-bit address)

One byte One byte
+0 Return value File number
+2
—————— Output buffer start address - - - - - - -
+4

The number returned when the file was opened.
Start address of output buffer (input)
The start address of the buffer used for storing the output data.
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11

FEOF Checksfor end of file
H'0B

Parameter Block

One byte One byte
+0 Return value File number
Parameters
* Return value (output)
0: File pointer is not at EOF
—1: EOF detected

File number (input)
The number returned when the file was opened.

12

FSEEK Movesthefile pointer to the specified position
H'0C

Parameter Block

One byte One byte
+0 Return value File number
+2 Derection Unused
+4 Offset upper word
+6 Offset lower word

Parameters

* Return value (output)
0: Normal completion
—1: Error

File number (input)

The number returned when the file was opened.

Direction (input)

0: The offset specifies the position as a byte count from the start of the file.

1: The offset specifies the position as a byte count from the current file pointer.
2: The offset specifies the position as a byte count from the end of thefile.
Offset (input)

The byte count from the location specified by the direction parameter.

13

FTELL Returns the current position of the file pointer
H'0D

Parameter Block
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One byte One byte
+0 Return value ‘ File number
+2 Offset upper word
+4 Offset lower word

Parameters

* Return value (output)
0: Normal completion
—1: Error
* File number (input)
The number returned when the file was opened.
» Offset (output)
The current position of the file pointer, as a byte count from the start of the file.

The following shows an example for inputting one character as a standard input (from a keyboard)

MOV, W #H 0101, RO
MOV. W #PARM R1

JSR @YS_CALL
sTOP NOP
SYS CALL NOP
PARM .DATA.W | NBUF
| NBUF .RES.B 2
.END
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4.23  Synchronizing Multiple Debugging Platfor ms

Multiple debugging platforms can be operated a the same timein the HEW. There are two methods available
to achieve this. These are outlined bel ow; the external method was availablein HEW 2.x. The Interna
synchronization of debugger targetsis the new preferred method for multiple target debugging in HEW 3.0.

4231 External HEW synchronization

Initiating a HEW from another HEW synchronizes multiple debugging platforms. The HEW that initiates
another HEW is called the master, and the initiated HEW is called the dave. Choose [Tools -> Launch Slave
HEW...] or click the [Launch Slave HEW] toolbar button ##| to initiate a slave HEW.

The slave HEW has the same functionality as the master HEW.

The slave HEW is notified of the following actions done in the master HEW to ensure synchronization of the
slave HEW and the master HEW.

* Resetgo
« Go
» Stop debugging

Note: Themaster HEW can initiate multiple dave HEW applications, but dave HEW applications
cannot be nested (no dave HEW can initiate another slave HEW).
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Internal HEW synchronization

The HEW also supportsinternal multiple target debugging. Thiswill allow you to connect to multiple target
componentsin the same HEW application. These targets can then be debugged simultaneoudly. The system
allows the user to setup a number of sessionswith different targets. Then when debugging the sessions can be
synched so that certain eventsin one session can trigger the same eventsin the others. Thisisvery similar to
that seen in the Externad HEW synchronization section above. Thisfacility though has the added advantage that
it is easy to swap sessions and see what is happening in the same application.

2 To setup internal HEW synchronization:

1
2.
3.

Select the [Options->Debug Sessions...] menu item.

Select the “ Synchronized Debug” tab of the dialog. The dialog displayed in figure 4.91 is displayed.
Select the sessions you wish to synchronize. All currently available sessions in the workspace are
displayed.

Click the synchronize session button. Theiconsfor these sessions should changed to checked rather
than unchecked.

Click the Enable synchronized debugging check box to switch thisfacility on.
Click OK to verify the changes.

Debug Sessions x|

Sessions  Synchronised Debug |

v Enable synchionized debuoging

Sezsiong | Debug Target I
E@ Demotworkzpace
Ell@ DemdWorkspace

; SimSessionSH3-05PCare SH3-DSP[Core) 5.
SimSessionSH3-DSP_L SH3-DSP Sirmulat...
DefaultSession
SimSeszionSH3-D5PCore...  SH3-DSP[Core] 5.
SimSeszsionSH3-D5P SH3-D5P Simulator

Un-zynchronize zeszion |

ok I Cancel |

Figure4.91 Simulator Memory Resour ce Dialog Box

2 Touseinterna HEW synchronization:

1
2.

Follow the options as specified in “ To setup internal HEW synchronization”.

Click on the session combo-box located on the standard toolbar. Select the Synch. Debug selection.
Thisisshown in figure 4.92. Thisoption isonly available when synchronized debugging has been
added to the system.
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3. Once selected the HEW debugger enables the Synchronized debugging facilities. This meansthe
addition of another toolbar thisis named Sync. session. This can also be viewed in Figure 4.92.

4. Theenable disable toolbar button on the Synch. session toolbar allows you to temporarily switch off the
synchronization without losing your settings for this feature.

5. When enabled changing the session in the Sync. session combo box changes the session you are
currently viewing. In the norma HEW debugging state this would mean the session is closed. In Synch.
session you can have multiple sessions open and the currently selected one on thistoolbar is the session
you are viewing.

6. Thissystem alows you to debug multiple targets or CPU cores simultaneously. Changing the session
changes the views you can see on the screen and the data displayed on these views.

E
j |IS_I,Jnc. session j | & | @ ,@

Sync.session E

lﬁ ||DemnWDrkspace - SimSessinnSHS-Dj

Seszion combo when
Synchronized debugging iz switched o

EnabletDizable Synchronized Debuaging Session list

Synchronized Debugging

Figure4.92 Synchronized debug toolbars

Note: Thereareanumber of capabilities that are synchronized when this facility isenabled. The
following tables display the capabilities when synchronized debugging is switched on or off. The example
shows what happensin the two synchronized sessions.

Session

Debugging function Target Debugger Session 1 Target Debugger Session 2
User click “GO” in any “GO” “GO”

Session

User click “STEP “Step” “Step”

Into/out/over” in any Session

User click “ESC” in any “BREAK” “BREAK”

“BREAK” by breakpoints, illegal
access or due to illegal User
Program

Stop running (Same Effect of
pressing ESC)

Stop running (Same Effect of
pressing ESC)

“BREAK” by breakpoints, illegal
access or due to illegal User
Program
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RESET CPU in any Session

RESET CPU

RESET CPU

Figure 4.93 Synchronized debugging on

Debugging function

Target Debugger Session 1

Target Debugger Session 2

User click “GO” in Session 1

“GO”

No activities, “GO” can only be
executed manually by User

User click “GO” in Session 2

No activities, “GO” manually
executed by User

GO

User click “STEP” in session 1

“STEP”

No activities, must “STEP”
manually by User

User click “STEP” in session 2

No activities, must “STEP”
manually by User

“STEP”

User click “ESC” in session 1

“BREAK”

Still executing, if previously
executing User Target Program

User click “ESC” in session 2

Still executing, if previously
executing User Target Program

“BREAK”

“BREAK” by breakpoints, illegal
access or due to illegal User
Program

Still executing, if previously
executing User Target Program

Still executing, if previously
executing User Target Program

“BREAK” by breakpoints, illegal
access or due to illegal User
Program

RESET CPU in session 1

RESET CPU

No activities

RESET CPU in session 2

No activities

RESET CPU

Figure 4.94 Synchronized debugging off

Note: Another differenceto the standard debugging system isthat it is possible to view the download
modulesin the workspace window for all synchronized sessions. Thisallows modules to be downloaded
for any of the available sessons easly.
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Section5 Command Lines

Table 5.1 lists the commands.

Table5.1

No. Command Name

Simulator/Debugger Commands

Abbreviation Function

1 ! - Comment

2 ADD_FILE AF Adds a file to the current project

3 ANALYSIS AN Enables or disables performance analysis

4 ANALYSIS_RANGE AR Sets or displays performance analysis functions

5 ANALYSIS RANGE_ AD Deletes a performance analysis range
DELETE

6 ASSEMBLE AS Assembles instructions into memory

7  ASSERT - Checks if an expression is true or false

8 BREAKPOINT BP Sets a breakpoint at an instruction address

9 BREAK_ACCESS BA Specifies a memory range access as a break condition

10 BREAK_CLEAR BC Deletes breakpoints

11 BREAK_CYCLE BCY Specifies a cycle as a break condition

12 BREAK_DATA BD Specifies a memory data value as a break condition

13 BREAK_DISPLAY BI Displays a list of breakpoints

14 BREAK_ENABLE BE Enables or disables a breakpoint

15 BREAK_REGISTER BR Specifies a register data as a break condition

16 BREAK_SEQUENCE BS Sets sequential breakpoints

17 BUILD BU Performs a build on the current project

18 BUILD_ALL BL Performs a build all on the current project

19 CACHE - Sets caching on or off

20 CHANGE_CONFIGURA CC Sets the current configuration
TION

21 CHANGE_PROJECT CP Sets the current project

22 COVERAGE Ccv Enables or disables coverage measurement

23 COVERAGE_DISPLAY CVD Displays coverage information

24 COVERAGE_LOAD CvL Loads coverage information

25 COVERAGE_RANGE CVR Sets a coverage range

26 COVERAGE_SAVE CVsS Saves coverage information

27 DEFAULT_OBJECT_FODO Sets the default object (program) format
RMAT

28 DISASSEMBLE DA Disassembles memory contents

29 ERASE ER Clears the [Command Line] window

30 EVALUATE EV Evaluates an expression
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Table5.1 Simulator/Debugger Commands (cont)

No. Command Name Abbreviation Function

31 EXEC_MODE EM Sets and displays execution mode.

32 FILE_LOAD FL Loads an object (program) file

33 FILE_SAVE FS Saves memory to a file

34 FILE_UNLOAD FU Unloads an object file from memory

35 FILE_VERIFY FV Verifies file contents against memory

36 GENERATE_MAKE_ GM Generates a build makefile for the current workspace
FILE

37 GO GO Executes user program

38 GO_RESET GR Executes user program from reset vector

39 GO_TILL GT Executes user program until temporary breakpoint

40 HALT HA Halts the user program

41 INITIALIZE IN Initializes the debugging platform

42 LOG LO Controls command output logging

43 MAP_DISPLAY MA Displays memory resource settings

44 MAP_SET MS Allocates a memory area

45 MEMORY_COMPARE MC Compares memory contents

46 MEMORY_DISPLAY MD Displays memory contents

47 MEMORY_EDIT ME Modifies memory contents

48 MEMORY_FILL MF Fills a memory area

49 MEMORY_FIND Ml Finds a string in an area of memory

50 MEMORY_MOVE MV Moves a block of memory

51 MEMORY_TEST MT Tests a block of memory

52 OPEN_WORKSPACE OW Opens a workspace

53 PROFILE PR Enables or disables profile

54 PROFILE_DISPLAY PD Displays profile information

55 PROFILE_SAVE PS Saves the profile information to file

56 QUIT QU Exits HEW

57 RADIX RA Sets default input radix

58 REGISTER_DISPLAY RD Displays register values

59 REGISTER_SET RS Changes register contents

60 REMOVE_FILE RF Removes a file from the current project

61 RESET RE Resets CPU

62 RESPONSE RS Sets a window refresh area

63 SLEEP - Delays command execution

64 STATUS STA Displays the debugging platform status

65 STEP ST Steps program (by instructions or source lines)

66 STEP_MODE SM Sets the step mode

67 STEP_OUT SP Steps out of the current function
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Table5.1 Simulator/Debugger Commands (cont)

No. Command Name Abbreviation Function
68 STEP_OVER SO Steps program, not stepping into functions
69 STEP_RATE SR Sets or displays rate of stepping
70 SUBMIT SuU Executes a command file
71 SYMBOL_ADD SA Defines a symbol
72 SYMBOL_CLEAR SC Deletes a symbol
73 SYMBOL_LOAD SL Loads a symbol information file
74 SYMBOL_SAVE SS Saves a symbol information file
75 SYMBOL_VIEW SV Displays symbols
76 TCL - Enables or disables the TCL
77 TRACE TR Displays trace information
78 TRACE_ACQUISITION TA Enables or disables trace information acquisition
79 TRACE_SAVE TV Outputs trace information into a file
80 TRACE_STATISTIC TST Analyzes statistic information
81 TRAP_ADDRESS TP Sets a system call address
82 TRAP_ADDRESS_ TD Displays system call address settings
DISPLAY
83 TRAP_ADDRESS TE Enables or disables the system call
ENABLE
84 UPDATE_ALL_ uD Updates the current projects build dependencies

DEPENDENCIES

The following describes the syntax of each command.
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51 I(COMMENT)
Abbreviation: None
Description:

Allows a comment to be entered, useful for documenting log files.

Syntax:
| <text>
Parameter Type Description
<text> Text Output text
Example:
| Start of test routine Outputs comment 'Start of test routine' into the [Command Line]

window (and to the log file, if logging is active).

52 ADD_FILE
Abbreviation: AF
Description:

Adds afile to the current project.

Syntax:
af <filename>
Parameter Type Description
<filename> String File name
Example:

add_file $(PROJDIR) \sbrk.c Adds the file sbrk.c to the project from the project directory.
Placeholders are valid syntax.

53 ANALYSIS
Abbreviation: AN
Description:

Enables/disables performance analysis. Counts are not automatically reset before running.
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Syntax:
an [<state>]
Parameter Type Description
None Displays the performance analysis state
<state> Keyword Enables or disables performance analysis
Enable Enables performance analysis
Disable Disables performance analysis
Reset Resets performance analysis counts
Examples:
ANALYSIS Displays performance analysis state.
AN enable Enables performance analysis.
AN disable Disables performance analysis.
AN reset Resets performance analysis counts.

54 ANALYSIS RANGE
Abbreviation: AR
Description:

Sets afunction for which the performance analysisis provided, or displays a function for which the performance
analysisis provided without parameters.

Syntax:
ar [<function name>]
Parameter Type Description
None Displays all functions for which the

performance analysis is provided

<function name> Character string Name of function for which the performance
analysis is provided

Examples:
ANALYSIS RANGE sort Provides the performance analysis for the function sort.
AR Displays the function for which the performance analysis

isprovided.
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55 ANALYSIS RANGE_DELETE

Abbreviation: AD

Description:

Deletes the specified function, or al functionsif no parameters are specified (it does not ask for confirmation).

Syntax:
ad [<index>]

Parameter Type Description

None Deletes all functions

<index> Numeric Index number of function to delete
Examples:

ANALYSIS RANGE_DELETE 6

AD
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56 ASSEMBLE
Abbreviation: AS
Description:

Assembles mnemonics and writes them into memory. In assembly mode, "' exits, "' steps back 2-byte, the Enter
key steps forward a byte.

Syntax:
as <address>

Parameter Type Description

<address> Numeric Address at which to start assembling
Example:

ASH’1000 Starts assembling from H’ 1000.

57 ASSERT
Abbreviation: None
Description:

Checks if an expression istrue or false. It can be used to terminate the batch file when the expression isfalse. If
the expression is false, an error is returned. This command can be used to write test harnesses for subroutines.

Syntax:

assert <expression>

Parameter Type Description
<expression> Expression Expression to be checked
Example:

ASSERT #R0 == 0x100 Returns an error if RO does not contain 0x100.
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5.8 BREAKPOINT

Abbreviation: BP

Description:

Specifies a breakpoint at the address where the instruction is written.
Syntax:

bp <address> [<count>] [<Action>]

Parameter Type Description
<address> Numeric The address of a breakpoint
<count> Numeric The number of times the instruction at the specified
address is to be fetched (1 to 16383, default = 1).
<Action> Keyword Action taken when the conditions are satisfied (optional,
default = Stop)
Stop (P) Halts the execution of the user program
Input (1) Inputs (saves) data to a file
Output (O) Outputs (reads) data from a file
Interrupt (T) Initiates a pseudo-interrupt
Format:

The method of defining each Action are as follows.
Stop

Input <filename> <addr> <size> <count>

Parameter Type Description

<filename> Character The name of the file from which data is input
string

<addr> Numeric Address to which the data is read.

<size> Numeric Size per data packet (1/2/4/8)

<count> Numeric Number of data packets (H'01 to H'FFFFFFFF)
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Output <filename> <addr> <size> <count> [<option>]

Parameter Type Description
<filename> Character The name of the file to which data is saved
string
<addr> Numeric Address from which data is output
<size> Numeric Size per data packet (1/2/4/8)
<count> Numeric Number of data packets (H'01 to H'FFFFFFFF)
<option> Keyword Specifies a new file or appends to an existing file.
(optional, makes a new file when abbreviated.)
A Adds the data to the existing file.

Interrupt <interrupt typel> [<priority>]

Parameter Type

Description

<interrupt type1> Numeric

Type of interrupt
Interrupt vector number (0 to FF)

<priority> Numeric

Interrupt priority (optional, default = 0)
Oto 17

Examples:

BREAKPOINT 0 2 A break occurs when an attempt is made to execute the instruction at
address H'0 for the second time.

BP CO Input in.dat Eight two-byte data fields are written from file “in.dat” to H’ 100 when
10028 an attempt is made to execute the instruction at address H'CO.

59 BREAK_ACCESS

Abbreviation: BA

Description:

Specifies amemory range as a break condition
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Syntax:

ba <start address> [<end address>] [<mode>] [<Action>]

Parameter Type Description
<start address> Numeric The start address of a breakpoint
<end address> Numeric The end address of a breakpoint (optional, default =
<start address>)
<mode> Keyword Access type (optional, default = RW).
R A break occurs when the specified range is read.
W A break occurs when the specified range is written to.
RW A break occurs when the specified range is read or
written to.
<Action> Keyword Action taken when the conditions are satisfied (optional,
default = Stop)
Stop (P) Halts the execution of the user program
Input (1) Inputs (saves) data to a file
Output (O) Outputs (reads) data from a file

Interrupt (T)

Initiates a pseudo-interrupt

Format:

The method of defining each Action are as follows.

Stop

Input <filename> <addr> <size> <count>

Parameter Type Description

<filename> Character The name of the file from which data is input
string

<addr> Numeric Address to which the data is read.

<size> Numeric Size per data packet (1/2/4/8)

<count> Numeric Number of data packets (H'01 to H'FFFFFFFF)

Output <filename> <addr> <size> <count> [<option>]

Parameter Type Description
<filename> Character The name of the file to which data is saved
string
<addr> Numeric Address from which data is output
<size> Numeric Size per data packet (1/2/4/8)
<count> Numeric Number of data packets (H'01 to H'FFFFFFFF)
<option> Keyword Specifies a new file or appends to an existing file.
(optional, makes a new file when abbreviated.)
A Adds the data to the existing file.
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Interrupt <interrupt typel> [<priority>]

Parameter Type Description
<interrupt type1> Numeric Type of interrupt
Interrupt vector number (0 to H'FF)
<priority> Numeric Interrupt priority (optional, default = 0)
Oto 17
Examples:

BREAK_ACCESS0 1000 W A break occurs when the specified range from address H'O to
address H'1000 is written to.

BA FFFF A break occurs when address H'FFFF is accessed.
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510 BREAK_CLEAR
Abbreviation: BC
Description:

Deletes breakpoints.

Syntax:

bc <index>

Parameter Type

Description

<index> Numeric

Index of the breakpoint to be canceled. If the index is
omitted, all breakpoints are deleted.

Examples:
BREAK_CLEARO

BC

511 BREAK_CYCLE
Abbreviation: BCY

Description:

Thefirst breakpoint is deleted.

All breskpoints are del eted.

Specifies the number of cycles as abreak condition.

Syntax:

by <cycle> [<count>] [<Action>]

Parameter Type Description
<cycle> Numeric The condition matching the number of cycles <cycle>xn.
<count> Keyword The condition satisfying the number of times. (optional,
default =ALL)
All Break condition is satisfied every time the condition is
matched.
Numeric 1to H'FFFF
Break condition is satisfied only when it matches the
specified number of times.
<Action> Keyword Action taken when the conditions are satisfied (optional,
default = Stop)
Stop (P) Halts the execution of the user program
Input (1) Inputs(saves) data to a file
Output (O) Outputs(reads) data from a file

Interrupt (T)

Initiates a pseudo-interrupt
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Format:
The method of defining each Action are as follows.
Stop

Input <filename> <addr> <size> <count>

Parameter Type Description

<filename> Character The name of the file from which data is input
string

<addr> Numeric Address to which the data is read.

<size> Numeric Size per data packet (1/2/4/8)

<count> Numeric Number of data packets (H'01 to H'FFFFFFFF)

Output <filename> <addr> <size> <count> [<option>]

Parameter Type Description
<filename> Character The name of the file to which data is saved
string
<addr> Numeric Address from which data is output
<size> Numeric Size per data packet (1/2/4/8)
<count> Numeric Number of data packets (H'01 to H'FFFFFFFF)
<option> Keyword Specifies a new file or appends to an existing file.

(optional, makes a new file when abbreviated.)
A Adds the data to the existing file.

Interrupt <interrupt typel> [<priority>]

Parameter Type Description
<interrupt type1> Numeric Type of interrupt
Interrupt vector number (0 to H'FF)
<priority> Numeric Interrupt priority (optional, default = 0)
Oto 17
Examples:

BREAK_CYCLE 1000 20 Specifies breaks to occur H’' 20 timesin every H’ 1000 cycles.

BCY 5000 Specifies a break to occur in every H'5000 cycles.
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512 BREAK_DATA

Abbreviation: BD

Description:

Specifies amemory data value as a break condition.
Syntax:

bd <address> <data> [<size>] [<option>] [<Action>]

Parameter Type Description
<address> Numeric The address where the break condition is checked.
<data> Numeric Access data
<size> Keyword Size (optional, default = B).
Byte Byte size
Word Word size
Longword Longword size
Single Single-precision floating-point size
Double Double-precision floating-point size
<option> Keyword Match or mismatch of data. The default is EQ.
EQ A break occurs when the data matches the specified
value.
NE A break occurs when the data does not match the
specified value.
<Action> Keyword Action taken when the conditions are satisfied (optional,
default = Stop)
Stop (P) Halts the execution of the user program
Input (1) Inputs(saves) data to a file
Output (O) Outputs(reads) data from a file
Interrupt (T) Initiates a pseudo-interrupt
Format:

The method of defining each Action are as follows.
Stop

Input <filename> <addr> <size> <count>

Parameter Type Description

<filename> Character The name of the file from which data is input
string

<addr> Numeric Address to which the data is read.

<size> Numeric Size per data packet (1/2/4/8)

<count> Numeric Number of data packets (H'01 to H'FFFFFFFF)
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Output <filename> <addr> <size> <count> [<option>]

Parameter Type Description
<filename> Character The name of the file to which data is saved
string
<addr> Numeric Address from which data is output
<size> Numeric Size per data packet (1/2/4/8)
<count> Numeric Number of data packets (H'01 to H'FFFFFFFF)
<option> Keyword Specifies a new file or appends to an existing file.
(optional, makes a new file when abbreviated.)
A Adds the data to the existing file.

Interrupt <interrupt typel> [<priority>]

Parameter Type Description
<interrupt type1> Numeric Type of interrupt
Interrupt vector number (0 to FF)
<priority> Numeric Interrupt priority (optional, default = 0)
Oto 17
Examples:

BREAK_DATA 0100L EQ

BD CO FFB NE

BD 4000 10

5.13
Abbreviation: Bl
Description:

Displays alist of breakpoints.

A break occurs when H'100 is written to memory address H'0
in longword.

A break occurs when a value other than H'FF is written to
memory address H'CO in byte.

A break occurs when H'10 is written to memory address
H'4000 in byte.

BREAK_DISPLAY

Syntax:
bi

Parameter Type Description

None Displays a list of breakpoints
Examples:

BREAK_DISPLAY

Bl

A list of breakpointsis displayed.
A list of breakpointsis displayed.
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Abbreviation: BE

Description:

Enables or disables a breakpoint.

Syntax:

be <flag> [<index>]
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Parameter Type Description
<flag> Keyword Enables or disables a breakpoint
E Enable
D Disable
<index> Numeric Index of the breakpoint to be canceled. If the index is
omitted, all breakpoints are deleted.
Examples:

BREAK_ENABLE D 0

BE E
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515 BREAK_REGISTER
Abbreviation: BR

Description:

Specifies aregister data as a break condition
Syntax:

br <register name> [<data> <size>] [<option>] [<Action>]

Parameter Type Description
<register> Character Register name.
string
<data> Numeric Access data.
<size> Keyword Access size. If no size is specified, the size of the

specified register is assumed. Note that when data is
specified, the size must not be omitted.

byte Byte size
word Word size
longword Longword size
single Single-precision floating-point size
double Double-precision floating-point size
<option> Keyword Match or mismatch of data. The default is EQ.
EQ A break occurs when the data matches the specified
value.
NE A break occurs when the data does not match the
specified value.
<Action> Keyword Action taken when the conditions are satisfied (optional,
default = Stop)
Stop (P) Halts the execution of the user program
Input (1) Inputs(saves) data to a file
Output (O) Outputs(reads) data from a file
Interrupt (T) Initiates a pseudo-interrupt

Format:
The method of defining each Action are as follows.
Stop

Input <filename> <addr> <size> <count>

Parameter Type Description

<filename> Character The name of the file from which data is input
string

<addr> Numeric Address to which the data is read.

<size> Numeric Size per data packet (1/2/4/8)

<count> Numeric Number of data packets (H'01 to H'FFFFFFFF)
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Output <filename> <addr> <size> <count> [<option>]

Parameter Type Description
<filename> Character The name of the file to which data is saved
string
<addr> Numeric Address from which data is output
<size> Numeric Size per data packet (1/2/4/8)
<count> Numeric Number of data packets (H'01 to H'FFFFFFFF)
<option> Keyword Specifies a new file or appends to an existing file.
(optional, makes a new file when abbreviated.)
A Adds the data to the existing file.

Interrupt <interrupt typel> [<priority>]

Parameter Type

Description

<interrupt type1> Numeric

Type of interrupt
Interrupt vector number (0 to H'FF)

<priority> Numeric

Interrupt priority (optional, default = 0)
Oto 17

Examples:

BREAK_REGISTER RO FFFFW EQ A bresk occurs when the lower two bytes of the RO

BRR10
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516 BREAK_SEQUENCE
Abbreviation: BS

Description:

Sets sequentia breakpoints

Syntax:

bs <address1> [<address2> [<address 3> [...] ] ] [<Action>]

Parameter Type Description
<address1> - Numeric Addresses of sequential breakpoints. Up to eight
<address8> addresses can be specified.
<Action> Keyword Action taken when the conditions are satisfied (optional,
default = Stop)
Stop (P) Halts the execution of the user program
Input (1) Inputs(saves) data to a file
Output (O) Outputs(reads) data from a file
Interrupt (T) Initiates a pseudo-interrupt
Format:

The method of defining each Action are as follows.
Stop

Input <filename> <addr> <size> <count>

Parameter Type Description

<filename> Character The name of the file from which data is input
string

<addr> Numeric Address to which the data is read.

<size> Numeric Size per data packet (1/2/4/8)

<count> Numeric Number of data packets (H'01 to H'FFFFFFFF)
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Output <filename> <addr> <size> <count> [<option>]

Parameter Type Description
<filename> Character The name of the file to which data is saved
string
<addr> Numeric Address from which data is output
<size> Numeric Size per data packet (1/2/4/8)
<count> Numeric Number of data packets (H'01 to H'FFFFFFFF)
<option> Keyword Specifies a new file or appends to an existing file.

(optional, makes a new file when abbreviated.)

A Adds the data to the existing file.

Interrupt <interrupt typel> [<priority>]

Parameter Type Description

<interrupt type1> Numeric Type of interrupt
Interrupt vector number (0 to H'FF)

<priority> Numeric Interrupt priority (optional, default = 0)
Oto 17

Examples:

BREAK_SEQUENCE 1000 2000 A break occurs when addresses H'1000 and H'2000 are
passed in this order.

BS 1000 A break occurs when address H'1000 is executed.
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517 BUILD
Abbreviation: BU
Description:

Starts a build operation on the current project.

Syntax:
bu

Parameter Type Description

None Starts a build operation on the current project
Examples:

build Starts a standard build process on the current project.

5.18 BUILD_ALL
Abbreviation: BL
Description:

Starts a build all operation on the current project.

Syntax:
bl
Parameter Type Description
None Starts a build all operation on the current project
Examples:
Build_all Starts a standard build al process on the current project.
519 CACHE

Abbreviation: None
Description:

Sets caching on or off, or displays the current caching state.
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Syntax:
CACHE [<state>]
Parameter Type Description
None Displays the current caching state
<state> Keyword Sets caching on or off
On Sets caching on
Off Sets caching off
Example:
CACHE Displays the current caching state.
CACHE on Turns on caching.

5.20 CHANGE_CONFIGURATION
Abbreviation: CC
Description:

Sets the current configuration.

Syntax:
cc <config name>
Parameter Type Description
<config name> Character Configuration name
string
Example:
CC Debug Sets the current configuration to Debug.

521 CHANGE_PROJECT

Abbreviation: CP

Description:
Sets the current project.
Syntax:
Cp <project name>
Parameter Type Description
<project name> Character Project name
string

328



High-performance Embedded Workshop User’s Manual
Example:

CP PROJ2 Sets the current project to PROJ2.

5.22 COVERAGE
Abbreviation: CV
Description:

Enables or disables the coverage range measurement or resets coverage information.

Syntax:
cv [<state>]
Parameter Type Description
none Displays coverage state.
<state> enable Enables coverage measurement.
disable Disables coverage measurement.
reset Resets result of coverage measurement.
Examples:
COVERAGE Displays coverage state.
CV enable Enables coverage measurement.
CVr Resets result of coverage measurement.

523 COVERAGE_DISPLAY
Abbreviation: CVD
Description:

Displays coverage information.

Syntax:
cvd

Parameter Type Description

none Displays coverage information.
Example:

COVERAGE_DISPLAY Displays coverage information.
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524 COVERAGE_LOAD
Abbreviation: CVL
Description:

L oads the coverage information from a.COV file.
If awrong file format is specified or the specified file is not found, a warning message will be displayed.

Note:  If the coverage range is specified by a source file, the saved .COV file cannot be loaded.
Syntax:

cvl <filename>

Parameter Type Description
filename Character File name
string
Examples:

COVERAGE_LOAD TEST Loadsthe coverage information from the TEST.COV file.

CLV COVERAGE.COV L oads the coverage information from the COVERAGE.COV
file.

525 COVERAGE_RANGE

Abbreviation: CVR

Description:

Sets the coverage range or displays the range of coverage measurement without parameters.
Syntax:

cvr [<start> <end>]

Parameter Type Description

none Displays the coverage measurement range.

<start> Numeric Start address of the coverage measurement
range.

<end> Numeric End address of the coverage measurement
range.

Examples:

COVERAGE_RANGE Measures the coverage of addresses between H’ 1000 and

H’1000 H’ 10FF H’10FF.

CVR Displays the range of coverage measurement.
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526 COVERAGE_SAVE
Abbreviation: CVS
Description:

Savesthe coverage information in a.COV or .TXT file.
If awrong file extension is specified, an error message will be output.

Syntax:

cvs <filename>

Parameter Type Description
filename Character File name
string
Examples:

COVERAGE_SAVE TEST  Savesthe coverage information in the TEST.COV file.

CVS COVERAGE.COV Saves the coverage information in the COVERAGE.COV file.

527 DEFAULT_OBJECT_FORMAT
Abbreviation: DO
Description:

Specifies the default format for loading object (program) files. The format specified with this command is only
valid when the format specification is omitted from the FILE_L OAD command.

Syntax:

do [<format>]

Parameter Type Description
none Displays the default format settings.
<format> Keyword Object format
Binary Binary type
Elf/Dwarf2 Elf/Dwarf2 type
IntelHex Intel Hex type
S-Record S type
Example:

DEFAULT_OBJECT_FORMAT  Displays the default format settings.

DO binary Specifies the binary format as the default format.
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528 DISASSEMBLE
Abbreviation: DA
Description:

Disassembles memory contents to assembly-language code. The display of disassembled memory isfully
symbolic.

Syntax:

da <address> [<length>]

Parameter Type Description

<address> Numeric Start address

<length> Numeric Number of instructions (optional, default = 16)
Examples:

DISASSEMBLEH'1005 Disassembles 5 lines of code starting at H’ 100.

DA H'3EO00 20 Disassembles 20 lines of code starting at H' 3EQ0.

529 ERASE
Abbreviation: ER
Description:

Clears the [Command Line] window

Syntax:
er

Parameter Type Description

none Clears the [Command Line] window
Example:

ER Clears the [Command Line] window.
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530 EVALUATE
Abbreviation: EV
Description:

Provides a calculator function, evauating simple and complex expressions, with parentheses, mixed radices, and
symbols. All operators have the same priority but parentheses may be used to change the order of evaluation.
The operators have the same meaning asin C/C++. Expressions can also be used in any command where a
number isrequired. Register names may be used, but must always be prefixed by the ‘# character. Theresult is
displayed in hexadecimal, decimal, octal, or binary.

Syntax:

ev <expression>

Parameter Type Description
<expression> Expression Expression to be evaluated
Valid operators:
&& logical AND 1] logical OR << left arithmetic >>  right arithmetic
shift shift
+  addition - subtraction * multiplication / division
%  modulo | bitwise OR &  bitwise AND ~  bitwise NOT
n bitwise exclusive OR |! logical NOT == equal to 1= unequal to
>  greater than < lessthan >= greater than or <= less than or
equal to equal to

Examples:

Result: H'16E D’ 366 O’ 556
B’00000000000000000000000101101110

EV H'123 + (D'73 | B'10)

EV #R1* #R2 Result: H'121 D289 O'441

B’ 00000000000000000000000100100001
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531 EXEC_MODE
Abbreviation: EM
Description:

Specifies the operation of the smulator/debugger when a simulation error occurs.

Syntax:
em [<mode>]
Parameter Type Description
None Displays the current execution mode.
<mode> Keyword Execution mode (operation of the simulator/debugger
when a simulation error occurs)
S Stops operation
C Continues operation
Examples:
EXEC_MODE Displays the current execution mode.
EM c Specifies to continue operation when a simulation

€rror occurs.
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532 FILE_LOAD

Abbreviation: FL

Description:

L oads an object code file to memory with the specified offset. Existing symbols are cleared, and the new ones

are defined. If an offset is specified this will be added to the symbols. Thefile extension defaultis . MOT.

Syntax:

fl [<format>] <filename> [<offset>] [<state>]

Parameter Type Description
<format> Keyword Object format (optional, default =
DEFAULT_OBJECT_FORMAT settings)
Binary Binary type
Elf/Dwarf2 Elf/Dwarf2 type
IntelHex Intel-Hex type
S-Record S type
<filename> Character string File name
<offset> Numeric Offset to be added to load address (optional, default = 0)
<state> Keyword Verify flag (optional, default = V)
\% Verify
N No verify
Examples:

FILE_LOAD A:\\BINARYWTESTFILE.A22  LoadsMotorola S-Record file "testfile.a22".

FL ANOTHER.MOT H’200

L oads Motorola S-Record file "another.mot"
with an offset of H' 200 bytes.
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533 FILE_SAVE
Abbreviation: FS
Description:

Saves the specified memory areadatato afile. The user iswarned if about to overwrite an existing file. Thefile
extension default is .M OT. Symbols are not automatically saved.

Syntax:

fs[<format>] <filename> <start> <end>

Parameter Type Description
<format> Keyword Object format (optional, default =
DEFAULT_OBJECT_FORMAT settings)
Binary Binary type
IntelHex Intel-Hex type
S-Record S type
<filename> Character string File name
<start> Numeric Start address
<end> Numeric End address
Examples:
FILE_SAVE TESTFILE 0 H’'2013 Saves address range 0-H' 2013 as Motorola S-
Record file"TESTFILE.MOT".
FS D:WSER\ANOTHER.A22 H’ 4000 Saves address range H’ 4000-H’ 4FFF as
H' 4FFF Motorola S-Record format file
"ANOTHER.A22".

534 FILE_UNLOAD
Abbreviation: FU
Description:

Unloads a file from memory at a specified offset. If no offset is supplied then memory will be scanned and the
first occurrence of the file will be unloaded.
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Syntax:

fu [<format>] <filename> [<offset>]

Parameter Type Description
<format> Keyword Object format (optional, default =
DEFAULT_OBJECT_FORMAT settings)
Binary Binary type
Elf/Dwarf2 Elf/Dwarf2 type
IntelHex Intel-Hex type
S-Record S type
<filename> Character string File name
<offset> Numeric Offset at which the file will be removed
(optional)
Examples:

FILE_UNLOAD TEST.A22

FU ANOTHER 200

Unloads the first occurrence of file ‘test.a22'
from memory.

Unloads file ‘another’ from memory location
H’ 200.
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535 FILE_VERIFY
Abbreviation: FV
Description:

Verifiesfile contents against memory contents. The file data must be in a Motorola S-Record format. The file
extension default is . MOT.

Syntax:

fv <filename> [<offset>]

Parameter Type Description
<filename> Character File name
string
<offset> Numeric Offset to be added to file address (optional, default = 0)
Examples:

FILE_VERIFY A:\BINARYWTEST.A22 VerifiesMotorola S-Record file "TEST.A22" against
memory.

FV ANOTHER 200 Verifies Motorola S-Record file "ANOTHER.MOT"
against memory with an offset of H'200 bytes.

536 GENERATE_MAKE_FILE
Abbreviation: GM

Description:

Generates amakefile for build usage outside of HEW.
Syntax:

gm [<mode>] [<scan>]

Parameter Type Description
<mode> String
ccep Generate make file from the current configuration in the current
project (default).
accp Generate make file from all the configurations in the current
project
acap Generate make file from all the configurations all projects
<scan> String
Scan Scan dependencies (default)
noscan noscan: Don't scan dependencies
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Example:

GENERATE_MAKE_FI
LE cccp scan

5.37 GO
Abbreviation: GO

Description:

Executes object code (the user program). While the user system is halted, a PC valueis displayed.

Syntax:

go [<state>] [<address>]
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Generates a makefile for the current configuration and current
project. Before the makefile is generated the dependencies are
scanned.

Parameter Type Description
<state> Keyword Specifies whether or not to continue command processing during
user program execution (optional, default = wait)
wait Causes command processing to wait until user program stops
continue Continues command processing during execution
<address> Numeric Start address for PC (optional, default = PC value)

Wait is the default and this causes command processing to wait until user program stops executing.

Continue allows you to continue to enter commands (but they may not work depending on the debugging

platform).
Examples:

GO

GO CONTINUE H’1000

Executes the user program from the current PC value. Command
processing cannot be continued.

Executes the user program from H’ 1000. Command processing can
be continued.
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538 GO_RESET

Abbreviation: GR

Description:

Executes the user program starting at the address specified in the reset vector.

While the user program is executing, the [Performance Analysis] window is updated.

Syntax:
or [<state>]
Parameter Type Description
<state> Keyword Specifies whether or not to continue command processing
during user program execution (optional, default = wait)
wait Causes command processing to wait until user program stops
continue Continues command processing during execution

Wait isthe default and this causes command processing to wait until user program stops executing.

Continue allows you to continue to enter commands (but they may not work depending on the debugging
platform)

Example:

GR Executes the user program starting at the address specified in the
reset vector (does not continue command processing).

539 GO_TILL
Abbreviation: GT
Description:

Executes the user program from the current PC with temporary breakpoints. This command takes multiple
addresses as parameters, and these are used to set temporary PC breakpoints (these breakpoints only exist for the
duration of the command).

Syntax:
ot [<state>] <address>...
Parameter Type Description
<state> Keyword Specifies whether or not to continue command processing
during user program execution (optional, default = wait)
wait Causes command processing to wait until user program
stops
continue Continues command processing during execution
<address>... Numeric Temporary breakpoint address (list)

Wait isthe default and this causes command processing to wait until user program stops executing
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Continue alows you to continue to enter commands (but they may not work depending on the debugging

platform)
Example:

GO_TILL H1000

5.40 HALT
Abbreviation: HA

Description:

Continues execution until the PC reaches address H' 1000.

Halts the user program. This command can be used after the GO command if the GO command uses continue for

option.
Syntax:
ha

Parameter

Type Description

none

Halts the user program

Example:

HA

Halts the user program.
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541 INITIALIZE
Abbreviation: IN
Description:

Initializes al breakpoints and memory mapping. It aso initializes debugging platform, as if you had reselected
thetarget DLL.

Syntax:
in
Parameter Type Description
none Initializes debugging platform.
Example:
IN Initializes debugging platform.
542 LOG

Abbreviation: LO
Description:

Controlslogging of command output to file. If no parameters are specified, logging statusis displayed. If an
existing fileis specified, you will be warned; if you answer ‘No', datawill be overwritten to the exigting file,
otherwise the file will be added. Logging is only supported for the command line interface.

Syntax:

lo [<state>|<filename>]

Parameter Type Description
none Displays logging status
<state> Keyword Starts or suspends logging
+ Starts logging
Suspends logging
<filename> Numeric Specifies the logging output file
Examples:
LOG TEST Storesthelogging in file TEST.
LO- Suspends logging.
LOG + Resumes logging.
LOG Displayslogging status

342



High-performance Embedded Workshop User’s Manual
543 MAP_DISPLAY
Abbreviation: MA
Description:

Displays memory resource settings.

Syntax:
ma

Parameter Type Description

none Displays the current memory resource settings
Example:

MA Displays the current memory resoruce settings.

544 MAP_SET
Abbreviation: MS
Description:

Allocates amemory area.
Syntax:

ms <start address> [<end address>] [<mode>]

Parameter Type Description
<start address> Numeric Specified start address
<end address> Numeric Specified end address (optional, default = start
address)
<mode> Keyword Access type (optional, default = RW)
R Read only
w Write only
RW Displays the current memory mapping
Examples:

MAP_SET 0000 3FFF RW A read/write-enabled areais allocated to addresses H'0000 to
H'3FFF.

MS 5000 A read/write-enabled areais allocated to address H'5000.
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545 MEMORY_COMPARE
Abbreviation: MC
Description:

Compares the memory area (between the start address and the end address) with the memory starting at
destination address.

Syntax:

mc <start> <end> <dest> [<access size>]

Parameter Type Description
<start> Numeric Start address
<end> Numeric End address
<dest> Numeric Destination address
<access Keyword Access size (optional, default = byte)
size> byte Displays in byte units
word Displays in word units (2 bytes)
long Displays in longword units (4 bytes)
ascii Displays in ASCII codes
single Displays in single-precision floating-point format
double Displays in double-precision floating-point format
Examples:
MEMORY_COMPARE H’1000 H'1FFF Compares the memory between H’ 1000 and
H’2000 LONG H’ 1FFF with the memory starting at H’ 2000

(using an access size of longword).
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546 MEMORY_DISPLAY
Abbreviation: MD

Description:

Displays memory contents.

Syntax:

md <address> [<length>] [<mode>]

Parameter Type Description
<address> Numeric Start address
<length> Numeric Length (optional, default = H'100 bytes)
<mode> Keyword Display format (optional, default = byte)
byte Displays in byte units
word Displays in word units (2 bytes)
long Displays in longword units (4 bytes)
ascii Displays in ASCII codes
single Displays in single-precision floating-point format
double Displays in double-precision floating-point format
Examples:

MEMORY_DISPLAY H’'C000 H'100 WORD  Displays H’' 100 bytes of memory starting at
H’C000 in word units

MEMORY_DISPLAY H’1000 H’FF Displays H' FF bytes of memory starting at
H’1000 in byte units

547 MEMORY_EDIT
Abbreviation: ME
Description:

Allows memory contents to be modified. When editing memory the current location may be modified in a
similar way to that described in the ASSEMBLE command description.

When editing, '." exits edit mode, "' goes back one data unit, and blank line goes forward without modification.
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Syntax:
me <address> [<mode>] [<state>]
Parameter Type Description
<address> Numeric Address to edit
<mode> Keyword Format (optional, default = byte)
byte Edits in byte units
word Edits in word units
long Edits in longword units
ascii Edits in ASCII codes
single Edits in the single-precision floating-point
format
double Edits in the double-precision floating-point
format
<state> Keyword Verify flag (optional, default = V)
\% Verify
N No verify
Example:

ME H'1000 WORD Modifies memory contents in word units starting from H’ 1000 (with
verification)

5.48 MEMORY _FILL
Abbreviation: MF
Description:

Modifies the contentsin the specified memory areato the specified data value.

346



High-performance Embedded Workshop User’s Manual

Syntax:
mf <start> <end> <data> [<mode>] [<state>]
Parameter Type Description
<start> Numeric Start address
<end> Numeric End address
<data> Numeric Data value
<mode> Keyword Data size (optional, default = byte)
byte Byte
word Word
long Longword
single Single-precision floating-point
double Double-precision floating-point
<state> Keyword Verify flag (optional, default = V)
\% Verify
N No verify
Examples:

MEMORY_FILL H’'CO000
H’ COFF H'55AA WORD

MF H'5000 H' 7FFF H'21

M odifies memory contents in the range from H’C000 to
H’ COFF to word data H'55AA.

M odifies memory contents in the range from H’5000 to

H’ 7FFF to data H’ 21.

5.49 MEMORY_FIND
Abbreviation: M1
Description:

Finds a string in amemory range.

Syntax:
mi <gtart> <end> <string>
Parameter Type Description
<start> Numeric Start address
<end> Numeric End address (including this address)
<string> Numeric Data to search for
Example:

MEMORY _FIND H’1000 H’'2000 H'12

Finds the first occurrence of the data H’ 12 between

addresses H'1000 and H’ 2000.
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550 MEMORY_MOVE
Abbreviation: MV

Description:

Moves datain the specified memory area.
Syntax:

mv <start> <end> <dest> [<state>]

Parameter Type Description
<start> Numeric Start address
<end> Numeric End address (including this address)
<dest> Numeric Destination start address
<state> Keyword Verify flag (optional, default = V)
\% Verify
N No verify
Examples:

MEMORY_MOVE H'’1000 H’'1FFF H' 2000

MV H’'FB80 H' FF7F H’ 3000

551 MEMORY_TEST
Abbreviation: MT

Description:

Performs read, write, and verification testing in the specified address range. The original contents of memory
have been replaced by the newly written data. The test will access the memory according to the map settings.

Moves memory contentsin the area from
H’1000 to H’ 1FFF into H'2000.

Moves memory contentsin the area from
H’'FB80 to H' FF7F into H’ 3000.

This simulator/debugger does not support the MEMORY _TEST command.

Syntax:

mt <start> <end>

Parameter Type Description

<start> Numeric Start address

<end> Numeric End address (including this address)
Examples:

MEMORY_TEST H'8000 H'BFFF

MT H’4000 H' 5000
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552 OPEN_WORKSPACE
Abbreviation: OW
Description:
Opens aworkspace.
Syntax:

ow <filename>

Parameter Type Description
filename Character Workspace file name
string
Example:
OW WKSP.HWS Opens the WKSP.HWSfile.

553 PROFILE
Abbreviation: PR
Description:

Enables, disables or sets the profiler display and resets the profiler information.

Syntax:
pr [<state>]
Parameter Type Description
None Displays the profiler information.
<state> Keyword Enables, disables or sets the profiler display
and resets the profiler information.
enable Enables the profiler.
tree-off Enables the profiler but does not trace function
calls during profile information acquisition.
disable Disables the profiler.
reset Resets the profiler information.
Examples:
PROFILE ENABLE Enables the profiler.

prr Resets the profiler information.
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554 PROFILE_DISPLAY
Abbreviation: PD

Description:

Displays the profiler information.

Syntax:

pd [<mode>] [<statel>] [<state2>] [<count>]

Parameter Type Description
<mode> Keyword Specifies the method of displaying the profiler
information. (optional, default=list)
tree Displays in tree format
list Displays in list format
<statel> Keyword Specifies whether or not to include child function
information in the parent function cycle
information. (optional, default=n)
Specifies child function information to be
included in the display.
n Specifies child function not to be included in the
display.
<state2> Keyword Specifies whether or not to control displaying
functions that are not executed (optional,
default=a).
e Displays only executed functions.
a Displays all functions.
<count> Numeric Specifies the nesting level for calling functions
to be displayed. This can be specified only
when the <mode> parameter is ‘tree’ (optional,
default = 16).
Examples:

PROFILE_DISPLAY TREE|  Specifies the profiler information to be displayed in tree
format and to include child functions.

pd Specifies the profiler information to be displayed in list
format, without child function information.
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555 PROFILE_SAVE

Abbreviation: PS

Description:

Savesthe profiler information to afile. The default file extension is.PRO.
Syntax:

ps [<filename>]

Parameter Type Description
None Saves the profiler information on all download
modules to files.
<filename> Character Specifies the name of the file to which profiler
string information is saved.
Example:

PROFILE_SAVE PR_INFO  Savesprofiler information to afile named PR_INFO.PRO.

556 QUIT

Abbreviation: QU

Description:

ExitsHEW. Closesalog fileif it is open.
Syntax:

qu

Parameter Type Description

None Exits HEW

Example:

Qu Exits HEW.

5.57 RADIX
Abbreviation: RA

Description:

Sets default input radix. If no parameters are specified, the current radix is displayed. Radix can be changed by

using B’, H’, D', or O’ before numeric data.
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Syntax:
ra[<mode>]
Parameter Type Description
none Displays current radix
<mode> Keyword Sets radix to specified type
Sets radix to hexadecimal
D Sets radix to decimal
(0] Sets radix to octal
B Sets radix to binary
Examples:
RADIX Displays the current radix.
RAH Sets the radix to hexadecimal.

558 REGISTER_DISPLAY
Abbreviation: RD
Description:

Displays register contents.

Syntax:
rd [<register>]
Parameter Type Description
none Displays all register contents
<register> Keyword Register name
Example:
RD Displays dl register contents
RD RO Displays the contents of RO
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559 REGISTER_SET
Abbreviation: RS

Description:

Changes the contents of aregister.
Syntax:

rs <register> <value> [<mode>]

Parameter Type Description
<register> Keyword Register name
<value> Numeric Register value
<mode> Keyword Data size (optional, default = corresponding
register size)
byte Byte
word Word
long Longword
single Single-precision floating-point
double Double-precision floating-point
Examples:
RS PC_StartUp Sets the program counter to the address defined by the symbol
_StartUp

RSROH'1234 WORD  Setsword data H’' 1234 to RO.
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560 REMOVE_FILE
Abbreviation: RF
Description:

Removes a from the current project.

Syntax:
rf <filename>
Parameter Type Description
<filename> String File name
Example:

remove file $(PROJIDIR)\sbrk.c Removes the file sbrk.c from the project.
Placeholders are valid syntax.
5.61 RESET
Abbreviation: RE
Description:

Resets the microprocessor. All register values are set to the initial values of the device. Memory mapping and
breakpoints are not initialized.

Syntax:
re

Parameter Type Description

none Resets the microprocessor
Example:

RE Resets the microprocessor.

562 RESPONSE
Abbreviation: RP
Description:

Specifies the frequency of the window update.
When along refresh interval is specified, the simulation becomes faster but the response, such as for the break
button, becomes sower. Set a frequency appropriate for the machine used.
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Syntax:
rp [<instruction number>]
Parameter Type Description
<instruction number> Numeric Specifies the frequency, in number of instruction
executions, the window is to update. 1 to 65535
(optional, default=40000)
Example:
RESPONSE 9 Sets the window to refresh every 9 information executions.
5,63 SLEEP

Abbreviation: None

Description:

Delays command execution for a specified period.

Syntax:
slegp <milliseconds>

Parameter Type

Description

<milliseconds> Numeric

Delayed time (ms)

The value must always be specified in decimal.

Example:

SLEEP D'9000 Delays 9 seconds.

5.64 STATUS
Abbreviation: STA

Description:

Displays the current status of the debugging platform. The contents of the [Platform] sheet in the [Status]

window is displayed.

Syntax:
sta
Parameter Type Description
None Displays the current status of the debugging platform.

355



High-performance Embedded Workshop User’s Manual
Example:

STA Displays the current status of the debugging platform.

5.65 STEP
Abbreviation: ST
Description:

Single step (in source line or instruction units) execution. Performs a specified number of instructions, from
current PC. Default is stepping by lines if source debugging is available. Count default is 1.

Syntax:
st [<mode>] [<count>]
Parameter Type Description
<mode> Keyword Type of single step (optional)
instruction Steps by assembly instruction
line Steps by source code line
<count> Numeric Number of steps (optional, default = 1)
Example:
STEP9 Steps code for 9 steps.

566 STEP_MODE

Abbreviation: SM

Description:
Selects the step mode.
Syntax:
sm <mode>
Parameter Type Description
<mode> Keyword Step mode
Auto Selects the mode automatically.
Assembly Steps by assembly-language instruction
Source Steps by source code line
Example:

STEP_MODE auto  Selects the step mode automatically.
When the [Editor] window is active, execution steps by source code line.
When the [Disassembly] window is active, execution steps by assembly-
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language instruction.

5.67 STEP_OUT
Abbreviation: SP
Description:

Steps the program out of the current function. (i.e., astep up). This works for both assembly-language and source
level debugging.

Syntax:
P

Parameter Type Description

none Steps the program out of the current function
Example:

SP Steps the program out of the current function.

5.68 STEP _OVER

Abbreviation: SO

Description:

Performs a specified number of instructions from current PC.

This command differsfrom STEPin that it does not perform single step operation in subroutines or interrupt
routines. These are executed at full speed.

Syntax:

S0 [<mode>] [<count>]

Parameter Type Description
<mode> Keyword Type of stepping (optional)
instruction Steps by assembly instruction
line Step by source code line
<count> Numeric Number of steps (optional, default = 1)
Example:
SO Steps over 1-step code.
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5.69 STEP_RATE
Abbreviation: SR
Description:

Controls the speed of stepping in the STEP and STEP_OVER commands. A rate of 6 causes the fastest stepping.
A vaue of 0 isthe slowest.

Syntax:
S [<rate>]
Parameter Type Description
none Displays the step rate
<rate> Numeric Step rate 0 to 6 (6 = fastest)
Examples:
SR Displays the current step rate.
SR 6 Specifies the fastest step rate.
570 SUBMIT

Abbreviation: SU
Description:

Executes afile of emulator commands. This command can be used even in a command file to be processed. Any
error abortsthefile.

Syntax:
su <filename>
Parameter Type Description
<filename> Character File name
string
Examples:
SUBMIT COMMAND.HDC Processes the file COMMAND.HDC.
SU A:SETURP.TXT Processesthe file SETUP.TXT on drive A:.

571 SYMBOL_ADD
Abbreviation: SA
Description:

Adds a symbol, or changes an existing one.
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Syntax:

sa <symbol> <value>
Parameter Type Description
<symbol> Character string Symbol name
<value> Numeric Value

Examples:

SYMBOL_ADD gtart H'1000  Defines the symbol start at H' 1000.

SA END_OF TABLE 1FFF  Uses current default radix and defines END_OF_TABLE at
H'1FFF .

572 SYMBOL_CLEAR
Abbreviation: SC
Description:

Deletes a symbol. If no parameters are specified, deletes all symbols (after confirmation).

Syntax:
sc [<symbol>]
Parameter Type Description
none Deletes all symbols
<symbol> Character Symbol name
string
Examples:
SYMBOL_CLEAR Deletes all symbals (after confirmation).
SC start Deletes the symbol ‘start’.

573 SYMBOL_LOAD
Abbreviation: SL
Description:

Loads symbols from file. File must bein XLINK Pentica-b format (i.e. 'XXXXH name'). The symbols are added
to the existing symbol table.
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Syntax:
sl <filename>
Parameter Type Description
<filename> Character File name
string
Examples:
SYMBOL_LOAD TEST.SYM Loadsthe file TEST.SYM.
SL MY_CODE.SYM LoadsthefileMY_CODE.SYM.

574 SYMBOL_SAVE
Abbreviation: SS
Description:

Saves symbolsto afilein XLINK Pentica-b format. The symbol file extension default is.SYM.

Syntax:
ss <filename>
Parameter Type Description
<filename> Character File name
string
Examples:
SYMBOL_SAVE TEST Saves symbol tableto TEST.SYM.
SSMY_CODE.SYM Saves the symbol tableto MY_CODE.SYM.
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575 SYMBOL_VIEW

Abbreviation: SV

Description:

Displays dl defined symbols, or those containing the case sensitive string pattern.
Syntax:

sv [<pattern>]

Parameter Type Description
none Displays all symbols
<pattern> Character Character string that should be contained in the symbols to
string be displayed
Examples:
SYMBOL_VIEW BUFFER Displays all symbols containing the word BUFFER.
SV Displays dl the symbols.
576 TCL

Abbreviation: None

Description:
Enables or disablesthe TCL.
Syntax:
tel [<state>]
Parameter Type Description
None Displays the TCL information.
<state> Keyword Enables or disables the TCL
enable Enables the TCL
disable Disables the TCL
Examples:
TCL Displaysthe TCL information.
TCL enable Enablesthe TCL.
TCLd Disablesthe TCL.
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577 TRACE
Abbreviation: TR
Description:

Displays the trace buffer contents. The record in the buffer that was executed first is O; older records have
positive offset values.

Syntax:

tr [[<start rec> [<count>]] | [<clear>]]

Parameter Type Description
<start rec> Numeric Record to start display (optional, default = most recent
record - 9)
<count> Numeric Number of records to be displayed (optional, default = 10)
<clear> Keyword Clears all trace records (optional)
clear Clears all trace records

Note: When a negative value is specified for <start rec> (-0 cannot be specified), the value is recognized
as a PTR value.

Examples:

TRO020 Displays twenty lines of trace buffer contents starting from the top of the
buffer.

TR Displays ten lines of trace buffer contents starting from the end of the buffer
(the ten most recently executed lines).

TR-2010 Displays trace buffer contents for which the PTR value is between —20
and -11.

TRC Clears all trace records.
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578 TRACE_ACQUISITION

Abbreviation: TA

Description:

Enables or disables trace information acquisition

Syntax:

ta<mode> [<trace full handling>] [<trace capacity>]

Parameter Type Description
<mode> Keyword Enables or disables trace information acquisition.
E Trace information acquisition is enabled.
D Trace information acquisition is disabled.
<trace full Keyword Specifies the operation when the trace buffer becomes full.
handling> C Continues operation. (default)
B Stops operation.
<trace capacity> Keyword Specifies the capacity of the trace buffer.
BUF=1 D'1024 records (default)
BUF=4 D'4096 records
BUF=16 D'16384 records
BUF=32 D'32768 records

Note: The capacity of the trace buffer can be modified only while the trace buffer is empty.

Examples:

TRACE_ACQUISITION E
B BUF=32

TAD

Trace information acquisition is enabled.
Operation stops when the trace buffer becomes full.
The capacity of the trace buffer is set to 32768.

Trace information acquisition is disabled.
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579 TRACE_SAVE

Abbreviation: TV

Description:

Saves the trace information in files. The files are in text format, so the default file extensionis . TXT.
Syntax:

tv<filename> [<mode>]

Parameter Type Description
<filename> Character File name
string
<mode> Keyword File writing mode
A Appends information to the file.
o} Overwrites the file. (default)
Examples:

TRACE_SAVE TEST Savesthe trace information in TEST.TXT.

TV TRACE.TXT Savesthe trace information in TRACE.TXT

5.80 TRACE_STATISTIC
Abbreviation: TST
Description:

Analyzes the statistic information under the specified conditions.

Syntax:
tst <item> <string>
Parameter Type Description
<item> Character Statistic information item to be analyzed
string
<string> Character Character string that specifies conditions
string
Example:
TST CODE1 E630 Analyzes the statistic information under condition CODEL = E630.
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581 TRAP_ADDRESS
Abbreviation: TP
Description:

Specifies the system call address for standard /O and file /0 functions from the user program. For details, refer
to section 4.22, Standard 1/0 and File 1/0O Processing.

Syntax:
tp <address>

Parameter Type Description

<address> Numeric System call address
Example:

TP 1000 Sets the system call address to 1000.

5.82 TRAP_ADDRESS DISPLAY
Abbreviation: TD
Description:

Displays the current system call address for standard 1/0 and file 1/O functions from the user program. For
details, refer to section 4.22, Standard /O and File |/O Processing.

The system call addressis displayed in the following format:
HXXXXXXXX Y

H'xxxxxxx: System call address (8-digit hexadecimal value)
Y: E: System call enabled
D: System call disabled

Syntax:
td
Parameter Type Description
None Displays the current system call address and whether the
system call is enabled or disabled.
Example:
TD Displays the system call address value and whether the system call

is enabled or disabled.
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583 TRAP_ADDRESS ENABLE
Abbreviation: TE
Description:

Enables or disables the system call for standard 1/0 and file 1/0 functions from the user program. For details,
refer to section 4.22, Standard 1/O and File 1/O Processing.

Syntax:
te <mode>
Parameter Type Description
<mode> Keyword Enables or disables the system call.
E Enables the system call.
D Disable the system call.
Example:
TEE Enables the system call.

5.84 UPDATE_ALL_DEPENDENCIES
Abbreviation: UD
Description:

Updates the dependencies for the current project.

Syntax:
ud

Parameter Type Description

None Updates the dependencies for the current project
Example:

update_all_dependencies Starts an update all dependencies operation on the current project.
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Section 6 Messages

6.1 Information M essages

The simulator/debugger outputs information messages as listed in table 6.1 to notify users of execution status.

Table6.1 Information Messages

Message

Contents

Break Access

The break access condition was satisfied and execution has stopped.

Break Cycle
Break Data
Break Register

Break Sequence

The break cycle condition was satisfied and execution has stopped
The break data condition was satisfied and execution has stopped.
The break register condition was satisfied and execution has stopped.

The break sequence condition was satisfied and execution has stopped.

PC Breakpoint

The breakpoint condition was satisfied and execution has stopped.

Sleep

Execution has been stopped by the SLEEP instruction.

Step Normal End
Stop
Trace Buffer Full

The step execution succeeded.
Execution has been stopped by the [Stop] button.

Since the Break mode was selected by [Trace buffer full handling] in the
[Trace Acquisition] dialog box and the trace buffer became full, execution
was terminated.
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6.2 Error M essages

The simulator/debugger outputs error messages to notify users of the errors of user programs or operation. Table
6.2 lists the error messages.

Table6.2 Error Messages

Message Contents

Address Error One of the following states occurred:
¢ A PC value was an odd number.
* Aninstruction was read from the internal I/0 area.
* Word data was accessed to an address other than address 2n.
« Longword data was accessed to an address other than address 2n.
Correct the user program to prevent the error from occurring.

Exception Error An error occurred during exception processing.
Correct the user program to prevent the error from occurring.

File Open Error An error occurred during opening a file with the break of file-input/output
action. Correct the file setting.

File Input Error An error occurred during reading a file with the break of file-input/output action.
Correct the file setting.

File Output Error  An error occurred during writing to a file with the break of file-input/output
action. Correct the file setting.

lllegal Instruction  Either of the following states occurred:
« A code other than an instruction was executed.
¢ MOV.B Rn,@-SP or MOV.B @SP+,Rn was executed.
Correct the user program to prevent the error from occurring.

lllegal Operation Either of the following states occurred:
« The relationship between flags C and H of CCR and the value before
compensation was illegal in the DAA or DAS instruction.
« Adivision by zero or an overflow occurred during DIVXU or DIVXS
instruction execution.
Correct the user program to prevent the error from occurring.
Memory Access One of the following states occurred:
Error « A memory area that had not been allocated was accessed.
« Data was written to a memory area having the write protect attribute.
« Data was read from a memory area having the read disable attribute.
« A memory area in which memory does not exist was accessed.

Allocate memory, change the memory attribute, or correct the user program to
prevent the memory from being accessed.

System Call Error ~ System call error occurred. Modify the incorrect contents of registers RO, R1,
and parameter block.

1/0 area not exist  The I/O area was deleted. Be sure to set the 1/O area.

The memory The memory resource was set outside the range of memory mapping. Modify
resource has not  the memory resource settings so that no error will occur.
been set up
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Appendix A: Trouble Shooting

| have clicked the “ Stop Build” button or selected [Build->Stop Build] to abort a build but the build
process has not stopped.
The HEW will stop the build after it has built the current file (or executed the current single phase). If the
builder does not respond after alonger period of time you can select [Build->Terminate Current Tool]
which will attempt to forcibly terminate the current process. Do NOT assume that any output from the tool
you terminated isvalid. It is recommended that you delete any output files produced and ensure that the
phaseis executed again.

| have atext file in the editor but it does not show any syntax coloring.
Ensure that you have named the file (i.e. saved it) and that the “ Enable syntax coloring” check box is set on
the “Editor” tab of the “Tools Options’ dialog, which islaunched via[Tools->Options...]. HEW checksa
file group to which the file' s extension belongs and decides whether the fileis colored. To view the current
defined extensions and their file groups, use the “File Extensions’ dialog which islaunched via [Proj ect-
>File Extensions...]. To view coloring information, use the “ Format” tab of the “Tools Options’ diaog,
which islaunched via[Tools->Options...]. (See the“ Syntax Coloring” section in chapter 4, “Using the
Editor” for details.)

| want to change the settings of a tool but the [Tools->Administration...] menu option cannot be selected.
[Tools->Administration...] cannot be selected while aworkspace is open. To enter the “ Tool
Administration” dialog first close the current workspace.

| did not edit any of the project files. But some of files were built again when | selected [Build->Build].
A fileisbuilt again if any of the following conditions holds:
1. Theoptionsfor the current file have been modified since the last build.
If any of the output files are missing.
Any of the source files have a newer date than the phase’s output files.
Any of the dependent files have a newer date than the phase’s output files.
In auser-defined custom build phase, the “Don’t check for input file(s) existence before executing”
check box is checked. To see the status of this check box, select [Options->Build Phases...], select the
phase in the “Build Phase Order” list in the “Build Order” tab, and click the“Modify...” button. Then
you will seethe “Don’t check for input file(s) existence before executing” check box on the “Command”
tab.
6. A subcommand fileis selected in Optimizing Linkage Editor.

| want to exclude a filein a project from build temporarily.
Push the right button of your mouse on the file in the “ Projects’ tab of the “Workspace” window, and select
[Exclude Build <file>], where <file> is the selected file. Then the file is excluded from build. To include the
filein build again, push the right button of your mouse on the file, and select [I nclude Build <file>].

| opened a workspace from my PC, and one of my colleagues opened the same workspace simultaneously
from another PC. | changed the settings of the workspace and saved it. He or she saved the workspace
after me. | opened the workspace again and found that the settings of the workspace differed from what |
had set before.
The settings saved last are enforced. Once HEW opens aworkspace, it is updated inside the memory. HEW
does not save the settings into a file until a user saves the workspace intentionally.

I want HEW to automatically specify default optionsto a file, which is newly added to a project.
Y ou can specify default optionsto a phase if the phase is a multiple build phase. Select a phase from the
[Options] menu. If the phaseisamultiple build phase, afilelist is displayed on the left-hand side of the
optionsdiaog (figure A.1). Inthefilelist, open afolder of afile group to which you want to specify your
default options. You will find a“Default Options” icon in the folder. Select the icon, specify options on the
right-hand side of the options dialog, and click “OK”. The options specified here will be given to any new
file of that file group when it isfirst added to the project.

o~ wDN
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Ea CAC++ source file
[:l C zource file
=43 Co+ source file

Default Options

Figure A.1: Options Dialog File List

? | selected [Build->Build All], but the dependenciesin the “ Projects’ tab of the “ Workspace” window is
not updated while selecting [Build->Build] updates the dependencies.
[Build->Build All] does not update the dependencies in the “ Projects’ tab of the “Workspace” window. To
update the dependencies, select [Build->Update All Dependencies].
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Appendix B: Regular Expressions

The High-performance Embedded Workshop editor allows you to include specia charactersin search strings
when performing a find or replace operation. These characters are listed in table B.1 and are detailed in the
following pages.

TableB.1: Regular Expression Characters

Character Function

? Matches any single character (except newline)

* Matches any number of occurrences (0 or more) of any character except a
newline

\n Matches a new line character

\t Matches a tab character

[1 Matches any one character or range listed within the brackets

\ Overrides any following regular expression character

*  Symbol: ?
Meaning:  This character matches any single character, except the newline character.
Example:  t?p matches“top”, “tip” but not “trap”.

¢ Symbol: *
Meaning:  This character matches any number of occurrences (O or more) of any character except a
newline. Thus, this character will not match across new lines. The* character will match as few
occurrences as are necessary to make the rest of the pattern match.

Example 1: t*o matchesthe “to” of “too”, the “tro” of “trowel” and the “ty 0" of
“sporty orange” but not “smart
orange” because the* character does not match across anew line.

* Symbol: \n
Meaning:  This character matches the newline character.
\n would be used to search for line endings or in patterns that cross line boundaries.
Example 1: ;\n
matches every occurrence of anewline following a semicolon
Example 2: ;\nif
searches for a semicolon, anew line and aline beginning with “if”.
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\t

This character matches the tab character.

\t8

Finds every occurrence of atab character followed by an 8.
init\t

Finds every occurrence of atab character following “init”.

[]

This matches any one character or arange of single characters listed within the brackets.
Brackets cannot be nested.

[-] specifies arange of characterse.g. [a-Z] or [0-9]. The beginning character in the range must
have alower ASCII value than the ending character of the range.

[~] matches asingle character if it isnot any one of the characters between
[~and]. This pattern also matches newline characters, unless the newline character isincluded
within the brackets.

[AEIOU]

Finds every uppercase vowel.

[<>7]

Findsaliteral <, >or ?.

[A-Za-z0-9 ]

Matches an upper or lowercase |etter, a digit or an underscore.

[~0-9]

Matches any character except a digit.

[\t\n]

Matches a space, atab or newline.

]

Matchesalitera ] if ] isplaced after \.

\

Thisisthe regular expression override character. If the character following the backdashisa
regular expression character, it istreated as anormal character. The backslashisignored if itis
followed by anormal (non-regular expression) character.

\*

Searches for every occurrence of an asterisk.
\

Searches for every occurrence of a backdash.
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Appendix C: Placeholders

This appendix describes how to use the placeholders, a feature provided by several of the High-performance
Embedded Workshop components.

C1 What is a Placeholder ?

A placeholder isa specia string, inserted into text, which is replaced at some subsequent time for the actual
value. For example, one of the HEW placeholdersis $(FULLFILE) which represents afile with afull path.
Suppose that you have an editor in c:\myedit\myeditor.exe, which can take the file to edit as a parameter. When
invoking the editor the following shortcut could be made, e.g.:

c:\myedit\myeditor.exe c:\files\filel.c

if you wanted to open FILEL.C from the directory c:\files. However, what happensif you want the HEW to open
any file through this editor? The problem is that the command above is specific to “c:\files\filel.c”. What we
want to be able to do is to tell the HEW to use the editor specified but to open the file that | have chosen at that
time. To do this, you can replace the specific name of thefile for ageneral placeholder, i.e.:

c:\myedit\myeditor.exe $(FULLFILE)

Now whenever the HEW launches the editor with afile, it knowsthat it has to replace $(FULLFILE) with the
fileyou have selected.

C2 Inserting a Placeholder

Placeholders can only be entered into three specific edit fields within the HEW (figures C.1, C.2 and C.3). There
are four ways a placeholder can be entered:

In thefirst example, place the insertion cursor at the point you would like to insert the placeholder and then
select the required placeholder from the pop-up menu to the right of the edit field.

File:
o projectymyprojecthouputhfile 7 out [ 3 |

Figure C.1: Placeholder Pop-up Menu

In the second exampl e, select the required placeholder other than “Custom directory” from the drop-down list
box and specify a sub-directory relative to the directory shown by the placeholder. If you select “Custom
directory”, specify an absolute directory path in the “ Sub-Directory” field.

Belative to

ICnnfiguration directony j

Sub-Directony

Figure C.2: Placeholder Drop-down List and Sub-Directory Field

373




High-performance Embedded Workshop User’s Manual

In the third example, place the insertion cursor at the point you would like to insert the placeholder, select the
required placeholder from the drop-down list box and then click the “Insert” button.

Placehalder:

Canfiguration directary j Inzert |

Figure C.3: Placeholder Drop-down List

In the fourth example, type the placeholder into the field directly. Ensure that you type the placeholder namein
uppercase and that it is preceded by $( and followed by ), i.e.

Thisis correct:
$(FILEDIR)

These are incorrect:
$(Filedir)

$( FILEDIR )
$FILEDIR
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C3 Available Placeholders

Table C.1 lists the placeholders and their meanings.

Table C.1: Placeholders

Placeholder Meaning
$(FULLFILE) Filename (including full path)
$(FILEDIR) File directory

$(FILENAME)

Filename (excluding path including extension)

$(FILELEAF)

Filename (excluding path and extension)

$(EXTENSION)

File extension

$(WORKSPDIR)
$(WORKSPNAME)
$(PROJDIR)

$(PROJECTNAME)

Workspace directory
Workspace name
Project directory

Project name

$(CONFIGDIR)

Configuration directory

$(CONFIGNAME)

Configuration name

$(HEWDIR) HEW installation directory

$(TCINSTALL) Toolchain install directory (on option dialog)
$(TOOLDIR) Tool installation directory (Tools Administration)
$(TEMPDIR) Temp directory

$(WINDIR) Windows® directory

$(WINSYSDIR) Windows® system directory

$(EXEDIR) Command directory

$(USERNAME) User login (Version control)
$(PASSWORD) User password (Version control)

$(VCDIR) “Virtual” version control directory
$(COMMENT) Comment (Version control)

$(LINE) Line number of an error/warning
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For example, the placeholders will be expanded as shown in table C.2.

Table C.2: Placeholder Expansions (Example)

Placeholder Expanded placeholder (example)
$(FULLFILE) c:\hew\workspace\project\file.src
$(FILEDIR) c:\hew\workspace\project
$(FILENAME) file.src

$(FILELEAF) file

$(EXTENSION)
$(WORKSPDIR)

src

c:\hew\workspace

$(WORKSPNAME) workspace
$(PROJDIR) c:\hew\workspace\project
$(PROJECTNAME) project

$(CONFIGDIR)

c:\hew\workspace\project\debug

$(CONFIGNAME) debug

$(HEWDIR) c:\hew

$(TCINSTALL) c:\hew\toolchains\renesas\sh\511
$(TOOLDIR) c:\hew\toolchains\renesas\sh\511
$(TEMPDIR) c:\Temp

$(WINDIR) c:\Windows

$(WINSYSDIR) c:\Windows\System

$(EXEDIR) v:\vc\win32

$(USERNAME) JHARK

$(PASSWORD) 214436

$(VCDIR) “c:\project” is mapped to “x:\vc\project”
$(COMMENT) “Please Enter Comment” dialog is invoked
$(LINE) 12

In table C.2, we are assuming that

o afilepathis*c:\hew\workspace\project\file.src”
» aworkspace named “workspace” islocated at “ c:\hew\workspace’
* aproject named “project” islocated at “ c:\hew\workspace\project”.

» aconfiguration named “debug” has a configuration directory located at “ c:\hew\workspace\project\debug” .

» HEW.EXEisingdledin “c:\hew”.

» a*.HRFfileof atoolchain (i.e. compiler, assembler, linker) islocated in “ c:\hew\tool chain\renesas\ish\511".
Thisisreferred to as $(TCINSTALL) on the option setting dialogs of the [Options] menu and as
$(TOOLDIR) on the “Tools Administration” dialog.

» the Windows® operating system isinstalled in “c:\Windows” and the Windows® system directory is
“c:\Windows\System”.

» aversion control executable path is“v:\vc\win32\ss.exe’, auser name and its password to login the version
control system are “JHARK” and “214436" respectively, §(COMMENT) is specified in acommand line to
the version control executable, and “c:\project” is mapped to “x:\vc\project” on the “ Projects’ tab of the
“Version Control Setup” dialog, which isinvoked via [Tools->Version Control->Configure...].

» anerror of compiler or assembler occurred at line 12.
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Note:  Not all of the placeholders are relevant in every field. For example, the $(LINE) placeholder has no
meaning when specifying a dependent files location. $(USERNAME), $(PASSWORD), $(VCDIR), and
$(COMMENT) placeholders are acceptable only in version control. If you enter a placeholder into an
edit field where it is not acceptable you might be informed.

c4 Placeholder Tips
Placeholders are there to allow you to create flexible paths to the various files used by the system.

* If thereisaplaceholder pop-up menu (k) next to an edit field into which you are about to enter a path or file,
you should consider how you can use a placeholder to make that path or file definition flexible.

 If you use several configurations, then the §(CONFIGDIR) placeholder is very useful to ensure that files can
be written to and from the current configuration’s directory.

»  Wherever possible, use a placeholder. They can always be removed or added later so don't be afraid to
experiment.
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Appendix D: 1/0 File Format

HEW formats the [IO] window based on information it findsin an I/O Register definition file. When you select a
debugging platform, HEW will look for a“<device>.10" file corresponding to the selected device and load it if

it exigts. Thisfileisaformatted text file that describes the I/O modules and the address and size of their registers.
You can edit thisfile, with atext editor, to add support for memory mapped registers or peripherals you may
have specific to your gpplication e.g. registersin an ASIC device mapped into the microcomputer's address space.
D.1  Fileformat

Each module name must be defined in the [Modules] definition section and the numbering of each module must
be sequential. Each module corresponds to a register definition section and within the section each entry defines
an /O regigter.

The [BaseAddress] definition is for devices where the location of 1/0 registers moves in the address space
depending on the CPU mode. In this case, the [BaseAddress] value is the base address of the 1/O registersin one
specific mode and the addresses used in the register definitions are the address locations of the registersin the
same mode. When the I/O register fileis actually used, the [BaseAddress] value is subtracted from the defined
register address and the resultant offset added to the relevant base address for the selected mode.

Each module has a section that defines the registers forming it along with an optional dependency, the
dependency is checked to seeif the module is enabled or not. Each register name must be defined in the section
and the numbering of each register must be sequentia. The dependency is entered in the section as dep=<reg>
<hit> <value>.

1. <reg>istheregister id of the dependency.
2. <bit>isthebit position within the register.
3. <vaue> isthe value that the bit must be for the module to be enabled.

The [Register] definition entry is entered in the format id=<name> <address> [<size>
[<absolute>[<format>[<bitfields>]]]].

1. <name> register name to be displayed.
2. <address> address of the register.
3. <size> which may be B, W or L for byte, word, or long word (default is byte).

4. <absolute> which can be set to A if the register is at an absolute address. Thisis only relevant
if the I/O area address range moves about on the CPU in different modes. In this casg, if a
register is defined as absol ute the base address offset cal culation is not performed and the
specified addressis used directly.

5. <format> Format for register output. Valid values are H for Hexadecimal, D for decimal, and B
for binary.

6. <bitfields> section defining the bits within the register.
Bitfield sections define the bits within a register each entry is of the type bit<no>=<name>.
1. <no>isthe bit number.

2. <name> isasymbolic name of the hit.
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Comment lines are allowed and must start with a“;” character.

i

Example :

Comment - SH7034 Farily 110 Regizster Definitions File

 [Modules]

Bazefddress=0

lodulel =Pewer_Down_Mode_FRegisters
Modules Medule2=DMA_Channel_Comrmon

—  Module3=DMA_0_Short_Address Mode

Moduled2=Bus_Contraller
Moduled3=Syatem
| Meoduledd=Interrupt_Cortroller

(DA _Channel_Comiman]
regd=regDMAWER
hoduke regl =regDMATCR
Definiticn reg2=regDMAECRH/ZAM
reg3=regDMABCRLSAM
redd =re gD M ABCRHFARM
rega=regCMABCRELFAM

dep=regM3TPCRH 7 0

Reqgister ‘
Bit
Value
[regDMAWER]
id=DMAWER Cedffff00 B A H dimewer_bitfields
Register name
Address ‘ ‘
S
Abzolute address flag
Fermat
Bitfields

[Hrmewer_bitfields]

Bitfiekds :
Definition | BROSWEDA
bt1=WEIB
bit2=WE1A
bita=WE1B
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Appendix E:  Symbol File Format

In order for HEW to be able to understand and decode the symbal file correctly, the file must be formatted asa
Pentica-B file:

1. Thefile must beaplain ASCII text file.
2. Thefile must start with the word “BEGIN”.

3. Each symbol must be on a separate line with the value first, in hexadecimal terminated by an
“H”, followed by a space then the symbol text.

4. Thefile must end with the word “END”.
Example:

BEG N

11FAH Synbol _nanme_1
11FCH Synbol _nane_2
11FEH Synbol _nanme_3
1200H Synbol _nane_4
END
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